Il y a actuellement 121 visiteurs
Lundi 18 Décembre 2017
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

Aidez moi :mon linux ne démarre plus !!

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

Aidez moi :mon linux ne démarre plus !!

Message le 29 Oct 2003 12:38

AHHHHHHHHH!!!
Ca fait 3 jour que je bosses sur un projet a rendre sous linux , je l'ai fini hier !! (évidemment je n'ai po pensé a la mettre sur disquette !!)
Et ce matin je voulais fusionner deux partitions sous windows avec partition magic 8 , l'opération a rattée (2 fois de suite!!).
Et maintenant je ne peux plus lancer linux : il me dit qu'il y a une erreur sur la partition hd9 ... et la il me lance un "shell" (une console koi) pour reparer tt ca mais je ne sais pas quoi faire!!
De plus je n'ai pas mes cd de mandrake sur moi : je les ai prêté!!
PAUVRE DE MOI (toujours sauvegarder sr disquette son boulot!!) :cry:

Si qqun peut essayer de m'aider se serait super COOL!
Je fais appelle a votre générostité et a votre connaissance !!
AIDEZ MOI!
Merci ++
Avatar de l'utilisateur
capunk2
Sous Expert(e)
Sous Expert(e)
 
Messages: 63
Inscription: 27 Oct 2003 10:44
Localisation: nantes
 


Message le 29 Oct 2003 16:39

oki

dans le shell qui se lance au démarrage (apres la détection du probleme) tu fais un e2fsck -f -c -D -p /dev/hdaX (ou X est ta partition posant problème)

Code: Tout sélectionner
-c => vérification des badblock
-f => forcer la vérification
-D => optimisation de l'organisation des dossiers/fichiers
-p => auto-réparation


ATTENTION: il faut vérifier que ta partition n'est pas montée !!
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

j'ai essayé!!

Message le 29 Oct 2003 19:41

J'ai essayé de taper ce que tu m'as dit, et ca ne marche po!!
Par contre j'ai remarqué que la partition qui (apparemment) pose problème n'est pas une partition de linux , mais une de windows (une des 2 que j'ai voulu fusionner a l'aide de partitionne magic 8!! ===> ce qui a raté !).
Donc je trouves ca étrange que linux ne veuille po démarer juste parce qu'il détecte un problème sur cette partition , je penses donc que je vais essayer de la formater (et meme peut etre de la supprimer pour la refaire ensuite).
Sinon rassurez vous j'ai récupérer mon projet grâce au fameu knoppix (linux qui se lance d'un cd!)!! D'ailleurs j'aurais une question a ce sujet : quand gt sous knoppix je ne pouvais écrire sous aucune partition ,celles en fat 32 et meme celles de linux ===> est ce normal ou faut il faire des reglages (cette question est juste a titre de curiositée!)
Sinon g recup mandrake 9.1 (ma version installée est la 9.0), y'a t'il une chance de refaire fonctionner linux en l'installant (si possible sans effacer mes données contenues sous linux actuellement!)
Merci d'avance!!
++
Avatar de l'utilisateur
capunk2
Sous Expert(e)
Sous Expert(e)
 
Messages: 63
Inscription: 27 Oct 2003 10:44
Localisation: nantes
 

Re: j'ai essayé!!

Message le 29 Oct 2003 20:02

capunk2 a écrit:J'ai essayé de taper ce que tu m'as dit, et ca ne marche po!!
Par contre j'ai remarqué que la partition qui (apparemment) pose problème n'est pas une partition de linux , mais une de windows (une des 2 que j'ai voulu fusionner a l'aide de partitionne magic 8!! ===> ce qui a raté !).

Connais tu l'état de la table des partitions apres le ratage ?

Donc je trouves ca étrange que linux ne veuille po démarer juste parce qu'il détecte un problème sur cette partition , je penses donc que je vais essayer de la formater (et meme peut etre de la supprimer pour la refaire ensuite).

As tu essayé de ré-écrire (confirmer) le changement (ou l'ancienne) table des partitions? ce n'est pas dangeureux pour tes données si tu réécris l'ancienne, et ca résoudra peut etre le probleme.

Sinon rassurez vous j'ai récupérer mon projet grâce au fameu knoppix (linux qui se lance d'un cd!)!!

Tient, un nouvel adepte :)

D'ailleurs j'aurais une question a ce sujet : quand gt sous knoppix je ne pouvais écrire sous aucune partition ,celles en fat 32 et meme celles de linux ===> est ce normal ou faut il faire des reglages (cette question est juste a titre de curiositée!)

C'est normal, car la politique de knoppix est : "on teste" et "on ne laisse pas l'utilisateur tout casser" (donc tout est en read-only).
Tu peux cependant démonter/remonter les partitions de ton systeme dans un shell root avec les commandes classiques...

Sinon g recup mandrake 9.1 (ma version installée est la 9.0), y'a t'il une chance de refaire fonctionner linux en l'installant (si possible sans effacer mes données contenues sous linux actuellement!)


Si ta partition /home etait une partition séparée (et que tu te souviens du nom de la partition) : Oui, sinon, essaye d'abord le résoudre le probleme par d'autres moyens...
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

je comprends po tout la !!!

Message le 29 Oct 2003 21:04

J'ai donc fait ce que j'avais dit : j'ai supprimer la partition qui apperemment posait pb (hda9 , soit la H sous windows)!
Ensuite je lance linux et la oh surprise : ..... ca n'a pas marché , mais ce qui est encore plus intrigant c que maintenant il me met que c'est la hda8 qui pose problème (ma partition G sous windows).
De plus j'ai essayé de faire une mise a jour de linux 9.0 vers 9.1 mais la il fait une vérif des dd et la il m'affiche le meme pb !!!!! :evil:
(voila ce qu'il m'affiche)

" erreur à la vérification du système de fichiers /dev/hda8 .
Souhaitez vous corriger les erreurs?
"

et la il me lance le shell en question

(alors que durant la mise a jour si je dis que oui alors il m'affiche:)

" fsck failed on /dev/hda8 with exit code 8 or signal 0 "


Donc je me dis que mon linux n'a pas été "altéré" par cette manipulation faite avec partition magic ===> donc ca me fait chier de le réinstaller et donc de devoir tout remettre après (ce qui est chiant sous linux parce que je suis debutant sous ce systeme!!).

D'ailleurs j'aimerais que tu m'expliques de quoi tu parles avec les tables de partitions... (je ne vois pas ce que c ni comment faire )

Merci d'avance pour votre aide!
++
Avatar de l'utilisateur
capunk2
Sous Expert(e)
Sous Expert(e)
 
Messages: 63
Inscription: 27 Oct 2003 10:44
Localisation: nantes
 



Sujets similaires

Message ordinateur ne démarre plus
salutdésolé si le sujet n'appartient pas à cette rubrique du forumj'ai un ordinateur de bureau hp compaq qui ne démarre plus.on appuyant sur le bouton mise en marche 10 bips puis s'atteindj'ai débranché touts les composent (j'ai laisser juste boite alimentation et carte mère )mais les bips restent ...
Réponses: 1

Message PC qui ne démarre plus sur Windows Vista
Bonjour,Je possède un pc avec os Windows Vista et cette après midi il a bippé plusieurs fois quand je l'ai mis sous tension sans pour cela démarrer comme d'habitude. J'ai remplacé la pile, j'ai tenté un clearcmos sans résultat. Pouvez vous m'aider s'il vous plait ? Merci
Réponses: 15

Message Windows ne démarre plus
Bonjour,J'ai fait l'acquisition, il y a 3 jours de cela, d'un portable Lenovo 15ISK sur lequel j'ai mis Windows 10. J'ai mis à jour les drivers, installé divers logiciels et tout allait bien, jusqu'à hier.L'origine de mon problème est une màj du bios que m'a proposé le logiciel de Lenovo qui m'avait ...
Réponses: 3

Message Ordinateur sous Linux très lent
Bonjour, J'ai installé Linux sur mon ordinateur par window avait planté, cependant depuis l'ordinateur est très très lent.Pourriez-vous me dire comment faire pour retrouver la rapidité qu'il avait avant ?Merci beaucoup
Réponses: 10

Message Portable ASUS UX305F ne démarre pas
Bonjour à tous !Pour installer Linux Ubuntu à côté de Windows 10 j'ai accédé au BIOS via Power + F2.Le BIOS n'est pas aisé. Il a fallu le déverrouiller pour pouvoir faire le démarrage sur le D.D. externe.J'ai donc installé Ubuntu qui a fonctionné. Je n'ai pas reverrouillé le BIOS.J'ai donc démarré a ...
Réponses: 14

Message unité centrale qui démarre en boucle
Bonjour,j'ai récupéré une UC depuis peu et lorsque je l'allume elle démarre en boucle, j'ai donc créé une clé bootable. J'ai essayé de démarré en appuyant sur plusieurs touches mais rien n'y fait.La carte mère est une msi ZH77A-G43. Est ce que vous auriez des pistes??merci
Réponses: 14

Message [Réglé] Mon PC démarre toujours sur AMERICAN MEGATRENDS
BonjourIl y a 2 jours, en allumant mon PC et il s'est mis sur une fenêtre AMERICAN MEGATRENDS me proposant d'aller dans le BIOS.Ce que j'ai fait en sélectionnant l'ordre de démarrage sur mon SSD car il était sur UEFI.Puis plusieurs fois j'ai eu la fenêtre : votre ordinateur a rencontré un problème, ...
Réponses: 18


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.