Il y a actuellement 53 visiteurs
Samedi 21 Octobre 2017
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

[Réglé][Debian] localisation du noyau

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

[Réglé][Debian] localisation du noyau

Message le 22 Aoû 2004 15:42

Salut,

Petite question rapide sur la localisation du noyau.
Il me semble que depuis que je suis passé en 2.6.7, le "make install" me copie automatiquement le vmlinuz (et system.map) sur /boot. La première fois, il m'a aussi actualisé la copie (et le ln) sur /, et fait le nécessaire our créer un vmlinuz.old (=> 2.4.18bf2).

Hors, lilo.conf va chercher /vmlinuz et /boot/map (!! pas trés cohérent non ?).

Depuis, si je recompile, il ne m'actualise rien. Je suis obligé de copier /boot/vmlinuz-2.6.7 sur /.

Ma question : puis-je supprimer un des 2, en remettant de l'ordre dans liko.conf ?
Je vire /vmlinuz et /System.map, et je modifie lilo.conf avec les bons chemins, par exemple.
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8872
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 


Message le 23 Aoû 2004 17:04

J'avoue n'avoir pas tout compris :oops: :oops:

Tu peux supprimer mais fait bien attention d'avoir un noyau valide sur lequel tu puisses booter :wink:

Moi ma techinque c'est de copier le nécessaire dans /boot (bzImage & Sytem.map) et faire les ln -s qu'il faut :wink:
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 10:46
Localisation: /Fr/Idf/77/Le Mée
 

Message le 23 Aoû 2004 17:21

Stormrider a écrit:J'avoue n'avoir pas tout compris :oops: :oops:

C'est pas grave, je la refais plus simple :

En gros, quand je recompile le noyau, j'ai le nouveau vmlinuz sur /boot et le nouveau System.map sur /boot.
Mais lilo (lilo.conf) va chercher vmlinuz sur /
Donc je suis obligé de le copier.

Si tu me dit que tu n'as qu'un vmlinuz et System.map sur /boot, c'est ok, je vais modifier pour faire pareil dans le lilo.conf....
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8872
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 23 Aoû 2004 17:45

Je n'ai pas qu'un vmlinuz dans /boot. J'en ai plusieurs.

C'est juste qu'après l'avoir copié dans /boot (par exemple /boot/vmlinuz.2.6.8_rc1), je fais un
Code: Tout sélectionner
$ cd /
$ ln -s /boot/vmlinuz.2.6.8_rc1 vmlinuz.2.6.8_rc1


Et je mets dans lilo /vmlinuz.2.6.8_rc1.

Comme ça je me retrouve avec des liens symboliques, au lieu de copier les fichiers.

Où tu peux aussi donner comme chemin à Lilo /boot/vmlinuz et non pas /vmlinuz tout court.
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 10:46
Localisation: /Fr/Idf/77/Le Mée
 

Message le 23 Aoû 2004 17:59

Ok, j'ai compris... et c'est bien ce que je pensais, j'ai trop de vmlinuz (et system.map) pour rien.
Déjà qu'il ne me reste plus que 200 MO...

Merci Stormrider :wink:
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8872
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 



Sujets similaires

Message [Configuration Debian 8] - Serveur mail, web, open
Hello les amis, Je possède un serveur dédié chez online.net actuellement qui est sur Debian 8. Au début j'avais installé Debian 9 pensant que c'était globalement la même chose mais j'ai eu des soucis avec l'installation de pam-mysql pour openvpn pour un site qui propose un service VPN : http://unsha ...
Réponses: 1

Message [Réglé] Mon PC démarre toujours sur AMERICAN MEGATRENDS
BonjourIl y a 2 jours, en allumant mon PC et il s'est mis sur une fenêtre AMERICAN MEGATRENDS me proposant d'aller dans le BIOS.Ce que j'ai fait en sélectionnant l'ordre de démarrage sur mon SSD car il était sur UEFI.Puis plusieurs fois j'ai eu la fenêtre : votre ordinateur a rencontré un problème, ...
Réponses: 18

Message [Réglé] Panne aléatoire Shuttle DS61
Bonjour à tous.Mes soucis sont les suivants:Au démarrage , le bios ne reconnais pas tout le temps mon disque dur interne donc problème de boot.Lorsqu?il est reconnu après quelques minute d'utilisation , windows se fige et reboot obligatoire.J'ai déjà essayé de changer le disque dur mais même problèm ...
Réponses: 9

Message [Réglé] Cercle bleu transparent avec un N à l’intérieur.
Bonjour,le titre de mon message est pas très parlant, mais il m'est impossible d'obtenir plus d'information sur ce maudit cercle bleu par recherche google.Sur la droite de la capture d'écran ci dessous, vous pouvez apercevoir le fautif.Ce cercle est ni mobile, ni configurable.Il apparaît qu'en jeu ...
Réponses: 10

Message [Réglé] Connexion wifi ne fonctionne pas
Bonjour,voila depuis quelques temps mon pc portable ne se connecte plus au wifi , il se connecte seulement au secteur . j'ai donc regarder la carte réseau et il y a un petit soucis le pilote "microsoft teredo tunneling adapter" ne veux pas ne mettre à jour il échoue à chaque fois :/ , fau ...
Réponses: 9

Message [Réglé] jdownloader ne se lance pas
bonjour, tout est dit dans le titre, après avoir télécharger JDOWNLOADER, je n'arrive pas a lancer le fichier executable, je suis sous w7 , navigateur CHROME, et 7zip pour décompresser, quand je clique dessus ,une fenêtre noire apparaî ...
Réponses: 14

Message [Réglé] Premier boot de la journée impossible
Bonjour,J'ai le message suivant au démarrage de mon PC :Information sur la carte mèreLa taille de la dramest deGeneric storage device 9454Sata port 1 : CT500 BX 100SSD1" " 2 : HL- DT - ST DD-RE BH10LS30" " 3 : WDC WD40EZRX-00SPEBOLes 3 sata port corresponden ...
Réponses: 6


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.