Il y a actuellement 57 visiteurs
Mardi 17 Octobre 2017
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

Pas de gestionnaire de fenêtres et autres pbs d'affichage

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

Pas de gestionnaire de fenêtres et autres pbs d'affichage

Message le 02 Jan 2009 13:08

Bonjour,

Je vous raconte les choses dans l'ordre car je ne sais pas ce qui est important:

Il y a 15 jours tout allait bien.
J'ai installé un nouveau DD externe (j'en avais déjà un). J'ai dû ajouter une ligne de mount dans le fstab.
Ca a marché sauf que lorsque je lançais mon PC, avant l'affichage du bureau, j'avais le message suivant:
"Le fichier $HOME/.dmrc de l'utilisateur a été ignoré. Ceci empêche de sauver la session et la langue par défaut. Le fichier devrait appartenir à l'utilisateur et avoir les permissions 644 . Le répertoire de l'utilisateur doit appartenir à l'utilisateur et ne doit pas être accessible en écriture par d'autres utilisateurs? "
Je cliquais sur OK puis le PC fonctionnait bien et j'avais remis à plus tard l'explication de ce message d'erreur pas très gênant.

De quoi s'agissait-il?
Je ne sais pas si ça a un rapport avec la suite:

Hier, l'affichage de l'ordi était bon mais depuis ce matin, quand je démarre, outre le message d'erreur ci-dessus, j'ai le problème suivant:
L'écran démarre en résol 800x600 et si je vais dans préférences / résol, je n'ai le choix qu'entre 800x600 et 640x480.
De plus, quand je lance une appli comme Firefox ou Write, je n'ai plus accès à la barre d'état, je ne peux donc lancer aucune autre appli, je ne peux lancer de terminal ni rien, je ne peux fermer l'appli que j'ai lancée (le bouton d'arrêt n'est pas là). Et si je clique sur le bouton en bas à gauche d'affichage du bureau, l'ordi me répond qu'aucun gestionnaire de fenêtres n'est activé.

Je ne peux donc me servir de mon ordi.

Quand je veux changer d'appli, je suis obliger de relancer l'ordi d'abord...

Comprenez-vous ce qui se passe? Pouvez-vous m'aider?

Je vous remercie pour votre aide et souhaite à tous les linuxiens une heureuse année 2009,

H
Hippocampe
Sous Expert(e)
Sous Expert(e)
 
Messages: 70
Inscription: 02 Jan 2009 13:03
 


Message le 02 Jan 2009 13:10

Quelle distrib. tu utilises ?
En cas de problème constaté sur un sujet, contactez un modérateur par MP. N'intervenez pas vous-même. Merci bien.
Aucune aide ni support ne sera fourni par MP.
Avatar de l'utilisateur
H3bus
Moderateur
Moderateur
 
Messages: 12195
Inscription: 08 Avr 2008 15:13
Localisation: /home/h3bus
 

Message le 02 Jan 2009 13:21

Salut,

Ubuntu Ibex
Hippocampe
Sous Expert(e)
Sous Expert(e)
 
Messages: 70
Inscription: 02 Jan 2009 13:03
 

Message le 02 Jan 2009 13:27

Ok, tu as quoi comme PC ? Fixe, portable ? Marque et modéle ?
En cas de problème constaté sur un sujet, contactez un modérateur par MP. N'intervenez pas vous-même. Merci bien.
Aucune aide ni support ne sera fourni par MP.
Avatar de l'utilisateur
H3bus
Moderateur
Moderateur
 
Messages: 12195
Inscription: 08 Avr 2008 15:13
Localisation: /home/h3bus
 

Message le 02 Jan 2009 13:38

PC fixe iventive

Si je comprends bien, comme metacity est le gestionnaire de fenêtres de gnome, mon metacity est out. si je demande à le réinstaller, on me dit qu'il est déjà installé.
Hippocampe
Sous Expert(e)
Sous Expert(e)
 
Messages: 70
Inscription: 02 Jan 2009 13:03
 

Message le 02 Jan 2009 13:44

Il semble certain que c'est l'ajout du DD externe et la bidouille du fstab qui t'a provoqué cela. Je pense que suite à cela ton PC a démarré sur un mauvais disque ou qqchose comme cela, surtout si c'est un disque USB et que la numérotation du disque s'est trouvée changée (sda1 en ssda2 ou sdb1 en sdb2 par exemple)
Deux choses :
- si tu enlèves tout simplement le DD avant de démarrer, est-ce que les choses ne reviennent pas à la normale ?
- peux-tu nous montrer ton fstab et tes disques avec le résultat des commandes suivantes :
=> cat /etc/fstab
=> fdisk -l
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8870
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 02 Jan 2009 14:29

Bonne idée d'essayer sans les dd. Mais non, le comportement reste le même.

A noter que j'ai deux dde que j'allume avant de lancer l'ordi et qu'ils n'apparaissent pas toujours dans le même ordre dans Nautilus, je ne sais pas si c'est important.

cat /etc/fstab donne (je ne peux faire de couper-coller donc je sucre les commentaires et les chaînes alphanumériques hyperlongues, de plus ici je ne peux utiliser les tabulations, comme tout le monde je suppose):
UUID=.... / ext3 realtime errors=remount-o 0 1
UUID=... none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw, user, noauto, exec, utf8 0 0
mount -t ntfs-3g /dev/sdb1 /media/Iomega - 0 force


fdisk -l donne:
ne peut ouvrir /dev/sda
ne peut ouvrir /dev/sdb
ne peut ouvrir /dev/sdc


Voilà, ça te parle?
Hippocampe
Sous Expert(e)
Sous Expert(e)
 
Messages: 70
Inscription: 02 Jan 2009 13:03
 

Message le 02 Jan 2009 15:02

Ouh ouh, tu ne m'oublies pas? Je suis dans une grosse m...

Je viens de remarquer un truc bizarre: dans le fstab, que je ne peux te copier, dans la description du 1er UUID il y a écrit relatime, ça ne devrait pas être realtime?
Hippocampe
Sous Expert(e)
Sous Expert(e)
 
Messages: 70
Inscription: 02 Jan 2009 13:03
 

Message le 02 Jan 2009 15:20

Hippocampe a écrit:Ouh ouh, tu ne m'oublies pas?

Hum... accessoirement j'ai aussi une vie et un travail (auquel je suis actuellement d'ailleurs). Donc je peux pas faire du SAV real-time...

Cette ligne :
Code: Tout sélectionner
mount -t ntfs-3g /dev/sdb1 /media/Iomega - 0 force

N'a absolument rien à faire dans un fstab... C'est une commande complète que tu as écrit, pas une syntaxe de fstab.
La syntaxe de fstab c'est
device point-de-montage type-de-systeme-de-fichier options...

Donc déjà faudrait plutôt écrire :
Code: Tout sélectionner
/dev/sdb1 /media/Iomega  ntfs-3g defaults,force 0 0

dans le fstab.
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8870
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 02 Jan 2009 15:54

Oui, c'est vrai, tu bosses, moi je chôme... Tu es dans l'informatique?

Tu me réponds quand tu peux.

J'ai d'ailleurs justement besoin de mon ordi pour en chercher, du boulot! Et en informatique en plus mais pas comme développeur, j'ai fait mon temps. J'ai bien connu les ordinateurs VAX avec le système VMS mais c'est vieux tout ça.

pour le $HOME/.dmrc, je suis allé dans Nautilus en root et j'ai mis comme propriétaire de home et tout ce qui est dedans 'mhp' (càd moi, l'unique utilisateur) alors que c'était avant 'root'. Depuis je n'ai plus le message d'erreur au démarrage. J'aurais pu y penser plus tôt...

Mais j'ai toujours le reste qui déconne, à savoir (je fais le point):
pb1: pas de gestionnaire de fenêtres en activité
pb2: résolution bloquée à une faible valeur
pb3: fonctionnement bizarre de "Verr num" (je l'ai remarqué il y a peu)

En somme, ce n'est peut-être pas si terrible à réparer même si ça empêche d'utiliser l'ordi. Sais-tu si pb1 entraîne pb2 ou pb3?

Je suppose que j'ai Metacity qui est le gestionnaire de fenêtres par défaut de Gnome. Peut-être puis-je chercher un autre gestionnaire?

Réponds quand tu auras le temps, à + et merci déjà pour tout ce que tu m'as dit.

H
Hippocampe
Sous Expert(e)
Sous Expert(e)
 
Messages: 70
Inscription: 02 Jan 2009 13:03
 

Message le 02 Jan 2009 20:00

Hippocampe a écrit:Oui, c'est vrai, tu bosses, moi je chôme... Tu es dans l'informatique?

Oui.
Hippocampe a écrit:Tu me réponds quand tu peux.

j'ai pas dit cela méchamment, c'est juste qu'un forum c'est pas forcément du 100% de temps de réponse.
Hippocampe a écrit:pour le $HOME/.dmrc, je suis allé dans Nautilus en root et j'ai mis comme propriétaire de home et tout ce qui est dedans 'mhp' (càd moi, l'unique utilisateur) alors que c'était avant 'root'. Depuis je n'ai plus le message d'erreur au démarrage. J'aurais pu y penser plus tôt...

Certes, mais c'est "sale" comme solution. Car cela n'explique pas comment ni pourquoi le dossier était passé à root. D'autre part, ce n'est pas parce que des fichiers appartiennent à root que les fichiers de config sont fait pour root. En effet tu as des fichiers de config qui contiennent expressement les noms d'utilisateurs et tu peux avoir des problème si un fichier contient toujours l'user "root" alors que tu l'as passé en propriétaire "mhp".
Cela pour dire que tu peux encore tomber sur des incohérences.

Pour repartir sur un truc plus propre, tu devrais plutpot recréer un autre user (sudo adduser mhp2 en console par exemple), puis te loguer par défaut sur cet user (systeme+admin+fenetre de connexion+sécurité+connexion auto). Tu récupères tes données en copiant/collant les fichier (documents, musique, etc...) de /home/mhp à /home/mhp2 (avec un ALT+F2 et gksudo nautilus => gaffe à pas tout péter avec cet accès en root). Ce sera mieux.

Hippocampe a écrit:pb1: pas de gestionnaire de fenêtres en activité

tu fais ALT+F2 (exécuter) et tu tapes metacity --replace
Si ton gestionnaire se lance, tu sauves les paramètres de session dans le menu système+préférences+sessions.
Hippocampe a écrit:pb2: résolution bloquée à une faible valeur

Tu peux éventuellement tenter de réconfigurer le serveur graphique en console par un sudo dpkg-reconfigure xserver-xorg
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8870
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 03 Jan 2009 08:24

Bonjour Casa,

Je n'avais pas parlé de méchanceté!! Tu as bien le droit de travailler;

Pour en revenir à nos moutons:
si je tape metacity --replace (j'ai essayé metacity replace, metacity-replace, metacity -replace) je tombe sur:
Erreur du gestionnaire de fenêtres: unable to open X display

Et quand je tape
sudo dpkg -reconfigure xserver-xorg, je tombe sur un texte que je ne comprends pas (des descriptions de commandes, je crois).

J'en suis toujours au même point.

J'aimerais régler ça avant de créer un deuxième utilisateur mais j'ai peut-être tort.

Bref, je suis toujours au même point.

Help, please.

H
Hippocampe
Sous Expert(e)
Sous Expert(e)
 
Messages: 70
Inscription: 02 Jan 2009 13:03
 

Message le 03 Jan 2009 10:41

Hippocampe a écrit:si je tape metacity --replace (j'ai essayé metacity replace, metacity-replace, metacity -replace) je tombe sur:
Erreur du gestionnaire de fenêtres: unable to open X display

Tu tapes bien cela en étant déjà en mode graphique, sur le bureau en faisant un ALT+F2 (lancer une application) ?
Il ne faut pas le taper dans une des premières console texte...
Hippocampe a écrit:sudo dpkg -reconfigure xserver-xorg, je tombe sur un texte que je ne comprends pas (des descriptions de commandes, je crois).

C'est surement la procédure de configuration... c'est normal. Si tu ne vois pas trop quoi répondre, essaye de trouver un tuto par l'exemple détaillé
http://www.google.fr/search?hl=fr&q=dpk ... configure+

Ici par exemple
=> http://www.freesoftwaremagazine.com/col ... econfigure
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8870
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 09 Jan 2009 14:25

Bonjour Casa,

Excuse mon long silence. J'ai dû me calmer après avoir failli exploser.

J"'ai suivi l'indication d'un forumeur d'un autre site qui a provoqué un énorme plantage. Ubuntu me prévenait que si je démarrais, rien ne fonctionnerait.

J'ai donc réinstallé Linux, Hardy puis Intrepid, et tous les logiciels perdus, le tout avec une connexion Internet de très faible débit suite à un problème financier avec mon fournisseur. Très long...

Et quand même, mon gestionnaire de fenêtres a redémarré au passage... Quand même.

L'ordi a fonctionné normalement mais je recommence à avoir le message sur le dmrc! Suis-je maudit???

Bonne fin de semaine,

H
Hippocampe
Sous Expert(e)
Sous Expert(e)
 
Messages: 70
Inscription: 02 Jan 2009 13:03
 



Sujets similaires

Message gestionnaire de tage disque 100
bonjour je viens de faire changer mon dd sur mon pc portable pourtant dans le gestionnaire de tache le disque dur reste à 100%en permanence pouvez vous m'aider ? je n'ai pas trouver de solution merci d'avance
Réponses: 1

Message "Les paramètre d'affichage Nvidia ne sont pas disponibles."
Bonjour à toutes et à tous. Avant toutes choses, je sais qu'il existe 40 milles sujets avec ce titre, mais mon problème est toujours différent de ce que l'on y trouve. Après avoir laissé mon ordinateur portable (Asus RoG GL752V, 960M sous Windows 10) pendant une vingtaine de minutes tout seul, sans ...
Réponses: 9

Message Logiciel permettant de cliquer sur plusieurs fenêtres
je suis à la recherche d'un autre logiciel qui lui n'a rien à voir, en effet je cherche un logiciel qui me permettrai d'effectuer certaines actions (clics gauche/droit en simultanées sur plusieurs fenêtres), si quelqu'un connaît un logiciel permettant d'effectuer ce genre de tâches.. J'ai cherché su ...
Réponses: 0

Message Affichage du bureau : raccourcis baladeurs...
Bonjour à tous,Voilà, lorsque l'on met à jour le pilote graphique (Nvidia dans mon cas), les raccourcis mis sur le bureau sont à chaque fois quelque peu chamboulés et ne se retrouvent plus à leur emplacement d'origine.OK, là pas de problème, je prends le temps de tout redisposer comme cela m'arrange ...
Réponses: 6

Message [Réglé] affichage intempestif
bonjour depuis quelque jour j'ai remarquer l'apparition de la fenêtre cmd sa dure 2 ou 3 seconde et elle disparaitet j'ai l'impression que mon ordi rame je voulait vous joindre les rapport frst mais il n'y a pas les option sous le message merci
Réponses: 18

Message Oulook 2016 : affichage des images
Bonjour,j'utilise Oulook 2016 pour ma messagerie.Néanmoins une chose m'ennuie : je ne parviens pas à faire afficher les images dans les messages. J'ai cherché dans les menus mais je n'ai rien trouvé.Quand je place le pointeur de la souris sur le cadre où l'image devrait s'afficher j'ai l'info suivan ...
Réponses: 3

Message DD reconnu dans le gestionnaire, pas dans l'explorateur.
Bonjour,Je viens d'acheter second DD, un seagate 4 To pour archivage. J'ai du l'indiquer en GTB dans le gestionnaire pour qu'il soit reconnu pour 4 To et non 2 dans le gestionnaire. Mais pas moyen de le voir dans mes dossiers. Si Système d'exploitation: Windows 10AJOUT DE MESSAGE:Voici ce qu'il me d ...
Réponses: 2


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 4 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.