Il y a actuellement 93 visiteurs
Lundi 24 Septembre 2018
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

Impossible de démarrer Debian (Lenny)

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

Impossible de démarrer Debian (Lenny)

Message le 06 Jan 2010 22:11

Bonjour,

J'ai une machine virtuelle sur laquelle j'ai installé Debian.
Depuis peu je n'arrive plus à démarrer dessus... elle se bloque à "Starting MTA :"

Mon MTA est exim4.

Peut être que ceci pourra vous aider :
Je travaille actuellement sur un projet qui consiste à paramétrer un serveur VPN basé sur IPsec sur cette machine virtuelle.

Cette machine démarrait correctement jusqu'à ce que j'installe XL2TP et que je modifie le fichier xl2tpd.conf.

Merci d'avance.
shinobitom
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 148
Inscription: 14 Avr 2009 20:06
 


Re: Impossible de démarrer Debian (Lenny)

Message le 07 Jan 2010 10:25

Vraiment personne pour m'aider?

Temps pis je me suis débrouillé tout seul mais j'ai encore un gros problème.j'ai démarrer en mode console et j'ai renommé le fichier exim4 de démarrage S20exim4 (ou S22exim4 je sais plus) S31exim4 de manière à ce qu'il démarre après le service de configuration reseaux dans :
/etc/rc2.d
/etc/rc3.d
/etc/rc4.d
/etc/rc5.d

Pour vous situer S31exim4 intervient juste après S30gmd.

La machine démarre correctement.

Problème :
Je narrive plus à me connecter à internet :

Avec ifconfig je remarque que ma configuration reseau est bonne. J'ai bien les bonnes adresses DNS dans /etc/resolv.conf.
Le fichier /etc/network/interfaces est bien configuré...

En vérité quand je lance le navigateur internet, il n'affiche pas de message d'erreur... La page reste blanche et il dit qu'il charge la page. On dirait que le programme cherche quelque chose... il boucle...
De la même manière lorsque je lance la configuration reseau avec /etc/init.d/networking restart, le programme boucle et ne fini jamais...

Il cherche quelque chose mais je ne sais pas quoi...

Merci d'avance.
Je vais aussi poster ce problème dans le forum reseau.
shinobitom
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 148
Inscription: 14 Avr 2009 20:06
 

Re: Impossible de démarrer Debian (Lenny)

Message le 07 Jan 2010 14:12

shinobitom a écrit:J'ai une machine virtuelle sur laquelle j'ai installé Debian.

A l'aide de quoi as tu fait ta machine virtuelle ?
shinobitom a écrit:Je travaille actuellement sur un projet qui consiste à paramétrer un serveur VPN basé sur IPsec sur cette machine virtuelle.

Un VPN dans une machine virtuelle ? Oui mais il faut donc peut-être s'attendre effectivement à des problèmes d'interfaces réseau... Comment est paramétrée ton interface virtuelle : pont, direct, NAT, ...
shinobitom a écrit:Cette machine démarrait correctement jusqu'à ce que j'installe XL2TP et que je modifie le fichier xl2tpd.conf.

Je ne connais pas, mais tu peux donner des indications sur ce que tu as modifié pour que tout le monde y voit plus clair...
shinobitom a écrit:Je vais aussi poster ce problème dans le forum reseau.

Inutile... ça embrouille. Si c'est le cas je verrouillerai.
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8917
Inscription: 13 Mai 2003 17:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Re: Impossible de démarrer Debian (Lenny)

Message le 07 Jan 2010 17:24

J'ai créé cette machine virtuelle sur Vmware Serveur avec les isos de Debian Lenny téléchargés sur le site de debian.
J'ai mis l'interface virtuelle du coté internet en NAT.

Quand à XL2TP, Il sagit d'un programme qui met en oeuvre les connexions L2TP.
Le protocole L2TP permet de transporter les paquets PPP en les encapsulant dans des paquets IP. Les trames PPP passent donc à travers un tunnel créé par L2TP.

voici les fichiers qui paramètrent mon serveur vpn :

1. /etc/ipsec.conf :

# /etc/ipsec.conf - Openswan IPsec configuration file
# RCSID $Id: ipsec.conf.in,v 1.15.2.6 2006-10-19 03:49:46 paul Exp $

# This file: /usr/share/doc/openswan/ipsec.conf-sample
#
# Manual: ipsec.conf.5


version 2.0 # conforms to second version of ipsec.conf specification

# basic configuration
config setup
overridemtu=1400
rp_filter=0
nat_traversal=yes
keep_alive=yes
virtual_private=%v4:10.0.0.0/8,%v4:192.168.0.0/16
nhelpers=0
uniqueids=yes

conn %default
left=192.168.0.9
keyingtries=3
compress=no
disablearrivalcheck=no
leftsendcert=always
leftcert=vpn-cert.pem
leftrsasigkey=%cert
rightca=%same
rightrsasigkey=%cert
dpddelay=30
dpdtimeout=60
dpdaction=hold
authby=rsasig
type=tunnel

conn vpn-12tp-XP
leftprotoport=17/1701
rightprotoport=17/1701
rightsubnet=vhost:%priv,%no
right=%any
rightid="/C=FR/ST=Haute-Savoie/O=UDS/OU=XP/CN=*/E=*"
auto=add
pfs=no

conn vpn-12tp-MACOS
leftid=192.168.0.9
leftprotoport=17/1701
rightprotoport=17/%any
rightsubnet=vhost:%priv,%no
right=%any
rightid="/C=FR/ST=Haute-Savoie/O=UDS/OU=MACOS/CN=*/E=*"
forceencaps=yes
auto=add
pfs=no

conn vpn-12tp-LINUX
leftid=192.168.0.9
leftprotoport=17/1701
rightprotoport=17/1701
rightsubnet=vhost:%priv,%no
right=%any
rightid="/C=FR/ST=Haute-Savoie/O=UDS/OU=LINUX/CN=*/E=*"
forceencaps=yes
auto=add
pfs=no

# Add connections here

# sample VPN connections, see /etc/ipsec.d/examples/


#Disable Opportunistic Encryption


2. /etc/xl2tpd/xl2tpd.conf

#
# Sample l2tpd configuration file
#
# This example file should give you some idea of how the options for l2tpd
# should work. The best place to look for a list of all options is in
# the source code itself, until I have the time to write better documetation :)
# Specifically, the file "file.c" contains a list of commands at the end.
#
# You most definitely don't have to spell out everything as it is done here

[global]
port = 1701
listen-addr=192.168.219.10

[lns default]
ip range = 192.168.2.1-192.168.2.254
local ip = 192.168.2.9
length bit = yes
refuse chap = yes
require pap = yes
require authentication = no
hostname = vpn
name = vpn
ppp debug = yes
pppoptfile = /etc/ppp/options.serveur.glmf

je pense à 90% que c'est dans ce fichier que je me suis trompé... mais je vois pas où...

voila voila... peut être que les processus de ipsec et xl2tpd une fois lancé plantent la machine...
shinobitom
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 148
Inscription: 14 Avr 2009 20:06
 

Re: Impossible de démarrer Debian (Lenny)

Message le 07 Jan 2010 17:55

Oups je reviens sur ce que j'ai dit.

Après avoir arrêté le service ipsec (/etc/init.d/ipsec stop) je remarque que les services réseaux fonctionnent correctement... j'ai du me tromper dans la configuration de ipsec.conf...

remarque : je viens de me rendre compte que dans mon fichier ipsec.conf les lignes variables left et leftid valent 192.168.219.10 (et non .9) bien que ce n'est pas cela qui ne fonctionne pas.

pour y voir plus clair voici la configuration réseau de l'interface coté internet :
adresse 192.168.219.10
netmask en /24
passerelle 192.168.219.2

je n'arrive vraiment pas à voir le problème...
shinobitom
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 148
Inscription: 14 Avr 2009 20:06
 



Sujets similaires

Message Installation application impossible - Tablette Polaroid
Bonjour à tous,J'ai une amie qui m'a demandé de l'aider à réparer sa tablette Polaroid.Cette dernière connaissant de forts ralentissements.J'ai remis la tablette aux valeurs d'usine, et synchronisé avec le compte gmail.Je souhaitais lui installer des applications qu'elle aimait bien : marmiton, prog ...
Réponses: 2

Message [Résolu] outlook 2003 impossible d'envoyer des messages
Bonjour,Depuis quelque temps, je ne peux plus envoyer de messages, une erreur suivante apparait: "le serveur sortant (SMTP) ne prend pas en charge les connections sécurisées par SSL...."Ca marchait parfaitement avant, impossible même en modifiant les paramètres du compte.Pouvez vous m'aide ...
Réponses: 5

Message Impossible de booter via USB , windows 7 installation
Bonsoir, je rencontre un soucis pour démarrer l'installation Windows 7 à l'aide d'une clé USB que j'ai formatter et flashé proprement.Lorsque je suis dans le Bios , j'appuye sur f8 et je choisis la clé USB ensuite j'ai un ecran noir avec un tiret blanc clignotant dans le coin supérieur gauche , impo ...
Réponses: 2

Message "Impossible de trouver adresse....."
Bonjour à tous!Alors voilà je vous écris pour ma mère, cela fait environ trois jours qu'elle ne peut plus jouer au jeu "Klondike" sur Facebook.Quand elle lance le jeu à la place d'avoir l'image du jeu elle reçoit ce message "Impossible de trouver l'adresse IP du serveur de klone-fb.va ...
Réponses: 1

Message Supression de mail outlook sur gmail impossible
Bonjour,Voila, avant j'avais un bon vieux android 4.1, depuis que je suis passé a la 5-6, l'application mail de base a disparue pour laisser place a Gmail, c'est la que les soucis arrivent. Avant, sur l'app mail de base, j'avais 4 mail, une gmail, deux mail perso fait sur un serveur mail perso et ce ...
Réponses: 1

Message [Résolu] lecture vidéo impossible
Bonjour;Je n'arrive pas à lire les vidéos sur YouTube, que se soit Google Chrome, Firefox, ou encore application du Windows Store, je n'obtient qu'une image noire, ou au mieux une image verte avec le son.Ce qui est encore plus bizarre VLC n'arrive plus à lire des MKV "j'ai une image noire avec ...
Réponses: 11

Message Connecxion Wi-fi impossible via Freebox
Déjà pour être bien tu devrais être en WPA2-PSK ou WPA2-AES ou mieux encore en WPAWPA2-PSK (TKIP/AES) d'après ce je lis le CCMP tu peux obtenir une compatibilité avec des dispositifs du coup basculé sur TKIP
Réponses: 5


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 4 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.