Il y a actuellement 84 visiteurs
Mercredi 13 Décembre 2017
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

mplayer plein écran

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

mplayer plein écran

Message le 19 Déc 2003 22:41

salut!

je suis tout nouveau sous linux (mandrake 9.1)!

tout se passe bien, en gros, mais je n'arrive pas à lire les divx en plein écran... quand je veux passer en full screen, le film reste en tout petit au milieu d'un océan de noir.

j'ai un xp 1600+, et une 3D prophet 4000XT.

merci d'avance!

PS. vous avez une solution hors ligne de commande? :oops:
en fait j'ai cherché un peu sur le net quelques solutions, j'ai tenté la commande -fs zoom, indiquée pour ce genre de symptome, mais ça marche pas.
tontonsigmund
Apprenti(e)
Apprenti(e)
 
Messages: 38
Inscription: 04 Mai 2003 15:43
 


Re: mplayer plein écran

Message le 19 Déc 2003 23:16

tontonsigmund a écrit:salut!
je suis tout nouveau sous linux (mandrake 9.1)!

Sois le bienvenu !

tout se passe bien, en gros, mais je n'arrive pas à lire les divx en plein écran... quand je veux passer en full screen, le film reste en tout petit au milieu d'un océan de noir.

mplayer est un programme tres modulaire, par défaut il sait gérer le décodage du film, le filtrage, le post-processing et pas mal d'autre chose, mais tout ce qui est de la sortie vers des périphériques (audio/video) est passé a d'autres programmes/bibliotheques, notemment pour tout ce qui concerne le redimensionnement, etc...
En somme il ne fait qu'appliquer un des principes de base des programmeurs unix: ne pas réinventer la roue a chaque fois, utiliser les outils déja existants...

En bref, pour le redimentionnement de ta vidéo, il te faut
- soit un "driver video spécial" inclus dans mplayer qui fait ca tout seul (ce qui n'est apparemment pas le cas)
- soit la bibliotheque SDL
- soit utiliser Xv

En résumé: commence par installer le package de la bibliotheque SDL (libsdl) avec ton gestionnaire de packages (rpmdrake).

Ensuite, pour lancer ton film, ouvre un terminal et tapes :
mplayer -vo sdl /le/repertoire/de/ton/film.avi

et une fois que le film est lancé appuie sur 'F' pour essayer de le mettre en plein écran. Si cela ne change rien, reviens nous raconter...

Si ca marche, reviens aussi pour que l'on t'explique comment faire pour éviter de mettre les parametres sur la ligne de commande...
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 19 Déc 2003 23:19

Sinon utilise le logiciel Xine (plus simple a utiliser & configurer mais avec bcp d'options) ou Totem (simple, peu d'options) ...
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 20 Déc 2003 12:35

salut glenux

merci pour cette prompte et pédagogique réponse. :D

alors...
1) pour ce qui est des packages sdl, je les ai téléchargés et installés sans problème.
2) xine, oui, j'ai tenté de jouer des divx avec lui, qui passe effectivement sans problème en plein écran.. ou presque sans problème: l'image est crade, j'ai l'impression qu'il passe en plein écran sans changer la résolution par rapport au petit écran de départ (suis-je clair??)
3) j'ai tenté la ligne de commande que tu m'as indiquée, et alors là, deux choses:
- soit il plante (ne lance pas le fichier mais répond bien à la commande puisqu'il indique toute une liste d'action qu'il semble entreprendre mais rien ne s'affiche, et, chose génante la souris ne répond plus)
- soit il refuse de lancer le fichier en me disant : "bash: syntax error near unexpected token `(' " ; ça dépend des fichiers en fait... un peu étrange..

enfin, je suis allé farfouiller dans mplayer en mode graphique, et j'ai vu que le driver audio utilisé était "sdl", et le driver vidéo "x11" (j'ai tenté avec les autres drivers vidéos, et il refuse)


... voilà en gros les résultats de ces quelques tentatives.




PS. je pars en vacances cet après midi, alors si je ne réponds pas à de nouveaux conseils, ne croyez pas que je sois un grossier personnage sans aucune reconnaissance! je referai signe de vie dans une semaine!
tontonsigmund
Apprenti(e)
Apprenti(e)
 
Messages: 38
Inscription: 04 Mai 2003 15:43
 

Message le 20 Déc 2003 15:04

ok on m'a conseillé de modifier le fichier mplayer.conf. ce que j'ai fait. ça marche maintenant!

seulement j'ai droit à un décalage son / image croissant...

:cry:
tontonsigmund
Apprenti(e)
Apprenti(e)
 
Messages: 38
Inscription: 04 Mai 2003 15:43
 

Message le 20 Déc 2003 15:27

tontonsigmund a écrit:enfin, je suis allé farfouiller dans mplayer en mode graphique, et j'ai vu que le driver audio utilisé était "sdl", et le driver vidéo "x11" (j'ai tenté avec les autres drivers vidéos, et il refuse)

Tu as essayé sdl et Xv comme mode vidéo ?

seulement j'ai droit à un décalage son / image croissant...


Ajoute :
framedrop = yes
a ton fichier .mplayer/config

Tu peux également changer le mode audio en "oss" au lieu de "sdl" ...
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 20 Déc 2003 15:45

Tu as essayé sdl et Xv comme mode vidéo ?

oui j'ai tenté et il me dit : error opening initializing the selected video out device

le framedrop est déjà réglé sur "yes" et passer en "oss" au lieu de "sdl" ne change rien..

par contre, j'ai mis "enable frame dropping" en mode graphique.. et le tout se resynchronise.. autrement dit: mille mercis glenux!!!

bon ben cette fois je crois que tout est réglé. je vous souhaite à tous de bonnes fêtes!

encore merci!
tontonsigmund
Apprenti(e)
Apprenti(e)
 
Messages: 38
Inscription: 04 Mai 2003 15:43
 



Sujets similaires

Message Ecran Bleu
Bonsoir à tous,Voilà presque un an que j'ai ce problème et je ne sais vraiment pas quoi faire, starf.Mon pc, à des moments totalement hasardeux, se mets à m'afficher cette écran ( désolé pour la qualitey de l'image)Donc j'explique très rapidement: j'avais win 7, j'suis passer à win 10 à ses débuts p ...
Réponses: 5

Message Ecran ne fonctionne plus sur ordinateur portable ASUS
Bonjour tout le monde,Ce weekend, j'ai eu la bonne idée de démonter mon ordinateur portable (Asus ROG G751JY) pour le dépoussiérer un peu.Après l'avoir remonter entièrement, j'ai la joie de m'apercevoir que mon écran ne s'allume plus lors de l'allumage de mon PC. Je le branche donc en HDMI sur la TV ...
Réponses: 1

Message Black out écran
Bonjour à tous,Je viens vers vous car je rencontre un petit soucis (config : W10 , CPU : i5 6500, GPU : R9380, 8 go de ram, DD 1To, avast en anti-virus et comodo en pare-feu). Il est arrivé que mon écran devienne tout noir (led orange) et que le son du PC se coupe, en pleine utilisation. La tour res ...
Réponses: 17

Message ecran bleu...virus???pilotes??je suis perdu...->hijack this
salut a tous je suis nouveau, je vien de m'inscrire. je viens a vous pour un probleme que tout le monde doit connaitre, les fameux ecrans bleus... voici ma config(je ne peut l'enregistrer car dans la liste proposée, je n'ai pas la marque de pc...) tour: IQON (philips) carte mere: Foxconn P4M800P7MB ...
Réponses: 38

Message Problème démarrage d'écran.
Bonsoir,Lorsque j'allume mon pc de bureau, mes écrans restent noir malgré qu'ils fonctionnent quand même.Ma config :Alim lepa 550wram 2x4go ddr3i5 3ghzEcrans de 60 hertz.Carte graphique : gigabyte GeForce 1050 TiJ'ai fait plusieurs test :- Tester les écrans sur un autre pc, ils fonctionnent.- Tester ...
Réponses: 8

Message petit carré noir sur l'écran
Bonjour à tous,Alors depuis quelques jours j'ai un carré noir qui apparait sur mon écran de pc il doit faire 5mm/5mm pas plus et il est toujours au même endroit. Je suis sous W8 64bitsMerci d'avance pour votre aide ++ Whishess
Réponses: 5

Message SOS plus d'écran LENONO
Bonjour et merci de lire mon SOS.Je viens de rejoindre le forum, j'y ai cherché des réponses mais pour le moment mon portable est toujours en panne.Voila le problème...J'ai un portable thinkpad lenovo X240 qui a maintenant quelques années mais qui fonctionne toujours très bien, en tous cas tout sauf ...
Réponses: 2


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité


.: Nous contacter :: Flux RSS :: Données personnelles :.