Il y a actuellement 101 visiteurs
Dimanche 17 Décembre 2017
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

pkoi mon linux9.1rame , meme sur des jeux de merde!!!

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

Que fais tu principalement sous linux?

Le sondage s’est terminé le 23 Nov 2003 12:05

je joues
0
Aucun vote
je programmes
0
Aucun vote
je tapes des conneries dans la console...
0
Aucun vote
je joues , je programmes, comme sous windows mais en gratuit quoi !!!
1
100%
 
Nombre total de votes : 1

pkoi mon linux9.1rame , meme sur des jeux de merde!!!

Message le 16 Nov 2003 12:05

Salut tt le monde!!!!
Ca fait quelques mois que je me mets à linux (madrake 9.1) , je m'en sers pour la programmation (pascal , c++ , prologue , diglog ...).
Cependant g installé les jeux fourni avec linux, mais ils rament à mort, alors que sous linux je fais tourner des jeux 10 fois mieux (graphiquement mais bcp moins pourri qu'une course de pingouins (pour ceux qui connaissent!!)).
J'aimerai savoir pourquoi et , si possible résoudre ce problème pour essayer ce jeux qui a l'air merveilleux (course de pingouins : et oui j'adore les pingouins qui glissent sur le ventre pour aller à toute vitesse ....... enfin bref!!).
J'ai cru comprendre que ct parce que linux ne se sert pas de ma carte graphique (geforce 2) qu'il reconnait bien pourtant.
Faut il installer quelque chose ?
Faut il configurer autre chose ?
Faut il taper des lignes de codes incompréhensibles dans la console ?
Faut il ne pas jouer avec des pingouins sous linux ?
.....

Aidez moi , j'ai besoin de vous alors ne faites pas les rats!!!! :wink:
Bon allez ++
Avatar de l'utilisateur
capunk2
Sous Expert(e)
Sous Expert(e)
 
Messages: 63
Inscription: 27 Oct 2003 10:44
Localisation: nantes
 


Re: pkoi mon linux9.1, meme sur des jeux de merde

Message le 16 Nov 2003 14:24

capunk2 a écrit:Salut tt le monde!!!!
Cependant g installé les jeux fourni avec linux, mais ils rament à mort, alors que sous linux je fais tourner des jeux 10 fois mieux (graphiquement mais bcp moins pourri qu'une course de pingouins (pour ceux qui connaissent!!)).
[...]
J'ai cru comprendre que ct parce que linux ne se sert pas de ma carte graphique (geforce 2) qu'il reconnait bien pourtant.

Manifestement tu as un probleme avec ta carte graphique...

Faut il installer quelque chose ?
Faut il configurer autre chose ?
Faut il taper des lignes de codes incompréhensibles dans la console ?
Faut il ne pas jouer avec des pingouins sous linux ?

commence par ouvrir un terminal et tapes glxinfo dedans, et dis nous ce que ca te sort...

D'autre part tu peux aussi nous envoyer ton fichier de configuration de XFree (/etc/X11/XF86Config-4 normalement) afin de voir si c'est cun probleme de driver ou de config.
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 21 Déc 2003 12:51

a y'est g tappé glxinfo , et voila se qu'il me met:

glxinfo
name of display: :0.0
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
client glx vendor string: SGI
client glx version string: 1.2
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 24 tc 1 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 0 0 None
0x24 24 tc 1 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 0 0 None
0x25 24 tc 1 24 0 r y . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x26 24 tc 1 24 0 r . . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x27 24 dc 1 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 0 0 None
0x28 24 dc 1 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 0 0 None
0x29 24 dc 1 24 0 r y . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x2a 24 dc 1 24 0 r . . 8 8 8 8 0 16 8 16 16 16 16 0 0 None

C grave docteur?

Merci pour vos réponses nombreuses (enfin j'espères!)
Avatar de l'utilisateur
capunk2
Sous Expert(e)
Sous Expert(e)
 
Messages: 63
Inscription: 27 Oct 2003 10:44
Localisation: nantes
 

Message le 21 Déc 2003 13:01

capunk2 a écrit:glxinfo
name of display: :0.0
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0 screen: 0
direct rendering: No


Forcément ... ca n'est pas fluide avec ce que tu as...

Voila ce que ca devrait donner :

name of display: :0.0
display: :0 screen: 0
direct rendering: Yes


C grave docteur?

Non, il faut juste dire a XFree d'utiliser le DRI...

Peux tu nous donner le contenu du fichier /etc/X11/XF86Config-4 ? (pour voir si le module du DRI est bien chargé)
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 21 Déc 2003 14:38

voici le contenu du fichier /etc/X11/XF86Config-4 :

# File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbCompat" ""
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
HorizSync 30-70
VertRefresh 50-150

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce2 DDR (generic)"
Driver "nv"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection
Avatar de l'utilisateur
capunk2
Sous Expert(e)
Sous Expert(e)
 
Messages: 63
Inscription: 27 Oct 2003 10:44
Localisation: nantes
 

Message le 21 Déc 2003 15:25

capunk2 a écrit:voici le contenu du fichier /etc/X11/XF86Config-4 :


C'est toi qui a choisi la config de ta carte graphique ou a-t-elle été détectée & configurée toute seule ?

Il y a de fortes chances que les drivers utilisés par mandrake ne soient pas les drivers "complets" de Nvidia ( parce que non libres ).
Il faudra donc probablement installer à la main les drivers binaires de nvidia.

Ces liens montrent la configuration de cartes Nvidia :
http://justlinux.free.fr/nvidia/nvidia.html
http://perso.wanadoo.fr/newbielinux/drivers/nvidia.htm

P.S: profite en pour envoyer un mail a Nvidia pour leur demander qu'ils fournissent des driver opensource ou les spécifications de leurs cartes aux développeurs de Xfree, (ou au minimum un script d'installation automatique) parce que :
- le matériel qu'ils fournissent est du matériel compatible PC et qu'il n'y a pas de raison de privilégier tel ou tel OS (surtout lorsque leurs drivers existent...)
- si c'est un probleme de drivers, ou de développement, il se trouve que la communauté linuxienne est prete a développer tous ce qu'il faut, mais pour cela il faut les spécification du matériel ou les sources des drivers...
- avec leur comportement actuel ils perdent bcp de clients Linuxiens...
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 21 Déc 2003 23:52

Ceci dit, Nvidia fournit des pilotes pour Linux, sur cette page notamment.
Pas d'ambition. Pas de concessions. Peu d'argent. Beaucoup d'amour. Beaucoup d'amis. Pas de calculs. [J. Lacarrière, Sourates]
Avatar de l'utilisateur
e-didier
PC-Infopraticien
PC-Infopraticien
 
Messages: 7022
Inscription: 07 Nov 2002 10:14
Localisation: Périgord
 

Message le 23 Déc 2003 22:30

C'est toi qui a choisi la config de ta carte graphique ou a-t-elle été détectée & configurée toute seule ?

c linux qui l'a détectée tout seul!!

Sinon pour les liens que vous m'avez donné, je les ai regardé vite fait , et ca m'a pas trop inspirer!!
Fo que je regarde lesquels driver fo que je télécharge (pour ma povre geforce2!!!) , et puis avant d'essayer n'importe quoi et de faire buguer mon linux (qui m'est assez précieux, surtout pour tous les projets que je dois rendre.....ect), je voulais savoir ce qu'il allait se pacer si je faisais une quconque fausse manip (bug d'affichage , plus rien a l'écran...).
Et si bug il risque d'y avoir : quelles précotions dois je prendre pour les éviter?

Merci et bonnes fêtes a tous : :P

PS: comment faites vous pour mettre "capunk2 à dit :" au dessus des citations? (et oui je suis curieux!! :oops: )
Avatar de l'utilisateur
capunk2
Sous Expert(e)
Sous Expert(e)
 
Messages: 63
Inscription: 27 Oct 2003 10:44
Localisation: nantes
 

Message le 23 Déc 2003 22:42

capunk2 a écrit:PS: comment faites vous pour mettre "capunk2 à dit :" au dessus des citations? (et oui je suis curieux!! )

Faut que la citation commence comme ça : [quote="capunk2"]. Donc tu rajoute à la main le "nomdumecquetucites"
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8882
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 24 Déc 2003 00:55

Il y a aussi un bouton "Citer" en haut à droite des messages.
Pas d'ambition. Pas de concessions. Peu d'argent. Beaucoup d'amour. Beaucoup d'amis. Pas de calculs. [J. Lacarrière, Sourates]
Avatar de l'utilisateur
e-didier
PC-Infopraticien
PC-Infopraticien
 
Messages: 7022
Inscription: 07 Nov 2002 10:14
Localisation: Périgord
 

Salut

Message le 02 Jan 2004 14:54

Salut mon ptit gars...

J'ai eu les mêmes problèmes avec ma nvidia sous Linux.... Pourkoi ca rame alors que Linux est censé être moins demandeur que Windows ???

Faut juste que tu installes tes drivers nvidia et apres tu auras plus (comprendre pu) de problèmes... Pour cela telecharge le nvidia-installer dispo sur leur site...
Ensuite tu lances ta connexion, tu tapes init 3 et tu lances nvidia-installer, ca te telechargera auto les derniers driver dispo pour ta carte et ensuite tu pourra jouer autant que tu veut (et bien mieux qke sous windows)

A+
Jmix90
Webmaster/Codeur junior
jmix90
Apprenti(e)
Apprenti(e)
 
Messages: 34
Inscription: 02 Jan 2004 13:55
 



Sujets similaires

Message Problème de puissance en jeux
Salut!J'ai un petit soucis avec ma config en jeux. D'abord je met ma config:-Intel core i5 760-Carte mere Asus P7P55D-AMD HD 7900 Series 3Go-16 Go RAM DDR3-Disque dur méchaniqueJe joue pour ainsi dire qu'avec des jeux Total War; et ce PC c'est un pote qui me l'a offert car il s'en fesait un autre en ...
Réponses: 3

Message configuration jeux pc
bonsoir je voudrais prendre un jeux sur steam mais j'ai un doute sur le fait que le jeu soit compatible avec mon pc quelqu?un pourrait me le confirmer.configuration requise du jeu (The Elder Scrolls IV: Oblivion® Game of the Year Edition) Interface : Windows XP, Windows 2000, Windows XP 64-BitProces ...
Réponses: 4

Message Casque de jeux qui ne marche pas
bonjour, étant néophyte dans le domaine de l'informatique je me permet de vous demander conseil pour un problème qui me semble insoluble.Voila j'ai un casque Turtle Beach Stealth 400 que je voudrais utilisé pour jouer sur mon pc, cependant il n'a pas l'air de marché, je m'explique.La clée Usb qui se ...
Réponses: 3

Message impossible de désinstaller AVG même avec remover
Bonjour à tous,Je vous écris (de nouveau ) car je ne peux pas supprimer AVG, et il m'embête toujours autant. J'ai essayé de passer par panneau de configuration, j'ai même essayé AVG Remover mais rien n'y fait. AVG Remover m'indique qu'il ne trouve aucun AVG actif sur mon pc...J'ai essayé de télécha ...
Réponses: 7

Message impossible de supprimer AVG même avec AVG Remover
Bonjour à tous, Je vous écris (de nouveau ) car je ne peux pas supprimer AVG, et il m'embête toujours autant. J'ai essayé de passer par panneau de configuration, j'ai même essayé AVG Remover mais rien n'y fait. AVG Remover m'indique qu'il ne trouve aucun AVG actif sur mon pc...J'ai essayé de téléch ...
Réponses: 1

Message Problème de ping uniquement sur les jeux
Bonjour à tous! Je viens de faire l'acquisition du Asus ROG FX502VM-FY526T et tout allait bien jusqu'à ce que je me rende compte que j'ai de gros freezs quand je joue en ligne (500-600 ms) mais quand je fais un test je tourne vers les 30 de ping. En plus je remarque que le problème se règle dès que ...
Réponses: 4

Message les jeux steam ne demarre pas!!!!!!
lorsque je veux lancer un jeux, nimporte lekel depuis steam ou depuis le cd, il me mettent le petit rectangle qui me di kil y a preparation du lancement du jeu puis apre o lieu de me mettre la page ac jouer... il ny a rien, rien ne ce passe comme javé klické sur rien!!!!! est ce ke kelk1 pe maider a ...
Réponses: 6


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.