Il y a actuellement 110 visiteurs
Mercredi 19 Juin 2019
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

[Problème]Création d'un accès FTP sous OpenMediaVault

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

[Problème]Création d'un accès FTP sous OpenMediaVault

Message le 08 Mar 2019 11:14

Bonjour,
je possède un serveur qui tourne sous OpenMediaVault et j'aimerais le configurer comme serveur FTP.
J'ai réussis a m'y connecter de l'extérieur via le port 21 que j'ai ouvert sur ma box mais lorsque j'essaie d'activer les certificats SSL/TLS pour sécuriser la connexion de l'exterieur ça ne fonctionne pas alors qu'en LAN bien.
J'en déduit donc que c'est une histoire de port mais les quels ouvrir? Il y en a tellement!
Je suis également perdu avec le mode actif et le mod passif...
Quelqu'un saurait m'aider ?

Voici le retour que j'ai sur le client filezilla:
Code: Tout sélectionner
Connexion établie, attente du message d'accueil...
Statut :   Initialisation de TLS...
Statut :   Vérification du certificat...
Statut :   Connexion TLS établie.
Statut :   Connecté
Statut :   Récupération du contenu du dossier...
Statut :   Le serveur a envoyé une réponse passive avec une adresse non routable. Adresse remplacée par celle du serveur.
Commande :   MLSD
Erreur :   Connection interrompue après 20 secondes d'inactivité
Erreur :   Impossible de récupérer le contenu du dossier


Cordialement
HiiiroZZ
Visiteur Confirmé
Visiteur Confirmé
 
Messages: 14
Inscription: 20 Mai 2016 17:17
 


Re: [Problème]Création d'un accès FTP sous OpenMediaVault

Message le 09 Mar 2019 14:06

Il faudra effectivement pour le SSL utiliser un port non standard de ton choix et pas déjà utiliser

tu as configurer quoi les ports ?
listen_port = ?
ftp_data_port = ?
pasv_min_port = ?
pasv_max_port = ?
Ne pas faire demain ce que tu peux faire aujourd'hui !!!
Image
Avatar de l'utilisateur
webdesigner
PC-Infopraticien
PC-Infopraticien
 
Messages: 2874
Inscription: 13 Aoû 2008 14:46
Localisation: Vernou la Celle sur Seine
 

Re: [Problème]Création d'un accès FTP sous OpenMediaVault

Message le 14 Mar 2019 10:40

Bonjour, j'utilise l'OS OpenMediaVault et la fonctionnalité FTP qui est intégrer de base.
J'ai juste le choix de modifier le port par défault et d'activer la plage de port passif...
Je ne sais pas quel port je dois ouvrir en plus que le 21 et je ne sais pas non plus comment savoir quel ports sont nécessaires...
HiiiroZZ
Visiteur Confirmé
Visiteur Confirmé
 
Messages: 14
Inscription: 20 Mai 2016 17:17
 

Re: [Problème]Création d'un accès FTP sous OpenMediaVault

Message le 14 Mar 2019 11:58

Cela donne quoi dans le panneau de OpenMediaVault tu dois voir un message vers le bas au niveau de l'onglet SSL
Server setup
Port 80 must be open for let's encrypt to verify your domain



Dans système => Paramètre généraux => Administration Web avec le port 80 par défaut de défini et plus bas le port 443 pour la connection sécurisé avec deux options

Active la connexion sécurisé déjà fait à priori
et
Force les connections sécuriées
Ne pas faire demain ce que tu peux faire aujourd'hui !!!
Image
Avatar de l'utilisateur
webdesigner
PC-Infopraticien
PC-Infopraticien
 
Messages: 2874
Inscription: 13 Aoû 2008 14:46
Localisation: Vernou la Celle sur Seine
 

Re: [Problème]Création d'un accès FTP sous OpenMediaVault

Message le 14 Mar 2019 12:37

Tu parles du panneau d'administration en ligne ?

J'utilise le port 82 pour mon serveur et j'ai bien forcer le SSL/TLS sur le port 443...
Les deux ports sont bien ouvert sur ma box.
HiiiroZZ
Visiteur Confirmé
Visiteur Confirmé
 
Messages: 14
Inscription: 20 Mai 2016 17:17
 

Re: [Problème]Création d'un accès FTP sous OpenMediaVault

Message le 14 Mar 2019 15:44

[quote]Les deux ports sont bien ouvert sur ma box[/quote]

d'accord mais tu as quoi comme Box internet et lorsque tu dis port ouvert tu veux dire que tu as fait les redirections sur la bonne IP ?
Ne pas faire demain ce que tu peux faire aujourd'hui !!!
Image
Avatar de l'utilisateur
webdesigner
PC-Infopraticien
PC-Infopraticien
 
Messages: 2874
Inscription: 13 Aoû 2008 14:46
Localisation: Vernou la Celle sur Seine
 

Re: [Problème]Création d'un accès FTP sous OpenMediaVault

Message le 14 Mar 2019 16:00

Etant belge j'ai une BBox3 de chez proximus, j'ai ouvert les ports et je les ai rediriger vers ma machine.
L'ouverture des ports fonctionne car j'ai accès a mon site internet qui tourne avec nginx depuis l'extérieur, mais se qui est bizarre c'est que je n'arrive pas à accèder au panneau de configuration en ligne de OMV de l'extérieur alors que les ports sont bon...

En soit le ftp fonctionne de l'extérieur quand il n'est pas sécuriser, c'est juste quand j'active et que je force le SSl/TLS pour celui-ci.
HiiiroZZ
Visiteur Confirmé
Visiteur Confirmé
 
Messages: 14
Inscription: 20 Mai 2016 17:17
 

Re: [Problème]Création d'un accès FTP sous OpenMediaVault

Message le 15 Mar 2019 10:32

j'essaie d'activer les certificats SSL/TLS pour sécuriser la connexion de l'exterieur


Dit moi c'est quoi comme certificat que tu utilises est-ce que il est valide ? Tu peux avoir un problème si tu utilises un certificat auto-signé certes le contenu sera crypté mais risque dans certains cas de ne pas fonctionné ...
Ne pas faire demain ce que tu peux faire aujourd'hui !!!
Image
Avatar de l'utilisateur
webdesigner
PC-Infopraticien
PC-Infopraticien
 
Messages: 2874
Inscription: 13 Aoû 2008 14:46
Localisation: Vernou la Celle sur Seine
 

Re: [Problème]Création d'un accès FTP sous OpenMediaVault

Message le 16 Mar 2019 12:50

Bonjour, non ils se ne sont pas validés, c'est des certificats créés à partir de OMV, ils sont auto signé... Ce que je ne comprend pas c'est que lorsque j'accède en local a mon serveur FTP et que les certificats sont activés, cela me met un message qui me dit que les certificats du serveur sont inconnus et ça me demande si je veux leurs faire confiances...
C'est n'est uniquement que lorsque je veux accéder à mon serveur depuis l'extérieur que ça ne va pas...
HiiiroZZ
Visiteur Confirmé
Visiteur Confirmé
 
Messages: 14
Inscription: 20 Mai 2016 17:17
 

Re: [Problème]Création d'un accès FTP sous OpenMediaVault

Message le 17 Mar 2019 14:30

Vous avez une idée de ce que ça pourrait être ?
HiiiroZZ
Visiteur Confirmé
Visiteur Confirmé
 
Messages: 14
Inscription: 20 Mai 2016 17:17
 

Re: [Problème]Création d'un accès FTP sous OpenMediaVault

Message le 19 Mar 2019 19:01

tu sais certains logiciel ou programme n'accepte pas les certificats auto signé, j'ai eu des problèmes avec des messageries de mail et FTP certains logiciels n'accepte d'aller plus loin d'autre oui du coup j'ai commencé à utiliser Let's Encrypt pour palier à cela.

Si c'est auto-signé et local cela doit passer par qu'il voit que c'est pas loin si je peux dire et qu'il doit avoir accès au fichier pour que cela fonctionne hors dans un certificat validé il doit y avoir un échange de clé des deux côtés pour qu'il soit valide les fameuses clés public et clé privée
Ne pas faire demain ce que tu peux faire aujourd'hui !!!
Image
Avatar de l'utilisateur
webdesigner
PC-Infopraticien
PC-Infopraticien
 
Messages: 2874
Inscription: 13 Aoû 2008 14:46
Localisation: Vernou la Celle sur Seine
 



Sujets similaires

Message problème d'appairage cpl netgear
Bonjour,mon problème est le suivant :j'ai deux plug netgear que j'utilisais avec ma box orange, je les avais appairés et tout fonctionnait parfaitement.je viens de passer chez sfr et là impossible de les appairer pour internet en filaire sur mon ordinateur.j'ai fait la même manip que d'habitude, mai ...
Réponses: 6

Message Problème de clic de souris
Hello ! J'espère être au bon endroit. Je rencontre un problème assez énervant depuis quelques jours avec ma souris, et bizarrement c'était dans les alentours où j'ai fais une màj windows 10. Voilà quand je clique j'ai l'impression que c'est trop sensible, et c'est comme si ca cliquait 2 fois au lieu ...
Réponses: 7

Message Probleme PC Bureau HP
Bonjour,BonsoirJe vien vers vous aujourd'hui car j'ai un probleme de micro freeze ma souris freeze de temps en temps je n'arrive pas a connaitre la cause du probleme ce probleme est apparue lorsque j'ai installer la derniere mise a jour de ma carte graphique qui est un APU Radeon r4 Graphics j'aurai ...
Réponses: 10

Message problème de connexion
Bonjour a tous pour les besoins de logiciel qui ne marche que sur Windows XP j'ai installé windows Virtual PC & et Windows XP mode sur un Windows 7 qui a une connexion internet par wifi de mon téléphone portable aucun souci petit bémol impossible d'avoir une connexion sur XP mode ??? merci d'ava ...
Réponses: 1

Message probleme recent ejection cle ou disque dur usb
salut tout le monde !depuis 3 ou 4 jours est ce un hasard ? après la mise a jour Windows 10 en version 18362.116 (64-bit OS) je n'arrive plus par l 'icône de la barre des taches à éjecter sans problème mon périphérique USB clé ou disque dur externe ...savez vous quel pourrai être ce petit problème ...
Réponses: 26

Message Problème avec casque razer tiamat 7.1 v2
Bonjour à tout le mondej'ai fait l?acquisition d'un casque razer tiamat 7.1 V2,et comme beaucoup de monde d?après ce que j'ai pu lire dans certain post il m'est impossible d'arriver à trouver un son correct (soit pas de basse,soit un son cristalin, soit un bruit de fond en permanence dans le casque) ...
Réponses: 1

Message [résolu] problème avec un epson xp-225 serie
bonsoir suite a de multiple soucis, j'ai réinstallé mint, tout va bien sauf l'imprimante, comme d'habitude mais elle est détectée.quand j'imprime elle reste sur inactif et imprime n'importe quoi .j'édite : j'ai installé le paquet : epson-inkjet-printer-escpr_1.6.22-1lsb3.2_amd64.debc'est toujours ...
Réponses: 11


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité


.: Nous contacter :: Flux RSS :: Données personnelles :.