Il y a actuellement 88 visiteurs
Dimanche 21 Janvier 2018
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

Probleme Data Binding Server Error in '/' Application.

Des difficultés avec un site internet ? Besoin d'aide pour configurer votre PC ou tout autre type de matériel informatique avec votre modem, votre routeur, votre connexion adsl et toutes vos liaisons sans fil Wi-Fi, Bluetooth et Infra-Rouge ? Posez vos questions sur ce forum d'entraide.

Probleme Data Binding Server Error in '/' Application.

Message le 04 Aoû 2013 10:49

Bonjour à tous,
quand je suis sur un site web j'ai des pages que je ne peux pas afficher, avec un message d'erreur que je ne comprends pas, voici le copier-coller intégral du message d'erreur que j'obtiens si je veux accéder à certains liens:





Server Error in '/' Application.

DataBinding: 'System.Data.Common.DataRecordInternal' does not contain a property with the name 'id'.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Web.HttpException: DataBinding: 'System.Data.Common.DataRecordInternal' does not contain a property with the name 'id'.

Source Error:


Line 7: <asp:Repeater ID="info_link" runat="server">
Line 8: <ItemTemplate>
Line 9: <li><a target="new" href='/link.aspx?linkid=<%#Eval("id")%>'><%#Eval("strname ")%></a></li>
Line 10: </ItemTemplate>
Line 11: </asp:Repeater>

Source File: E:\webroot\Shayanashop\Controls\infoLink.ascx Line: 9

Stack Trace:


[HttpException (0x80004005): DataBinding: 'System.Data.Common.DataRecordInternal' does not contain a property with the name 'id'.]
System.Web.UI.DataBinder.GetPropertyValue(Object container, String propName) +8672885
System.Web.UI.DataBinder.Eval(Object container, String[] expressionParts) +92
System.Web.UI.DataBinder.Eval(Object container, String expression) +106
System.Web.UI.TemplateControl.Eval(String expression) +40
ASP.controls_infolink_ascx.__DataBind__control3(Ob ject sender, EventArgs e) in E:\webroot\Shayanashop\Controls\infoLink.ascx:9
System.Web.UI.Control.OnDataBinding(EventArgs e) +99
System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding) +92
System.Web.UI.Control.DataBind() +15
System.Web.UI.Control.DataBindChildren() +211
System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding) +102
System.Web.UI.Control.DataBind() +15
System.Web.UI.WebControls.Repeater.CreateItem(Int3 2 itemIndex, ListItemType itemType, Boolean dataBind, Object dataItem) +124
System.Web.UI.WebControls.Repeater.CreateControlHi erarchy(Boolean useDataSource) +443
System.Web.UI.WebControls.Repeater.OnDataBinding(E ventArgs e) +51
System.Web.UI.WebControls.Repeater.DataBind() +75
infoLink.Page_Load(Object sender, EventArgs e) in E:\webroot\Shayanashop\Controls\infoLink.ascx.vb:3 2
System.Web.UI.Control.OnLoad(EventArgs e) +99
System.Web.UI.Control.LoadRecursive() +50
System.Web.UI.Control.LoadRecursive() +141
System.Web.UI.Control.LoadRecursive() +141
System.Web.UI.Control.LoadRecursive() +141
System.Web.UI.Control.LoadRecursive() +141
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +627

Version Information: Microsoft .NET Framework Version:2.0.50727.3649; ASP.NET Version:2.0.50727.3634

"





Je précise d'avance que tous mes navigateurs sont à jour, il y peu je n'avais aucun soucis, entre temps je n'ai rien téléchargé, même pas une musique ni fait aucune mise à jour car il n'y en a eu aucune à faire depuis quelque temps, et j'ai un pote avec un autre ordi et une autre connexion chez lui qui accede aux liens auxquels je n'arrive pas sans probleme.
De même j'ai déja réessayé en desactivant adblock et l'antivirus, même probleme. Mon antivirus ne détecte rien de particulier non plus, aucun autre probleme à déclarer à part ça et c'est assez embêtant des fois...

Voilà, help ... merci beaucoup :/
pilock
Visiteur
Visiteur
 
Messages: 1
Inscription: 04 Aoû 2013 10:46
 



Sujets similaires

Message Problème suite mise à jour W10 écran bleu
Bonjour à toutes et à tous, je viens ici en désespoir de trouver une solution à mon problème. J'ai récupérer le pc de mon amie car après une mise à jour sur W10 qui semble s'être mal passé puisqu'à présent plus moyen de l'allumer.Je vous montre le message "d'erreur" où il me demande de sél ...
Réponses: 6

Message Problème installation d'Open Media Vault
Bonjour, Je suis en train d'installer OMV sur un serveur Proliant (HP Proliant ML3580 avec 3 disques de 300Go brancher en SAS)pour en faire un NAS.Mais lors de l'installation, cela bloque au moment de la connexion sur un miroir Debian.Quelque soit le serveur choisit, le message est toujours le même: ...
Réponses: 4

Message Problème de wifi qui saute
Bonjour,j'ai un problème avec ma wifi qui saute toute les 5min, en me renseignant j'ai vu qu'il me manquait probablement quelques paquets et on m'a dit d'installer synaptic afin de pouvoir voir directement les paquets qu'il me manquait le problème c'est qu'après avoir installer synaptic impossible d ...
Réponses: 2

Message Problème avec mon ordinateur portable Toshiba Satellite
Bonjour,Depuis plus d'une semaine, j'ai un problème avec mon pc portable que je n'arrive pas à résoudre.Pour faire bref, il reste bloqué au démarrage (90% du temps avant de taper le mot de passe) comme s'il ramait énormément.Impossible de faire quoique ce soit...J'ai essayé de le restaurer à l'état ...
Réponses: 2

Message [Résolu] Problème de mise a jour Ubuntu 17.04
Bonjour à tous, Ce matin comme d'habitude je fais un petit update-upgrade dans le terminal et là petit soucis ça me fait une recherche de sources avec plusieurs error404 et ça me met de vérifier ma connexion internet alors que ma connexion est bonne puisque je fais ce sujet depuis le pc en question. ...
Réponses: 10

Message Problème de drop FPS en jeu
Bonjour, J'ai acheté une nouvelle config il y a environ 4 mois, la voici :Asus Prime z270-pi5-7600k KFA2 GTX 1070 EX 8Go16 Go RAM DDR4Je vous explique mon problème que j'ai depuis 1 semaine. Lorsque je suis en jeu (Exemple : CSGO, H1Z1, Rocket League, etc.), j'ai des drops FPS. Ces drops créent un g ...
Réponses: 5

Message [Réglé] Demande de Routman54 FRST problème Nvidia.
Rebonjour,En vue de mon problème : http://www.pc-infopratique.com/forum-informatique/erreur-installation-pilotes-nvidia-vt-84757.html Je poste ici mes deux rapports créés par le logiciel FRST que vous fournissez grâce à votre tutoriel afin de vérifier si je n'ai pas de virus ou quelque chose d'anor ...
Réponses: 5


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 7 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.