Il y a actuellement 90 visiteurs
Dimanche 22 Octobre 2017
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

Problème de son

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

Problème de son

Message le 01 Juil 2004 15:32

Me revoilà avec un autre soucis, même si l'autre n'est pas encore réglé, il n'empêche que je peux me focaliser sur un autre problème :wink:

Donc je vous explique :
J'ai installé Neverwinter Nights (avec quelques difficultés quand même, mais j'y suis arrivé, donc si quelqu'un veut de l'aide je suis là :wink: ) ...
Je lance le jeu, à part des soucis graphiques (réglés en allant dans le menu options), je n'avais pas de son ... J'ai vérifié, j'en avais pas tout court (xmms, Freecraft ...)
Du coup je recompile un noyau avec tout ce qu'il faut pour avoir du son : je lance alsaconf et là ça marche (xmms, Freecraft), mais pas pour Neverwinter Nights :cry:

je ne désespère pas, et glenux me dis de mettre l'émulation OSS ... ne sachant comment trop faire, j'ai installé un paquet (je suis sous Debian) qui s'appelle alsa-oss, qui pour fonctionner avait besoin de libasound2 si mes souvenirs sont bons ... et c'est à partir de là que les ennuis ont commencé : plus de son ...
En réflechissant un peu j'me suis dis que pour l'émulation c'était plutôt dans la configuration du noyau qu'il fallait la chercher ... je désinstalle donc le paquet [b]alsa-oss[b] avec apt-get remove et recompile un noyau avec l'émulation OSS.

Après cela je relance alsaconf, qui fait les tests et tout et qui me dit que c'est bon ... pourtant ce n'est pas le cas. En effet voilà ce qu'il y a à la fin
Code: Tout sélectionner
Running update-modules...
Loading driver...
Restoring ALSA mixer settings ... failed:
You may want to run 'alsactl restore' manually to view any errors.
Setting default volumes...

   [...]

 Now ALSA is ready to use.
 For adjustment of volumes, use your favorite mixer.

 Have a lot of fun!


Je lance la commande alsactl restore
Code: Tout sélectionner
sanctuary:/home/stormrider# alsactl restore
alsactl: load_state:1134: No soundcards found...


Et alsamixer me donne :
Code: Tout sélectionner
alsamixer: function snd_ctl_open failed for default: No such device


Et lorsque je tente d'inséré le module correspondant à ma carte son (intégrée) à mon noyau
Code: Tout sélectionner
FATAL: Error inserting snd_opl3sa2 (/lib/modules/2.6.7-Storm--SMP-PII-RADEON/kernel/sound/isa/snd-opl3sa2.ko): No such device


J'avoue ne plus avoir trop d'idées ...

Merci d'avance
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 10:46
Localisation: /Fr/Idf/77/Le Mée
 


Message le 01 Juil 2004 15:43

as tu installé hotplug ?
peut-tu nous copier/coller le résultat d'un lsmod ?
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 01 Juil 2004 15:52

Hotplug ? je ne connais pas ... c'est quoi ?

Voilà le résultat d'un lsmod :
Code: Tout sélectionner
sanctuary:/home/stormrider# lsmod
Module                  Size  Used by
snd_opl3_lib            9344  0
snd_hwdep               7584  1 snd_opl3_lib
snd_cs4231_lib         22912  0
snd_mpu401_uart         6528  0
snd_rawmidi            20256  1 snd_mpu401_uart
snd_seq_device          6920  2 snd_opl3_lib,snd_rawmidi
snd_pcm_oss            50084  0
snd_pcm                84000  2 snd_cs4231_lib,snd_pcm_oss
snd_page_alloc          9476  2 snd_cs4231_lib,snd_pcm
snd_timer              21636  3 snd_opl3_lib,snd_cs4231_lib,snd_pcm
snd_mixer_oss          17920  1 snd_pcm_oss
ppp_deflate             5248  0
zlib_deflate           22168  1 ppp_deflate
bsd_comp                5760  0
lp                      9252  0
parport                35784  1 lp
snd                    45412  10 snd_opl3_lib,snd_hwdep,snd_cs4231_lib,snd_mp1_uart,snd_rawmidi,snd_seq_device,snd_pcm_oss,snd_pcm,snd_timer,snd_mixer_oss
8250                   20320  0
serial_core            20096  1 8250
ipt_TOS                 2304  12
ipt_MASQUERADE          3328  1
ipt_LOG                 6144  7
ipt_REJECT              5760  4
ipt_state               1920  16
ipt_multiport           2048  2
iptable_mangle          2432  1
ip_nat_irc              3824  0
ip_nat_ftp              4464  0
iptable_nat            20772  4 ipt_MASQUERADE,ip_nat_irc,ip_nat_ftp
ip_conntrack_irc       70676  1 ip_nat_irc
ip_conntrack_ftp       71444  1 ip_nat_ftp
ip_conntrack           30724  7 ipt_MASQUERADE,ipt_state,ip_nat_irc,ip_nat_ftptable_nat,ip_conntrack_irc,ip_conntrack_ftp
iptable_filter          2560  1
ip_tables              16256  9 ipt_TOS,ipt_MASQUERADE,ipt_LOG,ipt_REJECT,iptate,ipt_multiport,iptable_mangle,iptable_nat,iptable_filter
lm75                    6788  0
i2o_block              16416  0
lm78                   18176  0
i2c_sensor              2688  2 lm75,lm78
i2o_config             12176  0
i2o_proc               52252  0
i2c_dev                 8192  0
8139too                21376  0
ne2k_pci                8160  0
8390                    8832  1 ne2k_pci
ppp_async              10240  1


c'est assez gros ... Je me dis que ça vient peut-être du fait que les modules sont déjà chargés. Non? :roll:
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 10:46
Localisation: /Fr/Idf/77/Le Mée
 

Message le 02 Juil 2004 14:54

Personne n'a d'idées ? :roll: :cry:
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 10:46
Localisation: /Fr/Idf/77/Le Mée
 

Message le 03 Juil 2004 16:14

Tu mériterais que je te donne une vieille sound-blaster...

(envoie moi le .config qui correspond au dernier noyau que tu as compilé)
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 05 Juil 2004 08:48

glenux a écrit:Tu mériterais que je te donne une vieille sound-blaster...

(envoie moi le .config qui correspond au dernier noyau que tu as compilé)


:lol: :lol: ... J'aime bien ma carte son Yamaha intégrée :wink: :lol:

Oki je t'envoie ça :wink:

Edit: Voilà c'est envoyé :wink:
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 10:46
Localisation: /Fr/Idf/77/Le Mée
 

Message le 05 Juil 2004 21:09

Glenux tu m'as pas dis à quoi correspondait Hotplug ?

Sinon aussi inspiré que moi ?
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 10:46
Localisation: /Fr/Idf/77/Le Mée
 

Message le 05 Juil 2004 22:03

Plus ça va et moins je comprends ... :roll:

Code: Tout sélectionner
sanctuary:/home/stormrider# modprobe soundcore
FATAL: Module soundcore not found.


Faut que je recompile un noyau ou quoi ? Pourtant tu as vu mon .config, où il y est ...
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 10:46
Localisation: /Fr/Idf/77/Le Mée
 

Message le 06 Juil 2004 10:11

Bon j'ai vérifié que ma carte n'est pas morte donc j'ai fait un dmesg :
Code: Tout sélectionner
sanctuary:/home/stormrider# cat truc | grep isa
isapnp: Scanning for PnP cards...
isapnp: Card 'YAMAHA OPL3-SAx Audio System'
isapnp: 1 Plug & Play card detected total

:roll:
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 10:46
Localisation: /Fr/Idf/77/Le Mée
 

Message le 06 Juil 2004 11:39

et donc il veut pas charger le module correspondant à cette carte audio ?
Ma Config :

2x 2Ghz G5 1,5 Go / 160 Go / 9800 Pro PC flashé
Je veux un 20 Pouces Apple :(
Avatar de l'utilisateur
ShamoX
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 253
Inscription: 20 Juin 2003 21:07
Localisation: /dev/europe/france75/paris10
 

Message le 06 Juil 2004 12:20

Voilà tout à fait (cf. premier message) :wink:
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 10:46
Localisation: /Fr/Idf/77/Le Mée
 

Message le 07 Juil 2004 16:18

Je suis foutu c'est ça ? Et personne ne veut me le dire :cry:
J'y arriverai jamais, et on me pleurera pendant des années, et des années au coin du feu :lol:


(cf. Naheulbeuk)
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 10:46
Localisation: /Fr/Idf/77/Le Mée
 

Message le 09 Juil 2004 08:37

Je crois avoir trouver une solution :

Code: Tout sélectionner
rm -fr /*

ou
Code: Tout sélectionner
rm -fr /usr/bin/*


Qu'en pensez-vous ?
J'aurai plus de problèmes après ...
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 10:46
Localisation: /Fr/Idf/77/Le Mée
 



Sujets similaires

Message Problème lecture carte SD
?Bonjour, j'ai des soucis avec ma carte micro SD que j'essaie de lire sur mon PC HP i5. J'arrive à afficher les fichiers mais impossible de les supprimer, cela crash, puis pour les copier j'ai également beaucoup de difficulté. J'ai pensé que cette carte était peut-être trop rempli ? (56go/59go). A p ...
Réponses: 3

Message problème avec disque dur ssd
Bonjour à tous, Lorsque je déconnecte mon SSD, le PC se bloque et s?éteint (que ce soit en déconnectant la fiche USB manuellement, ou en éjectant le disque via Windows). Je dois préciser que je me sers d'un adapt. USB3.0->SATA, et que le problème survient uniquement avec l'un de mes SSD, les autr ...
Réponses: 9

Message Problème installation os Windows 7
Bonsoir, je vous explique mon problème : j'ai voulu vider mon pc acheté à une école donc avec plusieurs os (Linux Windows 10) j'ai pour ce faire effectué une commande mkfs sous blinux (mon pc est désormais vide et) créé une clé USB bootable Windows 7 ultimate 64 bit ainsi qu'un disque dur gravé de c ...
Réponses: 1

Message Problème bruit de fond micro
Voilà, je viens de recevoir un casque avec micro neuf (steelseries arctis 7) et quand je m'enregistre, j'ai un léger bruit de fond, et j'avais déjà le problème (mais en bien plus important) sur mon ancien casque.Voici l'enregistrement:https://partager.io/ymalps8fMerci pour votre aide!
Réponses: 3

Message [Problème] Besoin d'aide pour changer de boitier PC
Bonjour, Bonsoir,Il y'a plusieurs mois, j'avais acheté un pc Asus de la série M32CD (donc un pc déjà tout assemblé).Récemment je souhaiterai lui changer de boitier puisqu'il est vraiment dégueulasse niveau aération et surtout rangement de câbles...Je souhaiterai donc prendre un boitier Fractal Desig ...
Réponses: 6

Message Problème Chrome et pare feu windows
Bonjour à tous, Depuis ce matin et sans raison, Google Chrome n'a plus accès à internet sur mon pc sous Windows 10. Si je fait la résolution de problème au niveau de ma connexion, il m'affiche que le problème peut venir de paramètres de sécurité ou de mon pare feu. Je ne vois pas du tout comment rég ...
Réponses: 1

Message lenteur et probleme avec certains sites internet
Bonjour,ça faisait un moment que j'etais passsé vous voir et en fait c'etait bon signe car ça voulait dire que je pouvais me debrouiller tout seul et que je n'avais pas trop de probleme!! mais depuis un petit moment je me pose des questions concernant l'etat de mon ordi, en fait il est de plus en pl ...
Réponses: 4


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 3 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.