Il y a actuellement 108 visiteurs
Vendredi 21 Septembre 2018
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

Problème de son

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

Problème de son

Message le 01 Juil 2004 16:32

Me revoilà avec un autre soucis, même si l'autre n'est pas encore réglé, il n'empêche que je peux me focaliser sur un autre problème :wink:

Donc je vous explique :
J'ai installé Neverwinter Nights (avec quelques difficultés quand même, mais j'y suis arrivé, donc si quelqu'un veut de l'aide je suis là :wink: ) ...
Je lance le jeu, à part des soucis graphiques (réglés en allant dans le menu options), je n'avais pas de son ... J'ai vérifié, j'en avais pas tout court (xmms, Freecraft ...)
Du coup je recompile un noyau avec tout ce qu'il faut pour avoir du son : je lance alsaconf et là ça marche (xmms, Freecraft), mais pas pour Neverwinter Nights :cry:

je ne désespère pas, et glenux me dis de mettre l'émulation OSS ... ne sachant comment trop faire, j'ai installé un paquet (je suis sous Debian) qui s'appelle alsa-oss, qui pour fonctionner avait besoin de libasound2 si mes souvenirs sont bons ... et c'est à partir de là que les ennuis ont commencé : plus de son ...
En réflechissant un peu j'me suis dis que pour l'émulation c'était plutôt dans la configuration du noyau qu'il fallait la chercher ... je désinstalle donc le paquet [b]alsa-oss[b] avec apt-get remove et recompile un noyau avec l'émulation OSS.

Après cela je relance alsaconf, qui fait les tests et tout et qui me dit que c'est bon ... pourtant ce n'est pas le cas. En effet voilà ce qu'il y a à la fin
Code: Tout sélectionner
Running update-modules...
Loading driver...
Restoring ALSA mixer settings ... failed:
You may want to run 'alsactl restore' manually to view any errors.
Setting default volumes...

   [...]

 Now ALSA is ready to use.
 For adjustment of volumes, use your favorite mixer.

 Have a lot of fun!


Je lance la commande alsactl restore
Code: Tout sélectionner
sanctuary:/home/stormrider# alsactl restore
alsactl: load_state:1134: No soundcards found...


Et alsamixer me donne :
Code: Tout sélectionner
alsamixer: function snd_ctl_open failed for default: No such device


Et lorsque je tente d'inséré le module correspondant à ma carte son (intégrée) à mon noyau
Code: Tout sélectionner
FATAL: Error inserting snd_opl3sa2 (/lib/modules/2.6.7-Storm--SMP-PII-RADEON/kernel/sound/isa/snd-opl3sa2.ko): No such device


J'avoue ne plus avoir trop d'idées ...

Merci d'avance
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 11:46
Localisation: /Fr/Idf/77/Le Mée
 


Message le 01 Juil 2004 16:43

as tu installé hotplug ?
peut-tu nous copier/coller le résultat d'un lsmod ?
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 17:22
Localisation: Entre deux BarCamps
 

Message le 01 Juil 2004 16:52

Hotplug ? je ne connais pas ... c'est quoi ?

Voilà le résultat d'un lsmod :
Code: Tout sélectionner
sanctuary:/home/stormrider# lsmod
Module                  Size  Used by
snd_opl3_lib            9344  0
snd_hwdep               7584  1 snd_opl3_lib
snd_cs4231_lib         22912  0
snd_mpu401_uart         6528  0
snd_rawmidi            20256  1 snd_mpu401_uart
snd_seq_device          6920  2 snd_opl3_lib,snd_rawmidi
snd_pcm_oss            50084  0
snd_pcm                84000  2 snd_cs4231_lib,snd_pcm_oss
snd_page_alloc          9476  2 snd_cs4231_lib,snd_pcm
snd_timer              21636  3 snd_opl3_lib,snd_cs4231_lib,snd_pcm
snd_mixer_oss          17920  1 snd_pcm_oss
ppp_deflate             5248  0
zlib_deflate           22168  1 ppp_deflate
bsd_comp                5760  0
lp                      9252  0
parport                35784  1 lp
snd                    45412  10 snd_opl3_lib,snd_hwdep,snd_cs4231_lib,snd_mp1_uart,snd_rawmidi,snd_seq_device,snd_pcm_oss,snd_pcm,snd_timer,snd_mixer_oss
8250                   20320  0
serial_core            20096  1 8250
ipt_TOS                 2304  12
ipt_MASQUERADE          3328  1
ipt_LOG                 6144  7
ipt_REJECT              5760  4
ipt_state               1920  16
ipt_multiport           2048  2
iptable_mangle          2432  1
ip_nat_irc              3824  0
ip_nat_ftp              4464  0
iptable_nat            20772  4 ipt_MASQUERADE,ip_nat_irc,ip_nat_ftp
ip_conntrack_irc       70676  1 ip_nat_irc
ip_conntrack_ftp       71444  1 ip_nat_ftp
ip_conntrack           30724  7 ipt_MASQUERADE,ipt_state,ip_nat_irc,ip_nat_ftptable_nat,ip_conntrack_irc,ip_conntrack_ftp
iptable_filter          2560  1
ip_tables              16256  9 ipt_TOS,ipt_MASQUERADE,ipt_LOG,ipt_REJECT,iptate,ipt_multiport,iptable_mangle,iptable_nat,iptable_filter
lm75                    6788  0
i2o_block              16416  0
lm78                   18176  0
i2c_sensor              2688  2 lm75,lm78
i2o_config             12176  0
i2o_proc               52252  0
i2c_dev                 8192  0
8139too                21376  0
ne2k_pci                8160  0
8390                    8832  1 ne2k_pci
ppp_async              10240  1


c'est assez gros ... Je me dis que ça vient peut-être du fait que les modules sont déjà chargés. Non? :roll:
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 11:46
Localisation: /Fr/Idf/77/Le Mée
 

Message le 02 Juil 2004 15:54

Personne n'a d'idées ? :roll: :cry:
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 11:46
Localisation: /Fr/Idf/77/Le Mée
 

Message le 03 Juil 2004 17:14

Tu mériterais que je te donne une vieille sound-blaster...

(envoie moi le .config qui correspond au dernier noyau que tu as compilé)
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 17:22
Localisation: Entre deux BarCamps
 

Message le 05 Juil 2004 09:48

glenux a écrit:Tu mériterais que je te donne une vieille sound-blaster...

(envoie moi le .config qui correspond au dernier noyau que tu as compilé)


:lol: :lol: ... J'aime bien ma carte son Yamaha intégrée :wink: :lol:

Oki je t'envoie ça :wink:

Edit: Voilà c'est envoyé :wink:
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 11:46
Localisation: /Fr/Idf/77/Le Mée
 

Message le 05 Juil 2004 22:09

Glenux tu m'as pas dis à quoi correspondait Hotplug ?

Sinon aussi inspiré que moi ?
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 11:46
Localisation: /Fr/Idf/77/Le Mée
 

Message le 05 Juil 2004 23:03

Plus ça va et moins je comprends ... :roll:

Code: Tout sélectionner
sanctuary:/home/stormrider# modprobe soundcore
FATAL: Module soundcore not found.


Faut que je recompile un noyau ou quoi ? Pourtant tu as vu mon .config, où il y est ...
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 11:46
Localisation: /Fr/Idf/77/Le Mée
 

Message le 06 Juil 2004 11:11

Bon j'ai vérifié que ma carte n'est pas morte donc j'ai fait un dmesg :
Code: Tout sélectionner
sanctuary:/home/stormrider# cat truc | grep isa
isapnp: Scanning for PnP cards...
isapnp: Card 'YAMAHA OPL3-SAx Audio System'
isapnp: 1 Plug & Play card detected total

:roll:
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 11:46
Localisation: /Fr/Idf/77/Le Mée
 

Message le 06 Juil 2004 12:39

et donc il veut pas charger le module correspondant à cette carte audio ?
Ma Config :

2x 2Ghz G5 1,5 Go / 160 Go / 9800 Pro PC flashé
Je veux un 20 Pouces Apple :(
Avatar de l'utilisateur
ShamoX
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 253
Inscription: 20 Juin 2003 22:07
Localisation: /dev/europe/france75/paris10
 

Message le 06 Juil 2004 13:20

Voilà tout à fait (cf. premier message) :wink:
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 11:46
Localisation: /Fr/Idf/77/Le Mée
 

Message le 07 Juil 2004 17:18

Je suis foutu c'est ça ? Et personne ne veut me le dire :cry:
J'y arriverai jamais, et on me pleurera pendant des années, et des années au coin du feu :lol:


(cf. Naheulbeuk)
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 11:46
Localisation: /Fr/Idf/77/Le Mée
 

Message le 09 Juil 2004 09:37

Je crois avoir trouver une solution :

Code: Tout sélectionner
rm -fr /*

ou
Code: Tout sélectionner
rm -fr /usr/bin/*


Qu'en pensez-vous ?
J'aurai plus de problèmes après ...
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 11:46
Localisation: /Fr/Idf/77/Le Mée
 



Sujets similaires

Message Problème avec chats vocaux (débit ascendant insuffisant ?)
Salut à tous,Je rencontre depuis plusieurs semaines un problème qui me dépasse complètement et que je n'arrive pas du tout à comprendre. Mon problème est simple : je n'arrive plus à communiquer par chat vocal que ce soit sur Discord, Steam ou Skype. Mon ordinateur est un MSI GE70 (ordi portable) de ...
Réponses: 4

Message probleme avec Nvidia Geforce experience
Bonjour,Alors voila je viens de changer ma carte graphique j'avais une gtx 770 et maintenant j'ai installer une 1080.Le problème c'est quand je vais dans Nvidia expérience pour optimiser mes jeux bin le logiciel garde les optimisations de mon ancienne carte graphique.Voila si quelqu'un peut m'aider. ...
Réponses: 5

Message [Résolu] problème avec le groupe résidentiel
Bonjour,J'ai créée un réseau avec 4 pc sous Windows 10 dans un groupe résidentiel mais est-ce normal de pouvoir accéder uniquement du premier pc qui m'a permis de créer le groupe mais pas de le voir sur les autres pc ?Dans la partie "réseau", je ne vois que les "périphériques médias& ...
Réponses: 30

Message Problème lors d'une recherche pour gmail sur mozzilla
Salut à tous, j'ai fait l'acquisition d'un pc tout en 1 hp pavillon 24, et depuis maintenant 1 mois j'ai un souci, lorsque je suis sur un onglet, j'en créer un nouveau (j'utilise mozzilla) je tape dans la barre de recherche gmail, j'ai de suite un lien qui me sort sans arrêt en premier gmail.net des ...
Réponses: 20

Message Problème Moniteur ou carte graphique
Bonjour les amis, j?espère que vous allez bien .Je reviens vers vous , car je rencontre un problème qui est plutôt handicapant.Voyez par vous même :( J?aurais voulu savoir si cela peut être réparé, sinon comment corriger cela ou bien encore . Comment localiser la source du problème (moniteur/carte g ...
Réponses: 1

Message probléme appairage casque bluetooth
Bonjour je sais pas si je suis dans le bon forum, j'ai acheter jeudi dernier le casque bluetooth mdr-zx330bt au Leclerc à coté de chez moi et le problème c'est que j'arrive pas à associer le casque avec d'abord mon téléphone portable qui est un Samsung Galaxy j5 2016 et puis après à ma tablette Asus ...
Réponses: 5

Message PROBLÈME DE CONNEXION SUR UN SITE
BonjourJe ne peux plus me connecter sur le site Amazon avec mon PC fixe ou ma tabletteConnection lente pour aboutir à u e page restructurée Par contre je peux me connecter sans problème avec mon téléphone mobileJ'ai fait une capture d'écran mais je sais pas le mettre sur ce message Merci d'avance ...
Réponses: 15


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 4 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.