Il y a actuellement 116 visiteurs
Lundi 18 Décembre 2017
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

problème dhcp avec debian gateway adsl

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

problème dhcp avec debian gateway adsl

Message le 21 Aoû 2004 09:33

Bonjour,

Je suis en train d'installer at home une debian woody (kernel recompilé en 2.6.7) pour faire une passerelle internet derrière un modem adsl ethernet eci.
Je suis les indications de formation linux d'Alexis De Lattre.

Si je suis sur la passerelle, je peux aller sur internet bien que j'ai un message de dhcpdiscover comme quoi il ne trouve pas.

Par contre, apparemment le nat ne fonctionne pas : pas d'accès depuis un autre pc sous windows sur mon réseau avec ip gateway pointant sur la passerelle.

Qq'un peut-il m'aider ?
alain999999
Visiteur
Visiteur
 
Messages: 4
Inscription: 21 Aoû 2004 09:24
 


Message le 23 Aoû 2004 16:59

Quel est le message de dhcpdiscover ?

Ta machine sous windows obtient elle une adresse ip valide ?

As-tu un firewall sur la passerelle qui pourrait bloquer les connexions de ton sous-réseau ?
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 10:46
Localisation: /Fr/Idf/77/Le Mée
 

problèmedhcp et nat

Message le 23 Aoû 2004 20:56

test ne pas tenir compte de ce message
alain999999
Visiteur
Visiteur
 
Messages: 4
Inscription: 21 Aoû 2004 09:24
 

prob adsl nat

Message le 23 Aoû 2004 21:03

j'avais fait un test car tout à l'heure j'ai répondu à ta question et le message s'est perdu.
eth0 = nic pointant vers modem adsl eci ethernet
eth1 = nic relié à switch de mon réseau local

Quel est le message de dhcpdiscover ?
dhcpdiscover on eth0 at 255.255.255.255 interval ....
no dhcp offers received
no working leases in persistent database -sleeping

Ta machine sous windows obtient elle une adresse ip valide ?
elle a une ip fixe et c'est ce que je veux (au moins pour l'instant).

As-tu un firewall sur la passerelle qui pourrait bloquer les connexions de ton sous-réseau ?
iptables configuré avec le script de alexis ...
théorqt les connexions sortantes sont autorisées

Je peux t'envoyer les fichiers de config.
Je pense à deux choses qui pourraient clocher :
- script iptables et notamment la ligne postrouting avec eth0
- options du noyau 2.6.8 recompilé non activées pour nat et firewall
Sur FReebsd, j'avais eu un soucis avec l'équivalent de eth0 et tun0 (ppp0) dans les scripts de ipfw (iptables).

Merci d'avance pour les réponses.
alain999999
Visiteur
Visiteur
 
Messages: 4
Inscription: 21 Aoû 2004 09:24
 

Message le 25 Aoû 2004 18:30

Vérifier les options du noyau serait déjà un bon point :wink:

Ensuite fais des pings entre : Passerelle -> Windows , et sens inverse. Donnes nous les résultats.

Ensuite peut-être d'abord essayer en static et passer en dhcp par la suite.

Eth0 c'est ton interface vers le modem, mais l'interface vers Internet c'est ppp0 non ?
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 10:46
Localisation: /Fr/Idf/77/Le Mée
 

prob nat ...

Message le 25 Aoû 2004 21:52

Vérifier les options du noyau serait déjà un bon point
JE NE CONNAIS PAS LES OPTIONS A INSERER

Ensuite fais des pings entre : Passerelle -> Windows , et sens inverse. Donnes nous les résultats.
CA PING DES DEUX COTES

Ensuite peut-être d'abord essayer en static et passer en dhcp par la suite.
JE SUIS EN STATIC SUR ETH1 (LOCAL) ET FORCEMENT DHCP SUR ETH0 PUISQUE RELIEE A ADSL FREE (SANS IP FIXE)

Eth0 c'est ton interface vers le modem, mais l'interface vers Internet c'est ppp0 non ?
OUI

AURAIS-TU UN SCRIPT MODELE AUTRE QUE CELUI DE FORMATION LINUX ?
JE PENSE A UN SOUCIS COTE POSTROUTING MAIS JE NE SUIS PAS SUR
alain999999
Visiteur
Visiteur
 
Messages: 4
Inscription: 21 Aoû 2004 09:24
 

Message le 26 Aoû 2004 07:24

Si tu as un doute sur tes iptables, le mieux à faire serait de toutes les loguer (acceptées et refusées).

Comme ça tu pourra avoir un suivi des requêtes de ton PC windows, et du traitement qu'il en est fait par les iptables.
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8882
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 02 Sep 2004 11:34

Tu n'es pas obligé d'être en dhcp pour eth0 : chez moi je ne le suis pas et ça marche :wink:

Utilises tu un firewall ? (genre shorewall) :roll:
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 10:46
Localisation: /Fr/Idf/77/Le Mée
 



Sujets similaires

Message Problème RAM remplacement du processeur ?
Bonjour à tous,Voilà j?ai un pc pas tous jeune un HP 8100 élite version slim et je voulais le booster un peu .J?ai donc commendé des barrettes de Ram de plusieurs marque différentes et à chaque goût le PC plante au démarrage .J?ai bien pris le modèle adapté DDR3 1333 MHz j?ai essayé plusieurs config ...
Réponses: 14

Message Problème ecran noir sur pc fixe
Bonjour j'ai un problème depuis 2 semaine mon pc je l'allume (c'est un hp) mais aucun signal sur l'écran sa me dit juste "Mise en ceille du moniteur" quand je l'allume et donc sa fait 2 semaine que je n'arrive plus a l'allumé
Réponses: 1

Message Problème :Chutes de FPS périodique
Bonjour à tous,Je me permets d?écrire ici car je rencontre un problème sur mon pc gamer.Voici mon problème :Lorsque je suis sur mon simulateur de vol x-plane 11, j'ai des chutes de FPS momentanément pour une durée d'environ de 4 secondes, c'est à dire pendant 1 minutes ou 2 je suis à 50 FPS, et d'un ...
Réponses: 10

Message Problème de déconnection intempestive de la wifi
Bonjour à tous,Tout d'abord je suis un Macuser pro au travail mais pas la force des choses, j'ai un pc Asus tournant sous Windows 10 à la maison....donc connaissance hyper basique.....Depuis certaines mise à jour de Windows, j'ai des déconnections intempestives de la wifi sur mon ordi.....et cela de ...
Réponses: 3

Message [Résolu] Problème après mise à jour
Bonjour, je suis sous Windows 7 pro, et je viens d'avoir ce message lorsque les mises à jour ont été effectuées "Windows ne peut pas mettre à jour des fichiers et services importants tant que le système les utilise. Sauvegardez vos fichiers avant de redémarrer". J'ai donc fait une analys ...
Réponses: 5

Message problème de fonts
Bonjour, je fais mon site sous ubuntu et firefox et il semble que mon gedit ne prend en compte que très peu de polices de caractère dans mon css. Pour l'heure seuls monospace serif et sans serif ont fonctionné. Je n'ai pas cursive, fantasy, et encore moins verdana. Pourtant j'ai vérifié avec gnome s ...
Réponses: 3

Message lenteur et probleme avec certains sites internet
Bonjour,ça faisait un moment que j'etais passsé vous voir et en fait c'etait bon signe car ça voulait dire que je pouvais me debrouiller tout seul et que je n'avais pas trop de probleme!! mais depuis un petit moment je me pose des questions concernant l'etat de mon ordi, en fait il est de plus en pl ...
Réponses: 7


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 3 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.