Il y a actuellement 52 visiteurs
Jeudi 20 Septembre 2018
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

[REGLE][debian] pb de son

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

[REGLE][debian] pb de son

Message le 20 Aoû 2004 10:36

Salut,
J'ai décidément bien du mal avec le son et j'aimerais repartir de 0 pour configurer tout ça.
Actuellement, les drivers ALSA sont chargés.
mon lsmod :
Module Size Used by
snd_ens1371 17544 -
snd_rawmidi 17696 -
snd_pcm 76256 -
snd_page_alloc 8712 -
snd_timer 18592 -
snd_ac97_codec 58500 -
snd 42400 -
soundcore 6720 -
intel_agp 15896 -
agpgart 26632 -
evdev 7424 -
usbkbd 5536 -
usbcore 91060 -

J'ai désactivé le module es1371 (OSS je crois) dans le /etc/modules car il devait poser problème avec les modules alsa. Mais je suis pas plus avancé.
2 soucis :
- j'ai installé XMSS et il me renvoit toujours un message d'erreur si j'essaye de lire un fichier :
'couldn't open audio".
Ceci en mettant les plugin de sortie sur ALSA (libalsa.so) ou OSS (liboss.so)
- en installant xmss, aptitude m'a suggéré et fait une mise à jour de ALSAPLAYER. Maintenant, quand je lance alsaplayer :
</home/casa> # alsaplayer test.wav
Failed to load text interface. This is bad (gtk,gtk,/usr/lib/alsaplayer)
Segmentation fault

J'aimerais donc repartir à 0.
Comment empêcher le chargement des drivers ALSA ? C'est pas dans /etc/modules, /etc/modules.conf, et j'ai essayé de mettre un exit 0 au début du script /etc/init.d/alsa mais ça change rien au niveau des modules (à part que la configuration alsal ne se lance pas).
Comment charger uniquement les drivers OSS pour tester si ça fonctionne ?
Comment remettre de l'ordre dans les drivers ALSA et pouvoir les utiliser ?
Comment faire pour alsaplayer ? Faut le remettre à jour, le désinstaller ?

ps : de plus, il m'est impossible de décharger un module avec RMMOD :
FATAL: Kernel does not have unload support.

J'ai oublié une option dans le noyau ?

Merci (ça fait beaucoup de choses...).
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8917
Inscription: 13 Mai 2003 17:32
Localisation: A.H.P... et jamais loin d'une Debian
 


Message le 20 Aoû 2004 10:55

Que donne
Code: Tout sélectionner
$ alsaconf
?
C'est sensé configurer tout tout seul :wink:

Même avec modconf tu n'arrives pas à enlever les modules ?
Sinon dans ton noyau tu as dû oublié de sélectionner l'option qui permet d'enlever un module :wink:

Vérifies que tu as bien ça de sélectionner
Loadable module support > Module unloading

:wink:
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 11:46
Localisation: /Fr/Idf/77/Le Mée
 

Message le 20 Aoû 2004 11:04

apt-get install hotplug devrait te permettre de mieux dormir (et avoir le poil doux et soyeux...)

Cet outil détecte et configure tout seul le matériel si possible...
De meme il chargera tout seul le nécessaire pour la carte son: OSS ou ALSA en fonction de tes préférences...
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 17:22
Localisation: Entre deux BarCamps
 

Message le 20 Aoû 2004 11:05

Alsaconf se passe bien. Il trouve ma carte, il modifie /etc/modprobe.d/sound avec :
alias snd-card-0 snd-ens1371
alias sound-slot-0 snd-ens1371


Mais après ? Je n'arrive pas à me servir de XMSS ou alsaplayer puisque ils tombent en erreur tous les 2.... Comment je peux corriger ça ?

Je n'ai effectivement pas mis l'option "module unloading" dans le noyau :cry: Si j'en ai besoin, il va falloir recompiler...
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8917
Inscription: 13 Mai 2003 17:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 20 Aoû 2004 11:16

glenux a écrit:apt-get install hotplug

J'ai déjà le package hotplug installé.

Par contre il est dans /etc/init.d/ mais pas dans /etc/rc2.d. Donc il ne se lance pas ? (je comprend pas tout, escuse pour les questions bêtes).

Comment ça fonctionne ? Il contrôle que les modules sont bien chargés pour les péréiphériques non ?

glenux a écrit:devrait te permettre de mieux dormir (et avoir le poil doux et soyeux...)

:D Woui, en ce moment je retape toutes les commandes Linux dans mon sommeil. Si ça peut m'aider à être plus zen...
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8917
Inscription: 13 Mai 2003 17:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 20 Aoû 2004 22:33

Bon, ben, j'ai trouvé plusieurs trucs au bout de quelques heures :

- le son était muté. Dans amixer, c'est pas le peine de mettre le son à fond s'il est muté ! J'suis vraiment un noob...
- j'ai viré alsaplayer avec apt-get, par contre aplay fonctionne bien (c'est la même chose en fait. Peut-être que ça le remplace même...)
- le plus important, j'ai trouvé un pb similaire sur un autre forum et c'était ça : en root XMMS fonctionnait / sur casa non. J'appartenais pas au groupe audio, c'est tout...

Soit dit en passant, le message de XMMS me disait de vérifier la config de ma carte : je pouvais toujours chercher...

Voilà, c'est réglé mais... juste si qqun pouvait me dire en quoi le fait d'appartenir au groupe audio donne des droits sur la lecture d'un fichier audio ? sur l'utilisation de la carte son ? sur quoi, en fait ?
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8917
Inscription: 13 Mai 2003 17:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 20 Aoû 2004 23:44

Voilà, c'est réglé mais... juste si qqun pouvait me dire en quoi le fait d'appartenir au groupe audio donne des droits sur la lecture d'un fichier audio ? sur l'utilisation de la carte son ? sur quoi, en fait ?


Si tu regarde dans /dev/ , tu veras des fichiers, chacun de ces fichiers correspond à un périphérique (présent ou non, en fonction de ce qui gère ton dev...).
Comme pour tout fichier, ceux-ci sont également soumis aux droits utilisateur/groupe/autres et aux ACL (si présentes).
Par défaut, le périphérique correspondant à la sortie audio (/dev/dsp ou /dev/sound/dsp) appartient a root et au groupe audio... (d'un autre coté, c'est logique non ?)
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 17:22
Localisation: Entre deux BarCamps
 

Message le 21 Aoû 2004 09:56

glenux a écrit:/dev/dsp ou /dev/sound/dsp

En fait, je m'en doutais et j'avais cherché ça... Mais j'ai pas de /dev/dsp ou /dev/sound/...
J'ai un /dev/rtc/ qui appartient au groupe audio. C'est le périphérique audio ?
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8917
Inscription: 13 Mai 2003 17:32
Localisation: A.H.P... et jamais loin d'une Debian
 



Sujets similaires

Message [Réglé] Ecran bleu
Bonjour les amis ! Voila j'ai mis a jour un utilitaire de mon MSI ' Battery Calibration' sur le site MSI http://www.msi.com/product/notebook/sup ... in8.1%2064 et depuis que je l'ai installé j'ai des écrans bleu qui arrive et mon ordi qui a du mal a se lancer.Comment je peux le réinstallé correcte ...
Réponses: 65

Message [Réglé] Acheter un pc ou acheter du matériel pour l'ancien?
Bonjour à toutes et à tous!Je me pose la question suivante : si je veux faire tourner des jeux triples A sur par exemple 3 ~ 4 ans, quelle serait la meilleur solution : acheter un nouveau pc avec tout les composants "à neuf" ou acheter le matériel nécessaire pour le remplacer par le matéri ...
Réponses: 18

Message [Réglé] Ornidateur bloqué sur outils de diagnostic mémoire
Bonjour,en voulant accélérer le démarrage de mon pc à la manière windows 7 (fichu windows 10), j'ai donc modifier le nombre de coeur de 1 à 3 et pour la ram j'ai coché la case "maximum" (il ne voulait pas d'une autre valeur appliquée manuellement). Sauf que je lance le redémarrage et surpr ...
Réponses: 21

Message [Réglé]Déconnexion inexplicable
Bonjour J'ai des déconnexions tous les 2-3 jours... Cela n'arrive pas à chaque fois. Quand ça le fait, j'ai le net pendant 30 secondes puis coupure... Je dois alors redémarrer le modem pour ravoir ma connexion. Le technicien est déjà passé et m'a dit que le problème venait de chez moi, de ma tour do ...
Réponses: 5

Message [Réglé] Ecran noir pas de signal en plein jeux
Ça ne peux pas être le jeu en lui-même qui me fait ça car sur 2 jeux à savoir CS GO ou Hitman Absolution ça me fait la même chose , de plus je joue toujours en faible qualité un peu partout dans les réglages.Je vais essayé en mode fenêtré si ça me fait la même chosePour information , après avoir cha ...
Réponses: 27

Message [Réglé] Ordinateur virus?
Bonjour,ça faisait quelques années que je n'avais pas eu besoin de vos services... mais je crois que depuis quelques jours mon ordinateur est infesté par soit des virus, soit par des trucs pas tres sympas....vu le succes des précédentes demandes, je me permets une nouvelle fois de vous appeler à l'a ...
Réponses: 12


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.