Il y a actuellement 91 visiteurs
Dimanche 25 Février 2018
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

[REGLE][debian] pb de son

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

[REGLE][debian] pb de son

Message le 20 Aoû 2004 09:36

Salut,
J'ai décidément bien du mal avec le son et j'aimerais repartir de 0 pour configurer tout ça.
Actuellement, les drivers ALSA sont chargés.
mon lsmod :
Module Size Used by
snd_ens1371 17544 -
snd_rawmidi 17696 -
snd_pcm 76256 -
snd_page_alloc 8712 -
snd_timer 18592 -
snd_ac97_codec 58500 -
snd 42400 -
soundcore 6720 -
intel_agp 15896 -
agpgart 26632 -
evdev 7424 -
usbkbd 5536 -
usbcore 91060 -

J'ai désactivé le module es1371 (OSS je crois) dans le /etc/modules car il devait poser problème avec les modules alsa. Mais je suis pas plus avancé.
2 soucis :
- j'ai installé XMSS et il me renvoit toujours un message d'erreur si j'essaye de lire un fichier :
'couldn't open audio".
Ceci en mettant les plugin de sortie sur ALSA (libalsa.so) ou OSS (liboss.so)
- en installant xmss, aptitude m'a suggéré et fait une mise à jour de ALSAPLAYER. Maintenant, quand je lance alsaplayer :
</home/casa> # alsaplayer test.wav
Failed to load text interface. This is bad (gtk,gtk,/usr/lib/alsaplayer)
Segmentation fault

J'aimerais donc repartir à 0.
Comment empêcher le chargement des drivers ALSA ? C'est pas dans /etc/modules, /etc/modules.conf, et j'ai essayé de mettre un exit 0 au début du script /etc/init.d/alsa mais ça change rien au niveau des modules (à part que la configuration alsal ne se lance pas).
Comment charger uniquement les drivers OSS pour tester si ça fonctionne ?
Comment remettre de l'ordre dans les drivers ALSA et pouvoir les utiliser ?
Comment faire pour alsaplayer ? Faut le remettre à jour, le désinstaller ?

ps : de plus, il m'est impossible de décharger un module avec RMMOD :
FATAL: Kernel does not have unload support.

J'ai oublié une option dans le noyau ?

Merci (ça fait beaucoup de choses...).
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8913
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 


Message le 20 Aoû 2004 09:55

Que donne
Code: Tout sélectionner
$ alsaconf
?
C'est sensé configurer tout tout seul :wink:

Même avec modconf tu n'arrives pas à enlever les modules ?
Sinon dans ton noyau tu as dû oublié de sélectionner l'option qui permet d'enlever un module :wink:

Vérifies que tu as bien ça de sélectionner
Loadable module support > Module unloading

:wink:
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 10:46
Localisation: /Fr/Idf/77/Le Mée
 

Message le 20 Aoû 2004 10:04

apt-get install hotplug devrait te permettre de mieux dormir (et avoir le poil doux et soyeux...)

Cet outil détecte et configure tout seul le matériel si possible...
De meme il chargera tout seul le nécessaire pour la carte son: OSS ou ALSA en fonction de tes préférences...
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 20 Aoû 2004 10:05

Alsaconf se passe bien. Il trouve ma carte, il modifie /etc/modprobe.d/sound avec :
alias snd-card-0 snd-ens1371
alias sound-slot-0 snd-ens1371


Mais après ? Je n'arrive pas à me servir de XMSS ou alsaplayer puisque ils tombent en erreur tous les 2.... Comment je peux corriger ça ?

Je n'ai effectivement pas mis l'option "module unloading" dans le noyau :cry: Si j'en ai besoin, il va falloir recompiler...
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8913
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 20 Aoû 2004 10:16

glenux a écrit:apt-get install hotplug

J'ai déjà le package hotplug installé.

Par contre il est dans /etc/init.d/ mais pas dans /etc/rc2.d. Donc il ne se lance pas ? (je comprend pas tout, escuse pour les questions bêtes).

Comment ça fonctionne ? Il contrôle que les modules sont bien chargés pour les péréiphériques non ?

glenux a écrit:devrait te permettre de mieux dormir (et avoir le poil doux et soyeux...)

:D Woui, en ce moment je retape toutes les commandes Linux dans mon sommeil. Si ça peut m'aider à être plus zen...
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8913
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 20 Aoû 2004 21:33

Bon, ben, j'ai trouvé plusieurs trucs au bout de quelques heures :

- le son était muté. Dans amixer, c'est pas le peine de mettre le son à fond s'il est muté ! J'suis vraiment un noob...
- j'ai viré alsaplayer avec apt-get, par contre aplay fonctionne bien (c'est la même chose en fait. Peut-être que ça le remplace même...)
- le plus important, j'ai trouvé un pb similaire sur un autre forum et c'était ça : en root XMMS fonctionnait / sur casa non. J'appartenais pas au groupe audio, c'est tout...

Soit dit en passant, le message de XMMS me disait de vérifier la config de ma carte : je pouvais toujours chercher...

Voilà, c'est réglé mais... juste si qqun pouvait me dire en quoi le fait d'appartenir au groupe audio donne des droits sur la lecture d'un fichier audio ? sur l'utilisation de la carte son ? sur quoi, en fait ?
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8913
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 20 Aoû 2004 22:44

Voilà, c'est réglé mais... juste si qqun pouvait me dire en quoi le fait d'appartenir au groupe audio donne des droits sur la lecture d'un fichier audio ? sur l'utilisation de la carte son ? sur quoi, en fait ?


Si tu regarde dans /dev/ , tu veras des fichiers, chacun de ces fichiers correspond à un périphérique (présent ou non, en fonction de ce qui gère ton dev...).
Comme pour tout fichier, ceux-ci sont également soumis aux droits utilisateur/groupe/autres et aux ACL (si présentes).
Par défaut, le périphérique correspondant à la sortie audio (/dev/dsp ou /dev/sound/dsp) appartient a root et au groupe audio... (d'un autre coté, c'est logique non ?)
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 21 Aoû 2004 08:56

glenux a écrit:/dev/dsp ou /dev/sound/dsp

En fait, je m'en doutais et j'avais cherché ça... Mais j'ai pas de /dev/dsp ou /dev/sound/...
J'ai un /dev/rtc/ qui appartient au groupe audio. C'est le périphérique audio ?
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8913
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 



Sujets similaires

Message [Réglé] Virus ou pas
BonjourDepuis quelques temps mon ordi fait des siennes. J'ai un Lenovo avec Windows 8.1Internet explorer est très lent, bloque des pages, mon Yahoo mail met des minutes pour effectuer des opérationsJ'ai des messages du type : internet explorer a modifié cette page pour empêcher le script de site à s ...
Réponses: 48

Message [Réglé]deezer
bonjour,Je voudrais savoir comment faire pour empêcher deezer de s'ouvrir au démarrage . Je suis allé dans gestionnaire des taches - démarrage , mais je ne trouve pas deezer .Je suis sur w10 . Merci.
Réponses: 3

Message [réglé] Achat portable conseil modèle / carte graphique
Bonjour à toutes et à tous Je vous écris afin d'avoir quelques informations concernant l'achat d'un pc.Actuellement j'ai un pc (HP pavillon ProtectSmart) avec un processeur AMD A8-4555M 1.6 Ghz, 8 Go de RAM et une carte graphique dont je ne retrouve pas le nom et il est sous windows 10Il a un peu ...
Réponses: 6

Message [Réglé] POP inofensive, mais qui reviennent sans cesse.
Bonjour,S'il s'agit du "cache" de Google Chrome, on peut le supprimer directement dans Chrome (Paramètres/Paramètres avancés/Confidentialité et sécurité/Effacer les données de navigation).
Réponses: 38

Message [Réglé] Pubs et barre secure search sur Firefox
Bonjour,Depuis maintenant plusieurs semaines, quand je clique sur un lien, une page de pub se lance à la place de l'onglet désiré mais cela ne se produit pas tout le temps et j'ai l'impression que cela se fait de manière aléatoire.De plus, au lancement de Firefox, une barre "secure search" ...
Réponses: 5

Message configuration matériel debian 9.3
bonjour,actuellement , j'ai un portable acer aspire 3630, avec celeom m 1.6 ghz pour le processeur, 1 go de ram et 64 mo de ram en graphique, bref ça rame sec. je voudrais m'acheter un pc fice d'occasion pour faire du linux ( debian 9.3 lxde).quelle configuation matériel me conseillez vous ?merci d' ...
Réponses: 5

Message [Réglé] windows 7 ne se lance plus après extension mémoire
BonjourSur mon pc portable HP DV7-4182sf Windows 7 64 bits équipé de 4go de mémoire Hyundai PC3-10700 (667 Mhz) cl7 (rèf: CPUZ), j'ai voulu rajouter une barette de 4go de marque Kingston KVR 13S9S8/4 PC3-10600 (1333 Mhz) cl9 1,5v.Mais au redémarrage de l'ordinateur, Windows ne se lance plus et j'a ...
Réponses: 25


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité


.: Nous contacter :: Flux RSS :: Données personnelles :.