Il y a actuellement 77 visiteurs
Samedi 23 Juin 2018
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

reseau avec samba entre mandrake et xp (reglé)

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

reseau avec samba entre mandrake et xp (reglé)

Message le 01 Sep 2004 19:22

me revoila toujours novice mais un peu moins !!

comme le dit le titre je voudrais monter un reseau entre mandrake et xp.

pour cela j' ai lu (lealinux) qu'il faut utiliser samba (et c'est pas simple!!)

j' ai tout suivi a la lettre mais je ne suis pas surt que toute mes etape soit correct

je dois maintenant utiliser swat pour configuere samba

je cite le paragraphe qui ma pose un peu pb :

http://lea-linux.org/reseau/samba.html

Utilisation de SWAT avec xinetd

Tout comme mentionné plus haut, il est fréquent que votre distribution fournisse plutôt xinetd. Il vous faudra donc modifier /etc/xinetd.d/swat pour activer le service. 2 étapes à suivre :

1. modification de /etc/xinetd.d/swat :

root@pingu# cat /etc/xinetd.d/swat
service swat
{
port = 901
socket_type = stream
wait = no
only_from = 127.0.0.1
user = root
server = /usr/sbin/swat
log_on_failure += USERID
disable = yes
}

2. Redémarrer xinetd :

root@pingu# /etc/rc.d/init.d/xinetd restart ou
root@pingu# service xinetd restart

mon pb c'etais de savoir si je dois cree manuellement ce fichier /etc/xinetd.d/swat et y ecrire ca :

service swat
{
port = 901
socket_type = stream
wait = no
only_from = 127.0.0.1
user = root
server = /usr/sbin/swat
log_on_failure += USERID
disable = yes
}

c' est ce que j' ai fais mais je suis pas sur .

bref ,mon vrai pb c' est quaénd je cherche a Générer et modifier smb.conf avec SWAT:

quand je tape http://root@localhost:901 dans la zone d'addresse de netscape celui ci me repond :

"the connection was refused when attempting to contact localhost:901"

et je ne sais pas du tout pourquoi j' ai ca comme reponse !!!

donc a nouveau j' aurais besoin d'aide

A+
Kg7
Sous Expert(e)
Sous Expert(e)
 
Messages: 45
Inscription: 17 Juil 2003 17:09
 


Message le 01 Sep 2004 22:12

Soit ton SWAT n'est pas démarré, soit ton firewall bloque les connexions qui vont sur le port en question. Dans les 2 cas, il faut vérifier :
- que swat est lancé,
- la configuration (port/machines autorisées/actions) de ton firewall..
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 17:22
Localisation: Entre deux BarCamps
 

Message le 01 Sep 2004 22:50

pour lancer swat c'est : service xinetd restart ?

et ce que j' ai fais est ce juste ? car peut etre ca vien de ca ?

je n 'ai pas installe de firewall .

est ce que par defaut mandrake en active un ?

enfet le probleme que j' ai pour cibler l' erreur c'est que je ne suis pas trop sur de ce que j'ai fais !!!
mais bon ca viendra avec le temps !
rhmmm et puis aussi que je ne comprend pas tout ce que je fais lol

A+
Kg7
Sous Expert(e)
Sous Expert(e)
 
Messages: 45
Inscription: 17 Juil 2003 17:09
 

Message le 01 Sep 2004 23:46

Kg7 a écrit:pour lancer swat c'est : service xinetd restart ?


C'est bon, par contre il faudrait voir les logs (/var/log/*) pour voir s'il n'y a pas des messages d'erreur lorsque tu lance swat...

Et puis j'ai une question: pourquoi ne configures-tu-pas samba directement ? (en editant smb.conf ?)
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 17:22
Localisation: Entre deux BarCamps
 

Message le 02 Sep 2004 10:23

parce que je n'y avait pas penser lol !!

et lea linux ne dit poas comment faire sans swat il mesemble
mais je vais essayer cette aprem

A+
Kg7
Sous Expert(e)
Sous Expert(e)
 
Messages: 45
Inscription: 17 Juil 2003 17:09
 

Message le 03 Sep 2004 18:02

bon il y a du progres !!

je vois quelque chose depuis windows mais quand je dois me loguer ca marche pas !

normal ca va pas marcher du premier coup !!

peut que le pb vient du fait que je crois que j' ai des petits pb avec les comptes :

je cree un compte smbuser et quand je reboot l' interface ne me propose plus de me logguer en root que en smbuser et le mot de passe ne marche pas !!
alors je suprime smbuser et je peux me logguer en root puis recree le compte

de plus quand j'utilise la commande smbpasswd j' obtiens ca (en gros) :

# smbpasswd smbuser password

failed to find entry for smbuser.
failed to modify entry for smbuser

je ne comprends pas pourquoi j' obtiens ca.

A+
Kg7
Sous Expert(e)
Sous Expert(e)
 
Messages: 45
Inscription: 17 Juil 2003 17:09
 

Message le 03 Sep 2004 19:44

1) Il faut créer des comptes samba
2) Je te conseille de mettre la protection au niveau partage (share) et d'autoriser l'acces en fonction des utilisateur/password
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 17:22
Localisation: Entre deux BarCamps
 

Message le 04 Sep 2004 00:12

nickel

merci bcp

ca marche !!!

moi meme j' y crois pas !!

A+

(certainement tre prochainement lol )
Kg7
Sous Expert(e)
Sous Expert(e)
 
Messages: 45
Inscription: 17 Juil 2003 17:09
 



Sujets similaires

Message [Réglé] PC portable budget moyen
Bonjour,Je vous contact car plusieurs fois je suis venu vers vos conseils qui ont porter plusieurs fois leur fruits.Mon père souhaiterais acheter un ordinateur portable pour surfer sur internet, word, etc... Bureautique en règle générale.Les seuls choses qui voudrait c'est: Un SSD et un HDD de 1TO. ...
Réponses: 23

Message [réglé]ajouter un périphérique audio
Bonjour Voici ce que j'ai dans "son" via l'icône haut-parleur de la barre des tâches en cliquant droit dessus:https://www.cjoint.com/c/HFtrkLKbqkyEt voici ce que j'ai dans comme périphérique connecté: https://www.cjoint.com/c/HFtpl6S8DoyJe suis donc obligé à chaque fois soit de passer pa ...
Réponses: 7

Message Réseau local saturé lors de gros transferts
Bonjour à tous,Je vous contacte puisque je suis dans le grand regret de constater d?importants ralentissements de mon réseau local lorsqu?il y a des transferts importants au sein de celui-ci.Mon réseau local est routé par un ASUS AC-3200 et contient divers périphériques en Wifi ainsi qu?un maximum d ...
Réponses: 3

Message [Réglé] Dispositif d'accès aux dossier (window10)
Bonsoir, je ne peux plus effectuer de mise a jour Windows car des mises à jour de sécurité importante sont obsolètes ou manquantes. En fouillant un peu j'ai constaté que le service de détection des menaces s'est arrêté. Je ne peux pas le redémarrer car il faut d'abord activer le dispositif d'accès a ...
Réponses: 9

Message [Réglé] Bug connexion
Bonjour tout le monde ! Alors je viens vous donner quelque nouvelle de mon ordi qui avec un pote à moi. Alors pâte thermique changé , nettoyage ventilateur fait ( pas très sale apparement ) , teste vidéo 4k sur internet pour voir si ça rame ( aucun soucis )., pour lui c?est un bon ordi pas de souci ...
Réponses: 46

Message [Réglé] Comment entrer la cle WPA sur ma tablette Android?
Bonjour.J'ai dû réinitialiser ma tablette Android (version 5.1) de modèle T-901 et je n'arrive pas à la connecter à Internet parce que je ne me souviens plus sur quoi j'avais appuyé pour qu'elle me demande mon numéro de clef WPA. Le Wi-Fi est activé, le nom de mon fournisseur Internet s'affiche com ...
Réponses: 4


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 4 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.