Il y a actuellement 46 visiteurs
Lundi 19 Février 2018
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

[Résolu] lecture impossible avec KsCD

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

[Résolu] lecture impossible avec KsCD

Message le 08 Déc 2007 17:05

Bonjour à tous,

J'ai un bête problème de lecture de CD avec KsCD.
Message d'erreur : "Problème d'accès ou de lecture du CDROM (ou pas de CD audio dans le lecteur.
Assurez-vous que vous avez le droit d'accéder à /dev/hdc"

J'ai été voir : le fichier en question est en rw-rw---
J'ai essayé sous root de modifier ça : impossible.

Je suis sous KDE 3.4.2, lien vers ma config ci-dessous.

Une idée ? Merci
Avatar de l'utilisateur
pacman1897
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 286
Inscription: 25 Juil 2003 10:40
 


Message le 08 Déc 2007 20:12

Tu peux vérifier le contenu de ton /etc/fstab pour savoir quels sont les attribus de montage des CDROM.
Ca devrait être qqchose de type
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0

(ou /mnt/cdrom... le point de montage peut-être différent)

Il faut aussi vérifier que tu appartiens au groupe cdrom et audio. En console utilisateur tu tapes groups pour le vérifier.
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8913
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 08 Déc 2007 21:24

/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec,users 0 0
/dev/hdd /mnt/cdrom2 auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec,users 0 0

Si je tape "groups" en console utilisateur normal, j'ai seulement le groupe "user" qui apparaît.
1. est-ce normal ?
2. sinon, quelle commande dois-je taper pour intégrer les groupes cdrom et audio ?

Merci casa04
Avatar de l'utilisateur
pacman1897
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 286
Inscription: 25 Juil 2003 10:40
 

Message le 08 Déc 2007 23:35

pacman1897 a écrit:Si je tape "groups" en console utilisateur normal, j'ai seulement le groupe "user" qui apparaît.
1. est-ce normal ?

Je ne crois pas non... enfin, je trouve ça bizzare
pacman1897 a écrit:2. sinon, quelle commande dois-je taper pour intégrer les groupes cdrom et audio ?

2 solutions, les deux en root console (ou avec un sudo):
- utiliser la commande adduser utilisateur groupe(s)
exemple : adduser pacman cdrom audio
- éditer le fichier /etc/group et y ajouter ton utilisateur sur les lignes de groupes en question. Exemples de ligne avec un user :
cdrom:x:24:laurent
floppy:x:25:laurent

Pour les deux commandes, il faut se déloguer et se reloguer pour que ça prenne effet.
D'autre part, question bête : quelle distribution ?
Et autre question : arrives-tu à lire/monter des CD de données, des DVD peut-être, utiliser les CD avec d'autres programmes.. etc ?
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8913
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 09 Déc 2007 00:29

Merci pour ces suggestions casa, mais c'est raté.

Quand je fais adduser pacman cdrom audio, en remplaçant pacman par mon vrai identifiant bien sûr, il me donne le man.

En root, , j'ai ajouté mon nom d'user aux deux groupes cdrom et audio dans etc/group, je me suis déloggé / reloggé : même erreur.

Bououou :cry:

Pour ma config, tu as le lien sous ma signature.
Avatar de l'utilisateur
pacman1897
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 286
Inscription: 25 Juil 2003 10:40
 

Message le 09 Déc 2007 11:03

pacman1897 a écrit:Quand je fais adduser pacman cdrom audio, en remplaçant pacman par mon vrai identifiant bien sûr, il me donne le man.

Etrange c'est pourtant la syntaxe. Voilà ce que j'ai :
Code: Tout sélectionner
root /home/laurent# adduser laurent audio
L'utilisateur « laurent » est déjà membre du groupe « audio ».

..et pas un man..
pacman1897 a écrit:En root, , j'ai ajouté mon nom d'user aux deux groupes cdrom et audio dans etc/group, je me suis déloggé / reloggé : même erreur.

Erreur de lecture ? mais es-tu bien dans le groupe maintenant ?

Tu n'as pas répondu aux autres questions : arrives-tu à exploiter le lecteur avec d'autres supports, d'autres programmes ?

En console root, met un disque dans le lecteur et essaye de le monter en étant root donc :
mount /dev/hdc ou mount /dev/hdd selon le lecteur.
Peut-être le message est-il explicite : ton lecteur n'arrive peut-être pas à trouver le CD ce qui signifie un mauvais support ou plus vraisemblablement une panne du lecteur.
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8913
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 09 Déc 2007 12:21

casa04 a écrit:Erreur de lecture ? mais es-tu bien dans le groupe maintenant ?

Je crains de ne pas être assez rigoureux dans ce que je fais, donc je te livre un copier coller des commandes que je cherche à passer, ça sera plus simple.

Tentative d'ajouter pac au groupe audio :
Code: Tout sélectionner
[root@localhost pac]# adduser pac audio
Usage: useradd [options] LOGIN
Options:
  -b, --base-dir BASE_DIR       base directory for the new user account
...

Appartenance aux groupes :
Code: Tout sélectionner
[pac@localhost ~]$ groups
pac cdrom audio


casa04 a écrit:Tu n'as pas répondu aux autres questions : arrives-tu à exploiter le lecteur avec d'autres supports, d'autres programmes ?
Peut-être le message est-il explicite : ton lecteur n'arrive peut-être pas à trouver le CD ce qui signifie un mauvais support ou plus vraisemblablement une panne du lecteur.

Exact, pardon. J'arrive à lire sans problème des DVD vidéos (c'est un lecteur combiné CD/DVD), des CD et DVD de données.

casa04 a écrit:En console root, met un disque dans le lecteur et essaye de le monter en étant root donc :
mount /dev/hdc ou mount /dev/hdd selon le lecteur.

Code: Tout sélectionner
[root@localhost ~]# mount /dev/hdd
mount: Aucun medium trouvé
[root@localhost ~]# mount /dev/hdc
/dev/hdc: Erreur d'entrée/sortie
mount: /dev/hdc: ne peut lire le super bloc

J'ai également essayé de lancer KsCD en root, et ça marche enfin, mais seulement avec un seul des deux lecteurs, le graveur.
Je ne cours donc plus absolument après une solution comme utilisateur normal, mais bien sûr ça serait plus confortable. :wink:
Avatar de l'utilisateur
pacman1897
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 286
Inscription: 25 Juil 2003 10:40
 

Message le 09 Déc 2007 13:51

pacman1897 a écrit:Tentative d'ajouter pac au groupe audio :
Code: Tout sélectionner
[root@localhost pac]# adduser pac audio
Usage: useradd [options] LOGIN
Options:
  -b, --base-dir BASE_DIR       base directory for the new user account
...

En fait c'est parce que adduser n'existe pas sur ta distribution, mais useradd oui. Pas grave, tu as fait l'autre solution...

Il n'est vraiment pas conseillée de lancer KSCD en root, c'est donc une solution provisoire et à défaut.

Trouvé sur un autre forum avec le même problème :
finalement j'ai regle le probleme de KsCD, en fait il fallait aller dans configuration de KsCD et changer peripherique CD rom, a la place de /dev/hdc/ fallait mettre media:/hdc

essaye...
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8913
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 09 Déc 2007 16:34

Gagné !!!

Le paramétrage media:/.hdc était le bon

Merci casa04, tu es persévérant, c'est quand même plus facile comme ça.

Allez pour se détendre, entre hier et aujourd'hui, j'ai posté 2 blagues dans le forum "pour rire".

à une prochaine et merci encore.
Avatar de l'utilisateur
pacman1897
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 286
Inscription: 25 Juil 2003 10:40
 



Sujets similaires

Message [Résolu]La 2ème partition ne se détecte plus au démarrage
Bonjour,J'utilise Windows 7, et j'ai formaté l'une de mes deux partitions. Or, depuis, quand je démarre mon ordinateur, la deuxième partition n'apparaît plus comme c'était le cas auparavant. Je ne peux donc avoir accès à cette deuxième partition. Que faire ?
Réponses: 2

Message [résolu] application compagnon
bonjour depuis ce midi si je veux télécharger une vidéo sur youtube j'ai cette fenêtre, le seul topic que j'ai trouvé la dessus n'est pas concluant . j'ai supprimé puis réinstallé DownloadHelper sans succès .d'ailleurs, je ne devrais pas avoir un fichier DownloadHelper dans fichier cacher ? merci ...
Réponses: 7

Message Pilote lecteur DVD : Lecture DVD protégé, comment?
Pilote lecteur DVD : Lecture DVD protégé, comment?Bonjour,Je possède 2 ordinateurs différent de marque Asus. Celui que j'utilise souvent possède un lecteur dvd/cd-rom(HL-DT-ST DVDRAM GUA0N). J'aimerai savoir s'il existe un pilote ou un autre chose qui permet à mon lecteur de lire les dvd avec un sys ...
Réponses: 5

Message [Résolu] Connection via Bluetooth impossible
Bon, j'étais pas très doué il faut l'admettre.En cherchant cinq minutes j'ai trouvé.J'imagine que personne n'aura jamais besoin de le savoir mais au cas où : les appareils ne sont pas visibles spontanément.Il faut utiliser le bouton :Ajouter un nouvel appareil, sélectionner le type d'appareil et là, ...
Réponses: 2

Message [Résolu] Probleme interférences hauts parleurs
Bonjour tous le monde et merci pour votre forum,Je viens vous demander de l'aide car j'ai un problème vraiment bizarre avec mes hauts parleurs connecté à ma carte mère (asus z370 P) en jack 3.5mm.Voici ce qui se passe:- Quand je branche les hauts parleurs a la CM j'entends déjà de légèrs parasites ...
Réponses: 10

Message [Résolu] Problème de mise a jour Ubuntu 17.04
Bonjour à tous, Ce matin comme d'habitude je fais un petit update-upgrade dans le terminal et là petit soucis ça me fait une recherche de sources avec plusieurs error404 et ça me met de vérifier ma connexion internet alors que ma connexion est bonne puisque je fais ce sujet depuis le pc en question. ...
Réponses: 10


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.