Il y a actuellement 49 visiteurs
Mardi 20 Février 2018
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

[résolu] Plus de Linux après insta Win XP

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

[résolu] Plus de Linux après insta Win XP

Message le 28 Mai 2005 07:20

Chers amis,

J'ai sur mon système une MDK 10.0, et hier soir, pour des raisons de ravail, j'ai du installer Win XP Pro SP2 à la place de mon vieux win98 SE.
Je précise que win98 était installé sur une première partition de 7,5 Go en début de DD. Elle était en FAT32. Lors de l'insta de WinXP, j'ai supprimé cette partition et l'ai formaté en FAT32, puis j'ai lancé l'insta de WinXP, qui s'est passée sans problème.

Après l'insta, j'ai inséré le CD1 de la MDK qui a rétabli le LILO d'origine.

Seulement pas de chance, mon pingouin refuse de redémarrer. Je réessaie plusieurs fois, et avec deux noyaux différents, et j'obtiens toujours ce message :

Activation des partitions d'échanges (swap) : swapon: /dev/hda7: Invalide argument [echec]
Activation des périphériques RAID
Vérification des systèmes de fichiers
/dev/hda8:
The superblock could not read or does not describe a correct ext2 ilesystem. If the device is valid... try running e2fsck with an alternate superblock : e2fsck -b 8193 (device)

fsck.ext3: Bad magic number in super-block while trying to open /dev/hda8
/dev/hda6:
The superblock could not read or does not describe a correct ext2 filesystem. If the device is valid... try running e2fsck with an alternate superblock : e2fsck -b 8193 (device)

fsck.ext2: Bad magic number in super-block while trying to open dev/hda6

Le système de fichier est corrompu. Voulez-vous réparer les erreurs ?

------------
(fin du messsage)

Voilà le contenu de mon /etc/fstab :
Code: Tout sélectionner
/dev/hda5 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda8 /home ext3 defaults 1 2
/dev/hda6 /lin_c ext2 defaults 1 2
/dev/scd0 /mnt/cdrom auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec 0 0
/dev/scd1 /mnt/cdrom2 auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,sync,codepage=850 0 0
/dev/hda9 /mnt/win_d vfat umask=0,iocharset=iso8859-15,codepage=850 0 0
/dev/hda1 /mnt/windows vfat umask=0,iocharset=iso8859-15,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hda7 swap swap defaults 0 0


Ma config complète (avant insta de Win XP) figure ici :
http://www.cantenot.net/10config.php

Comment dois-je faire pour retrouver mon pingouin favori ?

Merci beaucoup,

Pierre-Antoine 8)
Avatar de l'utilisateur
pacman1897
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 286
Inscription: 25 Juil 2003 10:40
 


Message le 28 Mai 2005 11:19

Essaye de démarrer sur un CD bootable et d'obtenir un shell.
A partir de là, regarde la table des partitions de ton disque dur pour voir si WindowsXP n'a pas changé "l'ordre" des partitions...
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 28 Mai 2005 11:36

glenux a écrit:Essaye de démarrer sur un CD bootable et d'obtenir un shell.
A partir de là, regarde la table des partitions de ton disque dur pour voir si WindowsXP n'a pas changé "l'ordre" des partitions...

Pardonnes-moi, mais c'est déjà trop fort pour moi.
Pour obtenir le shell, cela veut dire que j'utilise mettons une Knoppix et que j'ouvre une console ? C'est bien ça ?
Ensuite, où est-ce que je vais voir "l'ordre" des partitions modifié éventuellement par WinXP ?

Merci
Avatar de l'utilisateur
pacman1897
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 286
Inscription: 25 Juil 2003 10:40
 

Message le 28 Mai 2005 13:03

Pour obtenir le shell, cela veut dire que j'utilise mettons une Knoppix et que j'ouvre une console ? C'est bien ça ?


C'est effectivement cela.

Ensuite, où est-ce que je vais voir "l'ordre" des partitions modifié éventuellement par WinXP ?


en tapant (en root): fdisk /dev/hda
puis p (pour "print"), puis q (pour "quit").
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 29 Mai 2005 17:38

glenux a écrit:en tapant (en root): fdisk /dev/hda
puis p (pour "print"), puis q (pour "quit").

Dans le mille !!! C'est beau la compétence 8)
Voilà ce que me renvoie fdisk /dev/hda :
hda1 FAT32
hda2 Extended
hda5 Linux
hda6 swap
hda7 Linux
hda8 FAT32
hda9 Linux

J'ai essayé de modifier le fstab en changeant les paramètres que j'ai vu comme incorrects :
/dev/hda5 / ext3 defaults 1 1
CORRECT
/dev/hda7 /home ext3 defaults 1 2
INCORRECT : ce devrait être hda7
/dev/hda6 /lin_c ext2 defaults 1 2
INCORRECT : ce devrait être hda9 (Extended, c'est bien un FS ext2 ?)
/dev/hda9 /mnt/win_d vfat
INCORRECT : ce devrait être hda8
/dev/hda1 /mnt/windows vfat
CORRECT : heureusement, sinon, je n'aurai même pas de Windows
/dev/hda7 swap swap defaults 0 0
INCORRECT : ce devrait être hda6

mais ça ne marche pas. De plus je ne comprends pas ce que c'est que cette partition hda2 Extended : je suis pourtant sûr de n'avoir que six partitions.

Je ne comprends pas non plus ce qui se passe avec le fstab :
-quand je l'édite avec vi, les modifications sont bien prises en compte.
-quand je l'édite sous windows grâce à explore2fs, rien n'est modifié

Pourquoi cette différence ?
Avatar de l'utilisateur
pacman1897
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 286
Inscription: 25 Juil 2003 10:40
 

Message le 29 Mai 2005 19:46

pacman1897 a écrit:je ne comprends pas ce que c'est que cette partition hda2 Extended : je suis pourtant sûr de n'avoir que six partitions.

Extended est probablement le type de la partition "conteneur" dans le schéma partition primaire/partition étendue sur les PC x86 équipés d'un BIOS...

Je t'invite a regarder sur le site "commentcamarche" pour de plus amples informations concernant les partitions.

Je ne comprends pas non plus ce qui se passe avec le fstab :
-quand je l'édite sous windows grâce à explore2fs, rien n'est modifié

Il ne faut pas utiliser explore2fs, c'est souvent très dangeureux (corruptions du filesystem) pour les partitions linux...
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 29 Mai 2005 22:58

Ben oui, mais qu'est-ce que je dois faire maintenant pour retrouver mon pingouin ???
Avatar de l'utilisateur
pacman1897
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 286
Inscription: 25 Juil 2003 10:40
 

Message le 01 Juin 2005 22:05

C'est réglé ! 8) 8) 8)
Win$*#*§ XP m'avait bousillé mes partitions, heureusement, un linuxien averti m'a aidé à reconstitué un fstab correct.
J'avais eu la mauvaise idée de supprimer l'espace entre / et ext3, ce qui évidemment démolissait complètement le montage sous /.
Voilà la version correcte :
/dev/hda5 / ext3 defaults 1 1

et j'ai retrouvé mon pingouin !!!
Merci à tous pour vos contributions. :D :D :D
Avatar de l'utilisateur
pacman1897
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 286
Inscription: 25 Juil 2003 10:40
 



Sujets similaires

Message [Résolu]La 2ème partition ne se détecte plus au démarrage
Bonjour,J'utilise Windows 7, et j'ai formaté l'une de mes deux partitions. Or, depuis, quand je démarre mon ordinateur, la deuxième partition n'apparaît plus comme c'était le cas auparavant. Je ne peux donc avoir accès à cette deuxième partition. Que faire ?
Réponses: 2

Message [résolu] application compagnon
bonjour depuis ce midi si je veux télécharger une vidéo sur youtube j'ai cette fenêtre, le seul topic que j'ai trouvé la dessus n'est pas concluant . j'ai supprimé puis réinstallé DownloadHelper sans succès .d'ailleurs, je ne devrais pas avoir un fichier DownloadHelper dans fichier cacher ? merci ...
Réponses: 7

Message [Résolu] Connection via Bluetooth impossible
Bon, j'étais pas très doué il faut l'admettre.En cherchant cinq minutes j'ai trouvé.J'imagine que personne n'aura jamais besoin de le savoir mais au cas où : les appareils ne sont pas visibles spontanément.Il faut utiliser le bouton :Ajouter un nouvel appareil, sélectionner le type d'appareil et là, ...
Réponses: 2

Message [Résolu] Probleme interférences hauts parleurs
Bonjour tous le monde et merci pour votre forum,Je viens vous demander de l'aide car j'ai un problème vraiment bizarre avec mes hauts parleurs connecté à ma carte mère (asus z370 P) en jack 3.5mm.Voici ce qui se passe:- Quand je branche les hauts parleurs a la CM j'entends déjà de légèrs parasites ...
Réponses: 10

Message [Résolu] Problème de mise a jour Ubuntu 17.04
Bonjour à tous, Ce matin comme d'habitude je fais un petit update-upgrade dans le terminal et là petit soucis ça me fait une recherche de sources avec plusieurs error404 et ça me met de vérifier ma connexion internet alors que ma connexion est bonne puisque je fais ce sujet depuis le pc en question. ...
Réponses: 10

Message Chrome RESOLU
bonjour,quand j'ouvre chrome je tombe sur une page sans titre??Je suis obligé d'ouvrir un nouvel onglet dans paramètre pour avoir accès.Merci
Réponses: 3


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité


.: Nous contacter :: Flux RSS :: Données personnelles :.