Il y a actuellement 81 visiteurs
Dimanche 25 Février 2018
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

[~résolu] Mots de passe vides

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

[~résolu] Mots de passe vides

Message le 27 Avr 2007 15:00

Bonjour,

J'ai fait une connerie sur mon install de Xubuntu, j'ai voulu supprimer le mot de passe de l'utilisateur avec "passwd -d NomUser" et j'en ai profité pr faire pareil avec root. Mais le problème c'est que je ne peux plus me logger maintenant !
Quand je tape le login et le pass vide, il refuse, les anciens mots de passe ne fonctionnent plus non plus...
J'ai essayé de monter la partition depuis le CD Live mais ça ne marche pas...

j'essayais avec :

Code: Tout sélectionner
sudo mount /dev/hdc1 /home/ubuntu -o umask=000


et il me répond :
mount you must specify the filetype

Avec :

Code: Tout sélectionner
sudo mount -t ext2 /dev/hdc1 /home/ubuntu -o umask=000


ça donne "wrong fs type, bad option....

Elle est pourtant bien en extended 2, donc je vois pas.
“It has to start somewhere, it has to start sometime, what better place than here, what better time than now?”
Avatar de l'utilisateur
gael49
Expert(e)
Expert(e)
 
Messages: 1909
Inscription: 07 Sep 2004 20:11
Localisation: Les Mauges
 


Message le 27 Avr 2007 19:58

Tu es sur que c'est de l'ext2 et pas de l'ext3 ?
Liste tes partitions avec un fdisk -l ou avec cfdisk pour le controler.

Au niveau du système live, /home/ubuntu existe bien ? Il est généralement plus propre (à défaut de dire autre chose) de monter sur un truc genre /mnt vide et appartenant à root, plutot. Ceci pour accéder au fichier /etc/passwd pour reseter le mot de passe.

Et sinon... root n'existe pas sous *ubuntu... enfin, il n'est pas sensé exister. Alors changer le pass de root c'était un peu chaud peut-être. Si tu veux casser un système avec un vrai root, essaye avec une Debian plutôt :D
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8913
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 28 Avr 2007 11:40

Tu es sur que c'est de l'ext2 et pas de l'ext3 ?
Liste tes partitions avec un fdisk -l ou avec cfdisk pour le controler.


J'ai vu ça dans l'utilitaires de disques, mais j'ai testé aussi avec Ext3, c'est pareil.

Au niveau du système live, /home/ubuntu existe bien ?


Oui quand on démarre sur le LiveCD, il y a bien 'home/ubuntu', j'avais déjà monté des partitions Windows de cette façon.

Il est généralement plus propre (à défaut de dire autre chose) de monter sur un truc genre /mnt vide et appartenant à root, plutot. Ceci pour accéder au fichier /etc/passwd pour reseter le mot de passe.


ok je ferai comme ça la prochaine fois.

Et sinon... root n'existe pas sous *ubuntu... enfin, il n'est pas sensé exister. Alors changer le pass de root c'était un peu chaud peut-être. Si tu veux casser un système avec un vrai root, essaye avec une Debian plutôt


ça je savais pas, mais la commande " passwd -d root" ne m'a pas retourné, il m'a bien proposé de changer de pass et j'ai laissé vide.


Sinon je sais que sur Mandrake il y avait une procédure pour démarrer en "linux single" (je crois que c'étais ça) et ça ouvrait une session root sans mot de passe, ça n'existe pas sous Ubuntu ?
“It has to start somewhere, it has to start sometime, what better place than here, what better time than now?”
Avatar de l'utilisateur
gael49
Expert(e)
Expert(e)
 
Messages: 1909
Inscription: 07 Sep 2004 20:11
Localisation: Les Mauges
 

Message le 09 Mai 2007 16:06

J'ai "résolu" le problème en reformatant le Mac et en réinstallant Linux :-?
“It has to start somewhere, it has to start sometime, what better place than here, what better time than now?”
Avatar de l'utilisateur
gael49
Expert(e)
Expert(e)
 
Messages: 1909
Inscription: 07 Sep 2004 20:11
Localisation: Les Mauges
 



Sujets similaires

Message [Résolu]La 2ème partition ne se détecte plus au démarrage
Bonjour,J'utilise Windows 7, et j'ai formaté l'une de mes deux partitions. Or, depuis, quand je démarre mon ordinateur, la deuxième partition n'apparaît plus comme c'était le cas auparavant. Je ne peux donc avoir accès à cette deuxième partition. Que faire ?
Réponses: 2

Message [résolu] application compagnon
bonjour depuis ce midi si je veux télécharger une vidéo sur youtube j'ai cette fenêtre, le seul topic que j'ai trouvé la dessus n'est pas concluant . j'ai supprimé puis réinstallé DownloadHelper sans succès .d'ailleurs, je ne devrais pas avoir un fichier DownloadHelper dans fichier cacher ? merci ...
Réponses: 7

Message [Résolu] Connection via Bluetooth impossible
Bon, j'étais pas très doué il faut l'admettre.En cherchant cinq minutes j'ai trouvé.J'imagine que personne n'aura jamais besoin de le savoir mais au cas où : les appareils ne sont pas visibles spontanément.Il faut utiliser le bouton :Ajouter un nouvel appareil, sélectionner le type d'appareil et là, ...
Réponses: 2

Message [Résolu] Probleme interférences hauts parleurs
Bonjour tous le monde et merci pour votre forum,Je viens vous demander de l'aide car j'ai un problème vraiment bizarre avec mes hauts parleurs connecté à ma carte mère (asus z370 P) en jack 3.5mm.Voici ce qui se passe:- Quand je branche les hauts parleurs a la CM j'entends déjà de légèrs parasites ...
Réponses: 10

Message Ou est passé le widget "lien" de Wordpress?
Bonjour.J'aimerais ajouter des liens de blogs que j'aime sur la page d'accueil de mon propre blog mais je ne trouve aucun widget qui me permettrait de le faire. Selon les tutoriels que j'ai consulté, il est censé exister un widget "lien" mais j'ai cliqué partout et il est introuvable. ...
Réponses: 0

Message [Résolu] Problème de mise a jour Ubuntu 17.04
Bonjour à tous, Ce matin comme d'habitude je fais un petit update-upgrade dans le terminal et là petit soucis ça me fait une recherche de sources avec plusieurs error404 et ça me met de vérifier ma connexion internet alors que ma connexion est bonne puisque je fais ce sujet depuis le pc en question. ...
Réponses: 10

Message Mot de passe BIOS Perdu
Bonsoir,Voilà j'ai oublié le mot de passe de mon bios... On ma dit qu'il existait un logiciel qui pourrait retrouver le mot de passe... A part enlever la pile et de court-circuité... Mon collègue ma dit qu'il avait eu ce soucis et dans le magasin ou il avait apporté lui a trouvé son mot de passe grâ ...
Réponses: 1


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 3 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.