Il y a actuellement 73 visiteurs
Dimanche 23 Septembre 2018
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

[résolu] shell script francophone pour OpenOffice 2.0

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

[résolu] shell script francophone pour OpenOffice 2.0

Message le 14 Juin 2005 23:06

Bonjour les amis,

J'ai téléchargé et installé avec succès la dernière version d'OpenOffice 2.0 Bêta sur ma Mandrake 10.0, mais pas moyen de passer en français.
J'obtiens le message suivant en lançant le script du pack francophone :
Code: Tout sélectionner
[root@localhost bin]# sh OOo_1.9.104_LinuxIntel_langpack_fr.sh
You may only copy and distribute this program consistent with the
requirements and distribute this Program consistent with the
 requirements of either the GNU General Public License (GPL) and GNU
Lesser General Public License (LGPL) or the Sun Industry
Standards Source License (SISSL), respectively, depending on whether you
elected to obtain access to this program via the GPL/
LGPL Option or the SISSL Option. Copies of the GPL, LGPL and SISSL
licenses can be found http://www.openoffice.org/project/www
/license.html
------------------------------------
Third Party Code. Additional copyright notices and license terms
applicable to portions of the Software are set forth in the T
HIRDPARTYLICENSEREADME.html file.
------------------------------------
Copyright 2002,2005 Sun Microsystems, Inc.

Do you agree to the above license terms? [yes or no]
y

Searching for the openofficeorg installation ...

Where do you want to install the language pack ?
[/opt/openoffice.org1.9.104]
y
Unpacking and installing...
openofficeorg-fr-res-1.9.104-1.i586.rpm
openofficeorg-fr-1.9.104-1.i586.rpm
openofficeorg-fr-help-1.9.104-1.i586.rpm
rpm: les arguments de --prefix doivent commencer par un /
rpm: les arguments de --prefix doivent commencer par un /
rpm: les arguments de --prefix doivent commencer par un /
Done...
Quand je le lance, j'obtiens :
Code: Tout sélectionner
[root@localhost program]# sh setofficelang
/opt/openoffice.org1.9.104/program/setofficelang.bin - set the user
interface language of a OpenOffice.org/StarOffice/StarSuite installation

usage : /opt/openoffice.org1.9.104/program/setofficelang.bin [-afcpl]
<language> ..

  Options:
      -a       Change the default language of the installation.
               This may require administrative rights.
      -f       Force selection of language.
               Skips the check if this language is installed.
      -c       Display current active language.
      -p       Display current preferred language.
      -l       List all installed languages.
  <language> - A language specified by its ISO code (e.g. 'en-US','de')
or '-' for default.
               This language must be supported by the office installation

               If multiple languages are listed, the first one that is
installed is used.

Result codes:  0 - Setting language successfull
               1 - The language is not supported by this office installation
               2 - Invalid arguments
               3 - An internal error occurred

Mais seule la commande sh setofficelang -l renvoie quelque chose, en l'occurence : en-US
Toutes les autres commandes renvoient seulement l'invite de commande.

Est-ce que quelqu'un a réussi à passer en français ?
Merci.
Avatar de l'utilisateur
pacman1897
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 286
Inscription: 25 Juil 2003 11:40
 


Re: shell script francophone pour OpenOffice 2.0

Message le 15 Juin 2005 08:25

pacman1897 a écrit:Where do you want to install the language pack ?
[/opt/openoffice.org1.9.104]
y
Unpacking and installing...
openofficeorg-fr-res-1.9.104-1.i586.rpm
openofficeorg-fr-1.9.104-1.i586.rpm
openofficeorg-fr-help-1.9.104-1.i586.rpm
rpm: les arguments de --prefix doivent commencer par un /
etc....

Heuuu... do you speak english ? :D
Il te demande "où" (where) installer le langage pack, avec un chemin proposé par défaut... et tu lui réponds "OUI" (y).

A mon avis, c'est ce qui cloche. Il attend un chemin, pas un "y" ou un "n". D'ailleurs, tu vois plus loin qu'il essaye d'identifier un "/" dans le script, ce qui est le début d'un chemin.

edit : à mon avis, tu relances le script et tu ne fais que valider à la question... Ca devrait largement suffire.
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8917
Inscription: 13 Mai 2003 17:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 15 Juin 2005 22:50

Alors là je dis bravo et chapeau bas.
Il a suffit effectivement que je me place dans le répertoire d'installation d'OpenOffice et que j'exécute le script comme tu l'as dit, pour la proposition "fr" s'ajoute et devienne immédiatement opérationnelle.
Devant tant de compétence, on ne peux que s'incliner et remercier, d'autant plus que c'est la deuxième fois que tu me sors du bouillon. Merci donc, pour moi, et pour les potes qui me demandent de l'aide pour faire cette insta.

Voici donc la procédure complète, pour ceux que ça intéresse :

TELECHARGEMENT ET DECOMPRESSION DE LA VERSION ANGLOPHONE
Sur http://fr.openoffice.org dans n'importe quel répertoire, mais facile à retrouver :
Téléchargez l'archive par ftp (dans la barre d'adresse de Konqueror) :
ftp://openoffice.cict.fr/openoffice/dev ... all.tar.gz
et décompressez-la dans n'importe quel répertoire

INSTALLATION DE LA VERSION ANGLOPHONE
Le dossier créé lors de la décompression contient trois dossiers :
licenses/
readmes/
RPMS/
Ce dernier dossier contient 25 fichiers .rpm principaux qu'il convient de lancer tous à la fois grâce à l'utilitaire d'installation en ligne de commande urpmi
Donc ouvrez une console et déplacez-vous par la commande cd pour arriver dans le dossier RPMS.
Pour lancer l'installation, copiez-collez la commande suivante : urpmi op*
Cela aura pour effet d'installer les 25 rpm d'un seul coup dans le dossier créé spécialement :
/opt/openoffice.org1.9.104

CREER LES ICONES DE LANCEMENT DES MODULES D'OPENOFFICE
Pour créer les icônes, cliquez sur l'une des petites flêches vers le haut de la barre des tâches de KDE, puis :
"Menu du tableau de bord", "Ajouter", "Bouton spécial", "Application non KDE"
puis dans la ligne exécutables, copiez-collez :
/opt/openoffice.org1.9.104/program/swriter
pour le module de traitement de texte
/opt/openoffice.org1.9.104/program/scalc
pour le module de tableur
/opt/openoffice.org1.9.104/program/simpress
pour le module de présentation
/opt/openoffice.org1.9.104/program/sbase
pour le module de base de données
/opt/openoffice.org1.9.104/program/sdraw
pour le module de dessin
/opt/openoffice.org1.9.104/program/smath
pour le module de formules mathématiques

puis choisissez une icône en cliquant sur le bouton de droite
Vous pouvez maintenant lancer les différents modules d'OpenOffice version anglaise depuis votre barre des tâches.

TELECHARGER ET INSTALLER LE SHELL SCRIPT DE FRANCISATION
Téléchargez le shell script de francisation :
http://oootranslation.services.openoffi ... pack_fr.sh
et placez-le dans le dossier /opt/openoffice.org1.9.104
En console, déplacez-vous dans le dossier /opt/openoffice.org1.9.104
puis copiez-collez et lancez : sh OOo_1.9.104_LinuxIntel_langpack_fr.sh
A la question : Do you agree to the above license terms? (yes or no)
Répondez yes
A la question : Where do you want to install the language pack ? [/opt/openoffice.org1.9.104]
Laissez libre, appuyez seulement sur la touche Entrée

Une fois l'invite revenue, copiez-collez : sh setofficelang fr-FR
Cela a normalement pour effet de franciser OpenOffice.
Pour vérifier que le français est maintenant disponible, copiez-collez et lancez : sh setofficelang -l
Vous devez obtenir :
en-US
fr
Si c'est le cas, vous devez normalement avoir OpenOffice correctement installé et francisé.
Avatar de l'utilisateur
pacman1897
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 286
Inscription: 25 Juil 2003 11:40
 

Message le 16 Juin 2005 08:27

De rien... plus jeune, j'ai bien fait de pas trop sécher les cours d'anglais, c'est tout.
:wink:
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8917
Inscription: 13 Mai 2003 17:32
Localisation: A.H.P... et jamais loin d'une Debian
 



Sujets similaires

Message Script pour désactiver/activer Bluetooth
Bonjour, Connaissez-vous la commande en batch qui permet de désactiver les périphériques Bluetooth de notre PC ? J'aimerais en quelques lignes coder un .bat qui effectue ceci : - Désactive le Bluetooth - Wait 5 s - Réactive le Bluetooth Un grand merci !
Réponses: 0

Message [Résolu] outlook 2003 impossible d'envoyer des messages
Bonjour,Depuis quelque temps, je ne peux plus envoyer de messages, une erreur suivante apparait: "le serveur sortant (SMTP) ne prend pas en charge les connections sécurisées par SSL...."Ca marchait parfaitement avant, impossible même en modifiant les paramètres du compte.Pouvez vous m'aide ...
Réponses: 5

Message [Résolu] Demande de désinfection , Windows 10
Bonjour,je voudrais savoirs si m'ont pc à des adwares ou autres. Mon PC n'ai pas lent et ne montre pas de signe d'infection mais cela fait environs 7-8 mois donc peut êtres que des choses ce sont accumuler .Les rapports FRST demander:Addition.txtFRST.txtMerci d'avance
Réponses: 11

Message [Résolu] problème avec le groupe résidentiel
Bonjour,J'ai créée un réseau avec 4 pc sous Windows 10 dans un groupe résidentiel mais est-ce normal de pouvoir accéder uniquement du premier pc qui m'a permis de créer le groupe mais pas de le voir sur les autres pc ?Dans la partie "réseau", je ne vois que les "périphériques médias& ...
Réponses: 30

Message [résolu] adobe flash pour firefox
bonjour j'arrive a poster entre deux validations de cookies j'ai besoin d'adobe flash pour voir des vidéos sur forum auto et je ne peut pas l'installer j'ai téléchargé le paquet mais je coince toujours avec les installations le paquet : flash_player_npapi_linux.x86_64.tar.gzsi c'est celui la ...
Réponses: 3

Message [Résolu] réglage de firefox
bonjour entre le moment ou j'ai éteint le pc hier soir et ce matin quand je l'ai rallumé il c'est passé un truc (ça me rappel windows)quand j'ouvrais firefox j'avais une page blanche avec la fenêtre de recherche google au milieu ,ce matin c'est fini !j'ai les dernières pages visitées ,si je décoche ...
Réponses: 25


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 3 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.