Il y a actuellement 93 visiteurs
Samedi 16 Décembre 2017
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

speedtouch sous mandrake 10.0

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

speedtouch sous mandrake 10.0

Message le 19 Avr 2004 12:11

hi,

nouvelle version de mandrake et probleme identique...
J' ai recopier le microcode dans usr/share/speedtouch/ mais je n'a rrive pas a me connecter ....
sinon le reste est nickel ...

A+
Avatar de l'utilisateur
max_evans
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 245
Inscription: 25 Oct 2003 14:21
 


Message le 19 Avr 2004 13:12

Quel est ton fournisseur d'accès a internet ?
Quel était le message de mandrake pour l'installation du speedtouch ?
Quel fichier as-tu copié ?
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

speedtouch sous mdk10

Message le 19 Avr 2004 23:01

hi,

Je suis chez Scarlet.
Comme d' habitude, j' ai copier le alcaudsl.sys du cd d' instalation que j' ai renommé en mgmt.o que j' ai mis dans usr/share/speedtouch.
Mais quand je lance drakconnect il n' arrive pas a ce connecté.

A+
Avatar de l'utilisateur
max_evans
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 245
Inscription: 25 Oct 2003 14:21
 

alcatel sous mdk 10.0

Message le 20 Avr 2004 00:14

salut,

Bon j' ai fait quelques recherches et j' ai vu que j' était pas le seul a avoir ce probleme...apparement cela viendrais du kernel 2.6 !
Si quelqu' un a une solution (simple)....

A+
Avatar de l'utilisateur
max_evans
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 245
Inscription: 25 Oct 2003 14:21
 

Message le 20 Avr 2004 10:23

La méthode du driver user-space n'est apparemment plus valide dans le noyau 2.6.

Il semblerait que le driver soit fourni directement dans la distrib :

http://gav.homeip.net/wikini/wakka.php? ... ge24Vers26
http://www.linuxquestions.org/questions/history/154168
http://forum.hardware.fr/hardwarefr/OSA ... 5677-1.htm

- Premiere solution (qui nécessite de modifier à la main et recompiler le noyau) :
http://www.mail-archive.com/speedtouch@ ... 05299.html

- Deuxieme Solution (qui nécessite éventuellement une recompilation du noyau et quelques adaptations)
http://forums.gentoo.org/viewtopic.php?t=99759

- Un logiciel qui peut éventuellement t'aider a configurer ca (aucune garantie de succès).
http://speedtouchconf.sourceforge.net/

Apparemment la configuration de ton modem ne sera pas de tout repos...
Je profite donc de cette occasion pour te demande ton niveau de compétences en tant qu'utilisateur de Linux|Unix ...
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 20 Avr 2004 10:36

Apparemment Lea-Linux a rédigé une aide pour le driver qui nous intéresse :

http://lea-linux.org/hardware/pack-xtense.html

(la démarche a suivre commence au milieu de la page).
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

va y avoir du boulot...

Message le 20 Avr 2004 10:53

salut,

Merci pour ta réponse rapide et ton interet pour ma modeste personne ...lol

Mon niveau ... on va dire débutant confirmé... lol...

J' ai vu la howto de chez lea linux... pas de tout repos le tuto...
En plus sous mdk sans internet ... va falloir tout recuperer sous win ... bonjour la manip...
J' en profite aussi pour dire qu' il commence a etre enervant chez mandrake, cela fait 3 versions (9.1-9.2-10.0) et tjs pas une maniere simple pour installer la raie qui est quand meme un modem fort répandu.
Sur le board de mdk la moitie des probs viennet de ce modem.
Soit je m' arme de patience ou je repasse en 9.2 ou je change de distribution...

A+
Avatar de l'utilisateur
max_evans
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 245
Inscription: 25 Oct 2003 14:21
 

Re: va y avoir du boulot...

Message le 20 Avr 2004 11:33

max_evans a écrit:salut,
J' ai vu la howto de chez lea linux... pas de tout repos le tuto...

Tu remarqueras que c'est tt de meme la plus simple des solutions...

J' en profite aussi pour dire qu' il commence a etre enervant chez mandrake, cela fait 3 versions (9.1-9.2-10.0) et tjs pas une maniere simple pour installer la raie qui est quand meme un modem fort répandu.

Dans tous les cas, ce n'est malheureusement pas la faute de mandrake.
Pour des raisons légales, ils ne peuvent pas distribuer le firmware du speedtouch dans la distribution. C'est donc à l'utilisateur de se taper cette partie de l'installation...

Le probleme ici est le passage au noyau 2.6. Le driver du speedtouch a été inclus au kernel (tant mieu, mais le firmware ne peut pas tjrs pas etre distribué), ce qui nécessite de modifier ses habitudes.

Au final (lorsque le kernel est bien paramétré) la manip est plus simple qu'avec l'ancienne méthode...

change de distribution...
Cela reviendra au meme vu qu'il s'agit d'une non-adaptation des tutoriaux au nouveau noyau et que les distrib vont toutes passer au 2.6 progressivement...
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

merci

Message le 21 Avr 2004 10:56

salut,

Merci je te tiens au courant ...
A+
Avatar de l'utilisateur
max_evans
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 245
Inscription: 25 Oct 2003 14:21
 

speedtouch le retour ...

Message le 23 Avr 2004 08:37

hi,

En continuant mes recherches d'une solution facile j' ai trouve un petit utilitaire qui s' appelle speedtouchconf-20-03-2004.
Je le decompresse je le lance et voila le message :

Configuring SpeedTouch Driver...
Software Configuration - SUCCESS
Building SpeedTouch Driver...
Software Build - SUCCESS
Installing SpeedTouch Driver...
Software Installation - SUCCESS
You have a default router : **.**.***.* (removing it for you!)
Configuration finished.

Jusqu' ici tout va bien

Starting the connection
The modem lights should start flashing for approx. 20 seconds...

Mon modem ne clignote pas, les 2 lampes reste bien verte ...

The modem_run command failed (code 250)
modem_run results:
Failed to load microcode - this is not a problem if you
have already loaded the microcode.
The microcode can only be loaded once per system boot;
We'll assume that the microcode is already loaded, and
not call this an error.
You may encounter problems, though.

Logique vu que je lance la connection au demarrage de linux

Running : pppd call adsl
ppp0: erreur lors de la recherche d'infos sur l'interface: Périphérique non trouvé

Don't seem to have connected.

Please check the username and password in /etc/ppp/*-secrets.

Je check mais c' est les bons id et pass

Then run /etc/rc.d/init.d/speedtouch start

[ECHEC]

Et M... j' y était presque..... Tu vois ce que ça peux etre...Merci

A+
Avatar de l'utilisateur
max_evans
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 245
Inscription: 25 Oct 2003 14:21
 

Message le 23 Avr 2004 10:44

La démarche a suivre est donnée en 2eme partie de cette page (cherche Driver du kernel) :

http://lea-linux.org/hardware/pack-xtense.html

Tu peux (a priori) zapper toute la partie concernant la compilation du noyau.
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

compilation kernel

Message le 23 Avr 2004 23:29

salut,

J' ai zappe cette partie sur la compil du noyau...car c' est un niveau un peu trop pour moi mais bon j' ai imprime la howto et je vais essaye de decrypter ... :cry:

A+
Avatar de l'utilisateur
max_evans
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 245
Inscription: 25 Oct 2003 14:21
 

reprenons depuis le debut...

Message le 24 Avr 2004 09:57

hi,

dans le howto lealinux pourrait tu m' éclairer sur quelques points obscurs...

1. Comment voir si mon noyau est compilé avec les options demandées
2. quand je fait lsmod j' ai ceci :

lsmod

usb-uhci 24976 0 (unused)

3. quand je fait :

cat /proc/bus/usb/devices

S: Manufacturer=ALCATEL
S: Product=Speed Touch USB
S: SerialNumber=0090D03E456F
C:* #Ifs= 3 Cfg#= 1 Atr=80 MxPwr=500mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)
E: Ad=81(I) Atr=03(Int.) MxPS= 16 Ivl=50ms
I: If#= 1 Alt= 0 #EPs= 0 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)
I: If#= 1 Alt= 1 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)
E: Ad=06(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=07(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=87(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms

alors que dans le tuto ils ont :
If#= 0 Alt= 0 #EPs= 1 Cls=ff(vend.) Sub=00 Prot=00 Driver=usbdefvs

sinon j' ai installé les drivers speedtouch-1.2.tar et je n' ai pas eu de problemes...

help...

A+
Avatar de l'utilisateur
max_evans
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 245
Inscription: 25 Oct 2003 14:21
 

Re: reprenons depuis le debut...

Message le 24 Avr 2004 15:55

max_evans a écrit:hi,
1. Comment voir si mon noyau est compilé avec les options demandées


Tout d'abord, tape uname -a dans un terminal afin de déterminer la version de ton noyau.

Ensuite, normalement dans le répertoire /boot, il y a un/des fichiers nommés "config-X.Y.Z-blablabla" où X.Y.Z-blabla est le numéro du noyau.

Il contient toutes les options de configuration du noyau ( PARAMETRE=y ou n (ou m pour module) )

2. quand je fait lsmod j' ai ceci : lsmod

usb-uhci 24976 0 (unused)


Cela veut dire que le driver USB UHCI n'est pas utilisé. (mais peut etre que OHCI et EHCI le sont eux...)

3. quand je fait :
I: If#= 0 Alt= 0 #EPs= 1 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)
[...]
I: If#= 1 Alt= 0 #EPs= 0 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)
I: If#= 1 Alt= 1 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)
[...]
alors que dans le tuto ils ont :
If#= 0 Alt= 0 #EPs= 1 Cls=ff(vend.) Sub=00 Prot=00 Driver=usbdefvs

Cela veut dire (dans le tuto) que le module usbdevfs prend en charge ton périphérique normalement.

Peut-être devrais tu vérifier dans le fichier /etc/fstab la présence de la ligne :

none /proc/bus/usb usbdevfs defaults 0 0

et l'ajouter au cas échéant...
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

help...help..

Message le 26 Avr 2004 21:10

hello,

bon la il va falloir m' éclairer...
Il faut configurer le kernel (au moins pour les 2.22 et plus) de la maniére suivante :


Code Maturity Level Options
Prompt for development and/or incomplete code/drivers [Y]
Loadable Module Support
Enable Loadable Module Support [Y]
General Setup
Support for hot-pluggable devices [Y]
Networking Options
Packet Socket [Y]
Asynchronous Transfer Mode (ATM) (EXPERIMENTAL) [Y/M]
Network Device Support
PPP (Point-to-Point Protocol) Support [Y/M]
PPP Deflate Compression [Y/M]
USB Support
Support for USB [Y]
Preliminary USB Device Filesystem [Y]
UHCI (Intel PIIX4, VIA,...) Support [Y/M]
OHCI (Compaq, iMacs, OPTi, SiS, ALi, ...) support [Y/M]
Network Device Support
PPP Over ATM (EXPERIMENTAL) [Y/M]

ou et comment on voit ça et comment on le configure????????????????
Pour le reste, configurez correctement votre kernel

????????????????????????????????????????????????????????????

Désolé je suis un passionné pas informaticien ... (quoique qu' en je pose ce genre de question a des connaissances qui sont gradué en info (bac +3) j' ai l' impression qui me regarde comme si je débarquai de Mars !!! lol

Je comprend vite mais faut m' expliqué longtemps... re lol

A+

:roll:
Avatar de l'utilisateur
max_evans
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 245
Inscription: 25 Oct 2003 14:21
 

Suivante


Sujets similaires

Message speedtouch ST706 WL
Bonjour, Une petite question. Je possède un modem Thomson Speedtouch ST706 WL. Ceci est un ancien modem TELE2 belge que j'ai flashé et débridé pour le rendre passe partout. J'aimerais bien savoir combien de pc peuvent être connecter simultanément. Je demande ceci car les modems Philips de chez Bel ...
Réponses: 6

Message driver pour modem alcatel (thomson) speedtouch 330
Bonjour, Je dois installer mon modem thomson speed touch 330 sur vista mais je galère parce que je n'ai pas le bon driver étant donné que vista n'existait pas lorsque j'ai acheté mon modem... Vous pouvez me filer un lien pour le bon driver svp? Merci
Réponses: 1

Message Connectivité limitée ou inexistante: SpeedTouch 530 Ethernet
Bonjour à tous. Je suis nouveau sur ce forum et ceci est mon premier message. Je possède un PC contenant deux disques durs sous Windows XP. Sur les deux, j'y ai installé une connexion internet depuis longtemps déjà. Sur l'un des deux disques dur, un jour, la connexion internet ADSL n'a plus fonct ...
Réponses: 16

Message Installation de la mandrake sur disque sata
J'ai un serveur avec 3 disque sur sata et j'aimerai installer la Mandrake 10.1. L'installation commence a peine après j'ai une fenêtre qui me demande : Quel pilote disk/ide faut-il essayer? Après les avoir tous essayé j'ai toujours le même message d'erreur: le chargement du module xxxxx a échoué. Es ...
Réponses: 2

Message speedtouch de tele 2
Bonjour, Voila j'ai un modem wifi speedtouch de tele 2, je voudrais ouvrir les ports pour le xbox live et je n'y arrive pas, pouvais vous m'aider ?
Réponses: 1

Message PROBLEME MODEM SPEEDTOUCH AVEC XP
BONJOUR Je viens d'acheter un pc hp slimline 7530 avec xp j'avais auparavant un pc avec windows 98 le probleme est que je n'ai plus de connexion internet adsl ni avec mon ancien pc ni avec le nouveau a cause de mon speedtouch 330 je suis chez aol il mon donné le nouveau pilote du modem cela ne marc ...
Réponses: 1

Message [Mandrake 10.1] Problème d'installation d'une clé USB
Bonjour, J'ai actuellement un problème pour installer une clé USB sous Mandrake Linux 10.1 Plusieurs choses s'avèrent anormales lors de la procédure d'installation : - La clé ne semble pas reconnue car dans le repertoire dev, je n'ai pas de sda1. - La commande lsusb ne donne rien (aucun résulta ...
Réponses: 3


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 4 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.