Il y a actuellement 43 visiteurs
Vendredi 22 Juin 2018
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

[xinitrc]probleme fond d'ecrand fluxbox

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

[xinitrc]probleme fond d'ecrand fluxbox

Message le 13 Aoû 2003 17:55

voilas mon .xinitrc (comme dans la doc de fluxbox(je croi :roll: ))
Code: Tout sélectionner
#!/bin/sh
fluxbox & wmpid=$!
bsetbg ~/icones/gentoo1280x1024.jpg
wmbiff &
wmxmms &
#wmsmixer -w -s -r 2 -l "rgb:22/AA/FF" &
wmtop -a 4 -U &
wmnd -i eth0 &
wmclockmon &
wmdrawer &
wait $wmpid

quand je demare xinit pour la premiere foix l'image (bsetbg ~/icones/gentoo1280x1024.jpg ) s'affiche puis disparait mais si je quite fluxbox et que je le relance ça fonctionne :-?

comment faire pour que ça fonctionne depuis le premier coup ?
je suis débutant et j'ai installé GENTOO (j'avais pas plus con comme idée) mais bon j'aime bien les problemes ;-)
Avatar de l'utilisateur
gnuprotek
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 229
Inscription: 23 Juil 2003 17:02
 


Message le 13 Aoû 2003 20:14

Certains themes de fluxbox contiennent une commande pour changer l'apparence du fond (la root window).

Je te conseille de copier le theme que tu utilise dans ton ~/.fluxbox/styles et vérifier si ce qui correspond à rootCommand: dans ce fichier de theme lance bien la meme commande que toi pour ton fond d'écran...

(Profite en pour renommer le theme a ta facon, et n'oublies pas de modifier le fichier de config de fluxbox en conséquence)


Conseil personnel : Dans ton .xinitrc, définis une variable BGIMA de cette facon :

export BGIMA="/home/gnuprotek/background.jpg"

et dans ton fichier de theme de fluxbox, fais ceci :

rootCommand: bsetbg $BGIMA && Esetroot $BGIMA

Cela te permettra de changer plus facilement ton fond d'écran...
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 17:22
Localisation: Entre deux BarCamps
 

Message le 14 Aoû 2003 20:38

ça fonctionne :wink: (merci)

si j'ai bien compris tu crée une variable BGIMA avec le chemin de mon image
que tu affiche avec la commande bsetbg jusque la ça va
c'est apres que ça ce complique :o

ça &&<-- ça sert a quoi
et
ça Esetroot $BGIMA???

tu saurais m'expliquer svp :wink:
je suis débutant et j'ai installé GENTOO (j'avais pas plus con comme idée) mais bon j'aime bien les problemes ;-)
Avatar de l'utilisateur
gnuprotek
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 229
Inscription: 23 Juil 2003 17:02
 

Message le 14 Aoû 2003 20:57

gnuprotek a écrit:ça fonctionne :wink: (merci)

si j'ai bien compris tu crée une variable BGIMA avec le chemin de mon image
que tu affiche avec la commande bsetbg jusque la ça va

Impec, le reste c'est rien :)

&&<-- ça sert a quoi

Ca sert de séparateur entre 2 commandes. De plus la deuxieme commande est executée uniquement si la premiere réussi (contrairemetn à ";" qui permet d'executer une commande peu importe leur status a l'arrivée)

ça Esetroot $BGIMA???

c'est l'equivalent de bsetbg pour Enlightenment.
Malheureusement il n'y a pas encore de procédé commun a tous les logiciels sous Xfree pour gérer la transparence dans les applications et je suis obligé d'utiliser les 2 commandes pour etre sur que certaines app afficheront correctement certains trucs...
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 17:22
Localisation: Entre deux BarCamps
 

Message le 14 Aoû 2003 21:28

c'et plus claire comme ça :wink:

c'est avec Esetroot qu'on peus avoir un eterm totalement transparent (j'ai lu ça qq part mais je sai plus ou !!!! ou alors je suis totalement hors sujet :o j'arete pas de lire des tutos et je m'enbrouille un peus qq jours de repos ça me ferras du bien 8) ) si c'est ça !!! ça marche aussi avec xterm ?
je suis débutant et j'ai installé GENTOO (j'avais pas plus con comme idée) mais bon j'aime bien les problemes ;-)
Avatar de l'utilisateur
gnuprotek
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 229
Inscription: 23 Juil 2003 17:02
 

Message le 14 Aoû 2003 22:13

gnuprotek a écrit:c'et plus claire comme ça :wink:

c'est avec Esetroot qu'on peus avoir un eterm totalement transparent


Oui c'est ca, c'est (entre autres) Eterm qui ne supporte pas bsetbg...


ça marche aussi avec xterm ?
Xterm non, mais Aterm oui,et il bouffe moins de RAM que Eterm...
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 17:22
Localisation: Entre deux BarCamps
 

Message le 14 Aoû 2003 22:21

ok merci :wink:
je suis débutant et j'ai installé GENTOO (j'avais pas plus con comme idée) mais bon j'aime bien les problemes ;-)
Avatar de l'utilisateur
gnuprotek
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 229
Inscription: 23 Juil 2003 17:02
 



Sujets similaires

Message Problème nuance PDF Create 8
Bonjour depuis quelque temps, dès que j'allume mon ordinateur une fenêtre se lance comme celle de la photo :https://cjoint.com/c/HFprD3VRzYBquoi que je fasse elle ne peut pas être fermé....je n'ai aucune idée d'où cela peut venir et qu'est-ce que c'est excatementmerci d'avance pour votre aide
Réponses: 14

Message Problème de magnétisation
Bonjour bonsoir,Après maintes recherches je me tourne vers vous afin d'obtenir des réponses a mon problème.Je pense avoir un problème de magnétisation et cela affecte je pense mon disque dur physique 3.5".Parfois il est inaccessible, non reconnu par le pc comme si il était déconnecté puis après ...
Réponses: 4

Message problème avec le groupe résidentiel
Bonjour,J'ai créée un réseau avec 4 pc sous Windows 10 dans un groupe résidentiel mais est-ce normal de pouvoir accéder uniquement du premier pc qui m'a permis de créer le groupe mais pas de le voir sur les autres pc ?Dans la partie "réseau", je ne vois que les "périphériques médias& ...
Réponses: 29

Message PROBLEME IPHONE 7PLUS RESTE BLOQUE SUR L'ECRAN " Bonjour.."
Bonsoir,J'ai fais la réparation d'un Iphone 7 Plus ( écran cassée ) , etc ... Le probléme c'est qu'au redémarrage du télephone , que j'ai pris soin de restaurer car je le voulais ! Mais le bouton "Home" et les boutons " Volume " ne marche plus j'ai donc essayé de redémonter l'Ip ...
Réponses: 2

Message Virus ou problème de mise à jour
BonjourJ'ai déjà posté sur ce forum pour des problèmes récurrents avec un Lenovo et Windows 8.1. Après certaines mises à jour il débloque.Dernièrement j'ai eu les messages suivantsDefault boot device missing or boot failedInsert recovery media and hit any key...J'ai réussi à le démarrer je ne sais p ...
Réponses: 6

Message Problème connexion Disque dur Externe
Bonjour j'ai retrouvé dans la cave de mes parents il y a quelque jour un disque dur externe Seagate BlackArmor NAS 220 et je rencontre un petit problème a le faire fonctionner ... tout simplement le disque dur n'est pas reconnu par le logiciel. J'ai suivi la notice, branché le disque dur au secteur ...
Réponses: 5

Message Problème câble alimentation manquant.
Bonjour il y a quelque heure j'ai retrouvé dans ma cave un disque dur externe de 2 TB dont le modèle est :BlackArmor NAS 220 de Seagate. Il appartenait a ma famille mais en gros un des câble a été perdu et c'est le câble d'alimentation.. sur la notice la seule mention faites que j'ai trouvé est : 'p ...
Réponses: 4


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité


.: Nous contacter :: Flux RSS :: Données personnelles :.