Il y a actuellement 71 visiteurs
Mardi 25 Septembre 2018
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

[xinitrc]probleme fond d'ecrand fluxbox

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

[xinitrc]probleme fond d'ecrand fluxbox

Message le 13 Aoû 2003 17:55

voilas mon .xinitrc (comme dans la doc de fluxbox(je croi :roll: ))
Code: Tout sélectionner
#!/bin/sh
fluxbox & wmpid=$!
bsetbg ~/icones/gentoo1280x1024.jpg
wmbiff &
wmxmms &
#wmsmixer -w -s -r 2 -l "rgb:22/AA/FF" &
wmtop -a 4 -U &
wmnd -i eth0 &
wmclockmon &
wmdrawer &
wait $wmpid

quand je demare xinit pour la premiere foix l'image (bsetbg ~/icones/gentoo1280x1024.jpg ) s'affiche puis disparait mais si je quite fluxbox et que je le relance ça fonctionne :-?

comment faire pour que ça fonctionne depuis le premier coup ?
je suis débutant et j'ai installé GENTOO (j'avais pas plus con comme idée) mais bon j'aime bien les problemes ;-)
Avatar de l'utilisateur
gnuprotek
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 229
Inscription: 23 Juil 2003 17:02
 


Message le 13 Aoû 2003 20:14

Certains themes de fluxbox contiennent une commande pour changer l'apparence du fond (la root window).

Je te conseille de copier le theme que tu utilise dans ton ~/.fluxbox/styles et vérifier si ce qui correspond à rootCommand: dans ce fichier de theme lance bien la meme commande que toi pour ton fond d'écran...

(Profite en pour renommer le theme a ta facon, et n'oublies pas de modifier le fichier de config de fluxbox en conséquence)


Conseil personnel : Dans ton .xinitrc, définis une variable BGIMA de cette facon :

export BGIMA="/home/gnuprotek/background.jpg"

et dans ton fichier de theme de fluxbox, fais ceci :

rootCommand: bsetbg $BGIMA && Esetroot $BGIMA

Cela te permettra de changer plus facilement ton fond d'écran...
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 17:22
Localisation: Entre deux BarCamps
 

Message le 14 Aoû 2003 20:38

ça fonctionne :wink: (merci)

si j'ai bien compris tu crée une variable BGIMA avec le chemin de mon image
que tu affiche avec la commande bsetbg jusque la ça va
c'est apres que ça ce complique :o

ça &&<-- ça sert a quoi
et
ça Esetroot $BGIMA???

tu saurais m'expliquer svp :wink:
je suis débutant et j'ai installé GENTOO (j'avais pas plus con comme idée) mais bon j'aime bien les problemes ;-)
Avatar de l'utilisateur
gnuprotek
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 229
Inscription: 23 Juil 2003 17:02
 

Message le 14 Aoû 2003 20:57

gnuprotek a écrit:ça fonctionne :wink: (merci)

si j'ai bien compris tu crée une variable BGIMA avec le chemin de mon image
que tu affiche avec la commande bsetbg jusque la ça va

Impec, le reste c'est rien :)

&&<-- ça sert a quoi

Ca sert de séparateur entre 2 commandes. De plus la deuxieme commande est executée uniquement si la premiere réussi (contrairemetn à ";" qui permet d'executer une commande peu importe leur status a l'arrivée)

ça Esetroot $BGIMA???

c'est l'equivalent de bsetbg pour Enlightenment.
Malheureusement il n'y a pas encore de procédé commun a tous les logiciels sous Xfree pour gérer la transparence dans les applications et je suis obligé d'utiliser les 2 commandes pour etre sur que certaines app afficheront correctement certains trucs...
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 17:22
Localisation: Entre deux BarCamps
 

Message le 14 Aoû 2003 21:28

c'et plus claire comme ça :wink:

c'est avec Esetroot qu'on peus avoir un eterm totalement transparent (j'ai lu ça qq part mais je sai plus ou !!!! ou alors je suis totalement hors sujet :o j'arete pas de lire des tutos et je m'enbrouille un peus qq jours de repos ça me ferras du bien 8) ) si c'est ça !!! ça marche aussi avec xterm ?
je suis débutant et j'ai installé GENTOO (j'avais pas plus con comme idée) mais bon j'aime bien les problemes ;-)
Avatar de l'utilisateur
gnuprotek
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 229
Inscription: 23 Juil 2003 17:02
 

Message le 14 Aoû 2003 22:13

gnuprotek a écrit:c'et plus claire comme ça :wink:

c'est avec Esetroot qu'on peus avoir un eterm totalement transparent


Oui c'est ca, c'est (entre autres) Eterm qui ne supporte pas bsetbg...


ça marche aussi avec xterm ?
Xterm non, mais Aterm oui,et il bouffe moins de RAM que Eterm...
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 17:22
Localisation: Entre deux BarCamps
 

Message le 14 Aoû 2003 22:21

ok merci :wink:
je suis débutant et j'ai installé GENTOO (j'avais pas plus con comme idée) mais bon j'aime bien les problemes ;-)
Avatar de l'utilisateur
gnuprotek
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 229
Inscription: 23 Juil 2003 17:02
 



Sujets similaires

Message Problème avec chats vocaux (débit ascendant insuffisant ?)
Salut à tous,Je rencontre depuis plusieurs semaines un problème qui me dépasse complètement et que je n'arrive pas du tout à comprendre. Mon problème est simple : je n'arrive plus à communiquer par chat vocal que ce soit sur Discord, Steam ou Skype. Mon ordinateur est un MSI GE70 (ordi portable) de ...
Réponses: 4

Message probleme avec Nvidia Geforce experience
Bonjour,Alors voila je viens de changer ma carte graphique j'avais une gtx 770 et maintenant j'ai installer une 1080.Le problème c'est quand je vais dans Nvidia expérience pour optimiser mes jeux bin le logiciel garde les optimisations de mon ancienne carte graphique.Voila si quelqu'un peut m'aider. ...
Réponses: 5

Message [Résolu] problème avec le groupe résidentiel
Bonjour,J'ai créée un réseau avec 4 pc sous Windows 10 dans un groupe résidentiel mais est-ce normal de pouvoir accéder uniquement du premier pc qui m'a permis de créer le groupe mais pas de le voir sur les autres pc ?Dans la partie "réseau", je ne vois que les "périphériques médias& ...
Réponses: 30

Message Problème lors d'une recherche pour gmail sur mozzilla
Salut à tous, j'ai fait l'acquisition d'un pc tout en 1 hp pavillon 24, et depuis maintenant 1 mois j'ai un souci, lorsque je suis sur un onglet, j'en créer un nouveau (j'utilise mozzilla) je tape dans la barre de recherche gmail, j'ai de suite un lien qui me sort sans arrêt en premier gmail.net des ...
Réponses: 20

Message Problème Moniteur ou carte graphique
Bonjour les amis, j?espère que vous allez bien .Je reviens vers vous , car je rencontre un problème qui est plutôt handicapant.Voyez par vous même :( J?aurais voulu savoir si cela peut être réparé, sinon comment corriger cela ou bien encore . Comment localiser la source du problème (moniteur/carte g ...
Réponses: 1

Message probléme appairage casque bluetooth
Bonjour je sais pas si je suis dans le bon forum, j'ai acheter jeudi dernier le casque bluetooth mdr-zx330bt au Leclerc à coté de chez moi et le problème c'est que j'arrive pas à associer le casque avec d'abord mon téléphone portable qui est un Samsung Galaxy j5 2016 et puis après à ma tablette Asus ...
Réponses: 5

Message PROBLÈME DE CONNEXION SUR UN SITE
BonjourJe ne peux plus me connecter sur le site Amazon avec mon PC fixe ou ma tabletteConnection lente pour aboutir à u e page restructurée Par contre je peux me connecter sans problème avec mon téléphone mobileJ'ai fait une capture d'écran mais je sais pas le mettre sur ce message Merci d'avance ...
Réponses: 15


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 5 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.