Il y a actuellement 121 visiteurs
Mardi 06 Décembre 2022
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

changer la resolution d'affichage sous BT2

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

changer la resolution d'affichage sous BT2

Message le 20 Avr 2007 13:10

Bonjour tout le monde
je viens d'installer backtrack 2 en dur sur mon pc portable (petite config => celeron 450MHZ 128 de ram)

seulement mon affichage était en 800*600 sous kde

alors pendant le boot avant de lancer KDE avec la commande startx j'ai lancer xconf je penser que cela aller me configure correctement mon affichage l'effet a était inverse je me retrouve avec un affichage en 640*480 .

comment avoir un affichage en 1024*768 ?
je c'est que mon pc portable le supporte car sous windows xp il était en 1024*768

merci de votre aide
site web http://halflife2dm.free.fr
map db_rock
Image
Avatar de l'utilisateur
zelio22
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 382
Inscription: 29 Avr 2004 10:38
 


Message le 23 Avr 2007 09:49

es que quelqu'un peut m'aider
site web http://halflife2dm.free.fr
map db_rock
Image
Avatar de l'utilisateur
zelio22
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 382
Inscription: 29 Avr 2004 10:38
 

Message le 23 Avr 2007 13:55

Tu as quoi comme carte graphique ? Es-tu certain d'avoir sélectionné le bon modèle dans l'assistant xconf ?
Quel est le contenu du fichier xorg.conf situé (normalement) dans /etc/X11 ?
N'as-tu pas un outil dans BT2 te permettant de changer la résolution à la volée ?
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Faire le mort est une stratégie de défense chez les rongeurs, les insectes et les techniciens du support informatique
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 9023
Inscription: 13 Mai 2003 16:32
Localisation: Sisteron... et jamais loin d'une Debian
 

Message le 23 Avr 2007 15:10

Tu as quoi comme carte graphique ?

pour ma carte graf c'est une trident Cyber 9525

Es-tu certain d'avoir sélectionné le bon modèle dans l'assistant xconf ?

je ne trouve pas cette assistant
N'as-tu pas un outil dans BT2 te permettant de changer la résolution à la volée ?

oui seulement la seule resolution disponible et le 640*480

Voici le contenu du fichier xorg.conf

Code: Tout sélectionner
Section "ServerLayout"
Identifier     "X.org Configured"
Screen      0  "Screen0" 0 0
InputDevice    "Mouse0" "CorePointer"
InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath      "/usr/X11R6/lib/X11/rgb"
ModulePath   "/usr/X11R6/lib/modules"
FontPath     "/usr/X11R6/lib/X11/fonts/misc/"
FontPath     "/usr/X11R6/lib/X11/fonts/TTF/"
FontPath     "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath     "/usr/X11R6/lib/X11/fonts/CID/"
FontPath     "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath     "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
Load  "dbe"
Load  "dri"
Load  "extmod"
Load  "glx"
Load  "record"
Load  "xtrap"
Load  "freetype"
Load  "type1"
EndSection

Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
EndSection

Section "InputDevice"
Identifier  "Mouse0"
Driver      "mouse"
Option       "Protocol" "auto"
Option "ZAxisMapping" "4 5"
Option "Buttons" "3"
Option       "Device" "/dev/mouse"
Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier   "Monitor0"
VendorName   "Monitor Vendor"
ModelName    "Monitor Model"
EndSection

Section "Device"
Identifier  "Card0"
Driver      "trident"
VendorName  "Trident Microsystems"
BoardName   "Cyber 9525"
BusID       "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
SubSection "Display"
Viewport   0 0
Depth     1
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     4
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     8
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     15
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     16
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     24
EndSubSection
EndSection
site web http://halflife2dm.free.fr
map db_rock
Image
Avatar de l'utilisateur
zelio22
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 382
Inscription: 29 Avr 2004 10:38
 

Message le 23 Avr 2007 19:31

Essaye de lancer une configuration en tapant en console (en root) :
dpkg-reconfigure xserver-xorg

Je ne vois pas les résolutions possibles dans le xorg.conf... je ne sais pas comment l'aborder mais je pense que tu peux tenter de les rajouter.
En root :
Tu sauve d'abord ton xorg.conf actuel par un :
cd /etc/X11
cp xorg.conf xorg.conf.old


Tu édites ton xorg.conf (avec vim ou nano ou tout autre éditeur que tu connais) et tu ajoute les résolutions comme ceci :
Modes "1024x768" "800x600" "640x480"
... dans chaque "subsection" de la section "screen"
exemple :

...
SubSection "Display"
Viewport 0 0
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection
...


Rajoute aussi cette ligne pour une résolution par défaut :
DefaultDepth 24
ici :
...
Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"

...

Tu testes cela avec différentes résolutions par défaut, en les baissant :
DefaultDepth 24
puis
DefaultDepth 16
puis
DefaultDepth 15

La méthode pour tout cela, c'est de :
- modifier le xorg.conf
- lance X par startx et voir ce que ça donne
- fermer la session X au besoin
- recommencer avec d'autres paramètres dans le xorg.conf jusqu'à trouver ce qui doit aller
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Faire le mort est une stratégie de défense chez les rongeurs, les insectes et les techniciens du support informatique
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 9023
Inscription: 13 Mai 2003 16:32
Localisation: Sisteron... et jamais loin d'une Debian
 

Message le 23 Avr 2007 22:31

voici le nouveau xorg
il ne fonctionne pas non plus par contre quand je diminue le
DefaultDepth en dessous de 8 alors ca ne lance plus l'interface graphique

le commande dpkg-reconfigure xserver-xorg ne fonctionne pas

Code: Tout sélectionner
Section "ServerLayout"
Identifier     "X.org Configured"
Screen      0  "Screen0" 0 0
InputDevice    "Mouse0" "CorePointer"
InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath      "/usr/X11R6/lib/X11/rgb"
ModulePath   "/usr/X11R6/lib/modules"
FontPath     "/usr/X11R6/lib/X11/fonts/misc/"
FontPath     "/usr/X11R6/lib/X11/fonts/TTF/"
FontPath     "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath     "/usr/X11R6/lib/X11/fonts/CID/"
FontPath     "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath     "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
Load  "dbe"
Load  "dri"
Load  "extmod"
Load  "glx"
Load  "record"
Load  "xtrap"
Load  "freetype"
Load  "type1"
EndSection

Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
EndSection

Section "InputDevice"
Identifier  "Mouse0"
Driver      "mouse"
Option       "Protocol" "auto"
Option "ZAxisMapping" "4 5"
Option "Buttons" "3"
Option       "Device" "/dev/mouse"
Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier   "Monitor0"
VendorName   "Monitor Vendor"
ModelName    "Monitor Model"
EndSection

Section "Device"
Identifier  "Card0"
Driver      "trident"
VendorName  "Trident Microsystems"
BoardName   "Cyber 9525"
BusID       "PCI:1:0:0"
EndSection

Section "Screen"
DefaultDepth 24
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
SubSection "Display"
Viewport   0 0
Depth     1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

site web http://halflife2dm.free.fr
map db_rock
Image
Avatar de l'utilisateur
zelio22
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 382
Inscription: 29 Avr 2004 10:38
 

Message le 24 Avr 2007 07:32

Essaye, en console root :
xorgconfig
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Faire le mort est une stratégie de défense chez les rongeurs, les insectes et les techniciens du support informatique
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 9023
Inscription: 13 Mai 2003 16:32
Localisation: Sisteron... et jamais loin d'une Debian
 

Message le 24 Avr 2007 10:11

merci de ton aide après une bonne dizaine de xorgconfig
j'ai réussi a trouver la bonne résolution 1024*768 en 16bits
site web http://halflife2dm.free.fr
map db_rock
Image
Avatar de l'utilisateur
zelio22
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 382
Inscription: 29 Avr 2004 10:38
 



Sujets similaires

Message [résolu] problème d'affichage sur le forum d'orange
Bonjour J'ai besoin de communiquer en message privé avec Webconseiller mais quand je clique sur leurs pseudos, j'arrive sur la bonne page mais il n'y a pas le bouton pour envoyer un MP, bien sur il n'y a que moi avec ce souci. Ce que j'ai :Ce que je devrais voir :J'ai désactivé toutes les extensions ...
Réponses: 1

Message pb affichage facebook
bjr je suis sous w10 et depuis 2j quand j arrive en bas de facebook le defilement des publications de facebook va a toute vitessefirefox est a jour et je n ai pas de logiciel adblock avez vous une solutionmerci bcp
Réponses: 3

Message problème d'affichage sur pc HP
Bonjour,J'ai un problème sur un pc portable hp "pavilion dv6" car en allumant l'écran reste blanc et quand je le connecte sur un écran externe, j'aperçois le logo "ubuntu et il repart et l'écran devient "violet", c'est bizarre.Comment faire ? Merci Cdt
Réponses: 3

Message Changer le dns
Bonjour Est-ce que c'est bien utile de modifier le DNS pour plus de rapidité ?https://1.1.1.1/fr/Merci
Réponses: 20

Message Je voudrais changer le dossier du nom d'utilisateur, mais...
Bonjour à tous,comme le titre l'indique, je voudrais changer le nom du dossier utilisateur sous Windows auquel je suis connecté. La raison en est que je joue à un jeu (Halo Infinite) qui ne peut pas enregistrer ses paramètres car le nom du dossier a probablement un caractère spécial lettres (ö en al ...
Réponses: 1

Message Changer de carte graphique
Bonjour,Pourriez-vous m'indiquer un modèle carte graphique abordable car je souhaiterai changer mon ancienne qui est une "Nvidia Gtx 460" qui date de 2011 qui est sur mon pc avec un processeur i7 et 12 go de ram.MerciCordialement
Réponses: 5

Message [RESOLU] Probleme affichage de videos
Salut à tous !Avec mon PC portable ACER SWIFT 5, j'ai un petit bug d'affichage des vidéos notament sur Facebook.Les premieres secondes ressemble a ça (capture d'ecran) parfois meme ca rest comme ca.Le son lui fonctionne bien.C'est un probleme de mise a jour ? de codecs ou autres ? Merci !
Réponses: 8


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 10 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.