Il y a actuellement 147 visiteurs
Dimanche 27 Novembre 2022
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

Probleme de boot sous linux knoppix.

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

Probleme de boot sous linux knoppix.

Message le 16 Mar 2004 18:07

J'ai graver mon cd de knoppix mais quand je veux rebooter dessus comme le dise les consignes,il ya une erreur lors du chargement et apres ca s'arrete.Le message dit :Error:No suitable X-server found for your card.Comment je regle ce probleme moi?
Avatar de l'utilisateur
raphou
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 137
Inscription: 12 Jan 2004 20:36
 


Message le 16 Mar 2004 18:24

Réponse trouvé sur une faq knoppix :
"
Q: The graphical environment doesn't start on my system. I get messages such as:
retrying with Server XFree86(vesa)
retrying with Server XFree86(fbdev)
Error : no suitable X-Server found for your card.
A: On some machines, or with some graphics boards, Knoppix cannot determine which graphics X server to use with your hardware. It is then necessary to specify it manually as a boot option, using "xmodule=".
For example, some NVidia boards are not correctly detected. To use them, you must specify at the boot prompt: knoppix xmodule=nv
"

Knoppix n'est pas en mesure de reconnaitre ta carte graphique pour lui appliquer le driver approprié.
Il faut donc le démarrer avec l'option xmodule.
Syntaxes possible de xmodule ICI
Si ça fonctionne pas, tu reviens et tu donnes le modèle de ta carte graphique cette fois.
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Faire le mort est une stratégie de défense chez les rongeurs, les insectes et les techniciens du support informatique
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 9022
Inscription: 13 Mai 2003 16:32
Localisation: Sisteron... et jamais loin d'une Debian
 

Message le 16 Mar 2004 19:04

D'accord j'essaye ca.MERCI!
Avatar de l'utilisateur
raphou
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 137
Inscription: 12 Jan 2004 20:36
 

Message le 16 Mar 2004 19:25

p'tain ca marche pas .J'crois que j'ai pas compris ou est-ce qu'il fallait entrer le message et qu'est ce qu'il fallait entrer exactement.J'ai une carte graphic NVIDIA Geforce GTSGeforce pro.
Avatar de l'utilisateur
raphou
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 137
Inscription: 12 Jan 2004 20:36
 

Message le 16 Mar 2004 22:03

D'aprés les explicaions, avec une Geforce GTS il faut rentrer au boot de knoppix :
knoppix lang=fr xmodule=nv

C'est ça que tu tapes ?
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Faire le mort est une stratégie de défense chez les rongeurs, les insectes et les techniciens du support informatique
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 9022
Inscription: 13 Mai 2003 16:32
Localisation: Sisteron... et jamais loin d'une Debian
 

Message le 17 Mar 2004 13:10

J'ai tapé xmodule=nv seulement au debut .Je viens d'essayer ce que tu m'a dit et ca marche pas.En fait il a compris que knoppix lang=fr pasque j'ai essayé de le taper tout seul apres et ca a marché.Il faut que je l'ecrive avec des majuscules ou une syntaxe particuliere?
Avatar de l'utilisateur
raphou
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 137
Inscription: 12 Jan 2004 20:36
 

Message le 17 Mar 2004 14:51

J'espère qu'on se comprend bien...
La commande knoppix sert à lancer le chargement de knoppix
Ce qui est aprés cette commande, ce sont les arguments de la commande knoppix.
lang=fr pour un langage clavier en francais
xmodule=nv pour le forcer à reconnaitre ta Geforce

Donc... il faut taper (d'un seul trait) :
knoppix lang=fr xmodule=nv et valider.

Est-ce cela que tu tapes ???

(si ça fonctionne pas, je vais commencer à être limité sur cette question :roll: )
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Faire le mort est une stratégie de défense chez les rongeurs, les insectes et les techniciens du support informatique
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 9022
Inscription: 13 Mai 2003 16:32
Localisation: Sisteron... et jamais loin d'une Debian
 

Message le 17 Mar 2004 17:30

Mais nom de dieu ,c'est ca que je tape,et ca marche pas!
Avatar de l'utilisateur
raphou
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 137
Inscription: 12 Jan 2004 20:36
 

Message le 17 Mar 2004 17:53

raphou a écrit:Mais nom de dieu ,c'est ca que je tape,et ca marche pas!


essaye également de désactiver le framebuffer... les nvidia ont souvent du mal a supporter ca...

knoppix nofb

(tu peux éventuellement ajouter les parametres précédents : xmodule et lang...)
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2757
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 17 Mar 2004 18:26

glenux a écrit:(tu peux éventuellement ajouter les parametres précédents : xmodule et lang...)

Ca, ça signifie que tout ce que j'ai suggéré était faux ? :cry:
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Faire le mort est une stratégie de défense chez les rongeurs, les insectes et les techniciens du support informatique
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 9022
Inscription: 13 Mai 2003 16:32
Localisation: Sisteron... et jamais loin d'une Debian
 

Message le 17 Mar 2004 18:54

casa04 a écrit:Ca, ça signifie que tout ce que j'ai suggéré était faux ? :cry:


Absolument pas. C'est juste que la détection fonctionne assez bien en général, mais que le framebuffer ne peux pas etre désactivé automatiquement encore...
...Et qu'en général il y a des problemes avec le trio acpi/nvidia/framebuffer...
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2757
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 18 Mar 2004 20:33

Avec tout ca ,ca marche toujours pas! J'ai pas gravé linux pour rien quand meme? :roll:
Avatar de l'utilisateur
raphou
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 137
Inscription: 12 Jan 2004 20:36
 

Message le 20 Mar 2004 15:04

Vous avez pas d'idees?
Avatar de l'utilisateur
raphou
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 137
Inscription: 12 Jan 2004 20:36
 

Message le 20 Mar 2004 22:17

en passant xmodule=vesa avec nofb, cela fonctionne-t-il ?
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2757
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 22 Mar 2004 15:57

toujours pas.
Avatar de l'utilisateur
raphou
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 137
Inscription: 12 Jan 2004 20:36
 

Suivante


Sujets similaires

Message Quel distribution linux pour remplacer windows
BonjourJe suis un utilisateur de windows depuis plusieurs années maintenant, mais je cherche à me convertir vers une distribution linux, pour des raisons personnelles mais aussi professionnelles.Etant un gros débutant, je cherche une distribution plus semblable à windows, cela me permettra à m'y pre ...
Réponses: 1

Message Les Logiciels Utiles - GNU/Linux - Petit Retour 2019
Je me permets de reprendre ce magnifique sujet de w0lverineJe vais rajouter quelques liens qui peuvent être utiles...Le Monde du Libre est à vos pieds...Encore un tout petit pas Les Logiciels Utiles - GNU/Linux - Petit Retour...Message le 14 octobre 2019Pour les systèmes GNU/LinuxCle MultiBootUsb ...
Réponses: 4

Message problème d'allumage pc asus
Bonjour,Depuis quelques temps, mon pc portable Asus modèle G 741JW * T7105H" ne veut plus s'allumer alors qu'il est branché sur le secteur car il n'a plus de batterie pour l'instant mais je souhaite la changer si j'arrive à résoudre ce problème.L'alimentation serait-elle la source du problème ...
Réponses: 12

Message OS non détécté ? Problème de démarrage de l'ordinateur
Bonjour à tous,Je vous contacte au sujet d'un problème réccurent et assez problèmatique sur mon ordinateur fixe depuis maintenant quelques semaines. Pour résumer lors de démarrage de l'ordinateur, il arrive que Windows ne soit pas détecté (j'imagine) et que l'ordinateur affiche : " reboot and ...
Réponses: 9

Message [résolu] problème d'affichage sur le forum d'orange
Bonjour J'ai besoin de communiquer en message privé avec Webconseiller mais quand je clique sur leurs pseudos, j'arrive sur la bonne page mais il n'y a pas le bouton pour envoyer un MP, bien sur il n'y a que moi avec ce souci. Ce que j'ai :Ce que je devrais voir :J'ai désactivé toutes les extensions ...
Réponses: 1

Message portable sous linux pour enfant handicapé
Bonjour Un ordinateur portable pour enfant handicapé est à plus de 800 € comme ector. Est-ce que je peux acheter un portable d'occasion qui est sous windows et installé AccessDV Linux par exemple, à moins qu'il existe quelque chose de mieux ? C'est pour mon petit-fils. Merci d'avance
Réponses: 4

Message Problème de micro sur Hp Victus - grésillements
Bonjour,J'ai un problème sur mon pc portable Hp Victus (Windows 10). Lorsque je suis sur Skype ou des logiciels similaires, mes interlocuteurs me disent systématiquement que le son a beaucoup de grésillements, ce qui gêne beaucoup la conversation.J'utilise le micro du pc.J'utilise cela souvent pour ...
Réponses: 1


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité


.: Nous contacter :: Flux RSS :: Données personnelles :.
cron