Il y a actuellement 138 visiteurs
Dimanche 27 Novembre 2022
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

problème dhcp avec debian gateway adsl

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

problème dhcp avec debian gateway adsl

Message le 21 Aoû 2004 09:33

Bonjour,

Je suis en train d'installer at home une debian woody (kernel recompilé en 2.6.7) pour faire une passerelle internet derrière un modem adsl ethernet eci.
Je suis les indications de formation linux d'Alexis De Lattre.

Si je suis sur la passerelle, je peux aller sur internet bien que j'ai un message de dhcpdiscover comme quoi il ne trouve pas.

Par contre, apparemment le nat ne fonctionne pas : pas d'accès depuis un autre pc sous windows sur mon réseau avec ip gateway pointant sur la passerelle.

Qq'un peut-il m'aider ?
alain999999
Visiteur
Visiteur
 
Messages: 4
Inscription: 21 Aoû 2004 09:24
 


Message le 23 Aoû 2004 16:59

Quel est le message de dhcpdiscover ?

Ta machine sous windows obtient elle une adresse ip valide ?

As-tu un firewall sur la passerelle qui pourrait bloquer les connexions de ton sous-réseau ?
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 10:46
Localisation: /Fr/Idf/77/Le Mée
 

problèmedhcp et nat

Message le 23 Aoû 2004 20:56

test ne pas tenir compte de ce message
alain999999
Visiteur
Visiteur
 
Messages: 4
Inscription: 21 Aoû 2004 09:24
 

prob adsl nat

Message le 23 Aoû 2004 21:03

j'avais fait un test car tout à l'heure j'ai répondu à ta question et le message s'est perdu.
eth0 = nic pointant vers modem adsl eci ethernet
eth1 = nic relié à switch de mon réseau local

Quel est le message de dhcpdiscover ?
dhcpdiscover on eth0 at 255.255.255.255 interval ....
no dhcp offers received
no working leases in persistent database -sleeping

Ta machine sous windows obtient elle une adresse ip valide ?
elle a une ip fixe et c'est ce que je veux (au moins pour l'instant).

As-tu un firewall sur la passerelle qui pourrait bloquer les connexions de ton sous-réseau ?
iptables configuré avec le script de alexis ...
théorqt les connexions sortantes sont autorisées

Je peux t'envoyer les fichiers de config.
Je pense à deux choses qui pourraient clocher :
- script iptables et notamment la ligne postrouting avec eth0
- options du noyau 2.6.8 recompilé non activées pour nat et firewall
Sur FReebsd, j'avais eu un soucis avec l'équivalent de eth0 et tun0 (ppp0) dans les scripts de ipfw (iptables).

Merci d'avance pour les réponses.
alain999999
Visiteur
Visiteur
 
Messages: 4
Inscription: 21 Aoû 2004 09:24
 

Message le 25 Aoû 2004 18:30

Vérifier les options du noyau serait déjà un bon point :wink:

Ensuite fais des pings entre : Passerelle -> Windows , et sens inverse. Donnes nous les résultats.

Ensuite peut-être d'abord essayer en static et passer en dhcp par la suite.

Eth0 c'est ton interface vers le modem, mais l'interface vers Internet c'est ppp0 non ?
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 10:46
Localisation: /Fr/Idf/77/Le Mée
 

prob nat ...

Message le 25 Aoû 2004 21:52

Vérifier les options du noyau serait déjà un bon point
JE NE CONNAIS PAS LES OPTIONS A INSERER

Ensuite fais des pings entre : Passerelle -> Windows , et sens inverse. Donnes nous les résultats.
CA PING DES DEUX COTES

Ensuite peut-être d'abord essayer en static et passer en dhcp par la suite.
JE SUIS EN STATIC SUR ETH1 (LOCAL) ET FORCEMENT DHCP SUR ETH0 PUISQUE RELIEE A ADSL FREE (SANS IP FIXE)

Eth0 c'est ton interface vers le modem, mais l'interface vers Internet c'est ppp0 non ?
OUI

AURAIS-TU UN SCRIPT MODELE AUTRE QUE CELUI DE FORMATION LINUX ?
JE PENSE A UN SOUCIS COTE POSTROUTING MAIS JE NE SUIS PAS SUR
alain999999
Visiteur
Visiteur
 
Messages: 4
Inscription: 21 Aoû 2004 09:24
 

Message le 26 Aoû 2004 07:24

Si tu as un doute sur tes iptables, le mieux à faire serait de toutes les loguer (acceptées et refusées).

Comme ça tu pourra avoir un suivi des requêtes de ton PC windows, et du traitement qu'il en est fait par les iptables.
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Faire le mort est une stratégie de défense chez les rongeurs, les insectes et les techniciens du support informatique
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 9022
Inscription: 13 Mai 2003 16:32
Localisation: Sisteron... et jamais loin d'une Debian
 

Message le 02 Sep 2004 11:34

Tu n'es pas obligé d'être en dhcp pour eth0 : chez moi je ne le suis pas et ça marche :wink:

Utilises tu un firewall ? (genre shorewall) :roll:
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 10:46
Localisation: /Fr/Idf/77/Le Mée
 



Sujets similaires

Message problème d'allumage pc asus
Bonjour,Depuis quelques temps, mon pc portable Asus modèle G 741JW * T7105H" ne veut plus s'allumer alors qu'il est branché sur le secteur car il n'a plus de batterie pour l'instant mais je souhaite la changer si j'arrive à résoudre ce problème.L'alimentation serait-elle la source du problème ...
Réponses: 12

Message OS non détécté ? Problème de démarrage de l'ordinateur
Bonjour à tous,Je vous contacte au sujet d'un problème réccurent et assez problèmatique sur mon ordinateur fixe depuis maintenant quelques semaines. Pour résumer lors de démarrage de l'ordinateur, il arrive que Windows ne soit pas détecté (j'imagine) et que l'ordinateur affiche : " reboot and ...
Réponses: 9

Message [résolu] problème d'affichage sur le forum d'orange
Bonjour J'ai besoin de communiquer en message privé avec Webconseiller mais quand je clique sur leurs pseudos, j'arrive sur la bonne page mais il n'y a pas le bouton pour envoyer un MP, bien sur il n'y a que moi avec ce souci. Ce que j'ai :Ce que je devrais voir :J'ai désactivé toutes les extensions ...
Réponses: 1

Message Problème de micro sur Hp Victus - grésillements
Bonjour,J'ai un problème sur mon pc portable Hp Victus (Windows 10). Lorsque je suis sur Skype ou des logiciels similaires, mes interlocuteurs me disent systématiquement que le son a beaucoup de grésillements, ce qui gêne beaucoup la conversation.J'utilise le micro du pc.J'utilise cela souvent pour ...
Réponses: 1

Message problème de caméra dans facebook
Bonjour,J'ai un ami qui un pc portable modèle " HP 15 K078NZ" et depuis quelques jours, il n'arrive plus à contacter ses amis dans "Facebook" car il a toujours ce message "veuillez autoriser le micro, caméra et l'appareil photo" et vous pourrez les désactiver plus tard ...
Réponses: 0

Message [Réglé] problème écran
bonjourquand j'allume mon pc, genre 1 ou 2 minutes après, et c'est aléatoire en fait, l'écran clignote une fois puis les partie blanches normalement deviennent noires (voir photo), en cliquant en bas à droite de la barre des taches 2 fois sur le petit bouton pour afficher le bureau , tout revient à ...
Réponses: 5

Message problème d'envoie avec Thunderbird
Bonjour, dans Thunderbird, sur un pc sous Windows 10 , j'ai ce message d'erreur lorsque j'essaie d'envoyer un message. Une idée sur ce problème svp ? Merci.
Réponses: 4


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 3 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.