Il y a actuellement 150 visiteurs
Lundi 28 Novembre 2022
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

probleme wifi free ubuntu

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

probleme wifi free ubuntu

Message le 16 Mai 2009 22:04

Bonjour, Bonsoir,

Voilà je vous expose rapidement mon soucis: j'ai une freebox dont le wifi est activé ainsi que le dhcp, j'arrive parfaitement à m'y connecter avec mon eeepc et surfer sans soucis. Toutefois j'ai un soucis avec mon pc de bureau qui tourne sous ubuntu 9.04, équipé d'une clé usb wifi emtec... j'arrive à me connecter à ma box mais je n'ai aucun "flux" qui passe pas la possibilité d'afficher une page web rien... Alors que comme je le disais aucun soucis avec mon eeepc...

Je vous donne à la suite une liste de commandes que j'ai effectué lorsque je suis connecté à ma freebox...

Code: Tout sélectionner
~$ /sbin/iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

pan0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:"Freebox5"
Mode:Managed Frequency:2.432 GHz Access Point: **:**:**:**:**:**
Bit Rate=54 Mb/s Tx-Power=20 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Power Management:off
Link Quality=38/100 Signal level:-52 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

~$ /sbin/ifconfig
eth0 Link encap:Ethernet HWaddr 00:1d:72:a9:2f:ef
UP BROADCAST MULTICAST MTU:1500 Metric:1
Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)
Interruption:252 Adresse de base:0xa000

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
Packets reçus:166 erreurs:0 :0 overruns:0 frame:0
TX packets:166 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
Octets reçus:14564 (14.5 KB) Octets transmis:14564 (14.5 KB)

wlan0 Link encap:Ethernet HWaddr 00:1f:1f:3d:b5:a5
inet adr:192.168.0.6 Bcast:192.168.0.255 Masque:255.255.255.0
adr inet6: fe80::21f:1fff:fe3d:b5a5/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Packets reçus:7 erreurs:0 :0 overruns:0 frame:0
TX packets:125 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:1488 (1.4 KB) Octets transmis:12026 (12.0 KB)

wmaster0 Link encap:UNSPEC HWaddr 00-1F-1F-3D-B5-A5-35-61-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)

~$ /sbin/route -n
Table de routage IP du noyau
Destination Passerelle Genmask Indic Metric Ref Use Iface
192.168.0.0 0.0.0.0 255.255.255.0 U 2 0 0 wlan0
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 wlan0
0.0.0.0 192.168.0.4 0.0.0.0 UG 0 0 0 wlan0
~$ cat /etc/resolv.conf
# Generated by NetworkManager
nameserver 212.27.40.241
nameserver 212.27.40.240
:~$ nslookup www.google.fr
Server: 212.27.40.241
Address: 212.27.40.241#53

Non-authoritative answer:
www.google.fr canonical name = www.google.com.
www.google.com canonical name = www.l.google.com.
Name: www.l.google.com
Address: 209.85.229.104
Name: www.l.google.com
Address: 209.85.229.99
Name: www.l.google.com
Address: 209.85.229.147
Name: www.l.google.com
Address: 209.85.229.103

shin@shin-emachine:~$ ping -c2 www.google.fr

ping: unknown host www.google.fr


shin@shin-emachine:~$ cat /etc/network/interfaces
auto lo
iface lo inet loopback

shin@shin-emachine:~$ cat /etc/wpa_supplicant/wpa_supplicant.conf
cat: /etc/wpa_supplicant/wpa_supplicant.conf: Aucun fichier ou dossier de ce type

~$ lsusb
Bus 001 Device 016: ID 0781:5406 SanDisk Corp. Cruzer Micro 1/4GB Flash Drive
Bus 001 Device 015: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 003: ID 15ca:00c3 Textech International Ltd. Mini Optical Mouse
Bus 002 Device 002: ID 03f0:6204 Hewlett-Packard DeskJet 5150c
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Voilà j'espère que l'un d'entre vous arrivera à y comrpendre quelque chose... Et aura la générosité de me donner une réponse...

Merci et bonne soirée à tous
Code: Tout sélectionner
shin90
Visiteur
Visiteur
 
Messages: 7
Inscription: 16 Mai 2009 22:02
 


Message le 16 Mai 2009 22:36

Déplacé en section Linux, c'est fait pour ça...

Puisque ça fonctionne avec le eeepc, as-tu comparé un peu les sorties de toutes ces commandes pour voir les différences et/ou incohérences ?

Quelle est l'adresse ip de ta freebox, car je ne comprend pas trop d'ou sort l'adresse "192.168.0.4" dans la table de routage. Généralement c'est plutôt 192.168.0.1 la FB non ?

D'ailleurs c'est bizarre que le nslookup fonctionne et pas le "ping google.fr". On dirait donc clairement un simple problème de DNS.
Arrives-tu à pinger l'adresse de google ? => ping 216.239.59.104
Et à accéder à google.fr par son IP dans ton navigateur ?
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Faire le mort est une stratégie de défense chez les rongeurs, les insectes et les techniciens du support informatique
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 9023
Inscription: 13 Mai 2003 16:32
Localisation: Sisteron... et jamais loin d'une Debian
 

Message le 16 Mai 2009 22:49

Merci de ta rapide réponse et donc pour répondre à tes questions...

192.168.0.4 c'est l'ip de ma freebox, je ne sais pas pourquoi c'est comme ça mais bon... c'est affiché dans la page DHCP...
Et ensuite pour le ping google pas de réponse, "unreachable"
Car en fait il y a un espace dans la configuration de la clé ou je peux mettre un ID de client DHCP sa pourrait etre ça? mais il faudrait mettre quoi?


Et après comparaison les masque de sous réseau, route apr défaut et dns primaire et secondaire sont bon car ils correspondent à ce que j'ai sur mon eeepc...
Merci
shin90
Visiteur
Visiteur
 
Messages: 7
Inscription: 16 Mai 2009 22:02
 

Message le 17 Mai 2009 08:18

shin90 a écrit:Et ensuite pour le ping google pas de réponse, "unreachable"

Ca j'ai vu (ping www.google.fr), mais c'est la même chose avec : ping 216.239.59.104 ?

Et pour l'adresse directe dans le navigateur internet : http://216.239.59.104/ ?
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Faire le mort est une stratégie de défense chez les rongeurs, les insectes et les techniciens du support informatique
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 9023
Inscription: 13 Mai 2003 16:32
Localisation: Sisteron... et jamais loin d'une Debian
 

Message le 17 Mai 2009 08:47

ha oui désolé je voulais pas marqué google mai l'adresse que tu m'a donné et non aucun des deux ne fonctionne...

Hier soir j'ei eu une connection pendant 3 secondes chrono après avoir supprimé ma connexion en ethernet de la liste des connexions, meme si celle ci est inactive, je veux dire que rien est branché en eth, mais après ce délai de 3 secondes plus rien...
shin90
Visiteur
Visiteur
 
Messages: 7
Inscription: 16 Mai 2009 22:02
 

Message le 17 Mai 2009 15:43

Ho malheur, Ho désespoir, n'y a t il personne pour me porter secours?
shin90
Visiteur
Visiteur
 
Messages: 7
Inscription: 16 Mai 2009 22:02
 

Message le 17 Mai 2009 20:13

Bahh vu comme ça, il va falloir entrer effectivement dans des trucs un peu plus compliqués/bidouille.
Je serais d'avis de tenter la configuration manuelle du réseau. Soit tu passes par le paramétrage du réseau (menu systeme+administration) et tu te tapes la config à la main.
Soit tu édites le fichier /etc/network/interfaces et tu y mets qqchose comme ça :
Code: Tout sélectionner
auto wlan0
iface wlan0 inet static
        address 192.168.0.10
        netmask 255.255.255.0
        network 192.168.0.0
        broadcast 192.168.0.255
        gateway 192.168.0.4
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 212.27.40.241
        dns-search workgroup

(j'ai changé ton adresse IP au passage pour 192.168.0.10)
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Faire le mort est une stratégie de défense chez les rongeurs, les insectes et les techniciens du support informatique
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 9023
Inscription: 13 Mai 2003 16:32
Localisation: Sisteron... et jamais loin d'une Debian
 

Message le 17 Mai 2009 20:21

ok merci je vais tenter sa mais bon je me prépare quand meme à retourner sous windaube au cas ou...

mais je trouve qu'il y a un truc qui cloche car mon eeepc actuellement sous eeebuntu a exactement les même info de connection que mon pc de bureau sous jaunty, et pourtant le pc de bureau se connecte à la box mais ne semble pas recevoir de flux en retour... c'est peut etre con comme question mais étant donné que sur ceux deux pc j'ai une prise éthernet et en l'occurence un wifi (intégré pour l'un pas pour l'autre) je peux pas copier le fichier du eeepc qui "gère" tout se bazzar et le copier sur celui de bureau???

merci de ta réponse en tout cas
shin90
Visiteur
Visiteur
 
Messages: 7
Inscription: 16 Mai 2009 22:02
 

Message le 17 Mai 2009 23:06

fait nouveau: le script donné ci dessus ne fonctionne pas. Mais en l'état actuel des choses il se trouve que lorsque mon pc se trouve à côté de la freebox adsl sa connexion wifi marche sans soucis mais une fois de retour à l'étage, alors qu'il détecte bien le réseaux (2 barres sur quatres la plupart du temps) je n'arrive pas a afficher une seule page internet alors qu'au même endroit avec mon eeepc c'est possible et sans "lenteurs" qui plus est...
Je viens de reformarter sous ubuntu 8.10 pour arriver à tout ça et là je vais me lancer dans les mises à jour...

Si vous avez une idée pour corriger ça...
shin90
Visiteur
Visiteur
 
Messages: 7
Inscription: 16 Mai 2009 22:02
 

Message le 18 Mai 2009 07:25

shin90 a écrit:mais bon je me prépare quand meme à retourner sous windaube au cas ou...

Certes...

A ce point de la discussion, je rappelle quand même de manière générique qu'il n'y a pas que "Ubuntu" sur la planète Linux et que donc le choix ne se résume pas forcément à "Ubuntu sinon Windows".
Beaucoup d'autre distributions existent, sont fiables et éprouvées et peuvent aussi, sur plusieurs points, donner plus de satisfaction que Ubuntu dans des domaines divers et variés.
Debian (maman d' "Ubuntu"), Fedora, Mandriva, Suse pour ne citer vraiment que celles là, s'installeront aussi bien sur ton système.
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Faire le mort est une stratégie de défense chez les rongeurs, les insectes et les techniciens du support informatique
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 9023
Inscription: 13 Mai 2003 16:32
Localisation: Sisteron... et jamais loin d'une Debian
 

Message le 18 Mai 2009 08:19

ok je verrai car j'ai tenté opensuse et ça n'a rien changé déjà... ensuite comme dit dans mon dernier post le probleme semble se poser quand je m'éloigne de ma box, alors que sa ne devrait pas poser de probleme...
shin90
Visiteur
Visiteur
 
Messages: 7
Inscription: 16 Mai 2009 22:02
 

Message le 18 Mai 2009 09:08

Bonjour,

Et je rajouterai à la remarque de CaSa sur la qualité des OS un point à ne pas négliger;
le/les modules Wi-fi!! Toutes distributions & OS confondus, certaines "puces" Wifi sont pénibles.

De plus, il s'agit aussi d'un domaine ou la technologie avance en permanence, les firmware
évoluent, & les constructeurs font très facilement 'l'âne qui recule" face aux demandes
des développeurs Linux pour affiner la reconnaissance & l'usage des modules Wi-Fi.

J'en tient pour exemple deux machines qui passent régulièrement chez moi, un portable
Toshiba de 3 ans & un Samsung NC10 de quelques mois, les qualités d'accès au Wi-fi de la Box Aol
sont sans commune mesure d'une machine à l'autre.

Tant en termes de distance de connection qu'en niveau de celle-ci.
A+,
AtOM.
Le PC c'est comme la lune,il y a une face cachée.Eclairons-la!!!!
__________________
Avatar de l'utilisateur
Ask to Old Man
Moderateur
Moderateur
 
Messages: 19970
Inscription: 14 Mar 2004 10:06
Localisation: Argenteuil,Val d'Oise
 



Sujets similaires

Message repeteur ou routeur wifi
Bonjour,Je souhaiterais savoir ce qui est le mieux pour mon soucis.J'ai une veille maison a étage avec des murs plutot bien epais.Le signal wifi ne passe pas partout:à l'autre de bout de la maison le signal ne passe pas du tout.J'ai actuellement une freebox revolution à l'etage "enfermée" ...
Réponses: 6

Message problème d'allumage pc asus
Bonjour,Depuis quelques temps, mon pc portable Asus modèle G 741JW * T7105H" ne veut plus s'allumer alors qu'il est branché sur le secteur car il n'a plus de batterie pour l'instant mais je souhaite la changer si j'arrive à résoudre ce problème.L'alimentation serait-elle la source du problème ...
Réponses: 12

Message OS non détécté ? Problème de démarrage de l'ordinateur
Bonjour à tous,Je vous contacte au sujet d'un problème réccurent et assez problèmatique sur mon ordinateur fixe depuis maintenant quelques semaines. Pour résumer lors de démarrage de l'ordinateur, il arrive que Windows ne soit pas détecté (j'imagine) et que l'ordinateur affiche : " reboot and ...
Réponses: 9

Message [résolu] problème d'affichage sur le forum d'orange
Bonjour J'ai besoin de communiquer en message privé avec Webconseiller mais quand je clique sur leurs pseudos, j'arrive sur la bonne page mais il n'y a pas le bouton pour envoyer un MP, bien sur il n'y a que moi avec ce souci. Ce que j'ai :Ce que je devrais voir :J'ai désactivé toutes les extensions ...
Réponses: 1

Message Problème de micro sur Hp Victus - grésillements
Bonjour,J'ai un problème sur mon pc portable Hp Victus (Windows 10). Lorsque je suis sur Skype ou des logiciels similaires, mes interlocuteurs me disent systématiquement que le son a beaucoup de grésillements, ce qui gêne beaucoup la conversation.J'utilise le micro du pc.J'utilise cela souvent pour ...
Réponses: 1

Message [Réglé] impossible de connecter imprimante en wifi
bonjourj'ai une imprimante hp3639 avec un pc portable hpje n'arrive pas a connecter mon imprimante en wifi mais avec un cable elle fonctionneje ne sais pas comment faire pour activer le wifi de l'imprimantebien sur je n'ai plus la notice
Réponses: 6

Message problème de caméra dans facebook
Bonjour,J'ai un ami qui un pc portable modèle " HP 15 K078NZ" et depuis quelques jours, il n'arrive plus à contacter ses amis dans "Facebook" car il a toujours ce message "veuillez autoriser le micro, caméra et l'appareil photo" et vous pourrez les désactiver plus tard ...
Réponses: 0


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.