Il y a actuellement 41 visiteurs
Jeudi 23 Mai 2019
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

Probleme de compilation

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

Probleme de compilation

Message le 18 Nov 2003 22:01

Lorsque je compile un programme configure me dit ca:

configure: error: Library requirements (gnome-python-2.0 >= 1.99.17
pygtk-2.0 >= 1.99.17 gdk-2.0 gtk+-2.0 libgtop-2.0 >= 2.0.0) not met;
consider adjusting the
PKG_CONFIG_PATH environment variable if your libraries are in a
nonstandard prefix so pkg-config can find them.

Pourtant les librairies sont installées et il n'y a pas plus récent apparement.
Que faire ?
(j'ai Red Hat)
cimourdain
Sous Expert(e)
Sous Expert(e)
 
Messages: 60
Inscription: 27 Juil 2003 18:41
 


Re: Probleme de compilation

Message le 19 Nov 2003 23:56

cimourdain a écrit:Lorsque je compile un programme configure me dit ca:

configure: error: Library requirements (gnome-python-2.0 >= 1.99.17
pygtk-2.0 >= 1.99.17 [...]
Pourtant les librairies sont installées et il n'y a pas plus récent apparement.
Que faire ?
(j'ai Red Hat)


Souvent pour une meme bibliotheque (en anglais "library") il existe 2 packets :
- un packets pour le runtime (binaires compilés et utilisables par les programmes)
- un packet contenant tout ce qu'il faut pour le développement (soit les sources, soit les headers, soit certains outils de dev relatifs aux bibliotheques en question)

vérifie donc que tu as installé les packages pour le développement. En général il contiennent "-dev" ou "devel" dans leur nom...
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 17:22
Localisation: Entre deux BarCamps
 

Message le 22 Nov 2003 17:20

Oui je les ai installé et ca ne marche toujours pas ...
Le probleme ne vient il pas du fait qu eje n'ai pas de variable
PKG_CONFIG_PATH ? en effet quand je fais echo $PKG_CONFIG_PATH ca me renvoie rien, est ce normal ? sinon comment se fait il que ca n'ai pas été fait lors de l'installation des bibliotheques ?
cimourdain
Sous Expert(e)
Sous Expert(e)
 
Messages: 60
Inscription: 27 Juil 2003 18:41
 

Message le 22 Nov 2003 17:51

cimourdain a écrit:Oui je les ai installé et ca ne marche toujours pas ...
Le probleme ne vient il pas du fait qu eje n'ai pas de variable
PKG_CONFIG_PATH ? en effet quand je fais echo $PKG_CONFIG_PATH ca me renvoie rien, est ce normal ? sinon comment se fait il que ca n'ai pas été fait lors de l'installation des bibliotheques ?


quel logiciel essayes-tu de compiler ?
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 17:22
Localisation: Entre deux BarCamps
 

Message le 22 Nov 2003 19:29

gDesklets
cimourdain
Sous Expert(e)
Sous Expert(e)
 
Messages: 60
Inscription: 27 Juil 2003 18:41
 

Message le 22 Nov 2003 19:33

et il existe pas de package rpm pour gDesklets ?
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 17:22
Localisation: Entre deux BarCamps
 

Message le 22 Nov 2003 22:43

ah ouais ???! ben ca serait cool que tu me dise ou parce que j'ai pas trouvé ! et j'ai cherché pourtant avant de prendre les sources !
cimourdain
Sous Expert(e)
Sous Expert(e)
 
Messages: 60
Inscription: 27 Juil 2003 18:41
 



Sujets similaires

Message Problème DDE Verbatim
Bonjour, J'ai un soucis avec mon dde, depuis un petit moment. Voici comment ça a commencé : J'ai donc acheté un dde Verbatim de 2 TO. Quand je me suis fait livré, il était bel et bien emballé dans une boite avec écrit en gros 2to, donc jusque là tout va bien. Or quand je le branche, rien ne se passe ...
Réponses: 6

Message Problème pc toshiba
Bonsoir,J'ai un pc Toshiba, lors que je l'allume, il reste bloqué sur la page d accueil fond noir et écriture blanche. Merci pour vos réponses... Pierre
Réponses: 3

Message Problème de clic de souris
Hello ! J'espère être au bon endroit. Je rencontre un problème assez énervant depuis quelques jours avec ma souris, et bizarrement c'était dans les alentours où j'ai fais une màj windows 10. Voilà quand je clique j'ai l'impression que c'est trop sensible, et c'est comme si ca cliquait 2 fois au lieu ...
Réponses: 4

Message Age Of Empire : Windows 10, c'est un problème.
Bonjour J'ai eu envie de revenir à des jeux anciens, envie rapidement cassée grâce à l'ultime version Windows 10. J'ai installé Age Of Empire 2 depuis un CD-ROM, l'installation s'est bien passée. Je lance l'application et une fenêtre s'ouvre : The Conquerors PC nécessite la fonctionnalité Windows su ...
Réponses: 3

Message Problème démarrage
Bonjour,Je viens vers vous car j'ai un petit soucis avec mon ordinateur. En effet c'est un pc monté par mes soins, qui a toujours fonctionné et qui n'a même pas 6 mois. Hier j'ai voulu brancher un M2 dessus sur lequel j'avais complétement zappé qu'il y avait Windows. Donc je démarre mon pc grosse pa ...
Réponses: 4

Message Problème wysiwyg avec WDL Web site builder
Bonjour à tous !J'ai créé deux sites en HTML avec Website builder.Sur certaines pages, en mode édition (wysiwyg), je peux déplacer des images ou des blocs de texte du bas vers le haut mais pas l'inverse. C'est assez gênant !Il y a sans doute une balise manquante ou inappropriée....Pouvez vous m'aide ...
Réponses: 1

Message Problème mot de passe et mise à jour
Bonjour,J'ai un PC avec ubuntu 10,10.Il fonctionne mais j'ai plusieurs soucis :1) Pour le mettre à jour avec internet (version plus récente) il me demande un mot de passe qu'il n'accepte pas, j'ai beau avoir essayé tous les mots de passe que j'ai créé il ne veut rien savoir.2) Je n'ai plus de son po ...
Réponses: 1


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.