Il y a actuellement 78 visiteurs
Vendredi 27 Mai 2022
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

probleme grub et ubuntu

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

probleme grub et ubuntu

Message le 06 Oct 2008 18:26

bonjour à tous

j'ai un gros soucis : j'ai installé ubuntu avec le grub après windows xp sur une deuxieme partition de mon disque dur...le probleme est que quand je redemarre cela me marque "systeme d'exploitation manquant".si je regarde avec un logiciel adéquate j'ai bien ma partition xp et mes partitions linux...
de plus j'ai installer ubuntu il y a deux ans exactement de la meme façon et ça marché impec, j'ai donc retelécharger ubuntu et réinstaller: toujours pareil
la différence avec il ya deux ans c'est que j'ai changer de carte mère pour passer au core deux duo et que mon xp est en service pack 3...
le probleme vient-il de mon disque dur, voir de la MBR(j'ai un raptor WD SATA 74 GO)?

merci d'avance
pithut
Visiteur Confirmé
Visiteur Confirmé
 
Messages: 25
Inscription: 06 Oct 2008 18:14
 


Message le 06 Oct 2008 18:32

Bonjour.

Le problème est que ta partition Windows n'est pas bootable.

Tu repars en liveCd et tu vas dans Gparted.

Là, tu regardes les drapeaux de ta partition Windows et tu coches la ligne boot:


Image

Tu redémarres.
"Sois un AtOM, mon fils." RIP l'ami Ask To Old Man → 1948 - 2012
En cas de problème constaté sur un sujet, contactez un modérateur par MP svp. N'intervenez pas vous-même. Merci bien.
Avatar de l'utilisateur
r@in | b0w
PC-Infopraticien
PC-Infopraticien
 
Messages: 7714
Inscription: 09 Déc 2007 12:37
Localisation: Sur un Vostro tout propre
 

Message le 06 Oct 2008 19:56

mais justement j'arrive à booter sur xp : je lance un fdisk et j'ai la partition linux active, je change et j'active la partition xp et là xp démarre...
pithut
Visiteur Confirmé
Visiteur Confirmé
 
Messages: 25
Inscription: 06 Oct 2008 18:14
 

Message le 06 Oct 2008 20:01

Bonsoir,

Ton premier message n'est pas assez clair. Avec ta 2eme réponse voici ce que je comprends, à toi de me dire si c'est ça ou de tout mieux nous expliquer si c'est pas ça:

Tu arrive à démarrer sous nunux mais pas sous XP. Lorsque tu veux démarrer sous XP tu es obligé d'activer la partition XP et de mettre l'autre en inactive ? C'est ça ? :o Donc en gros ton grub n'est pas ou mal installé ?
Avatar de l'utilisateur
Grego
Expert(e)
Expert(e)
 
Messages: 1330
Inscription: 07 Oct 2005 15:40
 

Re: probleme grub et ubuntu

Message le 06 Oct 2008 20:03

pithut a écrit:le probleme est que quand je redemarre cela me marque "systeme d'exploitation manquant"


Comme dit Grego, ce n'est pas clair.

Après, si c'est juste ce qu'il explicite, tu rajoutes une entrée dans Grub pour avoir deux choix au lancement de Grub, il n'est pas mal installé mais plutôt mal configuré.
"Sois un AtOM, mon fils." RIP l'ami Ask To Old Man → 1948 - 2012
En cas de problème constaté sur un sujet, contactez un modérateur par MP svp. N'intervenez pas vous-même. Merci bien.
Avatar de l'utilisateur
r@in | b0w
PC-Infopraticien
PC-Infopraticien
 
Messages: 7714
Inscription: 09 Déc 2007 12:37
Localisation: Sur un Vostro tout propre
 

Message le 06 Oct 2008 20:19

je recommence j'ai xp sp3 sur ma machine,je veu installer ubuntu donc j'insere le cd, le menu d'install aparait puis après un petit moment j'arrive au partitionnement donc la j'installe ubuntu sur l'espace libre restant sur mon disque dur, puis j'installe le systeme (en boot sans option tout se fait a la suite...)...ect...j'arrive à l'install du grub...il s'installe normalement puis fin de l'installation de ubuntu: le cd s'ouvre je retire mon cd...le systeme redemarre puis après que le bios est pris la main j'ai :"systeme d'exploitation manquant" et ce meme si je redemarre.comme dans ce cas mon pc est inutilisable et que j'ai une astuce je met un cd de windows 98 SE dans la bécane je démarre pour avoir l'invite de commande et lancer un FDISK pour regarder l'état de mes partition j'ai la partition linux active et pas celle de windows donc j'active ma partition windows et donc celle de linux se désactive...je redemarre et la je boot sur xp (pas de grub donc) j'ai essayer au moins 10 fois et sa ce passe toujours comme j'ai décris...
est-ce que c'est plus clai?
merci de m'aider URGENT SVP en vous remerciant d'avance
pithut
Visiteur Confirmé
Visiteur Confirmé
 
Messages: 25
Inscription: 06 Oct 2008 18:14
 

Message le 06 Oct 2008 20:25

pithut a écrit:le systeme redemarre puis après que le bios est pris la main

Le BIOS ou le GRUB ?
Ce qu'on essaye de savoir c'est si ton démmarage arrive jusqu'au Grub ou pas déjà .
Avatar de l'utilisateur
Grego
Expert(e)
Expert(e)
 
Messages: 1330
Inscription: 07 Oct 2005 15:40
 

Message le 06 Oct 2008 20:28

je n'ai pas le GRUB:après que le bios passe la main a mon DD j'ai "systeme d'exploitation manquant"
pithut
Visiteur Confirmé
Visiteur Confirmé
 
Messages: 25
Inscription: 06 Oct 2008 18:14
 

Message le 06 Oct 2008 20:36

oki, donc regarde par là, normalement bootpart est ton ami
http://linux.jpvweb.com/mesrecetteslinu ... ot_windows

Tiens nous au courant ;)
Avatar de l'utilisateur
Grego
Expert(e)
Expert(e)
 
Messages: 1330
Inscription: 07 Oct 2005 15:40
 

Message le 06 Oct 2008 20:44

ok merci,je vais pouvoir me débrouiller avec ça...je vous tiens au courant...
pithut
Visiteur Confirmé
Visiteur Confirmé
 
Messages: 25
Inscription: 06 Oct 2008 18:14
 

Message le 06 Oct 2008 21:10

Re.

Alors, maintenant c'est plus clair.

Tu as flingué le MBR de Windows et ta machine semble être OEM, cad de marque (Acer, Packard-Bell pour garder le gratin).

Tu as fait une sauvegarde de ce MBR avant?

Sinon, rien à faire.

Le verdict est clair.

Tu peux récupérer tes dossiers Windows via Linux et réinstaller Windows, tu ne pourras rien faire d'autre.

Et, lors de ta prochaine migration, tu t'appuieras sur ce guide pour réaliser ta migration sans soucis.

La chose à retenir est qu'il faut installer le Grub sur la partition Linux et ensuite modifier le BOOT.INI de Windows sinon, sans cela, ta partition Windows est perdu.

Cela m'est arrivé, je sais de quoi je parle.
"Sois un AtOM, mon fils." RIP l'ami Ask To Old Man → 1948 - 2012
En cas de problème constaté sur un sujet, contactez un modérateur par MP svp. N'intervenez pas vous-même. Merci bien.
Avatar de l'utilisateur
r@in | b0w
PC-Infopraticien
PC-Infopraticien
 
Messages: 7714
Inscription: 09 Déc 2007 12:37
Localisation: Sur un Vostro tout propre
 

Message le 06 Oct 2008 21:20

r@in | b0w a écrit:Tu as fait une sauvegarde de ce MBR avant?
Sinon, rien à faire.

Le verdict est clair.
.

Au pire de toute façon sur un Mbr foireux il pourra toujours faire un fix mbr sous windows ...
Mais bon là il n'y a que la partition windows le pc démarre dessus donc c'est que le mbr n'est pas si mort que ça non ?
Avatar de l'utilisateur
Grego
Expert(e)
Expert(e)
 
Messages: 1330
Inscription: 07 Oct 2005 15:40
 

Message le 06 Oct 2008 21:37

Rien à voir ;)

On est, je pense, dans le cas d'une machine OEM.

Par nature, ces machines ne sont pas équipées d'un CD de Windows XP.

Alors, peut-être que je m'avance mais je suis quasiment sûr qu'on ne peut pas le récupérer.

C'est un MBR codé fait pour brider la machine.

S'il est touché, système d'exploitation manquant.

Si la partition Windows est bootable (et seulement la partition Windows) et que cela donne ce message d'erreur, c'est foutu.

A lire, ma migration et plus spécifiquement, le fameux missing operating system.
"Sois un AtOM, mon fils." RIP l'ami Ask To Old Man → 1948 - 2012
En cas de problème constaté sur un sujet, contactez un modérateur par MP svp. N'intervenez pas vous-même. Merci bien.
Avatar de l'utilisateur
r@in | b0w
PC-Infopraticien
PC-Infopraticien
 
Messages: 7714
Inscription: 09 Déc 2007 12:37
Localisation: Sur un Vostro tout propre
 

Message le 06 Oct 2008 22:52

:lol: :lol:
r@in | b0w a écrit:Tu as flingué le MBR de Windows et ta machine semble être OEM, cad de marque (Acer, Packard-Bell pour garder le gratin).
Dois-je croire que tu as pensé à certains d'entre-nous en écrivant ça...??
Le "Gotha" du PC OEM... ...V'la qu'l'arc-en-ciel me pètes un délire à la Papy
:lol: :lol:

Désolé du H/S pithut :wink:
A+,
AtOM.
Le PC c'est comme la lune,il y a une face cachée.Eclairons-la!!!!
__________________
Avatar de l'utilisateur
Ask to Old Man
Moderateur
Moderateur
 
Messages: 19970
Inscription: 14 Mar 2004 10:06
Localisation: Argenteuil,Val d'Oise
 

Message le 06 Oct 2008 23:12

Je garde ton expression Pb le maudit, ça claque :lol:
"Sois un AtOM, mon fils." RIP l'ami Ask To Old Man → 1948 - 2012
En cas de problème constaté sur un sujet, contactez un modérateur par MP svp. N'intervenez pas vous-même. Merci bien.
Avatar de l'utilisateur
r@in | b0w
PC-Infopraticien
PC-Infopraticien
 
Messages: 7714
Inscription: 09 Déc 2007 12:37
Localisation: Sur un Vostro tout propre
 

Suivante


Sujets similaires

Message Probleme paiement sur chaque site internet
Bonjour à tous, j'ai récemment fait faire une analyse sur le forum, analyse qui à été reconnu sans problème, mais depuis j'ai un souci des que je vais pour payer sur n'importe quel site internet, au moment de saisir ma CB, le moment ou ça interroge la banque et que ça demande par exemple de confirmé ...
Réponses: 2

Message Problème avec la XFX RX6500 XT
Bonjour,J'ai acheté sur Amazon tout les composants afin de monter moi même ma tour cependant je rencontre un problème incompréhensible dès l'installation de cette dernière. Je suis presque sur que le problème vient de la CG car avec un autre modèle (je n'ai actuellement pas la référence mais je pour ...
Réponses: 8

Message probleme espace disque dur C
Bonjourje suis sous Windows 11 , j'ai un problème d'espace sur disque C , celui ci augmente quand je supprimé des fichier de mon disque dur externe ,même en vidant la corbeille MErci
Réponses: 3

Message Plus GRUB
Bonjour !Encore besoin de vous !J'avais réussi à installer Win 10 et Ubuntu 22.04 et l'imprimante pour les deux. J'étais content, mais mon GRUB faisant apparaître plusieurs Win 10 alors je me suis dit que Boot repair arrangerait les choses.Malheureusement il a tout cassé sans doute de ma faute et ré ...
Réponses: 2

Message probleme woocomerce sur wordpress
Bonjour, je suis entrain d'installer woocomerce sur wordpress mais je cale, y aurait tíl des gens qui ont des connaissances ici? mercicyril
Réponses: 3

Message Problème lecture vidéo twitch
Salut tout le monde,Récemment j'ai eu un problème lorsque j'ai voulu regarder un stream sur la plateforme Twitch. J'avais juste le player qui affichait un écran noir et je n'avais pas de son. Cependant je pouvais accéder à l'espace de chat. Après quelques heures le problème avait disparu mais j'aime ...
Réponses: 3

Message [Réglé] Problème d'install, GTX 1050 neuve?
Bonjour,Je viens de recevoir ma carte graphique Gigabyte GTX 1050 TI (neuve) pour l?ajouter à une carte mère H67 Acer récupérée dans un Packard-Bell ixtreme M5850.Cette config fonctionne avec W10.J'ai connecté la carte (pas de connecteur alim, apparemment, juste le PCI-Express) et redémarré.Je vois ...
Réponses: 7


Qui est en ligne

Utilisateurs parcourant ce forum: Majestic-12 [Bot] et 1 invité


.: Nous contacter :: Flux RSS :: Données personnelles :.