Il y a actuellement 57 visiteurs
Mardi 03 Août 2021
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

Erreur sur accès OLE dans macro Excel 2003

Besoin d'aide pour configurer un serveur ? Vous souhaitez obtenir des conseils pour référencer votre site ? Un petit souci pour accéder à votre FTP ? Des soucis de programmation en PHP / ASP / HTML / XHTML / XML / XSLT / CSS / ReactJS / AngularJS / VueJS / CGI / PERL / C / MySQL / PostgreSQL ??? Nous avons peut-être la solution dans ce forum ...

Erreur sur accès OLE dans macro Excel 2003

Message le 31 Aoû 2009 15:34

Bonjour,

J'ai récemment développé une macro sous Excel 2003, pour réaliser un lien
OLE avec une table d'une base Access 2003.
Cette macro a marché parfaitement durant plusieurs mois, mais m'envoie
maintenant le message d'erreur "Erreur automation L'objet invoqué s'est
déconnecté de ses clients" sur la ligne ".RefreshBackgroundQuery" du code
ci-dessous...

Ce problème est quasiment permanent (sur une quinzaine d'essais, j'ai réussi
une fois à établir la liaison ce matin, alors qu'avant cela marchait toujours)

Quelqu'un aurait il une idée de la provenance de ce problème?

D'avance merci

Code de la macro concernée:

Columns("A:B").Select
Selection.ClearContents
With ActiveSheet.QueryTables.Add(Connection:=Array( _
"OLEDB;Provider=Microsoft.Jet.OLEDB.4.0;Password="""";User
ID=Admin;Data Source=D:AppliAccesssuivi_depenses_ipaq.mdb;Mode=Share Deny
Write;Ext" _
, _
"ended Properties="""";Jet OLEDB:System database="""";Jet
OLEDB:Registry Path="""";Jet OLEDB:Database Password="""";Jet OLEDB:Engine
Type" _
, _
"=5;Jet OLEDB:Database Locking Mode=0;Jet OLEDB:Global Partial Bulk
Ops=2;Jet OLEDB:Global Bulk Transactions=1;Jet OLEDB:New Data" _
, _
"base Password="""";Jet OLEDB:Create System Database=False;Jet
OLEDB:Encrypt Database=False;Jet OLEDB:Don't Copy Locale on Compact=" _
, "False;Jet OLEDB:Compact Without Replica Repair=False;Jet
OLEDB:SFP=False"), _
Destination:=Range("A1"))
.CommandType = xlCmdTable
.CommandText = Array("depenses")
.Name = "suivi_depenses_ipaq"
.FieldNames = True
.RowNumbers = False
.FillAdjacentFormulas = False
.PreserveFormatting = True
.RefreshOnFileOpen = False
.BackgroundQuery = True
.RefreshStyle = xlInsertDeleteCells
.SavePassword = True
.SaveData = True
.AdjustColumnWidth = True
.RefreshPeriod = 0
.PreserveColumnInfo = True
.SourceDataFile = "D:AppliAccesssuivi_depenses_ipaq.mdb"
.Refresh BackgroundQuery:=False
End With
tiwicom
Visiteur Confirmé
Visiteur Confirmé
 
Messages: 16
Inscription: 07 Juil 2008 17:50
 



Sujets similaires

Message problemes acces au site sur firefox
Salut tout le mondeje tenais à vous signaler sur la dernière version Firefox version 89.0 64 bits (nouveau design blanc moche pour mon gout) des problèmes accès à votre site PC-InfoPratique concernant la sécurité voici deux captures écran :https://cjoint.com/c/KFgrgpnLNBH htt ...
Réponses: 9

Message [Réglé] Erreur BCD
Bonjour,Pourriez-vous m'aider au sujet d'une erreur dans écran bleu indiquant "bcd 0xc0000034" sur un pc de bureau packard bell imedia s 2110 sous Windows 8 ?Comment dois-je faire pour réparer le démarrage car je n'arrive pas et je ne retrouve pas d'image iso afin de réinstaller car le p ...
Réponses: 18

Message Accès au forum
Yop,Chez moi sur ma tour pro, il me dit non sécurisé sur FF, Edge, Opera et Chrome. Ce serais pas un prob de FAI ? ( j'y crois pas trop mais sait on jamais )
Réponses: 31

Message Point d'acces sans fil mobile inaccessible
Mon point d'accès sans fil mobile ne fonctionne pas. Sur mon smartphone réinitialisé aux paramètres d'usine le problème persiste. Il est écrit ''récupération de l'adresse IP'' tout le temps mais il ne se connecte jamais. Le signal est proche du 100% et le nom du réseau est le bon. Il cherche à ce co ...
Réponses: 1

Message [Réglé] erreur ccleaner analyse de registre
Salut tout le mondeen me servant de CCleaner je me suis aperçu de cette erreur impossible à réparer j'ai recommencé chaque fois elle revient voici la capture écran :https://cjoint.com/c/KBgsoszS5Hf
Réponses: 11

Message Erreur installation w10
Bonjour bonsoir tout le monde,Voila je me suis acheté un ssd nvme je l?ai installé sur mon ordi et qui est bien reconnu par Windows.J?ai téléchargé w10 sur une clé. Mais lors de l?installation j?ai différent erreur:Erreur 0xC0000005 Ou bien Windows n?a pas pu préparer l?ordinateur à démarrer etc...C ...
Réponses: 24

Message CODE D'ERREUR BAD SYSTEM CONFIG INFO
Bonjour,J'ai un problème sur mon PC y'a un écran bleu qui est affiché avec le code d'erreur BAD system config info j'ai appelle le commerçante ou je l'ai acheté il m'ont fais une réinitialisation de mon PC elle n'a pas fonctionné Ils m'ont parlé que l OS a planté et de registre rien compris PS : Ils ...
Réponses: 4


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité


.: Nous contacter :: Flux RSS :: Données personnelles :.