Il y a actuellement 151 visiteurs
Dimanche 27 Septembre 2020
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

Partitions NTFS illisibles depuis WinXP après install Linux

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

Partitions NTFS illisibles depuis WinXP après install Linux

Message le 20 Oct 2003 20:43

Bonjour,

J'ai, heuuu... un petit problème suite à une installation de Mandrake 8.1

Sur un PC avec deux disques durs physiques différents, j'ai essayé de créer la configuration suivante :

HD0 - 4 partitions NTFS et Windows XP
HD1 - 3 partitions avec Mandrake 8.1

Windows XP et les partitions NTFS existaient avant l'installation de Linux.

Lors de l'installation de Mandrake, j'ai effectué le partitionnement de HD1 en sélectionnant comme disque hdb (l'utilitaire de partitionnement indiquait d'ailleurs les 4 partitions de hda comme NTSC... je n'y ai donc pas touché)

Après installation de Mandrake, je retourne sur WinXP qui m'indique que deux partitions sont illisibles... Le gestionnaire de disque WinXP détecte les deux partitions, m'indique qu'elles sont bien NTFS et "saines" mais que la partition est inconnue. Ainsi, Windows XP ne me permet plus d'y accéder ou d'attribuer une lettre de lecteur.

Hormis cela, Lilo fonctionne correctement et je peux booter sous WinXP ou Linux sans problèmes.

Je ne pense pas que Linux ait détruit les partitions... et je pense que les données doivent encore y être puisque le gestionnaire de disque WinXP indique l'espace utilisé et libre...

Depuis Linux, la commande fdisk -l m'indique que les deux partitions NTFs sont cachées. A ce moment, je me suis dit youppi... ya qu'à les rendre visible.
C'est ce que j'ai fait à l'aide d'un utilitaire Windows qui s'appelle BootUS. Le résultat n'a rien donné.

Est-ce que quelqu'un a déjà rencontré ce problème et pourrais m'aider à "reconnecter" ces deux partitions à WinXP ?

Merci infiniment.

PS - je suis nouveau sous Linux... et quand même encore perdu... :oops:
Quercus
Visiteur
Visiteur
 
Messages: 3
Inscription: 20 Oct 2003 15:48
Localisation: Gruyère (où y font le fromage)
 


Message le 20 Oct 2003 20:44

Il y a de bons utilitaires pour récupérer des partitions perdues à www.telecharger.com :wink:
Windows XP Home, AMD 3800+, 2048 DDR3200, K8T Neo2, X800 XT , IDE West200 + SATA Max200, 20.1 TFT Philipps, Plextor 708, Homework 5.1 500THX
Avatar de l'utilisateur
[RATIGAN]=Ripley=
Sous Expert(e)
Sous Expert(e)
 
Messages: 62
Inscription: 19 Oct 2003 19:53
Localisation: 93
 

Message le 20 Oct 2003 21:10

1) tu as changé la taille des partitions avec quel outil ?
2) tu as changé la taille des partition avant ou pendant l'installation ?
3) pourquoi as tu utilisé une vieille version de mandrake ?
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2757
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 20 Oct 2003 21:50

Rebonjour,

Tout d'abord, je remercie les deux personnes qui m'ont répondu... et pour répondre au post de Glenux, je n'avais pas modifié les partitions de /dev/hda. Tout cela s'était produit lors de l'installation de Linux

Mais après une recherche fructueuse... j'ai trouvé la réponse.

Je la poste si cela intéresse quelqu'un d'autre.

Il s'agirait d'une fonctionnalité des versions 21.6 et 21.7.5 de LILO.
D'ailleurs la version de LILO du Mandrake 8.1 est bien la 21.7.5.
Pour résoudre le problème, il faut effectuer les actions suivantes :

1) Modification du fichier /etc/lilo.conf

Editer le fichier /etc/lilo.conf (avec vi par exemple)
Ajouter les lignes suivantes juste avant la première ligne : image = /boot/vmlinuz (celle-ci se répétant plusieurs fois dans le fichier)

change-rules
reset


2) Enregistrement des modifications

Dans une fenêtre terminal, juste taper la commande lilo.

3) Modification du System ID de la partition

Note: il existe apparemment un code de système pour les partitions :
    Code 17 = Partition NTFS cachée
    Code 07 = Partition NTFS non cachée

Il est possible de modifier ce code à l'aide de la commande fdisk t /dev/hdx ou quelquechose comme cela. Si quelqu'un connait la syntaxe exacte... je suis preneur.

En fait, pour ma part, j'ai utilisé un utilitaire Windows :oops: qui s'appelle BootManager BootUS que l'on peut trouver à http://www.boot-us.com/.

L'utilisation de cet utilitaire est gratuite pour un usage privé.

4) Reboot de la machine

Et voilà...
Bonne soirée à tous. :D
Quercus
Visiteur
Visiteur
 
Messages: 3
Inscription: 20 Oct 2003 15:48
Localisation: Gruyère (où y font le fromage)
 

Message le 20 Oct 2003 22:20

Merci pour ces indications (c'est dingue, on en apprend tous les jours).
Mais je n'ai pas compri le détail de comment tu as bousillé tes partitions NTFS dans cette histoire...
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2757
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Partitions NTFS illisibles

Message le 21 Oct 2003 12:40

Puisqu'une petite précision s'impose... la voici :wink:

Lors de l'installation de Linux, je n'ai PAS détruit deux de mes quatre partitions NTFS. Elles étaitent toujours là... mais invisibles pour Windows XP.

Leurs status de partitions étaient passés de NTFS visible, actif... (code 07) à NTFS cachée (code 17).

Ce changement de status, opéré par l'installeur de Linux, a déconnecté les lettres de lecteur que Windows XP utilise pour monter les disques.

Comme le gestionnaire de disque de Windows XP est particulièrement limité... nul salut de ce côté là. Mais, celui-ci m'indiquait quand-même que les partitions existaient et qu'elles étaient en NTFS. Le luxe quoi ! Je pouvais même avoir une indication sur la taille occuppée et libre par les données... mais plus d'accès aux-dites données.

Concernant les causes, la seule manipulation effectuée lors de l'installation a été de cliquer sur ces deux partitions avec l'utilitaire de partitionnement de l'installeur Linux (mode expert). J'ai cliqué dessus, pour bien m'assurer d'avoir sélectionné le bon disque (en l'occurence le deuxième HD physique, celui destiné à Linux).

Une fois Linux installé, et la machine rebootée, quand je me suis connecté avec Windows XP... j'avais perdu l'accès à ces deux partitions.

Hypothèse :

Quand j'ai cliqué sur les deux partitions NTFS lors de l'installation, l'installeur a dû penser que ces deux partitions faisaient partie de l'installation... mais les a conservée en l'état. Ben oui, je n'ai demandé aucune modification.

Or, la version de LILO 21.7.5 contient apparemment la fonction de cacher les partitions "inutiles"... Diantre ! NTFS, n'est pas utile pour Linux... ext2fs suffit amplement (pour moi en tout cas) :wink:

En conclusion, l'effet de bord a été produit chez Windows Xp qui n'est pas capable de récupérer une partition cachée avec les utilitaires "on board".
Alors que fdisk (Linux) peut le faire... même si je ne sais pas comment... et une frayeur a été suffisante pour le moment.

Voilà... désolé pour le pâté et mon style ampoulé.

Bonne suite à tous et (sûrement) à bientôt.
Quercus
Visiteur
Visiteur
 
Messages: 3
Inscription: 20 Oct 2003 15:48
Localisation: Gruyère (où y font le fromage)
 

Message le 13 Sep 2004 07:20

Pour reprendre le sujet, je voudrais simplement dire que j'ai eu le même pb en installant ma Debian Sid : après avoir configuré Lilo et testé le boot sous XP, je me suis retrouvé avec ma partition système seulement, mes deux autres partitions FAT32 étant invisibles. Le problème a été résolu en suivant (en partie) la procédure donnée par Quercus : un coup de fdisk /dev/hdx (x=disque de windows), puis changement du type des partitions cachées...

Merci pour votre aide en tout cas ;)
Ryoichan
Visiteur
Visiteur
 
Messages: 1
Inscription: 13 Sep 2004 07:16
 



Sujets similaires

Message molotov et linux
bonjour j'ai installé molotov, premier ouverture, premier plantage, impossible de le quitter .et puis il est nul part, impossible de trouver l'icône dans le menu ? louche non ? merci
Réponses: 3

Message RE Connexion de deux PC sous Linux
Bonjour Diogène !Je refais appel à toi, car dans le cadre de mon installation du nouveau desktop, j'ai du mal à le connecter avec le portable.Pourtant j'ai bien un peu d'expérience maintenant !J'ai contrôlé leurs IP.Ils ont les mes noms d'utilisateurIls ont les mêmes mots de passe.Ils ont ts les deu ...
Réponses: 1

Message [résolu] webcam vx1000 microsoft et linux
bonjour ça fait deux mois que je n'ai pas vu mes petits enfants, j'ai branché ma vieille webcam sur mon pc et installé skype, mais ça ne fonctionne pas ? que dois je faire , merci
Réponses: 28

Message [Réglé] Redo Backup sous linux n'efface pas le disque entier
bonjour (ou bonne nuit..) à toutes et tousOui je sais la nuit me donne des envies cataclysmiques...J'ai testé Redo Backup car il bosse en live, sur linux & win !https://sourceforge.net/projects/redobackup/files/Lors de la restauration, il prévient que le disque entier va être effacé..., que neni ...
Réponses: 7

Message Les Logiciels Utiles - GNU/Linux - Petit Retour 2019
Je me permets de reprendre ce magnifique sujet de w0lverineJe vais rajouter quelques liens qui peuvent être utiles...Le Monde du Libre est à vos pieds...Encore un tout petit pas Les Logiciels Utiles - GNU/Linux - Petit Retour...Message le 14 octobre 2019Pour les systèmes GNU/LinuxCle MultiBootUsb ...
Réponses: 2

Message Dual-boot Windows Linux et démarrage sur boot loader Windows
Bonjour à tous,Je fais des études d'informatique et nous devons faire une install dual-boot Windows Linux avec démarrage sur boot loader Windows. Celui-ci doit proposer de soit démarrer Windows, soit de lancer Grub.Pas de problème pour le faire lors d'une install en mode Bios :1. Install Windows2. I ...
Réponses: 1


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 3 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.