Il y a actuellement 91 visiteurs
Samedi 24 Février 2018
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

[Réglé][Debian] Charge CPU

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

[Réglé][Debian] Charge CPU

Message le 29 Jan 2005 22:24

Salut à tous,

J'ai quand même un sérieux pb avec ma debian sous fluxbox : au bout de quelques temps d'utilisation, j'ai l'impression que ca rame sec. Trés sec même...

J'ai repéré le coupable depuis quelques temps, mais je ne sais pas pourquoi et comment il est coupable :
top a écrit: PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
2113 casa 25 0 55760 25m 23m R 95.8 13.5 47:33.22 python
2081 root 5 -10 39180 29m 11m S 2.0 16.0 6:34.96 XFree86
2537 casa 15 0 32392 12m 18m S 1.0 6.9 0:36.97 gnome-terminal
2101 casa 15 0 15776 8168 13m S 0.3 4.3 0:30.26 gkrellm
3139 casa 17 0 2060 1064 1844 R 0.3 0.6 0:06.89 top
1 root 16 0 1500 516 1344 S 0.0 0.3 0:00.36 init
2 root 34 19 0 0 0 S 0.0 0.0 0:00.00 ksoftirqd/0
3 root 5 -10 0 0 0 S 0.0 0.0 0:00.17 events/0
etc...


Qu'est-ce qui ne va pas avec python et comment remédier à ce problème ?

Entre 95 et 100% de la charge CPU pour Python, sans activité : normal/pas normal ?
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8913
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 


Message le 30 Jan 2005 10:38

Réponse au feeling: utiliserait-tu un diplay (pour gdesklet) mal programmé ?
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 30 Jan 2005 11:43

glenux a écrit:Réponse au feeling: utiliserait-tu un diplay (pour gdesklet) mal programmé ?

Possible... il me semble qu'avant l'utilisation de gdesklets je n'avais jamais remarqué cela (?).

Est-il possible que ce soit carrément le programme gDesklets qui fonctionne mal avec mon système ?
Je demande cela car en voulant visionner le log de chargement de gDesklet, dans la barre fluxbox, j'ai le phénomène suivant :
- la fenêtre du log se bloque au bout de quelques secondes
- 2 desklets, sur les 3 que j'utilise, ont disparu de mon bureau
- maintenant, j'ai un cadre gris à la place de l'icone gDesklets (barre fluxbox) et des menus contextuels (clic droit souris)

Pas trés concluant tout cela.
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8913
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 30 Jan 2005 12:17

casa04 a écrit:Possible... il me semble qu'avant l'utilisation de gdesklets je n'avais jamais remarqué cela (?).
Pas trés concluant tout cela.


Malheureusement ou Heureusement gdesklets est un logiciel qui evolue tres vite. La derniere evolution majeure (celle qui fait de gdesklets un deamon) a rendu obsolete de nombreux displays et fait planter un certain nombre d'autres desklets (par exemple la StarterBar ne fonctionne plus)...

Conseil: lance gdesklets à la main dans un terminal, et regarde les messages d'erreur... peut-être y a t'il un indice pour trouver la source de ton problème...
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 30 Jan 2005 12:44

Une fois de plus, tu étais dans le vrai.

J'utilisais 2 starterbar (v 0.31.2), et elle me faisaient cette instruction en boucle (vu dans le log):
get_full_path(/usr/share/pixmaps/psi.xpm) with self.__path =
/usr/share/gdesklets/Displays/psi-launcher
-> /usr/share/pixmaps/psi.xpm


La staterbar enlevée, je retombe à un Python à 1-2% de charge...

A l'avenir je serai plus attentif à l'utilisation de gdesklets.

Merci ;-)
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8913
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 



Sujets similaires

Message [Réglé] Virus ou pas
BonjourDepuis quelques temps mon ordi fait des siennes. J'ai un Lenovo avec Windows 8.1Internet explorer est très lent, bloque des pages, mon Yahoo mail met des minutes pour effectuer des opérationsJ'ai des messages du type : internet explorer a modifié cette page pour empêcher le script de site à s ...
Réponses: 48

Message [Réglé]deezer
bonjour,Je voudrais savoir comment faire pour empêcher deezer de s'ouvrir au démarrage . Je suis allé dans gestionnaire des taches - démarrage , mais je ne trouve pas deezer .Je suis sur w10 . Merci.
Réponses: 3

Message [réglé] Achat portable conseil modèle / carte graphique
Bonjour à toutes et à tous Je vous écris afin d'avoir quelques informations concernant l'achat d'un pc.Actuellement j'ai un pc (HP pavillon ProtectSmart) avec un processeur AMD A8-4555M 1.6 Ghz, 8 Go de RAM et une carte graphique dont je ne retrouve pas le nom et il est sous windows 10Il a un peu ...
Réponses: 6

Message [Réglé] POP inofensive, mais qui reviennent sans cesse.
Bonjour,S'il s'agit du "cache" de Google Chrome, on peut le supprimer directement dans Chrome (Paramètres/Paramètres avancés/Confidentialité et sécurité/Effacer les données de navigation).
Réponses: 38

Message [Réglé] Pubs et barre secure search sur Firefox
Bonjour,Depuis maintenant plusieurs semaines, quand je clique sur un lien, une page de pub se lance à la place de l'onglet désiré mais cela ne se produit pas tout le temps et j'ai l'impression que cela se fait de manière aléatoire.De plus, au lancement de Firefox, une barre "secure search" ...
Réponses: 5

Message configuration matériel debian 9.3
bonjour,actuellement , j'ai un portable acer aspire 3630, avec celeom m 1.6 ghz pour le processeur, 1 go de ram et 64 mo de ram en graphique, bref ça rame sec. je voudrais m'acheter un pc fice d'occasion pour faire du linux ( debian 9.3 lxde).quelle configuation matériel me conseillez vous ?merci d' ...
Réponses: 5

Message [Réglé] windows 7 ne se lance plus après extension mémoire
BonjourSur mon pc portable HP DV7-4182sf Windows 7 64 bits équipé de 4go de mémoire Hyundai PC3-10700 (667 Mhz) cl7 (rèf: CPUZ), j'ai voulu rajouter une barette de 4go de marque Kingston KVR 13S9S8/4 PC3-10600 (1333 Mhz) cl9 1,5v.Mais au redémarrage de l'ordinateur, Windows ne se lance plus et j'a ...
Réponses: 25


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 4 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.