Il y a actuellement 93 visiteurs
Dimanche 23 Septembre 2018
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

[Réglé] [Debian] config réseau pour connexion partagée

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

[Réglé] [Debian] config réseau pour connexion partagée

Message le 05 Aoû 2004 10:13

Je ne suis pourtant pas nouveau sur le sujet, mais je peine un peu...
Rappel :
- 1 Pc windows XP, connexion ADSL USB avec le sagem800 + un chip réseau
- 1 Pc Linux Debian + carte réseau Winbond
Je veux partager ma connexion ADSL (Win XP) pour Linux :
- Pc XP en statique 192.168.0.1, masque 255.255.255.0
- Pc Linux en statique 192.168.0.2, masque 255.255.255.0, passerelle 192.168.0.1

Les 2 Pc se pinguent, mais je ne fais rien d'autre. Sur Linux : impossible de faire un ping free.fr, ou un ping "adresse IP".
Au niveau du traffic (donné par l'observation du firewall sur XP), j'ai l'impression que les requêtes Linux n'arrivent pas sur le XP. Je pense à un problème DNS.

Comment déclarer le Pc Linux pour que XP serve de passerelle ?
J'ai essayé de renseigner le fichier resolv.conf, pour les DNS (si j'ai bien tout compris) avec l'adresse d'XP (192.168.0.1). Pas mieux...

Pourtant, ça doit être assez bête.

Merci d'avance.

Ps : Si qqun connait une bonne adresse "exhaustive" sur le paramétrage de la Debian et de Linux en général (surtout sur les arborescence, fichiers de paramétrage, config, commandes), je suis preneur.
Car j'arrive toujours à trouver qqchose sur google, mais c'est pas toujours bien adapté. Selon les distrib, les fichiers de configurations ne sont pas les mêmes, au même endroit, etc...
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8917
Inscription: 13 Mai 2003 17:32
Localisation: A.H.P... et jamais loin d'une Debian
 


Message le 05 Aoû 2004 10:24

Qu'as tu dans /etc/network/interfaces ?

As-tu un firewall sous XP, qui pourrai empêcher la connexion du PC sous Linux :wink:

Pour les configurations le site Léa Linux peut être un bon départ :wink:
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 11:46
Localisation: /Fr/Idf/77/Le Mée
 

Message le 05 Aoû 2004 10:37

Stormrider a écrit:Qu'as tu dans /etc/network/interfaces ?

Actuellement, je peux pas te dire ça, puisque j'ai pas mon Linux sous la main (==> ce soir).
Mais, il me semble que le fichier reflete ma config (IP, masque, passerelle), sans la notion de DNS.
C'est pareil si on fait un ifconfig, non ? Car le ifconfig ne me donne pas plus de paramètres.
Stormrider a écrit:As-tu un firewall sous XP, qui pourrai empêcher la connexion du PC sous Linux

Oui (Sygate), et non. Je crois quand même l'avoir bien paramétré (toutes les requêtes acceptées provenant du Linux).
Mais, de toutes les façons, je le désactive provisoirement quand je fais mes tests, donc il ne risque pas de bloquer.

Merci pour le site. Je le connaissais de nom, mais je ne l'ai jamais parcouru à fond...
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8917
Inscription: 13 Mai 2003 17:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 05 Aoû 2004 14:26

Bon, je suis un peu limite qqfois....

Pour le site et la doc, il suffisait d'aller sur debian.org bien sûr... :roll:

J'ai trouvé des infos sur le partage, sur divers sites. Il me semble que j'ai déjà dû me tromper sur le DNS (j'espère que c'est ça), dans le resolv.conf. Je mettrai celles de Free ce soir pour poursuivre mes tests.
Et je reverrai ma config réseau complète, une fois que je saurai où sont (et à quoi servent) tous les fichiers concernés.

Galère de repartir à zéro... :cry: mais je persiste.
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8917
Inscription: 13 Mai 2003 17:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 05 Aoû 2004 14:36

J'avais pas fait attentions : en effet dans le fichier resolv.conf tu dois mettre la/les adresse(s) de ton/tes serveur(s) DNS :wink:
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 11:46
Localisation: /Fr/Idf/77/Le Mée
 

Message le 05 Aoû 2004 14:56

Il me semble que la seule chose que tu ai oublié est de cocher la case partager dans Démarrer => Paramètres => Connexions réseaux => (interface de ton ADSL). Tu vas ensuite sur propriété, et dans l'onglet Partage. Tu coches activer le partage de cette connexion, il va te dire qu'il configure l'autre interface pour faire office de serveur dhcp.
Ensuite sous ta debian tu configures ton interface eth0 (je suppose) en dhcp
Tu mets ça dans ton fichier /etc/network/interfaces
Code: Tout sélectionner
# The loopback interface
auto lo
iface lo inet loopback
# My local connexion
auto eth0
iface eth0 inet dhcp

tu mets rien dans /etc/resolv.conf
normalement ils sera rempli automatiquement par le système dhcp.

Après ça tout devrait fonctionner. Sinon tu mets les mêmes adresse qui te sont données par ton fournisseur d'accès.
avec la forme :
Code: Tout sélectionner
search
nameserver xxx.xxx.xxx.xxx

Où tu remplaces xxx.xxx.xxx.xxx par des serveurs de noms.
tu mets autant de lignes nameserver que tu veux. Un ligne n'étant utilisé que si les lignes précédentes n'ont pas permis de résoudre le nom recherché.
Ma Config :

2x 2Ghz G5 1,5 Go / 160 Go / 9800 Pro PC flashé
Je veux un 20 Pouces Apple :(
Avatar de l'utilisateur
ShamoX
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 253
Inscription: 20 Juin 2003 22:07
Localisation: /dev/europe/france75/paris10
 

Message le 05 Aoû 2004 15:00

pour savoir si c'est le service de nom qui marche pas ou le service de routage essaie les deux commandes suivantes :
Code: Tout sélectionner
host www.free.fr
ping 213.228.0.42

si la première marche et donne une adresse (théoriquement la même que celle qu'il y a dans la commande de ping) alors ton service de nom fonctionne. Si la deuxième ne fonctionne pas et que tu arrive à pinguer ton XP alors c'est le routage qui ne marche pas.
Ma Config :

2x 2Ghz G5 1,5 Go / 160 Go / 9800 Pro PC flashé
Je veux un 20 Pouces Apple :(
Avatar de l'utilisateur
ShamoX
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 253
Inscription: 20 Juin 2003 22:07
Localisation: /dev/europe/france75/paris10
 

Message le 05 Aoû 2004 15:15

ShamoX a écrit:Il me semble que la seule chose que tu ai oublié est de cocher la case partager dans Démarrer => Paramètres => Connexions réseaux => (interface de ton ADSL). Tu vas ensuite sur propriété, et dans l'onglet Partage. Tu coches activer le partage de cette connexion

Tout ça, j'ai fait.
ShamoX a écrit:Il va te dire qu'il configure l'autre interface pour faire office de serveur dhcp.

Non, mais c'est pas grave...
ShamoX a écrit:Ensuite sous ta debian tu configures ton interface eth0 (je suppose) en dhcp

En fait, je voulais essayer en IP statique sur les 2 PC. S'il faut le dhcp, je le mettrais. Mais j'espère bien m'en sortir sans.
ShamoX a écrit:Sinon tu mets les mêmes adresse qui te sont données par ton fournisseur d'accès.

Woui... C'est ça que je compte essayer de faire.

Merci à vous deux...
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8917
Inscription: 13 Mai 2003 17:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 05 Aoû 2004 23:25

Problème résolu : ca venait bien des DNS du resolv.conf.

Merci...
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8917
Inscription: 13 Mai 2003 17:32
Localisation: A.H.P... et jamais loin d'une Debian
 



Sujets similaires

Message [Réglé] Ecran bleu
Bonjour les amis ! Voila j'ai mis a jour un utilitaire de mon MSI ' Battery Calibration' sur le site MSI http://www.msi.com/product/notebook/sup ... in8.1%2064 et depuis que je l'ai installé j'ai des écrans bleu qui arrive et mon ordi qui a du mal a se lancer.Comment je peux le réinstallé correcte ...
Réponses: 69

Message [Réglé] Acheter un pc ou acheter du matériel pour l'ancien?
Bonjour à toutes et à tous!Je me pose la question suivante : si je veux faire tourner des jeux triples A sur par exemple 3 ~ 4 ans, quelle serait la meilleur solution : acheter un nouveau pc avec tout les composants "à neuf" ou acheter le matériel nécessaire pour le remplacer par le matéri ...
Réponses: 18

Message [Réglé] Ornidateur bloqué sur outils de diagnostic mémoire
Bonjour,en voulant accélérer le démarrage de mon pc à la manière windows 7 (fichu windows 10), j'ai donc modifier le nombre de coeur de 1 à 3 et pour la ram j'ai coché la case "maximum" (il ne voulait pas d'une autre valeur appliquée manuellement). Sauf que je lance le redémarrage et surpr ...
Réponses: 21

Message connexion Goggle
BonjourSubitement, je n'ai plus eu de connexion à Goggle sur mon smartphone Lumia 640 Microsoft.Toutes les autres connexions se font sans problème...Pouvez-vous m'aider ? Merci.
Réponses: 2

Message Augmentation de ma config pour les derniers triple A comme
Bonsoir pour faire tourner les prochains gros jeux en ultra à 120 fps ou en high comme battelfield V par exemple (j'ai un 144hz) qu'est ce qu'il faut que je remplace dans ma config:Configuration matérielle :Windows 10 Professionnel ?(X64)?Intel Core i7 6700K OC Tension 1.320 4.30 GHz16 Go de mémoire ...
Réponses: 2

Message [Réglé]Déconnexion inexplicable
Bonjour J'ai des déconnexions tous les 2-3 jours... Cela n'arrive pas à chaque fois. Quand ça le fait, j'ai le net pendant 30 secondes puis coupure... Je dois alors redémarrer le modem pour ravoir ma connexion. Le technicien est déjà passé et m'a dit que le problème venait de chez moi, de ma tour do ...
Réponses: 5


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité


.: Nous contacter :: Flux RSS :: Données personnelles :.