Il y a actuellement 70 visiteurs
Mercredi 13 Décembre 2017
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

pb démarrage Xserver

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

pb démarrage Xserver

Message le 11 Oct 2003 17:21

Bonjour chers amis,
Je viens de faire le grand saut et d'installer Debian sur ma machine.
Je ne connais pratiquement rien à Linux, et ça se voit au résultat !
L'insta s'est bien passé, je précise que j'avais Win98 déjà installé, et que j'ai partitionné avec Partition Magic : aucun problème.
Le moment de vérité fut le démarrage.
Là, j'ai un message d'erreur que je n'arrive pas à interpréter (et d'abord pourquoi est-ce que tout est en anglais ?)

Voici un résumé du message :
cannot start X Server
Fatal Server Error
no screens found
(je ne me souviens plus le message anglais, mais en gros on me dit que je peux trouver un relevé de l'erreur dans) /var/log/XFree86.0.log
process set to nice value 0 instead of -10 as requested
disable X Server, restart GDM when configured correctly

Je crois comprendre que c'est l'interface graphique qui n'arrive pas à reconnaître ma carte graphique, qui est une
MSI-StarForce GeForce 4 Mx 440 (AGP 8X) 64Mo
Il me dit que la "Release Date" de XFree86 est du 21/12/01 et que la version est la 4.1.0.1
Peut-être que c'est trop vieux pour que ma carte graphique soit reconnue ?

En tout cas, merci de me donner des conseils clairs et précis, car je n'ai pas encore bien saisi le démarrage en mode "console" et bien sûr, je n'y connais rien en ligne de commande sous Linux.

Merci à tous pour votre contribution.
Avatar de l'utilisateur
pacman1897
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 286
Inscription: 25 Juil 2003 10:40
 


Re: pb démarrage Xserver

Message le 11 Oct 2003 21:04

pacman1897 a écrit:Bonjour chers amis,
Je viens de faire le grand saut et d'installer Debian sur ma machine.
Je ne connais pratiquement rien à Linux, et ça se voit au résultat !

Tout d'abord permet moi de te rappeller que Debian n'est déstinée aux débutants que dans le cas ou ceux-ci sont patients et ont la volonté de se plonger a fond dans la découverte du systeme (avec toutes les difficultés que cela implique)
Si tu ne te sent pas faire partie de la catégorie d'utilisateurs précédent, tu peux utiliser la distribution Mandrake ou RedHat qui sont bcp plus a jour, qui ont une installation et une configuration énormément facilitée, et qui reconnaissent et configurent presque toutes seules le matériel.

(et d'abord pourquoi est-ce que tout est en anglais ?)

Parce que tu n'as pas configuré / installé les locales qui gèrent les langages/traductions dans les logiciels.

Voici un résumé du message :
cannot start X Server
Fatal Server Error
no screens found
[...]
Je crois comprendre que c'est l'interface graphique qui n'arrive pas à reconnaître ma carte graphique, qui est une
MSI-StarForce GeForce 4 Mx 440 (AGP 8X) 64Mo
Il me dit que la "Release Date" de XFree86 est du 21/12/01 et que la version est la 4.1.0.1

Il s'agit exactement de cela. Tu as donc 2 possibilités:
- Soit configurer Xfree (dpkg-reconfigure xserver-xfree86 puis répondre aux questions) de telle sorte qu'il utilise VESA, puis récupérer les drivers de ta carte graphique sur internet et re-configurer ensuite Xfree
- Soit utiliser une distribution linux comme Mandrake ou Redhat qui reconnaissant toutes seule ta carte.
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 11 Oct 2003 23:01

Merci cher Glenux,

Effectivement, j'ai voulu faire vite, et comme un ami m'avait parlé cet été de Debian, et que j'ai vu sur certains sites que c'était la distri "la plus puissante", je me suis dit : "Tentons le coup."
Maintenant, je vois qu'il faut mieux y aller mollo, et je crois que je vais passer à Mandrake.
Mais que dois-je faire ? D'abord supprimer complètement Debian ? Si oui, en formattant les partitions réservées pour Linux ?
Merci beaucoup.
Avatar de l'utilisateur
pacman1897
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 286
Inscription: 25 Juil 2003 10:40
 

Message le 12 Oct 2003 08:29

pacman1897 a écrit:Effectivement, j'ai voulu faire vite, et comme un ami m'avait parlé cet été de Debian, et que j'ai vu sur certains sites que c'était la distri "la plus puissante", je me suis dit : "Tentons le coup."


C'est effectivement le cas, mais comme tout produit "puissant", elle comporte de nombreux réglages qui sont en fais "masqués" par les autres distributions, donc il faut vraiment avoir un esprit curieux pour utiliser une Debian (ou une Gentoo) si l'on est débutant...


Maintenant, je vois qu'il faut mieux y aller mollo, et je crois que je vais passer à Mandrake.

En fait a chaque personne/tempérament-d'utilisateur correspond une distribution Linux, il faut juste trouver celle qui te correspondra le mieu... (sachant que rien ne t'empeche de changer de distrib plus tard...)

Mais que dois-je faire ? D'abord supprimer complètement Debian ? Si oui, en formattant les partitions réservées pour Linux ?


Je te conseille de relancer l'installation de Debian, et de refaire le partitionnement du disque (supprimer les partitions Linux), et d'écrire la nouvelle table des partitions sur le disque.
Apres cela, laisse tomber le reste de l'installation et redémarre ta machine (enleve le CD de Debian).

Insere le CD de mandrake dans le lecteur, lance son installation.
Il suffira, à l'installation de mandrake, de demander le partitionnement automatique (ou pas).

(Au fait, de combien d'espace disque disposes-tu pour GNU/Linux ?)
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 12 Oct 2003 23:10

Je te conseille de relancer l'installation de Debian, et de refaire le partitionnement du disque (supprimer les partitions Linux), et d'écrire la nouvelle table des partitions sur le disque.

Est-ce que ce sont des options qui vont m'être proposées immédiatement quand je mettrai le CD de Debian dans le lecteur ?
Les opérations sur les partitions me donnent quelques sueurs froides, même si j'ai fait toutes les sauvegardes nécessaires. Je ne suis pas sûr d'être toujours très bon en anglais, surtout avec le jargon informatique.
De plus, je ne comprends pas le sens de l'expression "écrire la nouvelle table des partitions sur le disque".
Merci d'éclairer ma lanterne, cher Glenux.
Avatar de l'utilisateur
pacman1897
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 286
Inscription: 25 Juil 2003 10:40
 

pb config Freebox avec Mandrake 9.1

Message le 16 Oct 2003 13:12

Chers amis,

Comme conseillé par Glenux, je suis passé à une distri plus simple que Debian, et j'ai donc installé Mandrake 9.1.
L'insta s'est bien passé, j'apprécie que mon scanner et mon imprimante aient été reconnus du premier coup. 8)

Mais il y a quand même des petits mais.
Le plus gros vient de la Freebox. Je l'utilise en USB, et pas moyen de la connecter. J'ai le manuel en PDF, et j'ai essayé de suivre les instructions. D'abord, et cela va faire rire les habitués qui font ça dix fois par jour, je n'arrive pas à accéder aux fichiers réservés au super-utilisateur. J'ai trouvé sur un site l'astuce pour passer du mode graphique au mode console. Je me suis donc loggé en root sur la console 1, mais revenu au mode graphique, toujours pas moyen d'accéder aux fichiers verrouillés.
De plus, le guide Freebox me demande de passer certaines commandes. Quelques unes marchent, les autres rendent "no such file..."

Enfin, ma carte son est identifiée dans les périphériques, et son nom apparaît clairement, mais quand j'allume mes enceintes et que j'essaie de jouer un mp3 ... silence de mort. :-?

Vous voyez que j'ai vraiment besoin d'une main secourable... :D
Merci beaucoup à ceux qui auront des idées.
Avatar de l'utilisateur
pacman1897
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 286
Inscription: 25 Juil 2003 10:40
 

Message le 16 Oct 2003 21:34

quand j'allume mes enceintes et que j'essaie de jouer un mp3 ... silence de mort

J'ai eu ce petit désagrément la première fois, et il me semble que c'était tout simplement... le son réglé au minimum (muet quoi) par défaut. Cherche dans les paramètres du player.
J'ai trouvé sur un site l'astuce pour passer du mode graphique au mode console. Je me suis donc loggé en root sur la console 1, mais revenu au mode graphique, toujours pas moyen d'accéder aux fichiers verrouillés.

Tu as surement trouvé une astuce du style alt+ctrl+F1 (F2, F3...) non ? Il y a beaucoup plus simple... Il suffit de lancer une console. Son icone est accessible dans la barre des taches par défaut (KDE ou GNOME), ou dans le menu des applications.
Une fois lancée ta console (en mode fenêtre donc), tu retrouve le shell et le prompt avec ton login. Il suffit alors de taper su pour lancer le log en mode root (super user) et de taper ton mot de passe root.
N'oublies pas qu'en mode user (ton login) tu ne pourras agir que sur les répertoires (et sous répertoires) de ton home. Il faut toujours se logguer en root pour pouvoir installer, copier, supprimer, modifier etc...
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8879
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Re: pb config Freebox avec Mandrake 9.1

Message le 17 Oct 2003 06:48

pacman1897 a écrit:Mais il y a quand même des petits mais.
Le plus gros vient de la Freebox. Je l'utilise en USB, et pas moyen de la connecter. J'ai le manuel en PDF, et j'ai essayé de suivre les instructions.

Je te déconseille fort d'utiliser ta freebox en USB :
- d'une part, le temps de latence est énorme (comparé à l'ethernet)
- d'autre part cela fait fonctionner bcp plus ton processeur...
Un carte réseau neuve (compatible realtek, ne2000 ou 3com de préférence) ne coute que 12euros, et d'occaze tu peux en trouver à 3-4 euros... et les perf sont bien meilleures & la configuration est quasi-instantannée...

D'abord, et cela va faire rire les habitués qui font ça dix fois par jour, je n'arrive pas à accéder aux fichiers réservés au super-utilisateur.

C'est normal. Pourquoi veux tu accéder aux fichier du super-utilisateur ?

Enfin, ma carte son est identifiée dans les périphériques, et son nom apparaît clairement, mais quand j'allume mes enceintes et que j'essaie de jouer un mp3 ... silence de mort. :-?

0) vérifie le volume
1) Si tu utilise KDE : active/désactive le deamon aRtS
2) Si tu utilise Gnome : active/désactive le deamon EsD
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 17 Oct 2003 14:06

Sous KDE, j'ai essayé de tripoter dans tous les sens aRtS, mais rien du tout.
Peut-être un indice, quand j'essaie la cloche système, cela fonctionne.
Vois-tu une autre solution ?
Merci
Avatar de l'utilisateur
pacman1897
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 286
Inscription: 25 Juil 2003 10:40
 

Message le 17 Oct 2003 17:57

J'ajoute que je viens d'essayer de connecter ma freebox avec ma carte réseau avec un câble ad-hoc, mais toujours aucune connexion Internet en vue.
J'ai essayé sous Windows, ça marche impeccable.
Que faire ?
Merci.
Avatar de l'utilisateur
pacman1897
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 286
Inscription: 25 Juil 2003 10:40
 

Message le 17 Oct 2003 18:19

pacman1897 a écrit:J'ajoute que je viens d'essayer de connecter ma freebox avec ma carte réseau avec un câble ad-hoc, mais toujours aucune connexion Internet en vue.
[...]
Que faire ?

1) vérifier que ta carte réseau fonctionne/est-reconnue dans mandrake
2) configurer ta connexion internet en DHCP
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 17 Oct 2003 18:29

glenux a écrit:1) vérifier que ta carte réseau fonctionne/est-reconnue dans mandrake
2) configurer ta connexion internet en DHCP

Je crois que ma carte réseau est reconnue. J'ai vu qu'il me signalait une eth0 Via-Rhine ou quelque chose du genre.
Mais je ne sais pas du tout configurer ma connexion Internet en DHCP. J'ai essayé quelques trucs signalés sur le mode d'emploi de la Freebox, comme installé le paquet "dhcp-client", mais à chaque fois, il m'est répondu "no such command".
Puis-je avoir plus de détails ?
Merci beaucoup.
Avatar de l'utilisateur
pacman1897
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 286
Inscription: 25 Juil 2003 10:40
 

Message le 17 Oct 2003 19:01

2) configurer ta connexion internet en DHCP

Je crois que ma carte réseau est reconnue. J'ai vu qu'il me signalait une eth0 Via-Rhine ou quelque chose du genre.

Le fait qu'il ait reconnu eth0 est le plus important

Mais je ne sais pas du tout configurer ma connexion Internet en DHCP.

Je crois que dans mandrake il y a un outil nommé drakconnect (normalement c'est dans le panneau de configuration de la mandrake)

J'ai essayé quelques trucs signalés sur le mode d'emploi de la Freebox, comme installé le paquet "dhcp-client", mais à chaque fois, il m'est répondu "no such command".

Pour installer un logiciel il faut aller voir dans le gestionnaire de packages de ta mandrake, choisir le package, et installer...
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Internet : OK Carte son : toujours rien

Message le 19 Oct 2003 19:20

Ouf ! Le plus important est fait : j'ai la connexion Internet sans avoir rien installé de plus. 8) 8) 8)

Mais toujours rien pour la carte son : j'ai tripoté aRtS dans tous les sens et que dalle. :roll:
Quelqu'un a-t-il une idée ?
J'ai entendu parler d'ALSA, mais je ne sais pas du tout comment faire.

Merci beaucoup.
Avatar de l'utilisateur
pacman1897
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 286
Inscription: 25 Juil 2003 10:40
 

Re: Internet : OK Carte son : toujours rien

Message le 19 Oct 2003 19:50

pacman1897 a écrit:Ouf ! Le plus important est fait : j'ai la connexion Internet sans avoir rien installé de plus. 8) 8) 8)

Ok, bien :)

Mais toujours rien pour la carte son : j'ai tripoté aRtS dans tous les sens et que dalle. :roll:
Quelqu'un a-t-il une idée ?


Tout d'abord, vérifions si ta carte son est configurée...
Pour cela tu auras besoin du logiciel mpg123 ou mpg321 (installe le package si ce n'est pas fait).
De plus, je te prie de bien vouloir mettre un fichier .mp3 contenant du son audible à la racine de ton répertoire personnel (genre /home/toi/fichier.mp3 )

Au démarrage de ta machine, une fois qu'il propose de te logguer en mode graphique, tapes sur Ctrl + Alt + F1
Dans ce terminal, loggue toi en root, et tapes mpg123 /home/toi/fichier.mp3 (ou bien mpg321, selon ce que tu as installé).
S'il y a du son, c'est que ta carte son est correctement configurée (et qu'il y a un probleme de droits ou une chose dans ce gout là)
Sinon je te prie de bien vouloir relever le message d'erreur (ou ce qui est affiché au minimum).

J'ai entendu parler d'ALSA, mais je ne sais pas du tout comment faire.

ALSA est la partie qui gere le son (et les cartes sons) dans le noyau linux, et il prend la releve apres les bons et loyaux services de OSS (dans les anciens noyaux).
Normalement cela ne devrait rien changer pour toi.
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2753
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Suivante


Sujets similaires

Message Problème démarrage d'écran.
Bonsoir,Lorsque j'allume mon pc de bureau, mes écrans restent noir malgré qu'ils fonctionnent quand même.Ma config :Alim lepa 550wram 2x4go ddr3i5 3ghzEcrans de 60 hertz.Carte graphique : gigabyte GeForce 1050 TiJ'ai fait plusieurs test :- Tester les écrans sur un autre pc, ils fonctionnent.- Tester ...
Réponses: 8

Message MacOS Planté/ dossier point ? au démarrage
Bonsoir je possède un Macbook Pro de 2012, 2,5 GHz Intel Core i5, 4 Go 1600 Mhz DDR3 J'etais sous Sierra et j'ai voulu faire la MAJ High Sierra, mon chargeur était mal branché prise d'affectueuse, du coup la mise à jour a planté, après quelques va-et-vient sur les forums, j'ai réussi à redémarrer mo ...
Réponses: 0

Message problème démarrage ordi de bureau
Bonjour, J'ai récupéré par un parent 2 ordinateurs de bureau Futjitsu N° YLCS042321 formatés. J'ai installé sans problème Windows 8 Pro sur les 2. Au début démarrage OK. Depuis plusieurs jours rien ne va plus. Les ordinateurs se lancent une fois sur quatre, puis plus du tout. A l'allumage l'ordinate ...
Réponses: 1

Message touchpad non innactif au démarrage du pc
Bonjour, sur un notebook asus TP 200S sous Windows 10 le touch pad n'est pas actif au démarrage du pc, je dois faire "F9" pour qu'il fonctionne. je ne parviens pas à le faire démarrer automatiquement. Dans le gestionnaire il n'apparait pas dans l'onglet démarrage et je n'ai pas trouvé de p ...
Réponses: 6

Message affichage systématique du Bios au démarrage
bonjourj'ai déplacé mon nouveau sujet ici ...certain ont pensé que le mal venait de la pilepersonnellement je ne le pense pas car le Bios affiche correctement la date et l'heureavez-vous une autre idée sur le pourquoi de cet affichage ?édit Pac : ça commence ici
Réponses: 3

Message Problème au démarrage
Bonjour,Depuis peu (exactement, me semble-t-il, depuis que j'ai mis à niveau Silverfast 6 pour mon scanner OpticFilm7200 acheté d'occasion et livré avec CD d'origine et numéro de licence, le tout en règle) mon ordi plante à chaque coup au démarrage. De même si je le laisse en veille, impossible de l ...
Réponses: 3

Message Démarrage impossible suite à MAJ plantée avec Ubuntu Xenial
Kikoo Après plusieurs semaines de tranquillité, j'ai mon premier couac snif :/Les MAJ d'Ubuntu sont un peu bizarres côté logiciels. On a aucune notification rien, il faut lancer l'apps pour avoir la notification m'enfin bref. Je vois une MAJ système, c'est assez courant. Je l'installe.3 heures plus ...
Réponses: 69


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.