Il y a actuellement 61 visiteurs
Samedi 16 Décembre 2017
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

hotspot chillispot

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

hotspot chillispot

Message le 13 Jan 2009 12:03

Bonjour,

Actuellement en stage, mon but est de mettre en place un accès wifi. Pour le moment je suis encore en phase de test.

J'ais un serveur sous debian avec chillispot, avec 2 cartes réseaux dont celle coté internet et relié au réseaux de l'entreprise et l'autre directement en ethernet (le temp des tests) à un pc portable.

J'ais suivi la procédure de
"http://www.guellec.fr/ressources/rapports/documentation_hotspot.pdf"
mes paramètres :
eth0: 10.1.1.137 255.255.0.0
eth1 : 192.168.1.1 255.255.255.0
dns : 10.1.1.104

Cependant au moment où j'essaie de me connecter à internet et où je devrais être redirigé le navigateur cherche et n'ouvre aucune page.
Je reçois bien une IP et un dns automatiquement, je ping bien eth0 et eth1 mais quand je fais un "nslookup" vers un site internet il me dit "impossible de trouver le nom du serveur".

Si quelqu'un saurait quoi faire, merci d'avance pour vos réponses.
gaarah
Visiteur
Visiteur
 
Messages: 4
Inscription: 13 Jan 2009 11:07
 


Message le 14 Jan 2009 15:43

Pour un peu plus de précision voici quelques données qui je l'éspere vous seront utiles pour m'aider.

La config de mon serveur :
Code: Tout sélectionner
hotspot:/home/administrateur# ifconfig
eth0      Lien encap:Ethernet  HWaddr 00:40:F4:5A:0F:AF
          inet adr:10.1.1.137  Bcast:10.1.255.255  Masque:255.255.0.0
          adr inet6: fe80::240:f4ff:fe5a:faf/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6520 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3329 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:3399774 (3.2 MiB)  TX bytes:751167 (733.5 KiB)
          Interruption:20 Adresse de base:0xe800

eth1      Lien encap:Ethernet  HWaddr 00:40:F4:55:6B:BC
          adr inet6: fe80::240:f4ff:fe55:6bbc/64 Scope:Lien
          UP BROADCAST  MTU:1500  Metric:1
          RX packets:334 errors:0 dropped:0 overruns:0 frame:0
          TX packets:64 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:36230 (35.3 KiB)  TX bytes:8862 (8.6 KiB)
          Interruption:21 Adresse de base:0xec00

lo        Lien encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:560 (560.0 b)  TX bytes:560 (560.0 b)

tun0      Lien encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          inet adr:192.168.1.1  P-t-P:192.168.1.1  Masque:255.255.255.0
          UP POINTOPOINT RUNNING  MTU:1500  Metric:1
          RX packets:153 errors:0 dropped:0 overruns:0 frame:0
          TX packets:45 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:500
          RX bytes:10965 (10.7 KiB)  TX bytes:5024 (4.9 KiB)


nslookup a partir de mon serveur :
Code: Tout sélectionner
hotspot:/home/administrateur# nslookup www.google.fr
Server:         10.1.1.104
Address:        10.1.1.104#53

Non-authoritative answer:
www.google.fr   canonical name = www.google.com.
www.google.com  canonical name = www.l.google.com.
Name:   www.l.google.com
Address: 216.239.59.99
Name:   www.l.google.com
Address: 216.239.59.147
Name:   www.l.google.com
Address: 216.239.59.104
Name:   www.l.google.com
Address: 216.239.59.103


et nslookup depuis mon poste client :
Code: Tout sélectionner
C:Documents and Settingsdesert>nslookup www.google.fr
DNS request timed out.
    timeout was 2 seconds.
*** Impossible de trouver le nom de serveur pour l'adresse 10.1.1.104 : Timed ou
t
*** Impossible de trouver le nom de serveur pour l'adresse 192.168.1.1 : No resp
onse from server
*** Les serveurs par défaut ne sont pas disponibles
Serveur :  UnKnown
Address:  10.1.1.104

DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
*** Le délai de la requête sur UnKnown est dépassé
gaarah
Visiteur
Visiteur
 
Messages: 4
Inscription: 13 Jan 2009 11:07
 

Message le 15 Jan 2009 10:27

Si tu fais une requête de ton IP 192.168.... et qu'elle doit partir sur le 10.1.1... il doit falloir activer la translation d'adresse entre les cartes, se servir d'iptable et créer des règles de routage.

Je te renvoie à ces tutoriaux très bien faits
=> http://irp.nain-t.net/doku.php/130netfilter:start
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8882
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 15 Jan 2009 11:34

Le routage entre les 2 cartes est bien configuré.

En fait, via navigateur web, j'accède à la page d'authentification de chillispot (en tapant "http://192.168.1.1/cgi-bin/hotspotlogin.cgi" ) cependant chillispot devrait m'y redirigé directement dès que je rentre n'importe quelle adresse.

De plus, arrivée sur la page, a laplace de login et mdp il me marque :
ChilliSpot Login Failed
Login must use encrypted connection


Je pense qu'il doit y avoir un problème de DNS et de certificat donc je cherche mais sans véritable résultat...
gaarah
Visiteur
Visiteur
 
Messages: 4
Inscription: 13 Jan 2009 11:07
 

Message le 27 Jan 2009 09:20

Je n'est toujours pas trouvé de solution a mon probleme.

D'après les nombreuses doc sur le net c'est hyper simple, est pourtant sa marche pas lol.

Il me reste 2 semaine pour terminer mon projet de stage donc si quelqu'un peut m'aider.

N'hesitez pas a me demander le resultat de commande ou le contenu de tel ou tel fichiers.
gaarah
Visiteur
Visiteur
 
Messages: 4
Inscription: 13 Jan 2009 11:07
 

Message le 03 Mai 2009 16:54

salut gaarah ,

ChilliSpot Login Failed
Login must use encrypted connection

En fait ce message t'indique qu'il faut utiliser une connexion encrypter pour pouvoir utiliser chillispot. Il faut donc pour la ligne uamserver dans ton chilli.conf utilisé : https://192.168.1.1/cgi-bin/hotspotlogin.cgi .
Ensuite il te reste à activer la conf ssl pour ton serveur web.

En espérant que cela puisse t'aider.
A bientôt
romtux
Visiteur
Visiteur
 
Messages: 1
Inscription: 03 Mai 2009 16:47
 



Sujets similaires

Message comment cacher ssid de mon hotspot wifi
Bonjour, je voudrais cacher le ssid de mon hotspot wifi comment faire?J'utilise ces commandes:netsh wlan set hostednetwork ssid="kodo" key="12345678" mode=allow netsh wlan start hostednetwork, mais je ne sais pas comment masquer le SSIDmerci d'avance.
Réponses: 1

Message Création HotSpot
Ah oui, je n'avais pas vu :pIl est configuré en Acess Point. Mais je n'ai aucun autre choix, je pense que c'est parce que j'ai la version gratuite.
Réponses: 11

Message Hotspot SFR WiFi public
Bonsoir,j'ai besoin d'aide pour une amie. Elle n'a plus le net depuis 2/3 jours et en attendant, elle aimerait se connecter via le WiFi (ce qu'elle a déjà fait, enfin, son frère), il y a juste un petit problème. Comment peut-elle se connecter sans avoir internet ? Je m'explique, j'ai fait mes recher ...
Réponses: 11

Message Hotspot shield (VPN) au secours !
Bonsoir,De Samedi à Dimanche début d'après-midi j'utilisais Hotspot Shield qui est un VPN gratuit plus ou moins connue, depuis hier je croule sous les problèmes, voici ce qui se passe :-Samedi installation du VPN + utilisation jusqu'à dimanche fin de matinée-Hier fin de matinée-début d'aprem, le VPN ...
Réponses: 20

Message enlever hotspot sfr URGENT !!
bonjour j'ai un probleme je vient d'installer ma connection internet avec le cd livebox (wanadoo) en wifi mais quand je vais sur ma page de démarage internet sa me met hotspot sfr et je ne peut aller nul part
Réponses: 17

Message connecter tuner internet à hotspot sfr
Bonjour,Je ne suis pas un super technicien des réseaux, alors je demande de l'aide à des personnes plus habituées à jongler avec ces sujets.Je connecte aujourd'hui sur mes amplis à lampe YAQIN et système cabasse un pc portable connecté via un hotspot sfr. Par ce biais, je peux écouter des radios sur ...
Réponses: 0

Message Création Hotspot avec téléphone portable
Salut à tous =)Je possède un téléphone portable Sony Ericsson w705 et un ordinateur portable sous windows 7 qui est équipé du bluetooth, du wifi et de ports usb aussi lolEn gros, j'aimerais connecté mon téléphone portable par bluetooth ou usb pour que je puisse surfer sur le web bien sur, mais aussi ...
Réponses: 1


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.