Il y a actuellement 87 visiteurs
Mardi 25 Septembre 2018
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

Oulala du Linux ! Pas internet !

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

Oulala du Linux ! Pas internet !

Message le 24 Fév 2012 17:56

Bonjour,

Je suis dans un contexte très particulier dont je vous passerai les détails, mais voici la situation :

Un réseau avec 6 PC windows sur du 192.168.1.x/24 avec une livebox en 192.168.1.1 pour internet.

Il y a un vieux serveur linux debian qui démarre en mode commande.

J'ai le mdp root (pas chance), alors, mes connaissances en linux sont faible, mais je sais quand même configurer les IP

Il y a 2 cartes réseaux (le serveur faisait office de Proxy a une époque) donc j'ai fait :

ifconfig eth0 192.168.1.111 netmask 255.255.255.0
ifconfig eth1 192.168.1.112 netmask 255.255.255.0
route add default gw 192.168.1.1

Donc la le serveurs fonctionne sur eth1, et sur mes PC quand je ping 192.168.1.112, ça fonctionne.

Sur mon linux, quand je ping 192.168.1.1, ça fonctionne, donc je ping ma passerelle.

Pour les dns, j'ai essayé :

nano /etc/resolv.conf

une page apparait :

dans la quelle je met :

nameserver 80.10.246.2
nameserver 192.168.1.1
search orange.fr

Mais je n'arrive pas a quitter cette page, en plus il y'a tjr des ta de texte qui passe en boucle, se qui rends l'édition très pénible.
y'a bien "alt+x" pour quitter, mais ça ne fait rien, mise a part supprimer le flood incessant....
Ducou forcement rien ne s'enregistre si je redémarre, je suis donc bloqué dans le resolv.conf que je n'arrive pas a quitter !

Et sur les post windows le \\192.168.1.112 ne fonctionne pas, je sais qu'il y a une histoire de samba pour ça, mais pas plus.

j'ai essayer de regarder pour passer en mode interface sur le debian, avec la commande startx, mais ça ne fonctionne pas.
j'ai donc fait : apt-get install kde
mais bien sur dans les dns, il ne risque pas d'y arriver.

Le truc c'est que j'ai des données à récupérer sur ce serveur.

Donc voila, je voudrai simplement récupérer les données de ce serveur qui a vocation à être supprimé.

J'imagine que j'ai bon sur pas mal de truc, mais je me sens con de ne pas arriver a quitter le resolv.conf !

Merci.
Arethusa
Expert(e)
Expert(e)
 
Messages: 1124
Inscription: 01 Nov 2007 23:47
 


Re: Oulala du Linux ! Pas internet !

Message le 28 Fév 2012 11:14

Arethusa a écrit:Mais je n'arrive pas a quitter cette page, en plus il y'a tjr des ta de texte qui passe en boucle, se qui rends l'édition très pénible.

Surement des messages système indiquant un problème quelconque.... car sinon il n'y a jamais de perturbation en console.
Arethusa a écrit:y'a bien "alt+x" pour quitter, mais ça ne fait rien, mise a part supprimer le flood incessant....

C'est plutôt CTRL+O pour enregistrer et CTRL+X pour quitter. Les flood de message n'empêche absolument pas l'enregistrement.
Arethusa a écrit:Ducou forcement rien ne s'enregistre si je redémarre, je suis donc bloqué dans le resolv.conf que je n'arrive pas a quitter !
Et sur les post windows le \\192.168.1.112 ne fonctionne pas, je sais qu'il y a une histoire de samba pour ça, mais pas plus.
j'ai essayer de regarder pour passer en mode interface sur le debian, avec la commande startx, mais ça ne fonctionne pas.
j'ai donc fait : apt-get install kde
mais bien sur dans les dns, il ne risque pas d'y arriver.
Le truc c'est que j'ai des données à récupérer sur ce serveur.
Donc voila, je voudrai simplement récupérer les données de ce serveur qui a vocation à être supprimé.
J'imagine que j'ai bon sur pas mal de truc, mais je me sens con de ne pas arriver a quitter le resolv.conf !
Merci.

... oula... tout et n'importe quoi juste pour récupérer des données. Je ne vois pas le rapport entre le resolv.conf (les DNS) et le fait de vouloir récupérer des données. Ni KDE d'ailleurs, startx, etc... A part si tu veux installer des paquets peut-être..
Déjà, où sont tes données à récupérer ?
Ensuite plusieurs méthodes :
- livecd toutoulinux, puppylinux, ubuntu... tu le lances, il sait exploiter le format EXTx des disques, copier/coller sur le réseau ou sur un support USB.
- montage d'un lecteur réseau avec SMBMOUNT
- partage samba d'un répertoire

Que veux-tu faire ?
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8917
Inscription: 13 Mai 2003 17:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Re: Oulala du Linux ! Pas internet !

Message le 29 Fév 2012 00:53

Bonjour, de base je voulais passez en mode interface pour faciliter les manipulations, voir ce qui était partagé et autre.
D’où m'a volonté de le mettre sur internet, le seul problème étant les dns qui semble manqué dans le resolv.conf

Ce que je veux, c'est récupérer les données, mais personnes ne sais comment fonctionne ce serveur mise à part qu'il y a des données récup dessus, mais personnes ne sais trop quoi. (trop bien quand on arrive dans ce genre d'installation, en fait un ga est venu et a dit "bon le serveur linux ne vas plus, il vous fait un 2003", et a tout débranché, et est partie...).

Sinon, au pire je peut me débrouiller avec un autre ordinateur que je peut mettre dans le même réseau que se serveur, et en faisant un \\@ip ça fonctionne, le truc étant que quand j'étais sur place, aucun PC n'était dispo pour la manœuvre, vu que si je mets un PC sur la plage d’adresse du serveurs, celui ci perd l’accès internet et au autres ressources du "nouveau" réseau et nouveau serveur.

La ou c'est tordu c'est que si je mets le serveur linux sur la plage d'adresse du nouveau réseau, le partage ne fonctionne pas, autrement dit :

La le serveur et en (par exemple) 192.168.10.100, et ba si je mets un pc en 192.168.10.101, celui-ci peut accéder au serveur, MAIS, si je met le serveur en 192.168.1.100 et que je mets un pc en 192.168.1.101, ça ne fonctionne pas.
C'est comme si le partage ne fonctionnait que sur une plage d'adresse prédéfini.

A noter que le serveur ne sera plus utilisé par la suite.

Donc soit j'arrive à faire fonctionner le partage sur le 192.168.1.x, soit je viendrai avec un PC de chez moi que je métrais en 192.168.10.x pour récup les 150 Go de donnés (même si au final personne ne sais ce que c'est, mais ça c'est une autre histoire).

Sinon, effectivement, avec un CD live de linux et un DD externe en USB je devrai y arriver.


Au delà de tout ça, d'un point de vu personnel, si j'arrivais à configurer ce serveur en ligne de commande puis à y installer une interface graphique, je serai contant ^^

Merci pour ta réponse.
Arethusa
Expert(e)
Expert(e)
 
Messages: 1124
Inscription: 01 Nov 2007 23:47
 

Re: Oulala du Linux ! Pas internet !

Message le 29 Fév 2012 09:36

Donc on en revient déjà à la 1ere observation : quels sont ces fameux messages d'erreurs en console.
En 2 : CTRL+O et CTRL+X... as-tu essayé pour le resolv.conf ? Ca marche sans soucis même si les messages systèmes viennent perturber l'écran.

Autre chose et pas des moindres : WINSCP
C'est un client SSH graphique, un peu comme un client FTP, permettant de te connecter au serveur Linux distant et de copier/coller tout ce que tu veux dans le windows qui le lance. Simple non ?
Le seul impératif c'est que le serveur SSH soit installé sur le Linux :
Code: Tout sélectionner
apt-get install openssh-server

.. en console
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8917
Inscription: 13 Mai 2003 17:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Re: Oulala du Linux ! Pas internet !

Message le 02 Mar 2012 12:37

Bonjour, merci pour ton aide.

Je n'ai pas eu l'occasion d'y retournez cette semaine (malade).

Mais je ne manquerai pas de te tenir au courant.

Concernant les messages, il semblerai (de souvenir) que ce soit un flood d’adresse MAC.

Sinon, au delà des DNS, quand je change les IP, ça ne se sauvegarde pas, il doit y avoir une commande à faire après le
ifconfig eth0 192.168.1.111 netmask 255.255.255.0 pour que ça reste en mémoire ?

Merci, à bientôt.
Arethusa
Expert(e)
Expert(e)
 
Messages: 1124
Inscription: 01 Nov 2007 23:47
 

Re: Oulala du Linux ! Pas internet !

Message le 02 Mar 2012 12:48

Arethusa a écrit:Sinon, au delà des DNS, quand je change les IP, ça ne se sauvegarde pas, il doit y avoir une commande à faire après le ifconfig eth0 192.168.1.111 netmask 255.255.255.0 pour que ça reste en mémoire ?

Tu le fais en su (en root quoi) ?
Sinon tu peux changer la config directement en éditant le fichier /etc/network/interfaces;
Voici un exemple de syntaxe, adresse 192.168.1.30, passerelle 192.168.1.254 :
Code: Tout sélectionner
# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet static
        address 192.168.1.30
        netmask 255.255.255.0
        network 192.168.1.0
        broadcast 192.168.1.255
        gateway 192.168.1.254
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 80.10.246.2
        dns-search workgroup
auto eth0
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8917
Inscription: 13 Mai 2003 17:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Re: Oulala du Linux ! Pas internet !

Message le 02 Mar 2012 13:06

Bonjour, oui oui, j'étais bien en "root"

Mais le problème c'est que vu que j'étais bloqué dans ma conf de dns, je faisait un reset sur la tour....
Donc peut être normal que rien ne soit mémorisé, sinon, j'imagine qu'une foi mes IP configurée, la comamnde "reboot" ou "shutdown -r" m'aurai pas fait perdre mes réglages.

Sinon, le serveur faisait office de proxy à une époque, j'imagine que le flood viens de la.

Merci.
Arethusa
Expert(e)
Expert(e)
 
Messages: 1124
Inscription: 01 Nov 2007 23:47
 

Re: Oulala du Linux ! Pas internet !

Message le 02 Mar 2012 18:19

Arethusa a écrit:Mais le problème c'est que vu que j'étais bloqué dans ma conf de dns, je faisait un reset sur la tour....

... au lieu de CTRL+X comme je suggère.
Arethusa a écrit:Donc peut être normal que rien ne soit mémorisé, sinon, j'imagine qu'une foi mes IP configurée, la comamnde "reboot" ou "shutdown -r" m'aurai pas fait perdre mes réglages.

bien entendu..
Arethusa a écrit:Sinon, le serveur faisait office de proxy à une époque, j'imagine que le flood viens de la.

Je pense à un pare-feu configuré sur le serveur... les messages de blocages de trames sortent en console, les adresses MAC me font penser à ça.
Tu peux essayer de flusher les règles en console root pour voir si ça s'arrête : iptables -F
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8917
Inscription: 13 Mai 2003 17:32
Localisation: A.H.P... et jamais loin d'une Debian
 



Sujets similaires

Message Configuration bureautique + Internet sous Ubuntu (SSD ?)
Salut les gens.Merci Einstein pour la config. J'avoue qu'un i3 serait top, idem pour le SSD et la RAM de 6Go. Reste l'OS qui me fait ch***, vu que je le paye au prix fort, si c'est pour réinstaller dessus, intérêt relativement relatif et réduit sniff.Je vais continuer à creuser. D'autre part, ça n'e ...
Réponses: 43

Message tester sa ligne et debit internet
Salut tout le monde Voila je voudrait tester moi même le débit de ma ligne internet et je recherche le meilleur moyen logiciel ou site pour le faire pouvez vous s'il vous plait me conseiller , me renseigner ?
Réponses: 6

Message Linux + Windows = usure plus rapide du disque dur
Bonjour,mon ordi vient de tomber en panne ET le disque est mort. Il n'est pas lisible en le connectant dans un boitier externe. On m'a dit que c'était dû au fait d'avoir ces 2 systèmes en même temps qui usait plus le disque. J'aimerai savoir si c'est vrai pour mon prochain ordinateur.Merci de vos pa ...
Réponses: 6

Message Créer serveur sans connection internet
Bonjour,avec mon petit ami nous cherchons une solution pour nous faire un serveur Ark: Survivol Evolved mais sans connexion internet, nous ne l'avons pas dans l'appartement malgré nos essais (les opérateurs ne trouvent pas l'adresse). Nous jouons avec un MSI appache GE70 et un Asus ROG GL742WT, ce d ...
Réponses: 7

Message Vidéos internet en N&B sur secteur (Windows 10)
Bonjour,depuis quelques semaines, les vidéos internet sont en noir et blanc lorsque le PC et sur secteur mais sont bien en couleurs lorsque je le débranche.Si j'en crois les appels à l'aide sur internet, je ne suis pas le seul à avoir ce souci. Mais personne ne propose de solution (ou alors j'ai mal ...
Réponses: 1

Message pages internet qui s'ouvrent sans arret
salutquand je clique sur une pages internet plusieurs page s'ouvrent et mozilla me demande d'installer plusieurs module et la page et bloquécomment faire pour remédier a ca svp
Réponses: 6

Message Pages internet longues à s'ouvrir, pc lent
Bonjour à tous, J'ai un petit problème avec mon ordinateur portable. Il a quelques années déjà mais me sert encore beaucoup et j'espère le garder encore quelques temps. Les pages internet sont relativement longues à s'ouvrir, il ne s'agit pas d'un souci de connection, mes autres pc n'ont pas ce prob ...
Réponses: 7


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.