Il y a actuellement 47 visiteurs
Dimanche 25 Février 2018
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

Oulala du Linux ! Pas internet !

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

Oulala du Linux ! Pas internet !

Message le 24 Fév 2012 16:56

Bonjour,

Je suis dans un contexte très particulier dont je vous passerai les détails, mais voici la situation :

Un réseau avec 6 PC windows sur du 192.168.1.x/24 avec une livebox en 192.168.1.1 pour internet.

Il y a un vieux serveur linux debian qui démarre en mode commande.

J'ai le mdp root (pas chance), alors, mes connaissances en linux sont faible, mais je sais quand même configurer les IP

Il y a 2 cartes réseaux (le serveur faisait office de Proxy a une époque) donc j'ai fait :

ifconfig eth0 192.168.1.111 netmask 255.255.255.0
ifconfig eth1 192.168.1.112 netmask 255.255.255.0
route add default gw 192.168.1.1

Donc la le serveurs fonctionne sur eth1, et sur mes PC quand je ping 192.168.1.112, ça fonctionne.

Sur mon linux, quand je ping 192.168.1.1, ça fonctionne, donc je ping ma passerelle.

Pour les dns, j'ai essayé :

nano /etc/resolv.conf

une page apparait :

dans la quelle je met :

nameserver 80.10.246.2
nameserver 192.168.1.1
search orange.fr

Mais je n'arrive pas a quitter cette page, en plus il y'a tjr des ta de texte qui passe en boucle, se qui rends l'édition très pénible.
y'a bien "alt+x" pour quitter, mais ça ne fait rien, mise a part supprimer le flood incessant....
Ducou forcement rien ne s'enregistre si je redémarre, je suis donc bloqué dans le resolv.conf que je n'arrive pas a quitter !

Et sur les post windows le \\192.168.1.112 ne fonctionne pas, je sais qu'il y a une histoire de samba pour ça, mais pas plus.

j'ai essayer de regarder pour passer en mode interface sur le debian, avec la commande startx, mais ça ne fonctionne pas.
j'ai donc fait : apt-get install kde
mais bien sur dans les dns, il ne risque pas d'y arriver.

Le truc c'est que j'ai des données à récupérer sur ce serveur.

Donc voila, je voudrai simplement récupérer les données de ce serveur qui a vocation à être supprimé.

J'imagine que j'ai bon sur pas mal de truc, mais je me sens con de ne pas arriver a quitter le resolv.conf !

Merci.
Arethusa
Expert(e)
Expert(e)
 
Messages: 1122
Inscription: 01 Nov 2007 22:47
 


Re: Oulala du Linux ! Pas internet !

Message le 28 Fév 2012 10:14

Arethusa a écrit:Mais je n'arrive pas a quitter cette page, en plus il y'a tjr des ta de texte qui passe en boucle, se qui rends l'édition très pénible.

Surement des messages système indiquant un problème quelconque.... car sinon il n'y a jamais de perturbation en console.
Arethusa a écrit:y'a bien "alt+x" pour quitter, mais ça ne fait rien, mise a part supprimer le flood incessant....

C'est plutôt CTRL+O pour enregistrer et CTRL+X pour quitter. Les flood de message n'empêche absolument pas l'enregistrement.
Arethusa a écrit:Ducou forcement rien ne s'enregistre si je redémarre, je suis donc bloqué dans le resolv.conf que je n'arrive pas a quitter !
Et sur les post windows le \\192.168.1.112 ne fonctionne pas, je sais qu'il y a une histoire de samba pour ça, mais pas plus.
j'ai essayer de regarder pour passer en mode interface sur le debian, avec la commande startx, mais ça ne fonctionne pas.
j'ai donc fait : apt-get install kde
mais bien sur dans les dns, il ne risque pas d'y arriver.
Le truc c'est que j'ai des données à récupérer sur ce serveur.
Donc voila, je voudrai simplement récupérer les données de ce serveur qui a vocation à être supprimé.
J'imagine que j'ai bon sur pas mal de truc, mais je me sens con de ne pas arriver a quitter le resolv.conf !
Merci.

... oula... tout et n'importe quoi juste pour récupérer des données. Je ne vois pas le rapport entre le resolv.conf (les DNS) et le fait de vouloir récupérer des données. Ni KDE d'ailleurs, startx, etc... A part si tu veux installer des paquets peut-être..
Déjà, où sont tes données à récupérer ?
Ensuite plusieurs méthodes :
- livecd toutoulinux, puppylinux, ubuntu... tu le lances, il sait exploiter le format EXTx des disques, copier/coller sur le réseau ou sur un support USB.
- montage d'un lecteur réseau avec SMBMOUNT
- partage samba d'un répertoire

Que veux-tu faire ?
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8913
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Re: Oulala du Linux ! Pas internet !

Message le 28 Fév 2012 23:53

Bonjour, de base je voulais passez en mode interface pour faciliter les manipulations, voir ce qui était partagé et autre.
D’où m'a volonté de le mettre sur internet, le seul problème étant les dns qui semble manqué dans le resolv.conf

Ce que je veux, c'est récupérer les données, mais personnes ne sais comment fonctionne ce serveur mise à part qu'il y a des données récup dessus, mais personnes ne sais trop quoi. (trop bien quand on arrive dans ce genre d'installation, en fait un ga est venu et a dit "bon le serveur linux ne vas plus, il vous fait un 2003", et a tout débranché, et est partie...).

Sinon, au pire je peut me débrouiller avec un autre ordinateur que je peut mettre dans le même réseau que se serveur, et en faisant un \\@ip ça fonctionne, le truc étant que quand j'étais sur place, aucun PC n'était dispo pour la manœuvre, vu que si je mets un PC sur la plage d’adresse du serveurs, celui ci perd l’accès internet et au autres ressources du "nouveau" réseau et nouveau serveur.

La ou c'est tordu c'est que si je mets le serveur linux sur la plage d'adresse du nouveau réseau, le partage ne fonctionne pas, autrement dit :

La le serveur et en (par exemple) 192.168.10.100, et ba si je mets un pc en 192.168.10.101, celui-ci peut accéder au serveur, MAIS, si je met le serveur en 192.168.1.100 et que je mets un pc en 192.168.1.101, ça ne fonctionne pas.
C'est comme si le partage ne fonctionnait que sur une plage d'adresse prédéfini.

A noter que le serveur ne sera plus utilisé par la suite.

Donc soit j'arrive à faire fonctionner le partage sur le 192.168.1.x, soit je viendrai avec un PC de chez moi que je métrais en 192.168.10.x pour récup les 150 Go de donnés (même si au final personne ne sais ce que c'est, mais ça c'est une autre histoire).

Sinon, effectivement, avec un CD live de linux et un DD externe en USB je devrai y arriver.


Au delà de tout ça, d'un point de vu personnel, si j'arrivais à configurer ce serveur en ligne de commande puis à y installer une interface graphique, je serai contant ^^

Merci pour ta réponse.
Arethusa
Expert(e)
Expert(e)
 
Messages: 1122
Inscription: 01 Nov 2007 22:47
 

Re: Oulala du Linux ! Pas internet !

Message le 29 Fév 2012 08:36

Donc on en revient déjà à la 1ere observation : quels sont ces fameux messages d'erreurs en console.
En 2 : CTRL+O et CTRL+X... as-tu essayé pour le resolv.conf ? Ca marche sans soucis même si les messages systèmes viennent perturber l'écran.

Autre chose et pas des moindres : WINSCP
C'est un client SSH graphique, un peu comme un client FTP, permettant de te connecter au serveur Linux distant et de copier/coller tout ce que tu veux dans le windows qui le lance. Simple non ?
Le seul impératif c'est que le serveur SSH soit installé sur le Linux :
Code: Tout sélectionner
apt-get install openssh-server

.. en console
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8913
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Re: Oulala du Linux ! Pas internet !

Message le 02 Mar 2012 11:37

Bonjour, merci pour ton aide.

Je n'ai pas eu l'occasion d'y retournez cette semaine (malade).

Mais je ne manquerai pas de te tenir au courant.

Concernant les messages, il semblerai (de souvenir) que ce soit un flood d’adresse MAC.

Sinon, au delà des DNS, quand je change les IP, ça ne se sauvegarde pas, il doit y avoir une commande à faire après le
ifconfig eth0 192.168.1.111 netmask 255.255.255.0 pour que ça reste en mémoire ?

Merci, à bientôt.
Arethusa
Expert(e)
Expert(e)
 
Messages: 1122
Inscription: 01 Nov 2007 22:47
 

Re: Oulala du Linux ! Pas internet !

Message le 02 Mar 2012 11:48

Arethusa a écrit:Sinon, au delà des DNS, quand je change les IP, ça ne se sauvegarde pas, il doit y avoir une commande à faire après le ifconfig eth0 192.168.1.111 netmask 255.255.255.0 pour que ça reste en mémoire ?

Tu le fais en su (en root quoi) ?
Sinon tu peux changer la config directement en éditant le fichier /etc/network/interfaces;
Voici un exemple de syntaxe, adresse 192.168.1.30, passerelle 192.168.1.254 :
Code: Tout sélectionner
# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet static
        address 192.168.1.30
        netmask 255.255.255.0
        network 192.168.1.0
        broadcast 192.168.1.255
        gateway 192.168.1.254
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 80.10.246.2
        dns-search workgroup
auto eth0
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8913
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Re: Oulala du Linux ! Pas internet !

Message le 02 Mar 2012 12:06

Bonjour, oui oui, j'étais bien en "root"

Mais le problème c'est que vu que j'étais bloqué dans ma conf de dns, je faisait un reset sur la tour....
Donc peut être normal que rien ne soit mémorisé, sinon, j'imagine qu'une foi mes IP configurée, la comamnde "reboot" ou "shutdown -r" m'aurai pas fait perdre mes réglages.

Sinon, le serveur faisait office de proxy à une époque, j'imagine que le flood viens de la.

Merci.
Arethusa
Expert(e)
Expert(e)
 
Messages: 1122
Inscription: 01 Nov 2007 22:47
 

Re: Oulala du Linux ! Pas internet !

Message le 02 Mar 2012 17:19

Arethusa a écrit:Mais le problème c'est que vu que j'étais bloqué dans ma conf de dns, je faisait un reset sur la tour....

... au lieu de CTRL+X comme je suggère.
Arethusa a écrit:Donc peut être normal que rien ne soit mémorisé, sinon, j'imagine qu'une foi mes IP configurée, la comamnde "reboot" ou "shutdown -r" m'aurai pas fait perdre mes réglages.

bien entendu..
Arethusa a écrit:Sinon, le serveur faisait office de proxy à une époque, j'imagine que le flood viens de la.

Je pense à un pare-feu configuré sur le serveur... les messages de blocages de trames sortent en console, les adresses MAC me font penser à ça.
Tu peux essayer de flusher les règles en console root pour voir si ça s'arrête : iptables -F
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8913
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 



Sujets similaires

Message o dans e sous linux
salutj'ai un souci je voudrais écrire oeil avec le e dans le o mais je n'y arrive pas, tout ce que j'ai pu trouver sur le net, ne fonctionne pas, par ex alt gr plus le o, ou alt gr maj plus o . merci
Réponses: 0

Message Le pc HP de mes parents à une connexion internet quasinexist
Bonjour à tous.Mes parents ont acheté en janvier un pc HP équipé de Windows 10. Habitant dans le Jura dans un village, la connexion est loin d être rapide mais fin janvier une page sur est affiche leur disant que leur pc était infesté et qu il devaient appeler un numéro de téléphone. Et évidement i ...
Réponses: 13

Message lenteur et probleme avec certains sites internet
Bonjour,ça faisait un moment que j'etais passsé vous voir et en fait c'etait bon signe car ça voulait dire que je pouvais me debrouiller tout seul et que je n'avais pas trop de probleme!! mais depuis un petit moment je me pose des questions concernant l'etat de mon ordi, en fait il est de plus en pl ...
Réponses: 33

Message Ordi connecté à box, mais box non connectée à internet
Bonjour tout le monde.Comme souvent, ça fait un petit moment que je ne suis pas revenu sur le forum. J'avoue que j'y viens surtout quand j'ai un problème malheureusement, comme beaucoup de monde je pense.D'ailleurs pour le coup, je n'ai plus vraiment de problème, mais j'en ai eu un, et comme je suis ...
Réponses: 7

Message [Réglé] tous mes navigateurs internet ne fonctionnent plus
Tout d'abord bonsoir à tous!!!Depuis ce matin le pc de Madame ne veut plus surfer sur le net, j'envoie ce message, je précise que j'ai bien le net à la maison.J'ai essayé firefox, google chrome, maxthon mais ça rame et n'aboutit pasc'est un acer aspire 5720Zintel(R) pentium(R) dual cpu T2310 @ 1.46G ...
Réponses: 22

Message double connexion internet
bonjour ,je voulais savoir s'il y a un interet et si c'est possible de se connecter en wifi free+ 4G sosh ou wififree + cpl freecordialement le but etant d'avoir une meilleur connexion internet ….
Réponses: 1

Message Radio Internet
Bonjour,Une radio sur Ubuntu si vous en connaissez une bonne je suis preneur.Merci d'avance
Réponses: 4


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 6 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.