Il y a actuellement 98 visiteurs
Samedi 16 Décembre 2017
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

probleme grub et ubuntu

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

probleme grub et ubuntu

Message le 06 Oct 2008 18:26

bonjour à tous

j'ai un gros soucis : j'ai installé ubuntu avec le grub après windows xp sur une deuxieme partition de mon disque dur...le probleme est que quand je redemarre cela me marque "systeme d'exploitation manquant".si je regarde avec un logiciel adéquate j'ai bien ma partition xp et mes partitions linux...
de plus j'ai installer ubuntu il y a deux ans exactement de la meme façon et ça marché impec, j'ai donc retelécharger ubuntu et réinstaller: toujours pareil
la différence avec il ya deux ans c'est que j'ai changer de carte mère pour passer au core deux duo et que mon xp est en service pack 3...
le probleme vient-il de mon disque dur, voir de la MBR(j'ai un raptor WD SATA 74 GO)?

merci d'avance
pithut
Visiteur Confirmé
Visiteur Confirmé
 
Messages: 25
Inscription: 06 Oct 2008 18:14
 


Message le 06 Oct 2008 18:32

Bonjour.

Le problème est que ta partition Windows n'est pas bootable.

Tu repars en liveCd et tu vas dans Gparted.

Là, tu regardes les drapeaux de ta partition Windows et tu coches la ligne boot:


Image

Tu redémarres.
"Sois un AtOM, mon fils." RIP l'ami Ask To Old Man → 1948 - 2012
En cas de problème constaté sur un sujet, contactez un modérateur par MP svp. N'intervenez pas vous-même. Merci bien.
Avatar de l'utilisateur
r@in | b0w
PC-Infopraticien
PC-Infopraticien
 
Messages: 7687
Inscription: 09 Déc 2007 12:37
Localisation: Sur un Vostro tout propre
 

Message le 06 Oct 2008 19:56

mais justement j'arrive à booter sur xp : je lance un fdisk et j'ai la partition linux active, je change et j'active la partition xp et là xp démarre...
pithut
Visiteur Confirmé
Visiteur Confirmé
 
Messages: 25
Inscription: 06 Oct 2008 18:14
 

Message le 06 Oct 2008 20:01

Bonsoir,

Ton premier message n'est pas assez clair. Avec ta 2eme réponse voici ce que je comprends, à toi de me dire si c'est ça ou de tout mieux nous expliquer si c'est pas ça:

Tu arrive à démarrer sous nunux mais pas sous XP. Lorsque tu veux démarrer sous XP tu es obligé d'activer la partition XP et de mettre l'autre en inactive ? C'est ça ? :o Donc en gros ton grub n'est pas ou mal installé ?
Avatar de l'utilisateur
Grego
Expert(e)
Expert(e)
 
Messages: 1330
Inscription: 07 Oct 2005 15:40
 

Re: probleme grub et ubuntu

Message le 06 Oct 2008 20:03

pithut a écrit:le probleme est que quand je redemarre cela me marque "systeme d'exploitation manquant"


Comme dit Grego, ce n'est pas clair.

Après, si c'est juste ce qu'il explicite, tu rajoutes une entrée dans Grub pour avoir deux choix au lancement de Grub, il n'est pas mal installé mais plutôt mal configuré.
"Sois un AtOM, mon fils." RIP l'ami Ask To Old Man → 1948 - 2012
En cas de problème constaté sur un sujet, contactez un modérateur par MP svp. N'intervenez pas vous-même. Merci bien.
Avatar de l'utilisateur
r@in | b0w
PC-Infopraticien
PC-Infopraticien
 
Messages: 7687
Inscription: 09 Déc 2007 12:37
Localisation: Sur un Vostro tout propre
 

Message le 06 Oct 2008 20:19

je recommence j'ai xp sp3 sur ma machine,je veu installer ubuntu donc j'insere le cd, le menu d'install aparait puis après un petit moment j'arrive au partitionnement donc la j'installe ubuntu sur l'espace libre restant sur mon disque dur, puis j'installe le systeme (en boot sans option tout se fait a la suite...)...ect...j'arrive à l'install du grub...il s'installe normalement puis fin de l'installation de ubuntu: le cd s'ouvre je retire mon cd...le systeme redemarre puis après que le bios est pris la main j'ai :"systeme d'exploitation manquant" et ce meme si je redemarre.comme dans ce cas mon pc est inutilisable et que j'ai une astuce je met un cd de windows 98 SE dans la bécane je démarre pour avoir l'invite de commande et lancer un FDISK pour regarder l'état de mes partition j'ai la partition linux active et pas celle de windows donc j'active ma partition windows et donc celle de linux se désactive...je redemarre et la je boot sur xp (pas de grub donc) j'ai essayer au moins 10 fois et sa ce passe toujours comme j'ai décris...
est-ce que c'est plus clai?
merci de m'aider URGENT SVP en vous remerciant d'avance
pithut
Visiteur Confirmé
Visiteur Confirmé
 
Messages: 25
Inscription: 06 Oct 2008 18:14
 

Message le 06 Oct 2008 20:25

pithut a écrit:le systeme redemarre puis après que le bios est pris la main

Le BIOS ou le GRUB ?
Ce qu'on essaye de savoir c'est si ton démmarage arrive jusqu'au Grub ou pas déjà .
Avatar de l'utilisateur
Grego
Expert(e)
Expert(e)
 
Messages: 1330
Inscription: 07 Oct 2005 15:40
 

Message le 06 Oct 2008 20:28

je n'ai pas le GRUB:après que le bios passe la main a mon DD j'ai "systeme d'exploitation manquant"
pithut
Visiteur Confirmé
Visiteur Confirmé
 
Messages: 25
Inscription: 06 Oct 2008 18:14
 

Message le 06 Oct 2008 20:36

oki, donc regarde par là, normalement bootpart est ton ami
http://linux.jpvweb.com/mesrecetteslinu ... ot_windows

Tiens nous au courant ;)
Avatar de l'utilisateur
Grego
Expert(e)
Expert(e)
 
Messages: 1330
Inscription: 07 Oct 2005 15:40
 

Message le 06 Oct 2008 20:44

ok merci,je vais pouvoir me débrouiller avec ça...je vous tiens au courant...
pithut
Visiteur Confirmé
Visiteur Confirmé
 
Messages: 25
Inscription: 06 Oct 2008 18:14
 

Message le 06 Oct 2008 21:10

Re.

Alors, maintenant c'est plus clair.

Tu as flingué le MBR de Windows et ta machine semble être OEM, cad de marque (Acer, Packard-Bell pour garder le gratin).

Tu as fait une sauvegarde de ce MBR avant?

Sinon, rien à faire.

Le verdict est clair.

Tu peux récupérer tes dossiers Windows via Linux et réinstaller Windows, tu ne pourras rien faire d'autre.

Et, lors de ta prochaine migration, tu t'appuieras sur ce guide pour réaliser ta migration sans soucis.

La chose à retenir est qu'il faut installer le Grub sur la partition Linux et ensuite modifier le BOOT.INI de Windows sinon, sans cela, ta partition Windows est perdu.

Cela m'est arrivé, je sais de quoi je parle.
"Sois un AtOM, mon fils." RIP l'ami Ask To Old Man → 1948 - 2012
En cas de problème constaté sur un sujet, contactez un modérateur par MP svp. N'intervenez pas vous-même. Merci bien.
Avatar de l'utilisateur
r@in | b0w
PC-Infopraticien
PC-Infopraticien
 
Messages: 7687
Inscription: 09 Déc 2007 12:37
Localisation: Sur un Vostro tout propre
 

Message le 06 Oct 2008 21:20

r@in | b0w a écrit:Tu as fait une sauvegarde de ce MBR avant?
Sinon, rien à faire.

Le verdict est clair.
.

Au pire de toute façon sur un Mbr foireux il pourra toujours faire un fix mbr sous windows ...
Mais bon là il n'y a que la partition windows le pc démarre dessus donc c'est que le mbr n'est pas si mort que ça non ?
Avatar de l'utilisateur
Grego
Expert(e)
Expert(e)
 
Messages: 1330
Inscription: 07 Oct 2005 15:40
 

Message le 06 Oct 2008 21:37

Rien à voir ;)

On est, je pense, dans le cas d'une machine OEM.

Par nature, ces machines ne sont pas équipées d'un CD de Windows XP.

Alors, peut-être que je m'avance mais je suis quasiment sûr qu'on ne peut pas le récupérer.

C'est un MBR codé fait pour brider la machine.

S'il est touché, système d'exploitation manquant.

Si la partition Windows est bootable (et seulement la partition Windows) et que cela donne ce message d'erreur, c'est foutu.

A lire, ma migration et plus spécifiquement, le fameux missing operating system.
"Sois un AtOM, mon fils." RIP l'ami Ask To Old Man → 1948 - 2012
En cas de problème constaté sur un sujet, contactez un modérateur par MP svp. N'intervenez pas vous-même. Merci bien.
Avatar de l'utilisateur
r@in | b0w
PC-Infopraticien
PC-Infopraticien
 
Messages: 7687
Inscription: 09 Déc 2007 12:37
Localisation: Sur un Vostro tout propre
 

Message le 06 Oct 2008 22:52

:lol: :lol:
r@in | b0w a écrit:Tu as flingué le MBR de Windows et ta machine semble être OEM, cad de marque (Acer, Packard-Bell pour garder le gratin).
Dois-je croire que tu as pensé à certains d'entre-nous en écrivant ça...??
Le "Gotha" du PC OEM... ...V'la qu'l'arc-en-ciel me pètes un délire à la Papy
:lol: :lol:

Désolé du H/S pithut :wink:
A+,
AtOM.
Le PC c'est comme la lune,il y a une face cachée.Eclairons-la!!!!
__________________
Avatar de l'utilisateur
Ask to Old Man
Moderateur
Moderateur
 
Messages: 19970
Inscription: 14 Mar 2004 10:06
Localisation: Argenteuil,Val d'Oise
 

Message le 06 Oct 2008 23:12

Je garde ton expression Pb le maudit, ça claque :lol:
"Sois un AtOM, mon fils." RIP l'ami Ask To Old Man → 1948 - 2012
En cas de problème constaté sur un sujet, contactez un modérateur par MP svp. N'intervenez pas vous-même. Merci bien.
Avatar de l'utilisateur
r@in | b0w
PC-Infopraticien
PC-Infopraticien
 
Messages: 7687
Inscription: 09 Déc 2007 12:37
Localisation: Sur un Vostro tout propre
 

Suivante


Sujets similaires

Message Problème :Chutes de FPS périodique
Bonjour à tous,Je me permets d?écrire ici car je rencontre un problème sur mon pc gamer.Voici mon problème :Lorsque je suis sur mon simulateur de vol x-plane 11, j'ai des chutes de FPS momentanément pour une durée d'environ de 4 secondes, c'est à dire pendant 1 minutes ou 2 je suis à 50 FPS, et d'un ...
Réponses: 8

Message Problème de déconnection intempestive de la wifi
Bonjour à tous,Tout d'abord je suis un Macuser pro au travail mais pas la force des choses, j'ai un pc Asus tournant sous Windows 10 à la maison....donc connaissance hyper basique.....Depuis certaines mise à jour de Windows, j'ai des déconnections intempestives de la wifi sur mon ordi.....et cela de ...
Réponses: 3

Message [Résolu] Problème après mise à jour
Bonjour, je suis sous Windows 7 pro, et je viens d'avoir ce message lorsque les mises à jour ont été effectuées "Windows ne peut pas mettre à jour des fichiers et services importants tant que le système les utilise. Sauvegardez vos fichiers avant de redémarrer". J'ai donc fait une analys ...
Réponses: 5

Message problème de fonts
Bonjour, je fais mon site sous ubuntu et firefox et il semble que mon gedit ne prend en compte que très peu de polices de caractère dans mon css. Pour l'heure seuls monospace serif et sans serif ont fonctionné. Je n'ai pas cursive, fantasy, et encore moins verdana. Pourtant j'ai vérifié avec gnome s ...
Réponses: 3

Message lenteur et probleme avec certains sites internet
Bonjour,ça faisait un moment que j'etais passsé vous voir et en fait c'etait bon signe car ça voulait dire que je pouvais me debrouiller tout seul et que je n'avais pas trop de probleme!! mais depuis un petit moment je me pose des questions concernant l'etat de mon ordi, en fait il est de plus en pl ...
Réponses: 7

Message problème indéfini disque dur externe seagate
Bonjour, j'ai acheté un disque dur externe Seagate Back up slim. J'ai installé le logiciel en passant par le lien enregistré sur le logiciel. C'est extrêmement simple en apparence: l'installation se passe bien, je reçois un mail comme quoi je suis bien inscrite mais quand j'essaie d'ouvrir le logici ...
Réponses: 1

Message Problème démarrage d'écran.
Bonsoir,Lorsque j'allume mon pc de bureau, mes écrans restent noir malgré qu'ils fonctionnent quand même.Ma config :Alim lepa 550wram 2x4go ddr3i5 3ghzEcrans de 60 hertz.Carte graphique : gigabyte GeForce 1050 TiJ'ai fait plusieurs test :- Tester les écrans sur un autre pc, ils fonctionnent.- Tester ...
Réponses: 8


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 4 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.