Il y a actuellement 83 visiteurs
Jeudi 22 Février 2018
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

Problème install pilote nvidia Suse pour xgl

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

Problème install pilote nvidia Suse pour xgl

Message le 04 Mar 2008 00:21

Bonjour à tous,

Je suis niveau débutant sur Linux, j'ai installé une OpenSuse 10.2
version 2.6.18.2-34-defaut, j'ai compilé les sources en installant le kermel.

Je souhaite installé xgl, car ça me rendrant bien service en tout que déficient visuel,
Je n'est pas eu encore l'occasion de testé cette inovation technologique.

Ma machine à les caractéristiques :
Packard bell EsyNote SB85-P038W
Processeur Intel Cor Duo 2Ghz
Disque dure SATA 160 Go
Carte Graphique : Nvidia GeForce 6800 m GS
Mémoire vive : 2 GO

Le problème qui se pose, c'est quand je veux installer le pilote de la nvidia.

Déjà ce que je ne comprend pas, c'est que je trouve la référence de ma carte graphique, dans la version OpenSuse 10.1,
alors que moi, j'ai une Suse 10.2. Quel procédrue je dois suivre l'install Opensuse 10.1 ou 10.2?

Je me base sur les recommandations du site Nvidia
http://www.nvidia.fr/object/linux_ [...] 12_fr.html

Et les instructions particulières pour Nvidia Suse
http://www.suse.de/~sndirsch/nvidi [...] HOWTO.html

Donc je suis la procédure j'ajoute le nouveau dépôt avec Yast, en cliquant sur changer le support de l'installation,
ça télécharge bien le pilote, mais quand je veux l'installer.

Je fait rechercher x11-video-nvidiaG01, Yast le trouve bien je coche la case pour l'installer,
ensuite la licence de Nvidia qui s'affiche,
et quand je fait accepter pour installer, j'ai ce message d'erreur qui s'affiche :

********************************************************************
Impossible d'installer x11-video-nvidiaG01-1-0-9755-1.i586[20080302060304]
Aucun fournisseur de nvidia-gfxG01-kmp définissable pour x11-video-nvidiaG01-1-0-9755-1.i586[20080302060304]

Résolution du conflit :
- Ne pas installer x11-video-nvidiaG01
- Ignorer cette exigence cette fois uniquement
***********************************************************************************

Donc voilà je suis bloquer à cette étape qu'est le problème ? Faudrait-il que je l'install manuellement, ce pilote?
Quelle est la solution adaptée?

Est ce que vous pouvez m'aider ça serai vraiment sympa, je bloc depuis ce week-end dessus.

Je vous remercie pour l'aide que vous aller m'apporter

dav79
dav79
Visiteur
Visiteur
 
Messages: 2
Inscription: 03 Mar 2008 21:45
 


Message le 29 Mar 2008 17:52

Bonjour à tous,

je relance sur le sujet, que j'avais posté il y a quelque temps, je n'ai toujours pas trouvé de mon compté de solution, le compte sur vous, pour que vous m'aidier à trouver mon problème avec l'installation de Xgl avec une carte Nividai sur Opensuse.
Je pense que certainement quelqu'un à déjà eu ce problème, je compte sur votre générosité.

Merci d'avance

dav79
dav79
Visiteur
Visiteur
 
Messages: 2
Inscription: 03 Mar 2008 21:45
 

Message le 30 Mar 2008 13:36

Si tu veux tenter une installation manuelle tu peux. Pour ce faire, il faut suivre à peu près ce principe :
- démarrer le PC, télécharger le driver NVIDIA et le mettre dans ton home par exemple (/home/ton_login). C'est un fichier du style NVIDIA-bla-bla-version.sh
- revenir sur la fenêtre de connexion (se déconnecter)
- basculer sur la première console par ALT+CTRL+F1 et se loguer en root
- tuer le gestionnaire de connexion en faisant un killall kdm (il me semble que c'est kdm sur Suse, sinon killall gdm)
- sauvegarder le fichier xorg.conf par sécurité, en tapant :
cp /etc/X11/xorg.conf /etc/X11/xorg.conf.sauve
- rendre le driver nvidia exécutable par un chmod 744 et lancer l'installation en tapant :
chmod 744 /home/ton_login/NVIDIA-bla-bla.sh
/home/ton_login/NVIDIA-bla-bla.sh

- sur l'installation, si tout se passe correctement, il faut accepter la licence, ne pas chercher de driver précompilé sur le net, compiler ton propre driver, faire la modification automatique du fichier xorg.conf
- si tout s'est passé correctement, tu relances le gestionnaire par kdm

Si qqchose foire tu peux avoir le détail dans un fichier de log sur /var/log/nvidia-installer.log. Quoi qu'il en soit, il faut des paquets pour pouvoir faire la compilation, notamment les kernel-headers, build-essentials et gcc. Mais comme tu as compilé ton kernel il devrait déjà y avoir tout ça sur ton système.
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8913
Inscription: 13 Mai 2003 16:32
Localisation: A.H.P... et jamais loin d'une Debian
 



Sujets similaires

Message Problème casque commande vocale f1 2017
Bonjour je voudrais de l'aide, car j'ai un problème avec mon casque steelseries arctis 5 car dans le jeux f1 2017, quand je veut utilisé la commande vocal pour demander des infos à mon ingénieur, ça marche pas alors que le micro marche parfaitement avec Skype, discord et même cordana, alors je voudr ...
Réponses: 0

Message Problème installation W10
Bonsoir , je rencontre un soucis avec l'installation à zéro de windows 10 profesionel x64.J'ai bien flasher la clé avec l'iso officiel et l'installation se déroule bien sauf que à la fin de l'installation , il me dit que le pc doit redémarrer quand il redémarre je retombe sur la même page d'installa ...
Réponses: 1

Message Problème au démarrage BOOTMGR absent
Bonjour , As tu les Masters CD de restauration que tu n'as certainement pas oublié de créer lors de l'achat du PC ?Sinon il te faut un CD Bootable de seven pour réparer ton démarrage.Voici un tuto pris sur PCastuces , ça m'évite d'en faire un .Pour le Seven tu choisis le même que celui qui est dans ...
Réponses: 4

Message Problème sortie de veille via souris
Bonjour,Par moment , mon PC ne sort plus du mode veille lorsque je bouge la souris.Je suis obligé d'appuyer sur le bouton power de ma tour , cependant même en appuyant sur ce bouton , le pc ne sort pas de ce mode et je suis obligé de couper l'alimentation du PC via l'interrupteur de l'alim.Je pense ...
Réponses: 4

Message Problème avec un compte windows
Bonjour,Je suis sous windows 10.J'ai un compte au démarrage de mon ordinateur, sans mot de passe.Depuis quelques jours, l'ordinateur se lance de manière différente, passant par des messages qui semblent être sous dos; puis il lance le compte (appelé Tomy), et me dit ensuite qu'il ne parvient pas à s ...
Réponses: 1

Message Disque Dur 100% utilisé problème
Bonjour à tous,Voilà j'ai un soucis , mon ordinateur m'affiche souvent que tel ou tel logiciel ne répond pas , après quelques recherches , ce serait mon disque dur , en effet il sature souvent et atteins les 100% d'utilisation très rapidement , il a également un temps de réponse long , parfois entre ...
Réponses: 8

Message Problème Roccat Leadr
Bonjour à tous ,j'ai un soucis avec ma souris sans fil roccat leadr commandée depuis peu.lorsqu'on mets la souris sur son socle puis qu'on la reprends il n'y a plus de connexion entre la socle et la souris , je suis obligé de débrancher et rebrancher le socle pour que cela fonctionne.J'ai contacté l ...
Réponses: 2


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité


.: Nous contacter :: Flux RSS :: Données personnelles :.