Il y a actuellement 98 visiteurs
Lundi 24 Septembre 2018
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

Problème install pilote nvidia Suse pour xgl

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

Problème install pilote nvidia Suse pour xgl

Message le 04 Mar 2008 01:21

Bonjour à tous,

Je suis niveau débutant sur Linux, j'ai installé une OpenSuse 10.2
version 2.6.18.2-34-defaut, j'ai compilé les sources en installant le kermel.

Je souhaite installé xgl, car ça me rendrant bien service en tout que déficient visuel,
Je n'est pas eu encore l'occasion de testé cette inovation technologique.

Ma machine à les caractéristiques :
Packard bell EsyNote SB85-P038W
Processeur Intel Cor Duo 2Ghz
Disque dure SATA 160 Go
Carte Graphique : Nvidia GeForce 6800 m GS
Mémoire vive : 2 GO

Le problème qui se pose, c'est quand je veux installer le pilote de la nvidia.

Déjà ce que je ne comprend pas, c'est que je trouve la référence de ma carte graphique, dans la version OpenSuse 10.1,
alors que moi, j'ai une Suse 10.2. Quel procédrue je dois suivre l'install Opensuse 10.1 ou 10.2?

Je me base sur les recommandations du site Nvidia
http://www.nvidia.fr/object/linux_ [...] 12_fr.html

Et les instructions particulières pour Nvidia Suse
http://www.suse.de/~sndirsch/nvidi [...] HOWTO.html

Donc je suis la procédure j'ajoute le nouveau dépôt avec Yast, en cliquant sur changer le support de l'installation,
ça télécharge bien le pilote, mais quand je veux l'installer.

Je fait rechercher x11-video-nvidiaG01, Yast le trouve bien je coche la case pour l'installer,
ensuite la licence de Nvidia qui s'affiche,
et quand je fait accepter pour installer, j'ai ce message d'erreur qui s'affiche :

********************************************************************
Impossible d'installer x11-video-nvidiaG01-1-0-9755-1.i586[20080302060304]
Aucun fournisseur de nvidia-gfxG01-kmp définissable pour x11-video-nvidiaG01-1-0-9755-1.i586[20080302060304]

Résolution du conflit :
- Ne pas installer x11-video-nvidiaG01
- Ignorer cette exigence cette fois uniquement
***********************************************************************************

Donc voilà je suis bloquer à cette étape qu'est le problème ? Faudrait-il que je l'install manuellement, ce pilote?
Quelle est la solution adaptée?

Est ce que vous pouvez m'aider ça serai vraiment sympa, je bloc depuis ce week-end dessus.

Je vous remercie pour l'aide que vous aller m'apporter

dav79
dav79
Visiteur
Visiteur
 
Messages: 2
Inscription: 03 Mar 2008 22:45
 


Message le 29 Mar 2008 18:52

Bonjour à tous,

je relance sur le sujet, que j'avais posté il y a quelque temps, je n'ai toujours pas trouvé de mon compté de solution, le compte sur vous, pour que vous m'aidier à trouver mon problème avec l'installation de Xgl avec une carte Nividai sur Opensuse.
Je pense que certainement quelqu'un à déjà eu ce problème, je compte sur votre générosité.

Merci d'avance

dav79
dav79
Visiteur
Visiteur
 
Messages: 2
Inscription: 03 Mar 2008 22:45
 

Message le 30 Mar 2008 14:36

Si tu veux tenter une installation manuelle tu peux. Pour ce faire, il faut suivre à peu près ce principe :
- démarrer le PC, télécharger le driver NVIDIA et le mettre dans ton home par exemple (/home/ton_login). C'est un fichier du style NVIDIA-bla-bla-version.sh
- revenir sur la fenêtre de connexion (se déconnecter)
- basculer sur la première console par ALT+CTRL+F1 et se loguer en root
- tuer le gestionnaire de connexion en faisant un killall kdm (il me semble que c'est kdm sur Suse, sinon killall gdm)
- sauvegarder le fichier xorg.conf par sécurité, en tapant :
cp /etc/X11/xorg.conf /etc/X11/xorg.conf.sauve
- rendre le driver nvidia exécutable par un chmod 744 et lancer l'installation en tapant :
chmod 744 /home/ton_login/NVIDIA-bla-bla.sh
/home/ton_login/NVIDIA-bla-bla.sh

- sur l'installation, si tout se passe correctement, il faut accepter la licence, ne pas chercher de driver précompilé sur le net, compiler ton propre driver, faire la modification automatique du fichier xorg.conf
- si tout s'est passé correctement, tu relances le gestionnaire par kdm

Si qqchose foire tu peux avoir le détail dans un fichier de log sur /var/log/nvidia-installer.log. Quoi qu'il en soit, il faut des paquets pour pouvoir faire la compilation, notamment les kernel-headers, build-essentials et gcc. Mais comme tu as compilé ton kernel il devrait déjà y avoir tout ça sur ton système.
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8917
Inscription: 13 Mai 2003 17:32
Localisation: A.H.P... et jamais loin d'une Debian
 



Sujets similaires

Message Problème avec chats vocaux (débit ascendant insuffisant ?)
Salut à tous,Je rencontre depuis plusieurs semaines un problème qui me dépasse complètement et que je n'arrive pas du tout à comprendre. Mon problème est simple : je n'arrive plus à communiquer par chat vocal que ce soit sur Discord, Steam ou Skype. Mon ordinateur est un MSI GE70 (ordi portable) de ...
Réponses: 4

Message probleme avec Nvidia Geforce experience
Bonjour,Alors voila je viens de changer ma carte graphique j'avais une gtx 770 et maintenant j'ai installer une 1080.Le problème c'est quand je vais dans Nvidia expérience pour optimiser mes jeux bin le logiciel garde les optimisations de mon ancienne carte graphique.Voila si quelqu'un peut m'aider. ...
Réponses: 5

Message Plantage CG NVIDIA
Bonjour à tous,Je viens vers vous car mon PC est agé, mais comme ce n'est pas un portable, on peut changer les composants. Dont acte, avec l'ajout de RAM récemmnent, et en outre, j'ai acheté une CG NVIDIA GTX 960, car mon ancienne a grillé.Au final, j'ai un truc comme ça :Operating System Windows 7 ...
Réponses: 34

Message [Résolu] problème avec le groupe résidentiel
Bonjour,J'ai créée un réseau avec 4 pc sous Windows 10 dans un groupe résidentiel mais est-ce normal de pouvoir accéder uniquement du premier pc qui m'a permis de créer le groupe mais pas de le voir sur les autres pc ?Dans la partie "réseau", je ne vois que les "périphériques médias& ...
Réponses: 30

Message Problème lors d'une recherche pour gmail sur mozzilla
Salut à tous, j'ai fait l'acquisition d'un pc tout en 1 hp pavillon 24, et depuis maintenant 1 mois j'ai un souci, lorsque je suis sur un onglet, j'en créer un nouveau (j'utilise mozzilla) je tape dans la barre de recherche gmail, j'ai de suite un lien qui me sort sans arrêt en premier gmail.net des ...
Réponses: 20

Message Problème Moniteur ou carte graphique
Bonjour les amis, j?espère que vous allez bien .Je reviens vers vous , car je rencontre un problème qui est plutôt handicapant.Voyez par vous même :( J?aurais voulu savoir si cela peut être réparé, sinon comment corriger cela ou bien encore . Comment localiser la source du problème (moniteur/carte g ...
Réponses: 1

Message [Réglé] pilote pour CLV-S-NESY
bonjourje recherche le pilote pour une nintendo classic mini : CLV-S-NESYou puis-je trouver ce pilote et le telechargermerci d'avance pour vos reponsescdt
Réponses: 13


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 4 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.