Il y a actuellement 103 visiteurs
Lundi 24 Septembre 2018
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

[résolu] Commande Rsync pour sauvegarder sur le réseau

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

[résolu] Commande Rsync pour sauvegarder sur le réseau

Message le 14 Mai 2008 10:19

Salut tout le monde !

Je voudrais synchroniser le répertoire /var/www d'un serveur Debian sur un NAS à l'aide de rsync, mais je ne comprends pas comment lui indiquer la destination...

Voici la commande que j'essaye d'utiliser et qui ne fonctionne pas évidemment :

rsync -rv /var/www/ smb://iomega1500go/Backup_Intranet/
“It has to start somewhere, it has to start sometime, what better place than here, what better time than now?”
Avatar de l'utilisateur
gael49
Expert(e)
Expert(e)
 
Messages: 1918
Inscription: 07 Sep 2004 21:11
Localisation: Les Mauges
 


Re: Commande Rsync

Message le 14 Mai 2008 15:47

Je connais pas non plus, mais au lieu de taper cela...
gael49 a écrit:rsync -rv /var/www/ smb://iomega1500go/Backup_Intranet/

... j'aurais déjà plutôt vu de monter le partage samba sur un point fixe, puis de se servir du point fixe. Je ne sais pas si ça arrangera ton problème, mais ça parait plus "propre".
De type (la syntaxe ne doit pas être tout à fait celle-là) :
mkdir /mnt/backup (à ne faire qu'une seule fois)
mount -t cifs //iomega1500go/Backup_Intranet /mnt/backup
rsync -rv /var/www/ /mnt/backup/
umount /mnt/backup


(il est possible que le montage samba nécessite un utilisateur surtout si c'est un serveur2003 de l'autre coté, j'ai eu le problème. A ce moment là il faut ajouter à la fin de la ligne de montage un -ouser="ton_login_utilisateur%" (le % est important))
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8917
Inscription: 13 Mai 2003 17:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 14 Mai 2008 18:26

Merci Casa, je teste ça demain et je vous tiens au courant.

EDIT : J'ai eu le temps de tester le montage du partage et ça marche, mais j'essaierai lundi le rsync.
“It has to start somewhere, it has to start sometime, what better place than here, what better time than now?”
Avatar de l'utilisateur
gael49
Expert(e)
Expert(e)
 
Messages: 1918
Inscription: 07 Sep 2004 21:11
Localisation: Les Mauges
 

Message le 04 Juin 2008 14:10

Salut !

J'ai enfin pris le temps de retester Rsync et ça marche nickel, j'ai plus qu'à programmer le lancement de cette sauvegarde et ce sera bon.

Merci Casa !
“It has to start somewhere, it has to start sometime, what better place than here, what better time than now?”
Avatar de l'utilisateur
gael49
Expert(e)
Expert(e)
 
Messages: 1918
Inscription: 07 Sep 2004 21:11
Localisation: Les Mauges
 



Sujets similaires

Message [Résolu] outlook 2003 impossible d'envoyer des messages
Bonjour,Depuis quelque temps, je ne peux plus envoyer de messages, une erreur suivante apparait: "le serveur sortant (SMTP) ne prend pas en charge les connections sécurisées par SSL...."Ca marchait parfaitement avant, impossible même en modifiant les paramètres du compte.Pouvez vous m'aide ...
Réponses: 5

Message [Résolu] Demande de désinfection , Windows 10
Bonjour,je voudrais savoirs si m'ont pc à des adwares ou autres. Mon PC n'ai pas lent et ne montre pas de signe d'infection mais cela fait environs 7-8 mois donc peut êtres que des choses ce sont accumuler .Les rapports FRST demander:Addition.txtFRST.txtMerci d'avance
Réponses: 11

Message [Résolu] problème avec le groupe résidentiel
Bonjour,J'ai créée un réseau avec 4 pc sous Windows 10 dans un groupe résidentiel mais est-ce normal de pouvoir accéder uniquement du premier pc qui m'a permis de créer le groupe mais pas de le voir sur les autres pc ?Dans la partie "réseau", je ne vois que les "périphériques médias& ...
Réponses: 30

Message [résolu] adobe flash pour firefox
bonjour j'arrive a poster entre deux validations de cookies j'ai besoin d'adobe flash pour voir des vidéos sur forum auto et je ne peut pas l'installer j'ai téléchargé le paquet mais je coince toujours avec les installations le paquet : flash_player_npapi_linux.x86_64.tar.gzsi c'est celui la ...
Réponses: 3

Message [Résolu] réglage de firefox
bonjour entre le moment ou j'ai éteint le pc hier soir et ce matin quand je l'ai rallumé il c'est passé un truc (ça me rappel windows)quand j'ouvrais firefox j'avais une page blanche avec la fenêtre de recherche google au milieu ,ce matin c'est fini !j'ai les dernières pages visitées ,si je décoche ...
Réponses: 25

Message [Résolu] lecture vidéo impossible
Bonjour;Je n'arrive pas à lire les vidéos sur YouTube, que se soit Google Chrome, Firefox, ou encore application du Windows Store, je n'obtient qu'une image noire, ou au mieux une image verte avec le son.Ce qui est encore plus bizarre VLC n'arrive plus à lire des MKV "j'ai une image noire avec ...
Réponses: 11


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 10 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.