Il y a actuellement 119 visiteurs
Dimanche 27 Novembre 2022
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

reseau avec samba entre mandrake et xp (reglé)

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

reseau avec samba entre mandrake et xp (reglé)

Message le 01 Sep 2004 18:22

me revoila toujours novice mais un peu moins !!

comme le dit le titre je voudrais monter un reseau entre mandrake et xp.

pour cela j' ai lu (lealinux) qu'il faut utiliser samba (et c'est pas simple!!)

j' ai tout suivi a la lettre mais je ne suis pas surt que toute mes etape soit correct

je dois maintenant utiliser swat pour configuere samba

je cite le paragraphe qui ma pose un peu pb :

http://lea-linux.org/reseau/samba.html

Utilisation de SWAT avec xinetd

Tout comme mentionné plus haut, il est fréquent que votre distribution fournisse plutôt xinetd. Il vous faudra donc modifier /etc/xinetd.d/swat pour activer le service. 2 étapes à suivre :

1. modification de /etc/xinetd.d/swat :

root@pingu# cat /etc/xinetd.d/swat
service swat
{
port = 901
socket_type = stream
wait = no
only_from = 127.0.0.1
user = root
server = /usr/sbin/swat
log_on_failure += USERID
disable = yes
}

2. Redémarrer xinetd :

root@pingu# /etc/rc.d/init.d/xinetd restart ou
root@pingu# service xinetd restart

mon pb c'etais de savoir si je dois cree manuellement ce fichier /etc/xinetd.d/swat et y ecrire ca :

service swat
{
port = 901
socket_type = stream
wait = no
only_from = 127.0.0.1
user = root
server = /usr/sbin/swat
log_on_failure += USERID
disable = yes
}

c' est ce que j' ai fais mais je suis pas sur .

bref ,mon vrai pb c' est quaénd je cherche a Générer et modifier smb.conf avec SWAT:

quand je tape http://root@localhost:901 dans la zone d'addresse de netscape celui ci me repond :

"the connection was refused when attempting to contact localhost:901"

et je ne sais pas du tout pourquoi j' ai ca comme reponse !!!

donc a nouveau j' aurais besoin d'aide

A+
Kg7
Sous Expert(e)
Sous Expert(e)
 
Messages: 45
Inscription: 17 Juil 2003 16:09
 


Message le 01 Sep 2004 21:12

Soit ton SWAT n'est pas démarré, soit ton firewall bloque les connexions qui vont sur le port en question. Dans les 2 cas, il faut vérifier :
- que swat est lancé,
- la configuration (port/machines autorisées/actions) de ton firewall..
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2757
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 01 Sep 2004 21:50

pour lancer swat c'est : service xinetd restart ?

et ce que j' ai fais est ce juste ? car peut etre ca vien de ca ?

je n 'ai pas installe de firewall .

est ce que par defaut mandrake en active un ?

enfet le probleme que j' ai pour cibler l' erreur c'est que je ne suis pas trop sur de ce que j'ai fais !!!
mais bon ca viendra avec le temps !
rhmmm et puis aussi que je ne comprend pas tout ce que je fais lol

A+
Kg7
Sous Expert(e)
Sous Expert(e)
 
Messages: 45
Inscription: 17 Juil 2003 16:09
 

Message le 01 Sep 2004 22:46

Kg7 a écrit:pour lancer swat c'est : service xinetd restart ?


C'est bon, par contre il faudrait voir les logs (/var/log/*) pour voir s'il n'y a pas des messages d'erreur lorsque tu lance swat...

Et puis j'ai une question: pourquoi ne configures-tu-pas samba directement ? (en editant smb.conf ?)
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2757
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 02 Sep 2004 09:23

parce que je n'y avait pas penser lol !!

et lea linux ne dit poas comment faire sans swat il mesemble
mais je vais essayer cette aprem

A+
Kg7
Sous Expert(e)
Sous Expert(e)
 
Messages: 45
Inscription: 17 Juil 2003 16:09
 

Message le 03 Sep 2004 17:02

bon il y a du progres !!

je vois quelque chose depuis windows mais quand je dois me loguer ca marche pas !

normal ca va pas marcher du premier coup !!

peut que le pb vient du fait que je crois que j' ai des petits pb avec les comptes :

je cree un compte smbuser et quand je reboot l' interface ne me propose plus de me logguer en root que en smbuser et le mot de passe ne marche pas !!
alors je suprime smbuser et je peux me logguer en root puis recree le compte

de plus quand j'utilise la commande smbpasswd j' obtiens ca (en gros) :

# smbpasswd smbuser password

failed to find entry for smbuser.
failed to modify entry for smbuser

je ne comprends pas pourquoi j' obtiens ca.

A+
Kg7
Sous Expert(e)
Sous Expert(e)
 
Messages: 45
Inscription: 17 Juil 2003 16:09
 

Message le 03 Sep 2004 18:44

1) Il faut créer des comptes samba
2) Je te conseille de mettre la protection au niveau partage (share) et d'autoriser l'acces en fonction des utilisateur/password
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2757
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 03 Sep 2004 23:12

nickel

merci bcp

ca marche !!!

moi meme j' y crois pas !!

A+

(certainement tre prochainement lol )
Kg7
Sous Expert(e)
Sous Expert(e)
 
Messages: 45
Inscription: 17 Juil 2003 16:09
 



Sujets similaires

Message [Réglé] DD SATA bruyant
Bonsoir,Regarde aussi du côté de l'alimentation, on a déjà vu des fils internes trop près des pales et ça fait un petit bruit pas très agréable.Bonne soirée.
Réponses: 20

Message [Réglé] suppression des messages dans gmail
Bonjour, existe t'il une méthode pour supprimer les messages en grands nombre dans Gmail. Par exemple touts les messages d'avant une certaine date ? J'ai essayé notamment avec ceci dans la barre de recherche "before:2018/1/1" mais ça ne fonctionne pas. Merci.
Réponses: 5

Message Campagne & Réseau ! Box 4G ?
salut à toutes et tous J'ai en réparation ma Box 4G, TP-Link Archer MR600 V1, et je voulais savoir si d'autres boxs étaient plus à jour que la mienne ?Sachant que j'ai 10 jours d'attente pour récupérer ma box 4G, j'ai pris pour 60 ? la version plus basique de TPL:TL-MR100 Modem/routeur 4G LTE WiFi ...
Réponses: 0

Message [Réglé] MESSAGES D'ERREUR apres l'arrivée sur le bureau
Salut tout le monde Voici les faits : depuis ce matin sans qu'il se soit passer autre chose les jours d'avant sur l'ordinateur portable de mon amie après avoir démarré normalement et être arrivé sur le bureau sur lequel se trouvent les icônes soudain apparait un premier message d'erreur et lorsqu'o ...
Réponses: 18

Message [Réglé] impossible de connecter imprimante en wifi
bonjourj'ai une imprimante hp3639 avec un pc portable hpje n'arrive pas a connecter mon imprimante en wifi mais avec un cable elle fonctionneje ne sais pas comment faire pour activer le wifi de l'imprimantebien sur je n'ai plus la notice
Réponses: 6

Message [Réglé] Un anti viruis à jour est suffisant pour protéger ?
Bonjour, C'est ma première fois sur ce forum. J'ai eu une mésaventure avec mon PC, je ne sais pas vraiment si c'est l??uvre des virus (alors que mon antivirus est à jour). En effet, j'ai préparé certains documents que je dois transmettre à un cabinet d'expert comptable à Paris dans deux semaines. Ma ...
Réponses: 6


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 3 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.