Il y a actuellement 175 visiteurs
Vendredi 17 Septembre 2021
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

HTML/CSS [résolu]

Besoin d'aide pour configurer un serveur ? Vous souhaitez obtenir des conseils pour référencer votre site ? Un petit souci pour accéder à votre FTP ? Des soucis de programmation en PHP / ASP / HTML / XHTML / XML / XSLT / CSS / ReactJS / AngularJS / VueJS / CGI / PERL / C / MySQL / PostgreSQL ??? Nous avons peut-être la solution dans ce forum ...

HTML/CSS [résolu]

Message le 26 Nov 2011 00:20

Bonjour,

Je ne parviens pas à afficher une image de fond, mon navigateur ne l'affiche pas.
Et puis il y a aussi des symboles qui remplace les espaces dans mes url. Comment puis-je les supprimer ?

Merci
CSS --> http://s3.noelshack.com/uploads/images/16125767991927_css.jpg
HTML-->http://s3.noelshack.com/uploads/images/4645314092133_html.jpg
Xillis
Visiteur Confirmé
Visiteur Confirmé
 
Messages: 12
Inscription: 20 Aoû 2011 22:36
 


Message le 26 Nov 2011 00:26

Bonsoir,

tes chemins sont tous faux, ils pointent sur ton disque dur en direct.

Ton site est en ligne ou pas ?
Avatar de l'utilisateur
Skynet
Moderateur
Moderateur
 
Messages: 14807
Inscription: 19 Juil 2007 21:12
 

Re: HTML/CSS

Message le 26 Nov 2011 00:29

Non
Xillis
Visiteur Confirmé
Visiteur Confirmé
 
Messages: 12
Inscription: 20 Aoû 2011 22:36
 

Message le 26 Nov 2011 00:40

Ok, donc tu es en phase de test si je comprends bien.

Tu vas créer un dossier intitulé "images" dans ton répertoire "Site web".

Modifie ton CSS comme ceci :

Code: Tout sélectionner
body {
background-image:url(images/template.jpg);
}


Attention au mot "template.jpg", ne mets pas de majuscule. Donc modifie aussi le nom de ton image en conséquence.

De même, ne mets pas d'espace dans tes noms de fichiers/dossiers ou remplace cet espace par un underscore.

Exemple avec le répertoire "Site web" qui deviendra :

siteweb

ou

site_web

Tu me dis lorsque tu as fini et on passe au HTML.

P.S. : ferme ton bloc-notes (notepad) avant de modifier le nom de tes dossiers.
Avatar de l'utilisateur
Skynet
Moderateur
Moderateur
 
Messages: 14807
Inscription: 19 Juil 2007 21:12
 

Re: HTML/CSS

Message le 26 Nov 2011 01:03

Voilà c'est fait.
Xillis
Visiteur Confirmé
Visiteur Confirmé
 
Messages: 12
Inscription: 20 Aoû 2011 22:36
 

Message le 26 Nov 2011 01:05

Ok, donc pour ta page en html, tu remplaces cette ligne :

Code: Tout sélectionner
<link rel="stylesheet"href="/Users/Ophelie/Desktop/Site%20web/Style2.css" />


Par celle-ci :
Code: Tout sélectionner
<link href="style2.css" rel="stylesheet" type="text/css" />


Là encore, ne mets pas de majuscule à "style2.css".

Tu dois donc renommer ton fichier aussi.

Il ne reste plus qu'à tester ;).
Avatar de l'utilisateur
Skynet
Moderateur
Moderateur
 
Messages: 14807
Inscription: 19 Juil 2007 21:12
 

Re: HTML/CSS

Message le 26 Nov 2011 01:12

Non ça ne fonctionne toujours pas.
Xillis
Visiteur Confirmé
Visiteur Confirmé
 
Messages: 12
Inscription: 20 Aoû 2011 22:36
 

Message le 26 Nov 2011 01:14

Fais-moi un copier/coller de tes codes en entier sous forme de texte ici ;).
Avatar de l'utilisateur
Skynet
Moderateur
Moderateur
 
Messages: 14807
Inscription: 19 Juil 2007 21:12
 

Re: HTML/CSS

Message le 26 Nov 2011 01:16

<!DOCTYPE html>
<html>
<head>
<!-- En-tête de la page -->
<meta charset="utf-8" />
<link href="style2.css" rel="stylesheet" type="text/css" />
<title>Accueil</title>
<!--[if lt IE 9]>
<script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script>
<![endif]-->
</head>
<body>
<!-- Corps de la page -->
</body>
<footer>
<!-- Placez ici le contenu du pied de page -->
</footer>
</html>



body {background-image:file:///C:/Users/Ophelie/Desktop/Site_web/Images/template.jpg('images/template.jpg');}
Xillis
Visiteur Confirmé
Visiteur Confirmé
 
Messages: 12
Inscription: 20 Aoû 2011 22:36
 

Message le 26 Nov 2011 01:21

Chez moi ça fonctionne.

Tu as sans doute oublié de modifier ton CSS, puisque tu écris à la fin de ton message :

Xillis a écrit:body {background-image:file:///C:/Users/Ophelie/Desktop/Site_web/Images/template.jpg('images/template.jpg');}


Sinon, tes fichiers "index.html" et "style2.css" sont bien dans ton dossier "Site_web" ?
Avatar de l'utilisateur
Skynet
Moderateur
Moderateur
 
Messages: 14807
Inscription: 19 Juil 2007 21:12
 

Re: HTML/CSS

Message le 26 Nov 2011 01:24

Oui
Xillis
Visiteur Confirmé
Visiteur Confirmé
 
Messages: 12
Inscription: 20 Aoû 2011 22:36
 

Re:

Message le 26 Nov 2011 01:27

D'accord, donc remplace dans ton CSS entièrement cette ligne :

Code: Tout sélectionner
body {background-image:file:///C:/Users/Ophelie/Desktop/Site_web/Images/template.jpg('images/template.jpg');}


Par celle que j'ai mis au début du sujet, à l'identique sans rien modifier :

Code: Tout sélectionner
body {
background-image:url(images/template.jpg);
}


Et je t'assure que ça fonctionne.
Avatar de l'utilisateur
Skynet
Moderateur
Moderateur
 
Messages: 14807
Inscription: 19 Juil 2007 21:12
 

Re: HTML/CSS

Message le 26 Nov 2011 01:31

Oui ça fonctionne maintenant ! :D

Merci Skynet :)
Xillis
Visiteur Confirmé
Visiteur Confirmé
 
Messages: 12
Inscription: 20 Aoû 2011 22:36
 

Message le 26 Nov 2011 01:36

Parfait & de rien ;).

Voici un site qui t'aidera pour ne plus te tromper :

http://www.alsacreations.com/astuce/lir ... solus.html

Et aussi le "site du zéro" en général :

http://www.siteduzero.com/tutoriel-3-13 ... -css3.html
Avatar de l'utilisateur
Skynet
Moderateur
Moderateur
 
Messages: 14807
Inscription: 19 Juil 2007 21:12
 



Sujets similaires

Message [Résolu] PC lent - 2eme
Bonjour à tous,je reviens vers vous après avoir signalé un souci sur le PC de mon fils dans Nouvelle installation Win10 - Démarrage lentEn février dernier, grâce aux conseils du forum, j'ai réussi à corriger ce qui n'allait pas et le PC fonctionnait bien. Mais il est devenu très lent dernièrement. P ...
Réponses: 19

Message [Résolu] Veille disque dur externe / Port usb
Bonjour à tous,A chaque fois que je branche un disque dur externe celui-ci s'éteint automatiquement au bout de quelques minutes de non utilisation et se rallume dès utilisation. Cela le fait sur 2 DD externes différents. Pourtant, la mise en veille des ports usb pour économiser l'énergie est désacti ...
Réponses: 4

Message [résolu] gimp-> gThumb
Bonjour Je voudrais pouvoir imprimer plusieurs photos sur les mêmes feuilles, ça fait plusieurs jours que je tourne en rond avec gimp sans succès, j'ai suivi plusieurs topics du net mais je n'arrive pas à avoir la même chose. Merci
Réponses: 7

Message [résolu] numéro de portable
Bonjour mes parents n'ont jamais eu de portable, ils se sont décidés hier. Savez vous combien de temps il faut pour qu'ont leur mette en route leur numéro ? C'est à la poste mobile, donc sfr. Il n'y a aucune réponse sur gogole, ce n'est que pour la portabilité, forcément qui n'a pas de portable.. ...
Réponses: 7

Message [RESOLU] PC Tout en Un avec écran cassé...
bonjour à toutes et tousmon écran de pc est cassé, du moins 3 "grosses" rayures qui traversent l'épaisseur de l'écran...pc tout en un HP Omni 27 de 2011.... Sic Tout fonctionne bien mais sur le plan sécurité, y a-t-il une solution ?Si j'appuie sur les morceaux cassés, ils bougent...., en f ...
Réponses: 4

Message [ Résolu ] NVMe VS SSD sata
Bonjour à TousCe matin, j'ai installé un SSD NVMe, Samsung SSD 980 M.2 PCIe NVMe 1 To et je ne comprends pas les résultats du benchmark. Merci d'avanceBenchmark du NVMehttps://i.goopics.net/bq0vg.jpgBenchmark du Samsung 860 QVOhttps://i.goopics.net/WqLZ3.jpgLes résultats sont supérieurs en lecture/é ...
Réponses: 5


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 3 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.
cron