Il y a actuellement 52 visiteurs
Vendredi 22 Juin 2018
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

Debian/xp [résolu]

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

Debian/xp [résolu]

Message le 27 Mai 2009 12:02

Bonjour, alors voici une question récurrente !

Comment bien installer xp et linux en dualboot !

Initialement le PC avec XP, j'ai essayer d'installer Debian, sans trop comprendre ce qu'il me disait, j'ai deja installer des vertion de Linux bien plus facile !

AU final, j'ai eu au démarrage "impossible de trouver le système d'exploitati"

Dans mon inexpérience, j'avais quand même 3 partitions, une pour Xp et 2 pour Linux (je ne sais pas pourquoi mais j'ai pensé a une partition de "swap"

Bref, j'avai crée mes partition via l'interface de débian, mais bon...

La référence exacte de ce debian est "Debian 5.0.1 amd"

L'ordinateur est un Toshiba Satellite P300.


Voila donc si vous avais des idée sur la maniere de faire, sachant que le propriétaire du PC veut cette version de Linux est pas une autre.

J'imagine qu'il faut quand même installer XP en premier non ?

Merci.
Arethusa
Expert(e)
Expert(e)
 
Messages: 1124
Inscription: 01 Nov 2007 23:47
 


Message le 27 Mai 2009 13:10

En principe, tu installes XP en premier, et Debian ensuite. Celui ci installes le Grub, un petit programme qui se place dans le MBR et qui s'occupe de te donner le choix de l'OS que tu veux faire booter au démarrage de ton PC.
En cas de problème constaté sur un sujet, contactez un modérateur par MP. N'intervenez pas vous-même. Merci bien.
Aucune aide ni support ne sera fourni par MP.
Avatar de l'utilisateur
H3bus
Moderateur
Moderateur
 
Messages: 12195
Inscription: 08 Avr 2008 16:13
Localisation: /home/h3bus
 

Message le 27 Mai 2009 21:38

salut

bon deja +1 avec le principe de @H3bus

hors j'ai voulu tester pour voir la chose et effectivement par windows ou direct en bootant sur le CD il y a quelque chose qui ne va pas !

deja en bootant par le CD l'utilitaire de partitionnage est pas clair par contre c'est normal que tu est la partoche xp et 2 linux la 3eme etant bien pour le swapp

si on lance l'installation par windows le grub s'installe et permet de lancer l'installation au boot suivant mais au final on se retrouve avec le meme utilitaire de partitionnage alors que sous windows il etait preciser que l'on pourrait garder windows

pire encore apres 3 ou 4 reboot et redemarrage du processus d'installation par le boot/grub , on fini par se retrouver avec moin de choix que la fois d'avant avec leur outils de partitionnage ! bug du grub , glitch de l'installateur ou partionneur ?

en tous je ne t'aide pas mais je t'accorde que c'est plus simple a realisé sous une distrib ubuntu par exemple !

je suis loin d'etre expert linux et du mulitboot avec , mais oui tu a raison il y a bien quelque chose qui ne va pas en effet , attend plus expert ou peu etre faut t'il partitionner autrement avant avec un utilitaire neutre !

en tous cas en debutant sous windows sa devrais marcher mais se n'est pas le cas car de toute facon les choix proposé ensuite n'ont rien avoir avec les indications d'installation au debut de toute maniere ...........
Image
Avatar de l'utilisateur
psychocat
PC-Infopraticien
PC-Infopraticien
 
Messages: 15412
Inscription: 22 Mai 2008 22:46
Localisation: deux sevres , Niort
 

Message le 28 Mai 2009 10:26

Attends, pour que je sois sur de comprendre : Ton installation s'est terminée ?

Une fois l'installation faite, tu arrives à accéder à l'un ou l'autre des système ?
En cas de problème constaté sur un sujet, contactez un modérateur par MP. N'intervenez pas vous-même. Merci bien.
Aucune aide ni support ne sera fourni par MP.
Avatar de l'utilisateur
H3bus
Moderateur
Moderateur
 
Messages: 12195
Inscription: 08 Avr 2008 16:13
Localisation: /home/h3bus
 

Message le 28 Mai 2009 23:01

tu pose la question a qui ?
Image
Avatar de l'utilisateur
psychocat
PC-Infopraticien
PC-Infopraticien
 
Messages: 15412
Inscription: 22 Mai 2008 22:46
Localisation: deux sevres , Niort
 

Message le 29 Mai 2009 10:40

Je sais pas, les 2 ! :wink:
En cas de problème constaté sur un sujet, contactez un modérateur par MP. N'intervenez pas vous-même. Merci bien.
Aucune aide ni support ne sera fourni par MP.
Avatar de l'utilisateur
H3bus
Moderateur
Moderateur
 
Messages: 12195
Inscription: 08 Avr 2008 16:13
Localisation: /home/h3bus
 

Message le 29 Mai 2009 11:36

moi oui sauf que je me suis retrouvé avec un grub completement inutile car il n'y avait que linux au final , et xp il la degagé .

en gros il a procédé a une installation standart sans me laisser la possibilité de faire autrement a un moment donné comme c'etait precise au depart

Image <-- :lol:

Image

Image

Image

Image

Image

Image

voila apres

Image

Image

Image

Image

Image

apres sa installe , donc pour installer normalement ca va meme si je comprend pas vraiment trop bien tous se qu'il me propose mais pour le dual boot encore heureux que j'ai pas choisi le mode expert je craint le pire

Image

je pense qu'ils ont du se louper quelque part avec cette version c'est pas possible , je sais pas j'y comprend pas trop grand chose a mon niveau :-?

j'utiliserais bien dans se cas une celebre expression de Cartman dans southpark mais chuuuuuuuuut :roll:

et sinon par le CD on a le menu principale " installer , installer en mode graphique , etc " et sa repart idem a partir de la 5 eme images au dessus , meme principe :-?
Image
Avatar de l'utilisateur
psychocat
PC-Infopraticien
PC-Infopraticien
 
Messages: 15412
Inscription: 22 Mai 2008 22:46
Localisation: deux sevres , Niort
 

Message le 29 Mai 2009 11:50

En même temps, dans ton installation, tu lui demandes d'utiliser un disque entier, pas étonnant qu'il ait viré XP...

Image

Il faut passer en mode Manuel, et faire ton partitionnement.

Il te le répète bien ici qu'il va formater tout le disque :

Image
En cas de problème constaté sur un sujet, contactez un modérateur par MP. N'intervenez pas vous-même. Merci bien.
Aucune aide ni support ne sera fourni par MP.
Avatar de l'utilisateur
H3bus
Moderateur
Moderateur
 
Messages: 12195
Inscription: 08 Avr 2008 16:13
Localisation: /home/h3bus
 

Message le 29 Mai 2009 12:00

ah ah en mode manuel il me met une page apres sa bloque je suis obligé de revenir en arriere "retour" !

bien essayé ;) mais non c'est pas sa non plus DSL pour toi @h3bus :lol:

bien sur je suis bien ok avec toi dans se que tu me dit mais comme de toute facon j'ai pas 36 choix non plus , j'etais passé en mode bete et discipliner

et si je fait que des retours , on peu aussi arriver a un mega menu d'installation avec plein de choix mais rien de bien utile a se niveau .

menu caché car par stipulé nul part , c'est tres mal fait !

mais bon on va attendre "@papier peint" c'est son sujet il aura peu etre trouvé une explication afin de satisfaire son client :)
Image
Avatar de l'utilisateur
psychocat
PC-Infopraticien
PC-Infopraticien
 
Messages: 15412
Inscription: 22 Mai 2008 22:46
Localisation: deux sevres , Niort
 

Message le 29 Mai 2009 12:59

Il faudrait que je teste plus attentivement. Je verrais ça ce week end. CaSa pourra peut être nous renseigner, il est bien plus expert en Debian que moi.

Il faudrait aussi voir avec quelle version de Debian c'est le plus simple.
En cas de problème constaté sur un sujet, contactez un modérateur par MP. N'intervenez pas vous-même. Merci bien.
Aucune aide ni support ne sera fourni par MP.
Avatar de l'utilisateur
H3bus
Moderateur
Moderateur
 
Messages: 12195
Inscription: 08 Avr 2008 16:13
Localisation: /home/h3bus
 

Message le 29 Mai 2009 13:25

oui tout a fait ;)

il y a surement une raison de toute facon ......
Image
Avatar de l'utilisateur
psychocat
PC-Infopraticien
PC-Infopraticien
 
Messages: 15412
Inscription: 22 Mai 2008 22:46
Localisation: deux sevres , Niort
 

Message le 29 Mai 2009 13:38

H3bus a raison, en prenant un disque entier il l'utilise... entièrement.

De souvenir je n'ai jamais utilisé le partitionnement de Debian pour redimensionner une partition, j'utilise systématiquement Gparted en LiveCD "avant" pour dégager un espace vierge. C'est beaucoup plus simple/sûr pour la suite de l'installation.
Mais à le faire avec Debian, il faut effectivement passer par un partitionnement totalement manuel dans l'installeur Debian : en cliquant dans le paramétrage de la partition XP on peut modifier la taille pour la redimensionner.

Je fais toutes mes install sur ce principe :
- redimensionnement par Gparted avant pour laisser un espace vierge
- boot avec le CD de Debian (jamais sous windows)
- installation en mode texte/expert dès le départ (mais ça n'a pas grande importance)
- partitionnement assisté : disque entier, ou manuel pour fixer une taille de swap perso
... le reste c'est quasi répondre "oui" et "suivant" tout le temps

Et j'avoue ne jamais avoir aucun soucis, sauf si des composants du PC sont trop récents pour la détection.
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8917
Inscription: 13 Mai 2003 17:32
Localisation: A.H.P... et jamais loin d'une Debian
 

Message le 29 Mai 2009 13:42

CaSa a écrit:H3bus a raison, en prenant un disque entier il l'utilise... entièrement.

De souvenir je n'ai jamais utilisé le partitionnement de Debian pour redimensionner une partition, j'utilise systématiquement Gparted en LiveCD "avant" pour dégager un espace vierge.


J'avoue que les quelques fois ou j'ai eu une Debian à installer, c'était le seul système présent, donc pas de problème de partitionnement. Mais il est vrai que passer par Gparted en Live CD est une bonne alternative.
En cas de problème constaté sur un sujet, contactez un modérateur par MP. N'intervenez pas vous-même. Merci bien.
Aucune aide ni support ne sera fourni par MP.
Avatar de l'utilisateur
H3bus
Moderateur
Moderateur
 
Messages: 12195
Inscription: 08 Avr 2008 16:13
Localisation: /home/h3bus
 

Message le 29 Mai 2009 15:38

:oops: Oh!là!! J'avais lu ce topic en ZZ total moi!! :oops: J'aurais pu intervenir plus tôt.
Comme CaSa, je prépare ma partition (ou le disque dur au cas ou) hors Windows.
Soit avec Partition Manager que je possèdes ou encore Gparted. Et aussi tant sous Debian
que sous Mandriva, je boote la machine avec le CD/DVD correspondant.

J'y ai eu droit aussi à cliquer un poil trop vite sur "tout le disque" & là le Pingouin ne traine pas,
Il attrape le Windows & le renvoie plus loin que son créateur...

Pour Debian Lenny 5.0 je n'ai pas eu de difficultés notoires puisqu'il est encore sous VirtualBox...
Mais sauf erreur notoire de ma part, le principe de l'installeur reste le même à Mandriva.
A+,
AtOM.
Le PC c'est comme la lune,il y a une face cachée.Eclairons-la!!!!
__________________
Avatar de l'utilisateur
Ask to Old Man
Moderateur
Moderateur
 
Messages: 19970
Inscription: 14 Mar 2004 11:06
Localisation: Argenteuil,Val d'Oise
 

Message le 29 Mai 2009 18:50

et ben je suis aussi un mauvais alors
Image
Avatar de l'utilisateur
psychocat
PC-Infopraticien
PC-Infopraticien
 
Messages: 15412
Inscription: 22 Mai 2008 22:46
Localisation: deux sevres , Niort
 

Suivante


Sujets similaires

Message [résolu] application compagnon
bonjour depuis ce midi si je veux télécharger une vidéo sur youtube j'ai cette fenêtre, le seul topic que j'ai trouvé la dessus n'est pas concluant . j'ai supprimé puis réinstallé DownloadHelper sans succès .d'ailleurs, je ne devrais pas avoir un fichier DownloadHelper dans fichier cacher ? merci ...
Réponses: 11

Message [RESOLU] ACER Aspire v5 121 en rade...
bonjour à toutes et tousma fille m'a passé son pc pour que je vois ce que je peux en faire...Souci de boot "planté"... MBR en promenadepas de souci, je sors les gants de boxe et....Rien, impossible de résoudre ?C'est pas grave, du style du mec qui s'y connaît à donf..., je formate le systè ...
Réponses: 11

Message [résolu] tableau de bord vide !
bonsoir j'allume le pc en revenant du boulot, plus de lanceur dans le tableau de bord !si je clique droit, par exemple sur imprimante, puis "ajouter au tableau de bord " ça me met a droite entre l'icone de mise a jour et la température du cpu, deux icones de firefox, celui du terminal et d ...
Réponses: 2

Message [Résolu] mise a jour windows 10 1803
bonjourdepuis la dernière mise à jour d'avril 2018 mon pc rame plus que d'habitude, en utilisation normale (net, ...) et dans les jeux (perte de fps)suis je le seul ? j'ai vu que cette mise à jour posait un problème avec certain ssd https://www.cnetfrance.fr/news/windows- ... 868100.htmmerci
Réponses: 6

Message Changement de tel. RESOLU
bonjour, une petite question : quelle est la différence entre un tel. normal est un EDGE ? La différence de prix en vaut elle le coup . Merci.
Réponses: 5

Message windowsphone RESOLU
Bonjour,Je possède un lumia 950 , mes contacts sont sur mon téléphone et je voudrais les mettre sur ma carte SIM . Comment ? Merci.
Réponses: 2


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité


.: Nous contacter :: Flux RSS :: Données personnelles :.