Il y a actuellement 91 visiteurs
Mardi 22 Septembre 2020
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

changer la resolution d'affichage sous BT2

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

changer la resolution d'affichage sous BT2

Message le 20 Avr 2007 13:10

Bonjour tout le monde
je viens d'installer backtrack 2 en dur sur mon pc portable (petite config => celeron 450MHZ 128 de ram)

seulement mon affichage était en 800*600 sous kde

alors pendant le boot avant de lancer KDE avec la commande startx j'ai lancer xconf je penser que cela aller me configure correctement mon affichage l'effet a était inverse je me retrouve avec un affichage en 640*480 .

comment avoir un affichage en 1024*768 ?
je c'est que mon pc portable le supporte car sous windows xp il était en 1024*768

merci de votre aide
site web http://halflife2dm.free.fr
map db_rock
Image
Avatar de l'utilisateur
zelio22
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 382
Inscription: 29 Avr 2004 10:38
 


Message le 23 Avr 2007 09:49

es que quelqu'un peut m'aider
site web http://halflife2dm.free.fr
map db_rock
Image
Avatar de l'utilisateur
zelio22
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 382
Inscription: 29 Avr 2004 10:38
 

Message le 23 Avr 2007 13:55

Tu as quoi comme carte graphique ? Es-tu certain d'avoir sélectionné le bon modèle dans l'assistant xconf ?
Quel est le contenu du fichier xorg.conf situé (normalement) dans /etc/X11 ?
N'as-tu pas un outil dans BT2 te permettant de changer la résolution à la volée ?
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8976
Inscription: 13 Mai 2003 16:32
Localisation: Sisteron... et jamais loin d'une Debian
 

Message le 23 Avr 2007 15:10

Tu as quoi comme carte graphique ?

pour ma carte graf c'est une trident Cyber 9525

Es-tu certain d'avoir sélectionné le bon modèle dans l'assistant xconf ?

je ne trouve pas cette assistant
N'as-tu pas un outil dans BT2 te permettant de changer la résolution à la volée ?

oui seulement la seule resolution disponible et le 640*480

Voici le contenu du fichier xorg.conf

Code: Tout sélectionner
Section "ServerLayout"
Identifier     "X.org Configured"
Screen      0  "Screen0" 0 0
InputDevice    "Mouse0" "CorePointer"
InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath      "/usr/X11R6/lib/X11/rgb"
ModulePath   "/usr/X11R6/lib/modules"
FontPath     "/usr/X11R6/lib/X11/fonts/misc/"
FontPath     "/usr/X11R6/lib/X11/fonts/TTF/"
FontPath     "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath     "/usr/X11R6/lib/X11/fonts/CID/"
FontPath     "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath     "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
Load  "dbe"
Load  "dri"
Load  "extmod"
Load  "glx"
Load  "record"
Load  "xtrap"
Load  "freetype"
Load  "type1"
EndSection

Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
EndSection

Section "InputDevice"
Identifier  "Mouse0"
Driver      "mouse"
Option       "Protocol" "auto"
Option "ZAxisMapping" "4 5"
Option "Buttons" "3"
Option       "Device" "/dev/mouse"
Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier   "Monitor0"
VendorName   "Monitor Vendor"
ModelName    "Monitor Model"
EndSection

Section "Device"
Identifier  "Card0"
Driver      "trident"
VendorName  "Trident Microsystems"
BoardName   "Cyber 9525"
BusID       "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
SubSection "Display"
Viewport   0 0
Depth     1
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     4
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     8
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     15
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     16
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     24
EndSubSection
EndSection
site web http://halflife2dm.free.fr
map db_rock
Image
Avatar de l'utilisateur
zelio22
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 382
Inscription: 29 Avr 2004 10:38
 

Message le 23 Avr 2007 19:31

Essaye de lancer une configuration en tapant en console (en root) :
dpkg-reconfigure xserver-xorg

Je ne vois pas les résolutions possibles dans le xorg.conf... je ne sais pas comment l'aborder mais je pense que tu peux tenter de les rajouter.
En root :
Tu sauve d'abord ton xorg.conf actuel par un :
cd /etc/X11
cp xorg.conf xorg.conf.old


Tu édites ton xorg.conf (avec vim ou nano ou tout autre éditeur que tu connais) et tu ajoute les résolutions comme ceci :
Modes "1024x768" "800x600" "640x480"
... dans chaque "subsection" de la section "screen"
exemple :

...
SubSection "Display"
Viewport 0 0
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection
...


Rajoute aussi cette ligne pour une résolution par défaut :
DefaultDepth 24
ici :
...
Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"

...

Tu testes cela avec différentes résolutions par défaut, en les baissant :
DefaultDepth 24
puis
DefaultDepth 16
puis
DefaultDepth 15

La méthode pour tout cela, c'est de :
- modifier le xorg.conf
- lance X par startx et voir ce que ça donne
- fermer la session X au besoin
- recommencer avec d'autres paramètres dans le xorg.conf jusqu'à trouver ce qui doit aller
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8976
Inscription: 13 Mai 2003 16:32
Localisation: Sisteron... et jamais loin d'une Debian
 

Message le 23 Avr 2007 22:31

voici le nouveau xorg
il ne fonctionne pas non plus par contre quand je diminue le
DefaultDepth en dessous de 8 alors ca ne lance plus l'interface graphique

le commande dpkg-reconfigure xserver-xorg ne fonctionne pas

Code: Tout sélectionner
Section "ServerLayout"
Identifier     "X.org Configured"
Screen      0  "Screen0" 0 0
InputDevice    "Mouse0" "CorePointer"
InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath      "/usr/X11R6/lib/X11/rgb"
ModulePath   "/usr/X11R6/lib/modules"
FontPath     "/usr/X11R6/lib/X11/fonts/misc/"
FontPath     "/usr/X11R6/lib/X11/fonts/TTF/"
FontPath     "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath     "/usr/X11R6/lib/X11/fonts/CID/"
FontPath     "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath     "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
Load  "dbe"
Load  "dri"
Load  "extmod"
Load  "glx"
Load  "record"
Load  "xtrap"
Load  "freetype"
Load  "type1"
EndSection

Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
EndSection

Section "InputDevice"
Identifier  "Mouse0"
Driver      "mouse"
Option       "Protocol" "auto"
Option "ZAxisMapping" "4 5"
Option "Buttons" "3"
Option       "Device" "/dev/mouse"
Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier   "Monitor0"
VendorName   "Monitor Vendor"
ModelName    "Monitor Model"
EndSection

Section "Device"
Identifier  "Card0"
Driver      "trident"
VendorName  "Trident Microsystems"
BoardName   "Cyber 9525"
BusID       "PCI:1:0:0"
EndSection

Section "Screen"
DefaultDepth 24
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
SubSection "Display"
Viewport   0 0
Depth     1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

site web http://halflife2dm.free.fr
map db_rock
Image
Avatar de l'utilisateur
zelio22
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 382
Inscription: 29 Avr 2004 10:38
 

Message le 24 Avr 2007 07:32

Essaye, en console root :
xorgconfig
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8976
Inscription: 13 Mai 2003 16:32
Localisation: Sisteron... et jamais loin d'une Debian
 

Message le 24 Avr 2007 10:11

merci de ton aide après une bonne dizaine de xorgconfig
j'ai réussi a trouver la bonne résolution 1024*768 en 16bits
site web http://halflife2dm.free.fr
map db_rock
Image
Avatar de l'utilisateur
zelio22
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 382
Inscription: 29 Avr 2004 10:38
 



Sujets similaires

Message [Réglé] Edge: Impossible de changer moteur de recherche Bing
Bonjour J'ai un pc portable avec Windows 10. Lorsque il sort du mode veille, edge se lance automatiquement.. J'ai vu sur internet que certains ont réglé le problème en changeant le moteur de recherche Bing par un autre mais je n'arrive pas le changer. Par défaut Bing est sélectionné et les boutons s ...
Réponses: 10

Message Responsive : Changer la position de l'image de fond
Bonjour, sur un site que je développe, j'ai une image de fond qui est située au centre lorsque le site s'affiche sur un écran d'ordinateur. Seulement, pour le moment, en affichage mobile, l'image ne bouge pas et du texte vient la recouvrir (ce qui cache l'image et rend le texte illisible). J'aimerai ...
Réponses: 0

Message Bug affichage PACKARD BELL EASYNOTE SB87-P-021W
Bonjour à tous,En allumant mon PC portable, voici ce qui apparaît sur mon écran (écran séparé en deux par une ligne horizontale...)Pouvez-vous m'indiquer quel peut être le problème ?Merci d'avance.
Réponses: 2

Message Nouveau GPU , impossible de changer résolution [Résolu]
Bonjour, hier j'ai installé mon GPU à savoir une MSI 5700XT , le soucis c'est que je n'arrive pas à changer la résolution car tous les options sont grisé , je resté bloqué à 640x480 , la carte graphique est bien reconnue dans le gestionnaire des tâches.Je suis connecté avec un ancien cable HDMI.Une ...
Réponses: 7

Message Changer de refroidissement ?
Bonjour, ça vaut le coup de changer mon WC Cooler Master Seidon 120M par un Noctua NH-D15 ?J’utilise le WC depuis 4 ans pour information qui actuellement refroidit mon i7-8700k.
Réponses: 2

Message Lenteur d'affichage "net" des miniatures de photos dans les
Bonjour à tousJe suis récemment passé de Windows 7 à Windows 10 (avec changement de config) et je suis confronté à un problème que je n'avais pas sur mon ancien PC. Quand j'ouvre des dossiers contenant des photos, l'affichage de l'aperçu sur les miniatures n'est pas immédiat (ce qui n'était pas le c ...
Réponses: 4

Message Problème "d'affichage"
Bonsoir,Je viens vers vous pour solliciter votre expérience, j'ai un pc fixe, monté par mes soins et avec une config qui m'a été conseillé ici-même. Je dispose de ce pc depuis 2 mois, ainsi qu'un double screen, dvi et display port. Et hier soir en étant sur internet (twitch), j'ai commencer à avoir ...
Réponses: 3


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 4 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.