Il y a actuellement 102 visiteurs
Mardi 27 Juillet 2021
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

[réglé] htaccess pour bloquer la page d'un site

Besoin d'aide pour configurer un serveur ? Vous souhaitez obtenir des conseils pour référencer votre site ? Un petit souci pour accéder à votre FTP ? Des soucis de programmation en PHP / ASP / HTML / XHTML / XML / XSLT / CSS / ReactJS / AngularJS / VueJS / CGI / PERL / C / MySQL / PostgreSQL ??? Nous avons peut-être la solution dans ce forum ...

[réglé] htaccess pour bloquer la page d'un site

Message le 16 Aoû 2004 14:35

Bonjour,

je m'explique. J'ai conçu le site avec dreamweaver j'ai transférer avec filezilla les fichiers en .htm et des photos que j'avais.
En fait c'est l'une de ces pages là que je ne souhaite rendre accessible que par un mot de passe.
J'ai donc créer un répertoire dans lequel j'ai mis cette page avec le .htaccess. j'ai créer un autre répertoire dans lequel j'ai mis le fichier .txt avec les noms d'utilisateurs et les mots de passe.
le problème c'est qu'en mettant ma page .htm dans le répertoire je n'y ai plus accés depuis le lien de ma page d'accueil.
Comment faut il procéder ?

Merci
filemma
Visiteur
Visiteur
 
Messages: 5
Inscription: 21 Avr 2004 18:12
 


Message le 16 Aoû 2004 14:38

Qu'as tu mis comme lien ?

Pourrais-tu nous le monter, ainsi que l'arborescence de ton site ?

Merci :wink:
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 10:46
Localisation: /Fr/Idf/77/Le Mée
 

Message le 16 Aoû 2004 14:50

en fait au départ j'ai :

index.htm
privé.htm
photo.jpg
photo.jpg

avec dreamweaver sur la page index.htm j'ai mis un lien vers la page privé.htm , là ça fonctionne.

Mais en rajoutant un répertoire ça donne :
Répertoire
- privé.htm
index.htm
photo.jpg
photo.jpg

et là je n'ai plus accés ! et c'est dans ce répertoire que j'ai mis le htaccess
filemma
Visiteur
Visiteur
 
Messages: 5
Inscription: 21 Avr 2004 18:12
 

Message le 16 Aoû 2004 14:57

Il faut que tu modifies ton lien et que ça ressemble à
Code: Tout sélectionner
<a href="Répertoire/prive.htm" ... >
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 10:46
Localisation: /Fr/Idf/77/Le Mée
 

Message le 16 Aoû 2004 14:59

c'est ce que j'ai fait mais marche pas quand même
filemma
Visiteur
Visiteur
 
Messages: 5
Inscription: 21 Avr 2004 18:12
 

Message le 16 Aoû 2004 17:13

-évite les accents...
-met tes noms de fichier/dossiers en minuscules...
Avatar de l'utilisateur
glenux
PC-Infopraticien
PC-Infopraticien
 
Messages: 2757
Inscription: 01 Mar 2003 16:22
Localisation: Entre deux BarCamps
 

Message le 16 Aoû 2004 18:29

j'ai trouvé l'erreur, j'avais oublié de remettre à jour mon fichier index.htm avec le bon lien !!! tout ça pour ça... l'important c'est de trouver la solution quand même;

Merci à tous de votre aide
filemma
Visiteur
Visiteur
 
Messages: 5
Inscription: 21 Avr 2004 18:12
 

Message le 17 Aoû 2004 09:51

Stormrider a écrit:Il faut que tu modifies ton lien et que ça ressemble à
Code: Tout sélectionner
<a href="Répertoire/prive.htm" ... >


filemma a écrit:c'est ce que j'ai fait mais marche pas quand même


:lol:
I chose this life, This superficial lie, Constant compromise, Endless Sacrifice

Weiter, weiter ins Verderben, Wir müßen leben bis wir sterben
Avatar de l'utilisateur
Stormrider
Expert(e)
Expert(e)
 
Messages: 1637
Inscription: 08 Mai 2004 10:46
Localisation: /Fr/Idf/77/Le Mée
 

Message le 17 Aoû 2004 10:00

Stormrider a écrit:
Stormrider a écrit:Il faut que tu modifies ton lien et que ça ressemble à
Code: Tout sélectionner
<a href="Répertoire/prive.htm" ... >


filemma a écrit:c'est ce que j'ai fait mais marche pas quand même


:lol:


c'est exactement ça, je l'avais fait mais sans l'uploader sur mon site, d'où ma page introuvable, rien à voir en fait avec l'.htaccess qui fonctionne parfaitement !

merci encore
:roll: :roll: :roll:
filemma
Visiteur
Visiteur
 
Messages: 5
Inscription: 21 Avr 2004 18:12
 



Sujets similaires

Message [Réglé] marre des fenêtres d'acceptation des cookies ?
bonjour je trouvais insupportable d'avoir a accepter des cookies sur tous les sites et surtout sur ceux ou je ne suis que de passage .après une recherche, j'ai trouvé pour supprimer les "cookies warnings" https://www.presse-citron.net/marre-coo ... barrasser/la solution est peut être (a vo ...
Réponses: 9

Message [Réglé] Installer Office 2007
Bonjour,Je possède la suite Office 2007 avec sa clef d'activation sur CD que j'aimerais installer sur PC portable Windows 10, sans lecteur. Comment puis-je procéder, sachant que je ne suis pas une foudre de guerre en matière informatique?Merci à tous.
Réponses: 9

Message [Réglé] dommage pas de forum pour tirage photos
Salut tout le monde ! J?ai besoin d'un petit conseil pour imprimer une photo que je dois mettre dans un cadre photo de 15 cm par 15 cm, mais je ne trouve pas comment la rendre normale pas minuscule pas étirée ou autre ..... il n'y a pas de forum photo ou tirage photos imprimante, mais bon qui sait ...
Réponses: 10

Message [Réglé] Petite vérification !
Hello tout le monde ,Voila comme d'habitudes et un peu de temps en temps une petite vérification de votre part pour voir si tout va bien de mon coté Addition https://www.cjoint.com/c/KGooSJjfWy7First https://www.cjoint.com/c/KGooS5SKcg7Shortcuthttps://www.cjoint.com/c/KGooTAzz7k7ZHPDiag https://www ...
Réponses: 15

Message problemes acces au site sur firefox
Salut tout le mondeje tenais à vous signaler sur la dernière version Firefox version 89.0 64 bits (nouveau design blanc moche pour mon gout) des problèmes accès à votre site PC-InfoPratique concernant la sécurité voici deux captures écran :https://cjoint.com/c/KFgrgpnLNBH htt ...
Réponses: 9

Message [Réglé] Nouvelle installation Win10 - Démarrage lent
Bonjour,J'ai changé de PC dernièrement et comptais donner l'ancien à mon fils. Or, je ne le savais pas, il avait déjà un PC orienté gamer qu'il n'utilisait presque plus car très lent. J'y ai jeté un ?il et j'ai vu qu'il avait saturé son SSD alors que le disque classique était vide. J'ai déplacé les ...
Réponses: 17


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.