Il y a actuellement 127 visiteurs
Mardi 23 Juillet 2024
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

[Réglé] Pb. Installation Libreoffice sur Chromebook/Linux

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

[Réglé] Pb. Installation Libreoffice sur Chromebook/Linux

Message le 19 Nov 2023 08:17

Bonjour à tous,
j'ai un petit souci que je n'arrive pas à résoudre sur mon Chromebook avec Linux.
Je voulais installer LibreOffice sur mon chromebook. Pour cela, j'ai suivi un premier tutoriel :
https://www.youtube.com/watch?v=wkenkjZMjWk
Comme j'avais des messages d'erreur lors de l'installation des fichiers Deb, j'ai arrêté et j'ai suivi un deuxième tuto :
https://www.youtube.com/watch?v=ctdt2Yf4TRE
Celui-ci a très bien fonctionné. Mais j'essaie maintenant d'installer la langue française pour l'interface.
J'ai téléchargé le fichier sur le site de LibreOffice : https://fr.libreoffice.org/download/download/?type=deb-x86_64&version=7.6.2&lang=fr
Mais je me retrouve encore avec des messages d'erreur au moment de l'installation je fais la commande "sudo dpkg - i *.deb"
Voici le résultat :
dpkg: error processing archive libobasis7.6-fr_7.6.2.1-1_amd64.deb (--install):
package architecture (amd64) does not match system (arm64)
dpkg: error processing archive libreoffice7.6-dict-fr_7.6.2.1-1_amd64.deb (--install):
package architecture (amd64) does not match system (arm64)
dpkg: error processing archive libreoffice7.6-fr_7.6.2.1-1_amd64.deb (--install):
package architecture (amd64) does not match system (arm64)
Errors were encountered while processing:
libobasis7.6-fr_7.6.2.1-1_amd64.deb
libreoffice7.6-dict-fr_7.6.2.1-1_amd64.deb
libreoffice7.6-fr_7.6.2.1-1_amd64.deb


Quelqu'un peut-il m'expliquer ?
Merci beaucoup. :P
cedricgcg
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 199
Inscription: 12 Oct 2003 08:17
Localisation: Lavandou (83)
 


Re: Problème installation Libreoffice sur Chromebook/Linux

Message le 19 Nov 2023 10:10

Salut cedricgcg :)

En recherchant avec "package architecture (amd64) does not match system (arm64)"

Tu trouves des réponses, surtout en Anglais. Attend un de nos Pingouins 8) pour plus. :lol:

Sinon, un site Français qui permet au moins de comprendre pourquoi certains disent

préférer crever tout seuls que de demander de l'aide aux Schtroumpfs-à-lunettes. :roll:

https://forum.openoffice.org/fr/forum/v ... hp?t=66894

Bon Dimanche. ;)

Image
En cas de problème constaté sur un sujet, contactez un modérateur par MP svp. N'intervenez pas vous-même. Merci bien.
Avatar de l'utilisateur
Pac428
PC-Infopraticien
PC-Infopraticien
 
Messages: 29408
Inscription: 23 Mai 2006 13:25
Localisation: Le Goulag du Maine.
 

Re: Problème installation Libreoffice sur Chromebook/Linux

Message le 19 Nov 2023 10:47

Bonjour,

Je n'ai jamais vraiment compris comment se situaient les Chromebook parmi les différentes architectures (processeur 64 bits mais système en 32 bits, compatibilité hasardeuse...)
J'avais essayé de créer une machine virtuelle chromebook pour faire des essais, mais ça n'a jamais fonctionné.

Bon passons, ces propos liminaires ne te sont guère utiles, je le crains.
On va essayer de reprendre depuis le début.

La première commande à effectuer est :
sudo apt install libreoffice libreoffice-l10n-fr

(en espérant que les dépôts installés contiennent nativement cette application)

Est-ce que tu peux nous copier le résultat de cette commande ?
Avatar de l'utilisateur
diogene
Moderateur
Moderateur
 
Messages: 12447
Inscription: 24 Avr 2009 22:41
Localisation: Dordogne
 

Re: Problème installation Libreoffice sur Chromebook/Linux

Message le 19 Nov 2023 18:05

Bonsoir Diogene, et merci.
Voici une copie du résultat
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
libobasis7.6-fr:amd64 : Depends: libobasis7.6-core:amd64 (>= 7.6.2.1) but it is not installable
Depends: libobasis7.6-core:amd64 (<= 7.6.2.1-1) but it is not installable
libreoffice : Depends: libreoffice-base but it is not going to be installed
Depends: libreoffice-calc but it is not going to be installed
Depends: libreoffice-core (= 1:7.0.4-4+deb11u7) but it is not going to be installed
Depends: libreoffice-draw but it is not going to be installed
Depends: libreoffice-impress but it is not going to be installed
Depends: libreoffice-math but it is not going to be installed
Depends: libreoffice-report-builder-bin but it is not going to be installed
Depends: libreoffice-writer but it is not going to be installed
Depends: python3-uno (>= 4.4.0~beta2) but it is not going to be installed
Recommends: fonts-crosextra-caladea but it is not going to be installed
Recommends: fonts-crosextra-carlito but it is not going to be installed
Recommends: fonts-dejavu but it is not going to be installed
Recommends: fonts-liberation but it is not going to be installed
Recommends: fonts-liberation2 but it is not going to be installed
Recommends: fonts-linuxlibertine but it is not going to be installed
Recommends: fonts-noto-core but it is not going to be installed
Recommends: fonts-noto-extra but it is not going to be installed
Recommends: fonts-noto-mono but it is not going to be installed
Recommends: fonts-noto-ui-core but it is not going to be installed
Recommends: fonts-sil-gentium-basic but it is not going to be installed
Recommends: libreoffice-nlpsolver but it is not going to be installed
Recommends: libreoffice-report-builder but it is not going to be installed
Recommends: libreoffice-script-provider-bsh but it is not going to be installed
Recommends: libreoffice-script-provider-js but it is not going to be installed
Recommends: libreoffice-script-provider-python but it is not going to be installed
Recommends: libreoffice-sdbc-mysql but it is not going to be installed
Recommends: libreoffice-sdbc-postgresql but it is not going to be installed
Recommends: libreoffice-wiki-publisher but it is not going to be installed
Recommends: libreoffice-java-common (>= 1:7.0.4~) but it is not going to be installed
libreoffice-l10n-fr : Depends: libreoffice-common (>= 1:7.0.0~alpha~) but it is not going to be installed
Recommends: libreoffice-core (> 1:7.0.4) but it is not going to be installed
libreoffice7.6-dict-fr:amd64 : Depends: libreoffice7.6-ure:amd64 (>= 7.6.2.1) but it is not installable
Depends: libreoffice7.6-ure:amd64 (<= 7.6.2.1-1) but it is not installable
Depends: libobasis7.6-core:amd64 (>= 7.6.2.1) but it is not installable
Depends: libobasis7.6-core:amd64 (<= 7.6.2.1-1) but it is not installable
Depends: libreoffice7.6:amd64 (>= 7.6.2.1) but it is not installable
Depends: libreoffice7.6:amd64 (<= 7.6.2.1-1) but it is not installable
libreoffice7.6-fr:amd64 : Depends: libreoffice7.6:amd64 (>= 7.6.2.1) but it is not installable
Depends: libreoffice7.6:amd64 (<= 7.6.2.1-1) but it is not installable
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).


Ma version de chromebook : Version 118.0.5993.124 (Build officiel) (64 bits)
cedricgcg
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 199
Inscription: 12 Oct 2003 08:17
Localisation: Lavandou (83)
 

Re: Problème installation Libreoffice sur Chromebook/Linux

Message le 19 Nov 2023 21:04

Cette installation a l’air possible mais ne se fait pas.
Je pense que les erreurs viennent du fait qu’une autre version de libre office est déjà installée. Il faudrait supprimer cette installation et lancer à nouveau la commande.

sudo apt remove —purge libreoffice*
sudo apt —fix-broken install
sudo apt install libreoffice libreoffice-l10n-fr
Avatar de l'utilisateur
diogene
Moderateur
Moderateur
 
Messages: 12447
Inscription: 24 Avr 2009 22:41
Localisation: Dordogne
 

Re: Problème installation Libreoffice sur Chromebook/Linux

Message le 20 Nov 2023 20:57

Merci.
Je teste
cedricgcg
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 199
Inscription: 12 Oct 2003 08:17
Localisation: Lavandou (83)
 

Re: Problème installation Libreoffice sur Chromebook/Linux

Message le 20 Nov 2023 21:10

:D :D :D :D :D :D :D :D :D :D :D :D
Merci Diogène !
Comment aider quelqu'un en trois lignes de commande !!
C'est vraiment formidable d'avoir des modérateurs impliqués et experts.
Un grand merci.
cedricgcg
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 199
Inscription: 12 Oct 2003 08:17
Localisation: Lavandou (83)
 

Re: Pb. Installation Libreoffice sur Chromebook/Linux

Message le 20 Nov 2023 21:31

J'avais réglé le sujet mais je l'ouvre à nouveau car j'ai une petite question liées à ce problème :
Je me retrouve avec un dossier contenant kes icônes de la version que je viens d'installer mais également les icônes de Libreoffice version 7.6.2 qui est en anglais et que j'avais installé.
Comment puis-je désinstaller cette version afin de n'en garder qu'une ?
Sinon, puis-je tout désinstaller (si c'est plus simple) afin de réinstallé que la bonne version ?
cedricgcg
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 199
Inscription: 12 Oct 2003 08:17
Localisation: Lavandou (83)
 

Re: Pb. Installation Libreoffice sur Chromebook/Linux

Message le 20 Nov 2023 22:48

On peut lister tous les paquets installés sur ton ordi en rapport avec libreoffice.

Tu tapes cette commande :
sudo dpkg -l | grep 'libreoffice'

Et tu nous copies le résultat.

NB : Sur un clavier Azerty, la barre verticale entre "sudo dpkg -l" et "grep 'libreoffice' " est obtenue en appuyant simultanément sur AltGr et 6
Avatar de l'utilisateur
diogene
Moderateur
Moderateur
 
Messages: 12447
Inscription: 24 Avr 2009 22:41
Localisation: Dordogne
 

[Réglé] Pb. Installation Libreoffice sur Chromebook/Linux

Message le 21 Nov 2023 17:02

Voici :
ii liblibreoffice-java 1:7.0.4-4+deb11u7 all LibreOffice UNO runtime environment -- Java library
ii libreoffice 1:7.0.4-4+deb11u7 arm64 office productivity suite (metapackage)
ii libreoffice-base 1:7.0.4-4+deb11u7 arm64 office productivity suite -- database
ii libreoffice-base-core 1:7.0.4-4+deb11u7 arm64 office productivity suite -- shared library
ii libreoffice-base-drivers 1:7.0.4-4+deb11u7 arm64 Database connectivity drivers for LibreOffice
ii libreoffice-calc 1:7.0.4-4+deb11u7 arm64 office productivity suite -- spreadsheet
ii libreoffice-common 1:7.0.4-4+deb11u7 all office productivity suite -- arch-independent files
ii libreoffice-core 1:7.0.4-4+deb11u7 arm64 office productivity suite -- arch-dependent files
ii libreoffice-draw 1:7.0.4-4+deb11u7 arm64 office productivity suite -- drawing
ii libreoffice-impress 1:7.0.4-4+deb11u7 arm64 office productivity suite -- presentation
ii libreoffice-java-common 1:7.0.4-4+deb11u7 all office productivity suite -- arch-independent Java support files
ii libreoffice-l10n-fr 1:7.0.4-4+deb11u7 all office productivity suite -- French language package
ii libreoffice-math 1:7.0.4-4+deb11u7 arm64 office productivity suite -- equation editor
ii libreoffice-nlpsolver 0.9+LibO7.0.4-4+deb11u7 all "Solver for Nonlinear Programming" extension for LibreOffice
ii libreoffice-report-builder 1:7.0.4-4+deb11u7 all LibreOffice component for building database reports
ii libreoffice-report-builder-bin 1:7.0.4-4+deb11u7 arm64 LibreOffice component for building database reports -- libraries
ii libreoffice-script-provider-bsh 1:7.0.4-4+deb11u7 all BeanShell script support provider for LibreOffice scripting framework
ii libreoffice-script-provider-js 1:7.0.4-4+deb11u7 all JavaScript script support provider for LibreOffice scripting framework
ii libreoffice-script-provider-python 1:7.0.4-4+deb11u7 all Python script support provider for LibreOffice scripting framework
ii libreoffice-sdbc-firebird 1:7.0.4-4+deb11u7 arm64 Firebird SDBC driver for LibreOffice
ii libreoffice-sdbc-hsqldb 1:7.0.4-4+deb11u7 arm64 HSQLDB SDBC driver for LibreOffice
ii libreoffice-sdbc-mysql 1:7.0.4-4+deb11u7 arm64 MariaDB/MySQL SDBC driver for LibreOffice
ii libreoffice-sdbc-postgresql 1:7.0.4-4+deb11u7 arm64 PostgreSQL SDBC driver for LibreOffice
ii libreoffice-style-colibre 1:7.0.4-4+deb11u7 all office productivity suite -- colibre symbol style
ii libreoffice-wiki-publisher 1.2.0+LibO7.0.4-4+deb11u7 all LibreOffice extension for working with MediaWiki articles
ii libreoffice-writer 1:7.0.4-4+deb11u7 arm64 office productivity suite -- word processor
ii libreoffice7.6-debian-menus 7.6.2-1 all LibreOffice 7.6 desktop integration


Merci
cedricgcg
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 199
Inscription: 12 Oct 2003 08:17
Localisation: Lavandou (83)
 

Re: Pb. Installation Libreoffice sur Chromebook/Linux

Message le 21 Nov 2023 17:16

Si ma méthode de recherche est bonne, il n'y a pas grand chose à enlever.

sudo apt remove --purge libreoffice7.6-debian-menus

Tu nous dis ce que ça donne.
Avatar de l'utilisateur
diogene
Moderateur
Moderateur
 
Messages: 12447
Inscription: 24 Avr 2009 22:41
Localisation: Dordogne
 

Re: Pb. Installation Libreoffice sur Chromebook/Linux

Message le 21 Nov 2023 17:35

Je viens d'effectuer la commande. Cela n'a rien changé. J'ai toujours les icônes et l'application s'ouvre quand je clique dessus.
Voici le résultat au cas où :
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following packages will be REMOVED:
libreoffice7.6-debian-menus*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 2,347 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 52280 files and directories currently installed.)
Removing libreoffice7.6-debian-menus (7.6.2-1) ...
/usr/bin/gtk-update-icon-cache
gtk-update-icon-cache: Cache file created successfully.
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for shared-mime-info (2.0-1) ...
Processing triggers for desktop-file-utils (0.26-1) ...
(Reading database ... 52011 files and directories currently installed.)
Purging configuration files for libreoffice7.6-debian-menus (7.6.2-1) ...
dpkg: warning: while removing libreoffice7.6-debian-menus, directory '/usr/local' not empty so not removed
cedricgcg
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 199
Inscription: 12 Oct 2003 08:17
Localisation: Lavandou (83)
 

Re: Pb. Installation Libreoffice sur Chromebook/Linux

Message le 22 Nov 2023 17:59

Si c'est plus simple de tout supprimer pour repartir d'une installation propre, je suis prêt.
cedricgcg
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 199
Inscription: 12 Oct 2003 08:17
Localisation: Lavandou (83)
 

Re: Pb. Installation Libreoffice sur Chromebook/Linux

Message le 22 Nov 2023 18:16

En regardant la vidéo d'installation que tu as utilisée pour installer libreoffice, je découvre qu'il s'agit d'une installation par flatpak, et que mes malheureuses commandes apt n'ont aucun effet dessus.

On peut commencer par cette commande :
sudo flatpak uninstall --user org.libreoffice.LibreOffice

Cela devrait te débarrasser de l'ancien libreoffice (en laissant l'autre).

Ensuite, si ça fonctionne et si tu n'as plus besoin de flatpak, tu peux aussi le désinstaller :
sudo apt remove --purge flatpak


Il va certainement rester des fichiers de configuration à supprimer manuellement. Je te regarde ça.


Édition

J'ai trouvé !

Il suffit de supprimer le dossier app créé dans ton dossier personnel.
Tu ouvres l'explorateur de fichiers, tu vas dans les options pour afficher les fichiers cachés (sous Linux, les noms des fichiers cachés sont précédés d'un point, par exemple : .config)
Ensuite, dans ton dossier personnel, tu devrais trouver un dossier .var, qui contient lui-même un dossier app, dans lequel libreoffice stockait ses paramètres de fonctionnement.
Tu supprimes ce répertoire et normalement, toute trace de ta première installation aura disparu.
Avatar de l'utilisateur
diogene
Moderateur
Moderateur
 
Messages: 12447
Inscription: 24 Avr 2009 22:41
Localisation: Dordogne
 

Re: Pb. Installation Libreoffice sur Chromebook/Linux

Message le 22 Nov 2023 18:25

Erreur à la première commande :
error: org.libreoffice.LibreOffice/*unspecified*/*unspecified* not installed


Je n'avais pas vu l'édition de ton post.
Je m'y attache maintenant
cedricgcg
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 199
Inscription: 12 Oct 2003 08:17
Localisation: Lavandou (83)
 

Suivante


Sujets similaires

Message Il y a t-il un antivirus compatible avec LInux ?
Salut, je suis sur Kali Linux, je cherche un anitivrus compatible avec Linux, mais les antivrus connu comme Norton, AVG, Avast ou Bitdefender ne sont pas compatible avec Linux, et il semble que McAfee est cessé sa compatibilité avec Linux en Septembre 2023.Je ne fais pas confiance aux antivirus grat ...
Réponses: 3

Message [Réglé] CPU AM4 récent ?
Bonjour et bel été à tous.Je suis l'heureux possesseur d'un ryzen 5 5600x sur une carte mère MSI B550 gaming plus.J'aimerais savoir si un upgrade significatif du CPU est envisageable. Malheureusement, sur le site MSI, la page dédiée à la liste des CPU compatibles est buggée. Je ne suis pas sûr des i ...
Réponses: 3

Message [Réglé] Il y a-t-il une appli bloc-note sur Kali Linux ?
Salut, j'ai essayé d'installer le logiciel simple note sur Kali Linux, même après avoir résolut le problème des dépendances, ça ne marche pas, je voudrais savoir si il existe sur Kali Linux une application pré-installé qui fait office de bloc-note numérique ?Si oui, quelle est sont nom ?Quelqu'un pe ...
Réponses: 2

Message [Réglé] son
Bonjour, petits soucis, sur le téléphone de la belle-mère quand elle nous appelle, on ne l'entend pas, par contre sur le sien elle nous entend ..comme elle n'est pas trop près de chez nous , qu'est-ce qu'il faudrait vérifiée à part le volume que l'on a vérifié hier ...quand je regarde une vidéo y a ...
Réponses: 8

Message [ Réglé ]Souci apres flash bios
Bonjour à tous ,je reviens vers vous car j'ai besoin de vos lumières . j'ai la carte mère Gigabyte Z790 Aorus elite AX . Je viens de mettre à jour le dernier bios de la carte mère , le FJe . Télécharger ici sous Gigabyte : https://www.aorus.com/fr-fr/motherboard ... 1x/Support J'ai réglé le ...
Réponses: 3

Message [Réglé] recherche antivirus et anti trojan pour tel android
Salut tout le mondeje possede un Samsung GALAXY S23 ULTRA, système Android version 14 et version One Ui 6.0 je ne sais pas trop à quoi cela correspond exactement, c'est juste pour information il y a bien dessus maintenance de l'application un onglet protection des applications, mais comme je fais ...
Réponses: 6


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.