Il y a actuellement 87 visiteurs
Samedi 19 Septembre 2020
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

[réglé] Installation de vmwaretools sous debian

L'informatique, ce n'est pas qu'un PC équipé de Windows. Ce forum est dédié aux utilisateurs de systèmes d'exploitation dérivés d'unix (GNU/Linux, *BSD, etc...) et aux autres OS alternatifs.

[réglé] Installation de vmwaretools sous debian

Message le 23 Fév 2007 20:57

Bonjour,
Dans une nouvelle tentative de me mettre a utiliser gnu/Linux, j'ai installé une débian sous vmware.

J'essaye d'installer vmware tools, Premiere etape, un cd virtuel est monté. j'ai réussi à décompresser l'archive dans un dossier tmp.

Deuxiemme etape, lancer le fichier d'installation en mode su. c'est la que ca coince.
voici un copier coller du terminal :

debian:/home/blux# /home/blux/tmp/vmware-tools-distrib/vmware-install.pl
Creating a new installer database using the tar3 format.

Installing the content of the package.

In which directory do you want to install the binary files?
[/usr/bin]

What is the directory that contains the init directories (rc0.d/ to rc6.d/)?
[/etc]

What is the directory that contains the init scripts?
[/etc/init.d]

Unable to copy the source file ./installer/services.sh to the destination file
/etc/init.d/vmware-tools.

Execution aborted.

debian:/home/blux#

Quelqu un peut m'éclairer ? Merci d'avance.
Asus P5Q pro // Quad Core Q9450 // Corsair XMS2 PC6400 CL4 - (8 go) // WD Caviar 250 go Sata II x4 - WD Caviar 500 go Sata II- Maxtor 320 go Sata I // 8800 GT Zilent // Alim Corsair TX650W
Avatar de l'utilisateur
blu
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 315
Inscription: 28 Avr 2003 19:51
 


Message le 24 Fév 2007 11:19

Au lieu de ça :
Code: Tout sélectionner
debian:/home/blux# /home/blux/tmp/vmware-tools-distrib/vmware-install.pl

... fais plutôt ça :
Code: Tout sélectionner
debian:/home/blux# cd /home/blux/tmp/vmware-tools-distrib
debian:/home/blux# ./vmware-install.pl


Il faut exécuter le script à partir de là où il est car il utilise des chemins relatif.
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8976
Inscription: 13 Mai 2003 16:32
Localisation: Sisteron... et jamais loin d'une Debian
 

Message le 24 Fév 2007 21:38

Génial, ca fonctionne ! Merci.

Pourrais tu me dire ce qu'est un chemin relatif ?
Et le "." devant /vmware-install.pl, il sert a quoi ? j'ai essayé sans pendant un quart d'heure car je ne l'avais pas vu :lol:

Comme ca, en plus du fait que cela fonctionne, j'aurai compris pourquoi :D
Asus P5Q pro // Quad Core Q9450 // Corsair XMS2 PC6400 CL4 - (8 go) // WD Caviar 250 go Sata II x4 - WD Caviar 500 go Sata II- Maxtor 320 go Sata I // 8800 GT Zilent // Alim Corsair TX650W
Avatar de l'utilisateur
blu
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 315
Inscription: 28 Avr 2003 19:51
 

Message le 24 Fév 2007 21:56

Le point signifie le dossier courant.
Si tu ne le met pas, ton système cherche un fichier vmware-install.pl à la racine de l'arborescence de tes dossiers.
Walk of shame, walk of game... what uuuup !
Avatar de l'utilisateur
coyote89
PC-Infopraticien
PC-Infopraticien
 
Messages: 7862
Inscription: 07 Mai 2003 17:39
Localisation: Chine :)
 

Message le 24 Fév 2007 23:04

Contrairement à Windows et son mode commande (ms-dos), dans un shell Unix/Linux le répertoire courant n'est pas implicitement dans le PATH. C'est à dire qu'il ne fait pas partie des chemins parmi lesquels le système va chercher la commande qu'on tape et qu'on essaye d'exécuter.

Il faut donc toujours lui indiquer manuellement, en tapant le ./ signifiant que le programme est dans le répertoire courant.

Effectivement, au début c'est un peu déroutant et on se demande pourquoi la commande n'est pas trouvée alors qu'on est au bon endroit :wink:
Libérez-vous : http://www.debian.org
Nobody knows what sysadmin does... until he stops doing it
Avatar de l'utilisateur
CaSa
PC-Infopraticien
PC-Infopraticien
 
Messages: 8976
Inscription: 13 Mai 2003 16:32
Localisation: Sisteron... et jamais loin d'une Debian
 

Message le 24 Fév 2007 23:15

Ah, c'était donc ca.

Encore merci :)
Asus P5Q pro // Quad Core Q9450 // Corsair XMS2 PC6400 CL4 - (8 go) // WD Caviar 250 go Sata II x4 - WD Caviar 500 go Sata II- Maxtor 320 go Sata I // 8800 GT Zilent // Alim Corsair TX650W
Avatar de l'utilisateur
blu
Apprenti(e) Expert(e)
Apprenti(e) Expert(e)
 
Messages: 315
Inscription: 28 Avr 2003 19:51
 



Sujets similaires

Message [réglé] ca veut pas y allé
bonjour depuis quelques jours je n'arrive plus a aller sur le site cdis... avec firefox ,si je prend l'autre navigateur edge ca fonctionne ..je comprend pas y a quelque chose qui bloque ? un probleme avec le navigateur? j'ai essayer de reparer firefox mais c'est pareil ,les autres sites fonctionnent ...
Réponses: 14

Message [Réglé] Edge: Impossible de changer moteur de recherche Bing
Bonjour J'ai un pc portable avec Windows 10. Lorsque il sort du mode veille, edge se lance automatiquement.. J'ai vu sur internet que certains ont réglé le problème en changeant le moteur de recherche Bing par un autre mais je n'arrive pas le changer. Par défaut Bing est sélectionné et les boutons s ...
Réponses: 10

Message [Réglé] Disque surchargé
Bonjour,Je viens d'acheter un ordinateur de bureau de marque Compaq tournant sous W 7.Problème, le disque C/ de 11 Go est presque plein tandis que D/ est quasiment vide (540 Go de libre).J'essaie donc d'installer Open Office sur D/ mais cela ne fonctionne pas, les dossiers se copient visiblement sur ...
Réponses: 7

Message [Réglé] Suppression de programmes inutiles et louches
Bonjour, L'ordinateur d'un ami contient des programmes qui ne peuvent être désinstallé et qui semblent être inutile. Cependant, je ne sais pas comment effectuer cette démarche pour s'en débarrasser.De plus je ne suis pas capable de les identifier moi-même. Ils ralentissent l'ordinateur et gênent (dé ...
Réponses: 12

Message [Réglé] VLC en Français
bonjourj'ai besoin de VLC pour couper un morceau d'une vidéo (si on peut avec VLC) mais pour ça il faut que ce soit en Français, je n'y arrive pas.comment faire?merci
Réponses: 6

Message [Réglé] impossible de visionner mes vidéos !
Bonjour,Depuis quelques temps, mon PC refuse de lire les vidéos ! ... et je me demande bien pourquoi, car je n'ai rien modifié et jusqu'à présent tout fonctionnait normalement!maintenant quand je veux lire le fichier vidéo d'une carte et bien je n'ai qu'un écran vert ou noir (cela dépend du logiciel ...
Réponses: 21

Message [Réglé] message intempestif Google lors de recherches
Salut tout le monde !Depuis quelques jours lorsque j'effectue une recherche Google sur mon navigateur Firefox à chaque fois j'ai ce message cela devient lassant : bien entendu je peut le fermer mais cela ne faisait pas cela avant la réinstallation de Firefox que puis je faire svp ? j'ai bien essay ...
Réponses: 4


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.