Il y a actuellement 132 visiteurs
Samedi 15 Août 2020
accueilactualitésdossierscomparer les prixtélécharger gratuitement vos logicielsoffres d'emploiforum informatique
Connexion
Créer un compte

Petit tuto problème activation flash sur les sites

Besoin d'aide pour configurer un serveur ? Vous souhaitez obtenir des conseils pour référencer votre site ? Un petit souci pour accéder à votre FTP ? Des soucis de programmation en PHP / ASP / HTML / XHTML / XML / XSLT / CSS / ReactJS / AngularJS / VueJS / CGI / PERL / C / MySQL / PostgreSQL ??? Nous avons peut-être la solution dans ce forum ...

Petit tuto problème activation flash sur les sites

Message le 20 Avr 2006 09:51

Salut à tous.

J'ai du chercher quelque peut alors je me dis que cela pourrait peut $etre vous être utile à vous aussi.

Depuis la dernière mise à jour de sécurité de Microsoft sur le navigateur Internet explorer (Windows XP), nous avons droit à un cadre assez laid autour de nos animations flash. Elle ne sont d'ailleurs activées que quand on clique une première fois dessus.

pour éviter cela , voici une procédure pour afficher vos animations flash sans cette activation.

Crèer un fichier .js (dans notre example activeflash.js)
mettez y dedans votre bout de code flash avec des document.write:
Code: Tout sélectionner
 document.write('<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="665" height="213" style="margin-left:51px ">');
      document.write('<param name="movie" value="/modules/Headlines/flash/dvd2netfr.swf">');
      document.write('<param name="quality" value="high">');
      document.write('<embed src="/modules/Headlines/flash/dvd2netfr.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="665" height="213"></embed>');
    document.write('</object>');


Ensuite à la place de votre code <object>.... dans votre fichier HTML ou PHP, vous devez mettre le code suivant :

Code: Tout sélectionner
<script src="activeflash.js"></script>


Voilà :lol:
Avatar de l'utilisateur
Gotcha
Expert(e)
Expert(e)
 
Messages: 742
Inscription: 04 Déc 2002 11:23
Localisation: c:\Belgium\Namur
 


flash probleme code

Message le 03 Mai 2006 12:15

bonjour,
j'ai essaye ton code
ca marche très bien mais pas ds firefox!!

quelqu'un a trouve quelque chose?
c'est quand même un gros problème!!!

j'ai cherché partout

la seule chose qui marche :
un fichier js :

function run_flash(url,width,height)
{
document.write('<object classid="clsid:d27cdb6e-..." >
');
document.write('<param name="movie" value="movie">
');
document.write('<embed src="'+url+'" width="'+width+'" height="'+height+'" type="application/x-shockwave-flash">
');
document.write('</embed>
');
document.write('</object>
');
}


puis après l'appeler et l'introduire dans ta page

malheureusement cedtte solution entoure légèrement l'animation (en petit gris) et la laisse charger vide (les barres de chargemnts ne s'affiche plus)

koi faire?
merci!!!
gers
Visiteur
Visiteur
 
Messages: 1
Inscription: 03 Mai 2006 11:53
Localisation: thionville
 

Message le 07 Juin 2006 17:17

Salut,

bon, voilà, je suis en train de m'excercer sur un logiciel que je viens de découvrir ; Dreamweaver (V8.0).

J'ai un petit souci avec des animations flash. Une fois que j'ai créé ma page avec les différents objets flash, lorsque je le transfert sur mon ftp, ils n'apparaissent plus (voici la page http://ravi37170.free.fr/images/ravimade/) :(
Je précise que le player est installé (j'arrive à voir des médias flash sur d'autres sites, donc ca doit être bon non ?).

Autre souci, après avoir fait quelques modifs sur cette page, j'ai remarqué qu'en retirant les objets flash, ils sont toujours présents dans l'apercu de Dreamweaver :-/ :(

Conception dans DW (on remarque qu'il n'y a pas de flash ??!!)

Image


et quand je regarde l'apercu dans DW :mad:

Image

Merci de votre aide car ca fait 1h que je suis decu et je ne vois pas :(
Image

Image
Avatar de l'utilisateur
ravy37170
Expert(e)
Expert(e)
 
Messages: 835
Inscription: 05 Jan 2004 22:18
Localisation: Tours (37)
 

Message le 07 Juin 2006 17:40

Bonjour,

Cela ne va pas trop t'aider, mais bien que les technologies Flash sont "dernier cri", je trouve qu'il n'est pas bon de faire des sites de ce genre. D'une part parce qu'on peut faire des trucs déjà pas mal en XHTML // CSS // PHP (les trois ensembles) et d'autre part parce que tout le monde n'a pas la chance d'avoir un lecteur de flash.
Par contre tu as du payer une fortune pour Macromedia, il est pas donné. Dans l'ensemble il est bien utile pour mettre en place un tableau, après on s'occupe sous un logiciel simple d'édition de pages HTML de mettre en place le contenu de ton tableau, comme les fichiers swf par exemple. Et puis pour l'affichage de dreamweaver je crois que tu dois sauver ta solution, et relancer le programme. Mais comme je l'ai dit avant, il faut, même si le logiciel est super, souvent repasser derrière pour voir le code, mais avec un autre logiciel.
Sous windows j'utilise NotePad++ ou encore Scite pour tout ce qui est édition, mais il existe aussi Gvim qui est simple et permet de supprimer les morceaux de code en trop ou d'en ajouter. Evidemment sous linux il y a le très très bon logiciel Quanta, dont on ne peux plus se passer après l'avoir utilisé.
Le savoir m'a appris que je ne savais rien
Le MIEUX est l'ennemi du BIEN.
Avatar de l'utilisateur
blankoworld
PC-Infopraticien
PC-Infopraticien
 
Messages: 5993
Inscription: 21 Juin 2004 09:41
Localisation: Pala
 

Message le 07 Juin 2006 19:56

Idem, je déconseille le flash, trop de soucis pour un résultat graphique certes mais qui ne s'affiche pas pareillement chez tous les utilisateurs.
Walk of shame, walk of game... what uuuup !
Avatar de l'utilisateur
coyote89
PC-Infopraticien
PC-Infopraticien
 
Messages: 7862
Inscription: 07 Mai 2003 17:39
Localisation: Chine :)
 

Message le 07 Juin 2006 22:36

je sais que je devrais vous écouter mais c'est plus fort que moi, quand je vois les réalisations possibles, j'ai vraiment envie de faire une grosse partie en Flash

Voici un premier jus de ma page d'accueil

http://ravi37170.free.fr/images/ravimade/
Image

Image
Avatar de l'utilisateur
ravy37170
Expert(e)
Expert(e)
 
Messages: 835
Inscription: 05 Jan 2004 22:18
Localisation: Tours (37)
 

Message le 08 Juin 2006 16:01

salut,

alors, je suis en train de me prendre la tête sur flash mx depuis ce matin et j'ai besoin d'aide.

J'essaie de réaliser un clip avec un défilement d'images, transition par interpolation de mouvement (je modifie donc le paramaètre alpha de 0 à 100%). Je vous met le lien du fichier

http://ravi37170.free.fr/images/divers/ ... ccueil.fla

le calque 1 fonctionne bien (fondu sortant) par contre le calque 2, je n'arrive pas à avoir un fondu entrant :evil: :evil:

Merci de m'aider car là, je deviens fou :oops:
Image

Image
Avatar de l'utilisateur
ravy37170
Expert(e)
Expert(e)
 
Messages: 835
Inscription: 05 Jan 2004 22:18
Localisation: Tours (37)
 

Message le 08 Juin 2006 19:23

personne pour m'aider ? :cry:
Image

Image
Avatar de l'utilisateur
ravy37170
Expert(e)
Expert(e)
 
Messages: 835
Inscription: 05 Jan 2004 22:18
Localisation: Tours (37)
 

Message le 08 Juin 2006 19:54

ravy37170 a écrit:personne pour m'aider ? :cry:

:cry: Désolé je ne comprends même pas comment tu fais pour avoir une page d'accueil aussi belle, alors de t'expliquer comment faire ... ça me dépasse :-?.
Le savoir m'a appris que je ne savais rien
Le MIEUX est l'ennemi du BIEN.
Avatar de l'utilisateur
blankoworld
PC-Infopraticien
PC-Infopraticien
 
Messages: 5993
Inscription: 21 Juin 2004 09:41
Localisation: Pala
 

Message le 09 Juin 2006 08:10

:cry: :cry: j'ai envoyé la meme question à un autre forum et j'attend de voir le pb

Faut croire que ca doit être simple pour la plupart des internautes car en cherchant, je ne trouve pas la réponse à ma question sur le net.

Et dire que j'ai passé des h et des h :evil:
Image

Image
Avatar de l'utilisateur
ravy37170
Expert(e)
Expert(e)
 
Messages: 835
Inscription: 05 Jan 2004 22:18
Localisation: Tours (37)
 

Message le 09 Juin 2006 08:50

Là, j'ai fait un diaporama "beta" et voici comment ca va rendre. Il y a encore un gros boulot artistique et également pour rendre la navigation pratique (puisque le liens photos renvoie que au mod PuRItY et donc il faudra que j'intègre les autres mods)

J'ai pris un modèle de diaporama sur Dreamweaver que j'ai modifié à ma sauce ;)

http://ravi37170.free.fr/images/ravimade/photos.html

Ps : quand vous cliquerez dessus, attendre qq secondes pour le chargement (il faut que j'intègre une barre de progression du téléchargement)
Image

Image
Avatar de l'utilisateur
ravy37170
Expert(e)
Expert(e)
 
Messages: 835
Inscription: 05 Jan 2004 22:18
Localisation: Tours (37)
 

Message le 10 Juin 2006 11:37

J'ai enfin réussi !!!!!!!!!!!!! Je viens de comprendre le paramètre alpha pour les fondus !!!

En fait, j'avais créé un masque (rectangle blanc transformé en symbole graphique) puis j'ai ajouter une interpolation entre ce masque et l'image. Et voilà la betise, il fallait prendre l'image au début et à la fin et non créer un masque. Ensuite pour faire un fondu entrant, la première image doit avoir un alpha à 0% (en passant alpha de 100% à 0%, l'image devient un rectangle blanc) et la dernière un alpha de 100% (on voit l'image normalement).

Je sais pas si j'étais clair

En tout cas, 2 jours pour comprendre ca


et voilà avec les beaux fondus http://ravi37170.free.fr/images/ravimade/
Image

Image
Avatar de l'utilisateur
ravy37170
Expert(e)
Expert(e)
 
Messages: 835
Inscription: 05 Jan 2004 22:18
Localisation: Tours (37)
 

Message le 10 Juin 2006 12:14

ravy37170 a écrit:En tout cas, 2 jours pour comprendre ca

Le travail ça paie toujours :wink:.
En tout cas chapeau, tu as l'esprit artistique, je t'en félicite. Tu réussis de superbes choses.
Pas comme d'autres qui ne font rien de leur journée ... (je ne citerai pas Blanko).
Le savoir m'a appris que je ne savais rien
Le MIEUX est l'ennemi du BIEN.
Avatar de l'utilisateur
blankoworld
PC-Infopraticien
PC-Infopraticien
 
Messages: 5993
Inscription: 21 Juin 2004 09:41
Localisation: Pala
 



Sujets similaires

Message Suite problème Installation .NET Framework 3.5
Je passe sur cette section du forum après les indications de heracles et de routman sur le post suivant :viewtopic-87451-0-asc-15.htmlJ'ia donc effectué l'analyse FRST et voici les 3 fichiers joints :https://www.cjoint.com/c/JEmi7oL2VBnhttps://www.cjoint.com/c/JEmi7Gt4kgnhttps://www.cjoint.com/c/JEm ...
Réponses: 135

Message probleme bios
bonjour je dispose d un pc hp model 17-ca1012nf j ai un problème au démarrage j ai un écran noir avec le message suivant:bios corruption has been deteced. bios recoery will begin automatically when you restart pcbios recovery will take several minutesdo not shut or remove external power from your pc ...
Réponses: 2

Message [Réglé] Problème nouvelle config
Bonsoir,récemment j'ai demandé sur le forum que l'on me conseille une config, et je l'ai reçu aujourd'hui. J'ai monté le PC en regardant bien plusieurs Tutos SAUF que j'ai un bon gros problème. Mon écran ne détecte pas du tout le PC, il n'y a pas de signal. En plus de ça les deux ventilos de ma cart ...
Réponses: 2

Message Retour à l'état d'usine: problème "error"
Bonjour,Mon pc étant relativement lent (windows 7 edition familliale premium 64bits, asus x5die de 2008) j'ai voulue le remettre aux paramètres d'usine via la touche f9 au démarrage de windows. En option j'ai choisis de ne refaire que la partition système C.Voici la procédure que j'ai suivi (pour un ...
Réponses: 15

Message Tuto resoudre un problème d'installation de Windows en UEFI
Suite à un changement de matériel ou à une fausse man?uvre lors de l'installation de Windows en UEFI il arrive que le message suivant soit inscrit: "impossible d'installer Windows sur le lecteur ....(afficher détail)le détail expliquant, par exemple que le lecteur n'est pas en GPT....mais pas ...
Réponses: 0

Message vieux jeux sur pc récent: problème de lag
Bonjour,suite au problème avec mon vieux pc, j'essai donc je faire tourner un de mes vieux jeux sur mon pc gaming. Le problème est que le jeu lag énormément au point que c'est injouable. Il s'agit du jeu Les Fourmis de Microids.Mon vieux pc:Asus X5DIEwindows 7 64bitsRam: 4 Gb DDR3Intel pentium 2.14 ...
Réponses: 15

Message Problème de son avec adaptateur audio usb 2.0
Bonjour et merci d'avance à ceux qui viendront m'aider.Je fais du montage vidéo et pour le son, je n'utilise qu'un casque audio qui était jusqu'à présent connecté à ma carte son sur la façade de mon PC (suite à un problème de fiche jack coincée depuis longtemps dans la carte son à l'arrière du PC).J ...
Réponses: 0


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 3 invités


.: Nous contacter :: Flux RSS :: Données personnelles :.